]> git.pld-linux.org Git - packages/apache1-mod_mp3.git/commitdiff
- initial PLD spec
authorGrzegorz Sterniczuk <grzegorz@sterniczuk.eu>
Fri, 5 Oct 2001 13:17:50 +0000 (13:17 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added sample mod_mp3.conf file

Changed files:
    apache1-mod_mp3.spec -> 1.1

apache1-mod_mp3.spec [new file with mode: 0644]

diff --git a/apache1-mod_mp3.spec b/apache1-mod_mp3.spec
new file mode 100644 (file)
index 0000000..377e8c7
--- /dev/null
@@ -0,0 +1,75 @@
+%define                arname          mod_mp3
+%define                mod_name        mp3
+Summary:       MP3 Apache module
+Name:          apache-mod_mp3
+Version:       0.25
+Release:       1
+License:       distributable
+Group:         Networking/Daemons
+Group(de):     Netzwerkwesen/Server
+Group(pl):     Sieciowe/Serwery
+Source0:       ftp://ftp.tangent.org/pub/apache/%{arname}-%{version}.tar.gz
+Source1:       %{arname}.conf
+URL:           http://media.tangent.org/
+Requires:      apache >= 1.3.12
+Prereq:                grep
+Provides:      %{arname}
+BuildRequires: apache >= 1.3.12
+BuildRequires: apache-devel >= 1.3.12
+BuildRequires: expat-devel
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define         _pkglibdir      %(%{_sbindir}/apxs -q LIBEXECDIR)
+%define         _sysconfdir     /etc/httpd
+
+%prep
+%setup -q -n %{arname}-%{version}
+
+%description
+This turns apache into your basic RIAA hating, but every college
+student loving mp3 streaming server. It can play from a list of files,
+either straight through or randomly. It can also be used to cache
+mp3's into memory and have the server operate entirely from memory.
+Enjoy, groove, mp3s not included.
+
+%build
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
+
+install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
+
+gzip -9nf README ChangeLog LICENSE
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+if [ -f %{_sysconfdir}/httpd.conf ] && \
+    ! grep -q "^Include.*/%{arname}.conf" %{_sysconfdir}/httpd.conf; then
+       echo "Include %{_sysconfdir}/%{arname}.conf" >> %{_sysconfdir}/httpd.conf
+fi
+if [ -f /var/lock/subsys/httpd ]; then
+    /etc/rc.d/init.d/httpd restart 1>&2
+fi
+       
+%preun
+if [ "$1" = "0" ]; then
+    %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+    grep -E -v "^Include.*%{arname}.conf" %{_sysconfdir}/httpd.conf > \
+       %{_sysconfdir}/httpd.conf.tmp
+    mv -f %{_sysconfdir}/httpd.conf.tmp %{_sysconfdir}/httpd.conf
+    if [ -f /var/lock/subsys/httpd ]; then
+        /etc/rc.d/init.d/httpd restart 1>&2
+    fi
+fi
+
+%files
+%defattr(644,root,root,755)
+%config(noreplace) %{_sysconfdir}/mod_mp3.conf
+%attr(755,root,root) %{_pkglibdir}/mod_mp3.so
+%doc *.gz faq.html
This page took 0.051711 seconds and 4 git commands to generate.