]> git.pld-linux.org Git - packages/apache-mod_wsgi.git/blob - apache-mod_wsgi.spec
- use conf.d for apache config fragment; rel 2
[packages/apache-mod_wsgi.git] / apache-mod_wsgi.spec
1 %define         mod_name        wsgi
2 %define         apxs            /usr/sbin/apxs
3 Summary:        WSGI interface for the Apache Web server
4 Summary(pl.UTF-8):      Interfejs WSGI dla serwera WWW Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        1.0
7 Release:        2
8 License:        Apache Group License
9 Group:          Networking/Daemons
10 Source0:        http://modwsgi.googlecode.com/files/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  44e20174c127a50a75f040f881b0a52c
12 Source1:        %{name}.conf
13 Patch0:         %{name}-apache-version.patch
14 URL:            http://code.google.com/p/modwsgi/
15 BuildRequires:  %{apxs}
16 BuildRequires:  apache-devel >= 2.0.52-7
17 BuildRequires:  apr-devel >= 1:1.0.0
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  python-devel >= 2.3
21 BuildRequires:  rpmbuild(macros) >= 1.268
22 Requires:       apache(modules-api) = %apache_modules_api
23 Requires:       apr >= 1:1.0.0
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
27 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
28
29 %description
30 The mod_wsgi adapter is an Apache module that provides a WSGI
31 compliant interface for hosting Python based web applications within
32 Apache. The adapter is written completely in C code against the Apache
33 C runtime and for hosting WSGI applications within Apache has a lower
34 overhead than using existing WSGI adapters for mod_python or CGI.
35
36 %description -l pl.UTF-8
37 Adapter mod_wsgi jest modułem udostępniajacym interfejs WSGI dla
38 aplikacji WWW napisanych w języku Python i osadzonych w serwerze
39 Apache. Adapter jest w całosci napisany w języku C w oparciu o
40 bibliotekę runtime Apache i ma mniejsze wymagania niż w przypadku
41 używania istniejących adapterów WSGI dla mod_python lub CGI.
42
43 %prep
44 %setup -q -n mod_%{mod_name}-%{version}
45 %patch0 -p1
46
47 %build
48 %{__aclocal}
49 %{__autoconf}
50 HTTPD_VERSION=$(rpm -q --qf '%{V}' apache-devel); export HTTPD_VERSION
51 %configure \
52         --with-apxs=%{apxs}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir}}
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/61_mod_wsgi.conf
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post
67 %service -q httpd restart
68
69 %postun
70 if [ "$1" = "0" ]; then
71         %service -q httpd restart
72 fi
73
74 %files
75 %defattr(644,root,root,755)
76 %doc README
77 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
78 %attr(755,root,root) %{apachelibdir}/*.so
This page took 0.693988 seconds and 4 git commands to generate.