]> git.pld-linux.org Git - packages/apache-mod_wsgi.git/blob - apache-mod_wsgi.spec
Version 3.5-1. Security update (CVE-2014-0240)
[packages/apache-mod_wsgi.git] / apache-mod_wsgi.spec
1 # TODO:
2 # - build py2 and py3 variants both?
3
4 #
5 # Conditional build:
6 %bcond_with     python3 # use CPython 3.x
7
8 %define         mod_name        wsgi
9 %define         apxs            /usr/sbin/apxs
10 Summary:        WSGI interface for the Apache Web server
11 Summary(pl.UTF-8):      Interfejs WSGI dla serwera WWW Apache
12 Name:           apache-mod_%{mod_name}
13 Version:        3.5
14 Release:        1
15 License:        Apache
16 Group:          Networking/Daemons
17 # Source0:      http://modwsgi.googlecode.com/files/mod_%{mod_name}-%{version}.tar.gz
18 # https://github.com/GrahamDumpleton/mod_wsgi/archive/3.5.tar.gz
19 Source0:        https://github.com/GrahamDumpleton/mod_wsgi/archive/%{version}.tar.gz
20 # Source0-md5:  ed08ce86cf34a60441b708db05da970f
21 Source1:        %{name}.conf
22 URL:            http://code.google.com/p/modwsgi/
23 BuildRequires:  %{apxs}
24 BuildRequires:  apache-devel >= 2.0.52-7
25 BuildRequires:  apr-devel >= 1:1.0.0
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 %if %{with python3}
29 BuildRequires:  python3-devel
30 %else
31 BuildRequires:  python-devel >= 2.3
32 %endif
33 BuildRequires:  rpmbuild(macros) >= 1.268
34 Requires:       apache(modules-api) = %{apache_modules_api}
35 Requires:       apr >= 1:1.0.0
36 # http://helpful.knobs-dials.com/index.php/Mod_wsgi_notes#PyEval_AcquireThread:_non-NULL_old_thread_state
37 Conflicts:      apache-mod_python
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
41 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
42
43 %description
44 The mod_wsgi adapter is an Apache module that provides a WSGI
45 compliant interface for hosting Python based web applications within
46 Apache. The adapter is written completely in C code against the Apache
47 C runtime and for hosting WSGI applications within Apache has a lower
48 overhead than using existing WSGI adapters for mod_python or CGI.
49
50 %description -l pl.UTF-8
51 Adapter mod_wsgi jest modułem udostępniającym interfejs WSGI dla
52 aplikacji WWW napisanych w języku Python i osadzonych w serwerze
53 Apache. Adapter jest w całości napisany w języku C w oparciu o
54 bibliotekę uruchomieniową Apache i ma mniejsze wymagania niż w
55 przypadku używania istniejących adapterów WSGI dla modułu mod_python
56 lub CGI.
57
58 %prep
59 %setup -q -n mod_%{mod_name}-%{version}
60
61 %build
62 %{__aclocal}
63 %{__autoconf}
64 %if %{with python3}
65 PYTHONBIN=%{__python3}
66 %else
67 PYTHONBIN=%{__python}
68 %endif
69 %configure \
70         --with-apxs=%{apxs} \
71         --with-python=$PYTHONBIN
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir}}
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/61_mod_wsgi.conf
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post
85 %service -q httpd restart
86
87 %postun
88 if [ "$1" = "0" ]; then
89         %service -q httpd restart
90 fi
91
92 %files
93 %defattr(644,root,root,755)
94 %doc README
95 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
96 %attr(755,root,root) %{apachelibdir}/*.so
This page took 0.07248 seconds and 3 git commands to generate.