]> git.pld-linux.org Git - packages/apache-mod_qos.git/blob - apache-mod_qos.spec
use template-spec for apache module base; verbose files in system dir
[packages/apache-mod_qos.git] / apache-mod_qos.spec
1 %define         mod_name        qos
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: Quality Of Service
4 Name:           apache-mod_%{mod_name}
5 Version:        11.1
6 Release:        1
7 License:        Apache
8 Group:          Networking/Daemons/HTTP
9 Source0:        https://downloads.sourceforge.net/project/mod-qos/mod_qos-%{version}.tar.gz
10 # Source0-md5:  286d2d2b2f5abae9ccc48fa58f17dda1
11 Source1:        %{name}.conf
12 URL:            http://opensource.adnovum.ch/mod_qos/
13 BuildRequires:  %{apxs}
14 BuildRequires:  apache-devel >= 2.0.0
15 BuildRequires:  libpng-devel
16 BuildRequires:  openssl-devel
17 BuildRequires:  pcre-devel
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires:       apache(modules-api) = %apache_modules_api
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
23 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
24
25 %description
26 mod_qos is a quality of service module for the Apache Web Server. It
27 implements control mechanisms that can provide different priority to
28 different requests and controls server access based on available
29 resources.
30
31 %prep
32 %setup -q -n mod_%{mod_name}-%{version}
33
34 %build
35 cd tools
36 %{__aclocal}
37 %{__autoconf}
38 %{__automake}
39 %configure \
40         --with-pcre=%{_bindir} \
41         --with-png=%{_bindir} \
42         --with-ssl=%{_prefix}
43 %{__make}
44 cd ..
45
46 %{apxs} -c -o mod_qos.la apache2/mod_qos.c
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
51 %{__make} -C tools install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 install -p .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
55 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/97_mod_%{mod_name}.conf
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 %service -q httpd restart
62
63 %postun
64 if [ "$1" = "0" ]; then
65         %service -q httpd restart
66 fi
67
68 %files
69 %defattr(644,root,root,755)
70 %doc doc/*
71 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
72 %attr(755,root,root) %{_pkglibdir}/mod_%{mod_name}.so
73 %attr(755,root,root) %{_bindir}/qscheck
74 %attr(755,root,root) %{_bindir}/qsexec
75 %attr(755,root,root) %{_bindir}/qsfilter2
76 %attr(755,root,root) %{_bindir}/qsgeo
77 %attr(755,root,root) %{_bindir}/qsgrep
78 %attr(755,root,root) %{_bindir}/qshead
79 %attr(755,root,root) %{_bindir}/qslog
80 %attr(755,root,root) %{_bindir}/qslogger
81 %attr(755,root,root) %{_bindir}/qspng
82 %attr(755,root,root) %{_bindir}/qsrotate
83 %attr(755,root,root) %{_bindir}/qssign
84 %attr(755,root,root) %{_bindir}/qstail
This page took 0.088644 seconds and 3 git commands to generate.