]> git.pld-linux.org Git - packages/apache-mod_mpm_itk.git/blob - apache-mod_mpm_itk.spec
- rel 2; rebuild with fixed config
[packages/apache-mod_mpm_itk.git] / apache-mod_mpm_itk.spec
1 %define         mod_name        mpm_itk
2 %define         apxs            /usr/sbin/apxs
3 %define         ver     2.4.7
4 %define         subver  02
5 Summary:        mod_mpm_itk - allows you to run each of your vhost under a separate uid and gid
6 Name:           apache-mod_mpm_itk
7 Version:        %{ver}.%{subver}
8 Release:        2
9 License:        Apache v2.0
10 Group:          Networking/Daemons/HTTP
11 Source0:        http://mpm-itk.sesse.net/mpm-itk-%{ver}-%{subver}.tar.gz
12 # Source0-md5:  241eddeef8d3931c6699a51d5d2169a7
13 Source1:        %{name}.conf
14 URL:            http://mpm-itk.sesse.net/
15 BuildRequires:  %{apxs}
16 BuildRequires:  apache-devel >= 2.4.7
17 BuildRequires:  apr-devel >= 1:1.0
18 BuildRequires:  apr-util-devel >= 1:1.0
19 BuildRequires:  libcap-devel
20 Requires:       apache(modules-api) = %{apache_modules_api}
21 Requires:       apache-base >= 2.4.7
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
25 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
26
27 %description
28 apache2-mpm-itk (just mpm-itk for short) is an MPM (Multi-Processing
29 Module) for the Apache web server. mpm-itk allows you to run each of
30 your vhost under a separate uid and gid - in short, the scripts and
31 configuration files for one vhost no longer have to be readable for
32 all the other vhosts.
33
34 mpm-itk is based on the traditional prefork MPM, which means it's
35 non-threaded; in short, this means you can run non-thread-aware code
36 (like many PHP extensions) without problems. On the other hand, you
37 lose out to any performance benefit you'd get with threads, of course;
38 you'd have to decide for yourself if that's worth it or not. You will
39 also take an additional performance hit over prefork, since there's an
40 extra fork per request.
41
42 %prep
43 %setup -q -n mpm-itk-%{ver}-%{subver}
44
45 %build
46 %configure \
47         --with-apxs=%{apxs}
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_pkglibdir},%{_sysconfdir}/conf.d}
53
54 install -p .libs/mpm_itk.so $RPM_BUILD_ROOT%{_pkglibdir}
55 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/10_mod_%{mod_name}.conf
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 %service -q httpd restart
62
63 %postun
64 if [ "$1" = "0" ]; then
65         %service -q httpd restart
66 fi
67
68 %files
69 %defattr(644,root,root,755)
70 %doc CHANGES README
71 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
72 %attr(755,root,root) %{_pkglibdir}/mpm_itk.so
This page took 0.082291 seconds and 3 git commands to generate.