]> git.pld-linux.org Git - packages/anjuta.git/blob - anjuta.spec
- updated to 1.1.1-20030412 snap (they changed version from 1.2.0 to 1.1.1)
[packages/anjuta.git] / anjuta.spec
1 %define         snap    20030425
2
3 Summary:        Gnome integrated development environment
4 Summary(pl):    Zintegrowane ¶rodowisko programowania dla Gnome
5 Summary(pt_BR): Ambiente de desenvolvimento integrado C e C++
6 Name:           anjuta
7 Version:        1.1.1
8 Release:        0.%{snap}.1
9 Epoch:          1
10 License:        GPL
11 Group:          Development/Tools
12 #Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
13 Source0:        %{name}-%{version}-%{snap}.tar.bz2
14 Patch0:         %{name}-am.patch
15 Patch1:         %{name}-gettext.patch
16 URL:            http://anjuta.sourceforge.net/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  glib2-devel >= 2.0.6
20 BuildRequires:  intltool
21 BuildRequires:  gnome-common
22 BuildRequires:  libglade2-devel >= 2.0.0
23 BuildRequires:  libgnomeprintui-devel >= 2.2.0
24 BuildRequires:  libgnomeui-devel >= 2.2.0
25 BuildRequires:  libtool
26 BuildRequires:  libzvt-devel >= 2.0.0
27 BuildRequires:  ncurses-devel
28 BuildRequires:  pcre-devel
29 BuildRequires:  pkgconfig
30 BuildRequires:  vte-devel >= 0.9.0
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Anjuta is a very versatile integrated development environment for C
35 and C++ GNU/Linux. Written in GTK/Gnome and written for GTK/Gnome, it
36 features many advanced programming tools and utilities. Besides many
37 other, it has project management, application wizards, onboard
38 interactive debugger, and a powerful source editor with source
39 browsing.
40
41 %description -l pl
42 Anjuta to wszechstronne zintegrowane ¶rodowisko programowania dla
43 jêzyka C oraz C++. Zosta³o napisane z wykorzystaniem tandemu
44 GTK/Gnome, w³a¶nie po to by go w takim otoczeniu u¿ywaæ. Miêdzy innymi
45 posiada zarz±dcê projektów, kreator aplikacji, wbudowany interaktywny
46 odpluskwiacz oraz edytor z mo¿liwo¶ci± przegl±dania ¼róde³.
47
48 %description -l pt_BR
49 O Anjuta é um ambiente de desenvolvimento integrado (IDE) versátil
50 para as linguagens C e C++. Foi escrito para o GTK/GNOME e tem uma
51 série de características de programação avançadas. Basicamente é uma
52 interface gráfica com o usuário para um conjunto de utilitários de
53 linha de comando e ferramentas para programação para o Linux. Estas
54 são geralmente executadas em um console em modo texto e podem ser não
55 amigáveis.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60 %patch1 -p0
61
62 %build
63 CXXFLAGS="%{rpmcflags} -fno-exceptions"
64 #rm -f missing
65 #%%{__gettextize}
66 #intltoolize
67 #%%{__libtoolize}
68 #%%{__aclocal} -I /usr/share/aclocal/gnome2-macros
69 #%%{__autoheader}
70 #%%{__autoconf}
71 #%%{__automake}
72 ./autogen.sh
73 %configure \
74         --disable-static
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT \
82         gnomemenudir=%{_datadir}/applications
83
84 %find_lang %{name} --with-gnome
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files -f %{name}.lang
90 %defattr(644,root,root,755)
91 %doc README ChangeLog NEWS TODO AUTHORS COPYING 
92 %doc FUTURE INSTALL doc/ScintillaDoc.html
93 %attr(755,root,root) %{_bindir}/*
94 %dir %{_libdir}/anjuta
95 %attr(755,root,root) %{_libdir}/anjuta/lib*.so*
96 %{_libdir}/anjuta/lib*.la
97 %{_pixmapsdir}/anjuta
98 %{_datadir}/anjuta
99 %{_datadir}/applications/*
100 %{_datadir}/mime-info/*
101 %{_datadir}/mimelnk/application/*
102 %{_mandir}/man1/*
This page took 0.054235 seconds and 3 git commands to generate.