]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- rpm-build-macros >= 1.600 required for fixed cmake macro
[packages/amarok.git] / amarok.spec
1 # TODO
2 # - try not to link with static mysql
3
4 %define         state   stable
5 %define         qtver   4.7.0
6 %define         kdever  4.5.0
7
8 Summary:        A KDE audio player
9 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
10 Name:           amarok
11 Version:        2.4.0
12 Release:        1
13 License:        GPL
14 Group:          X11/Applications/Multimedia
15 Source0:        ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
16 # Source0-md5:  bdb6ddc8e38d0982a0786ff8ac96d923
17 Patch0:         %{name}-disable_qtscriptbindings_check_fix.patch
18 URL:            http://amarok.kde.org/
19 BuildRequires:  QtNetwork-devel >= %{qtver}
20 BuildRequires:  QtSql-devel >= %{qtver}
21 BuildRequires:  automoc4 >= 0.9.88
22 BuildRequires:  cmake >= 2.8.0
23 BuildRequires:  curl-devel
24 BuildRequires:  gettext-devel
25 BuildRequires:  glib2-devel
26 BuildRequires:  kde4-kdelibs-devel >= %{kdever}
27 BuildRequires:  kde4-kdemultimedia-devel >= %{kdever}
28 BuildRequires:  libgpod-devel >= 0.7.0
29 BuildRequires:  liblastfm-devel
30 BuildRequires:  libmtp-devel >= 0.3.0
31 BuildRequires:  libofa-devel
32 BuildRequires:  libwrap-devel
33 BuildRequires:  loudmouth-devel
34 BuildRequires:  mysql-devel >= 5.1.31-3
35 BuildRequires:  pcre-devel
36 BuildRequires:  pkgconfig
37 BuildRequires:  qca-devel
38 BuildRequires:  qt4-build >= %{qtver}
39 BuildRequires:  qt4-qmake >= %{qtver}
40 BuildRequires:  qtscriptbindings
41 BuildRequires:  rpmbuild(macros) >= 1.600
42 BuildRequires:  soprano-devel
43 BuildRequires:  strigi-devel >= 0.7.0
44 BuildRequires:  taglib-devel >= 1.6
45 BuildRequires:  taglib-extras-devel >= 1.0.0
46 BuildRequires:  xorg-lib-libXpm-devel
47 Requires(post,postun):  /sbin/ldconfig
48 Requires:       kde4-kdemultimedia-audiocd
49 Requires:       kde4-phonon
50 Requires:       qtscriptbindings
51 Suggests:       libvisual-plugin-actor-JESS
52 Suggests:       libvisual-plugin-actor-bumpscope
53 Suggests:       libvisual-plugin-actor-corona
54 Suggests:       libvisual-plugin-actor-flower
55 Suggests:       libvisual-plugin-actor-gdkpixbuf
56 Suggests:       libvisual-plugin-actor-gforce
57 Suggests:       libvisual-plugin-actor-gstreamer
58 Suggests:       libvisual-plugin-actor-infinite
59 Suggests:       libvisual-plugin-actor-jakdaw
60 Suggests:       libvisual-plugin-actor-lv_analyzer
61 Suggests:       libvisual-plugin-actor-lv_gltest
62 Suggests:       libvisual-plugin-actor-lv_scope
63 Suggests:       libvisual-plugin-actor-madspin
64 Suggests:       libvisual-plugin-actor-nastyfft
65 Suggests:       libvisual-plugin-actor-oinksie
66 Suggests:       libvisual-plugin-input-alsa
67 Suggests:       libvisual-plugin-input-esd
68 Suggests:       libvisual-plugin-input-jack
69 Suggests:       libvisual-plugin-input-mplayer
70 Suggests:       libvisual-plugin-morph-alphablend
71 Suggests:       libvisual-plugin-morph-flash
72 Suggests:       libvisual-plugin-morph-slide
73 Suggests:       libvisual-plugin-morph-tentacle
74 Obsoletes:      amarok-arts
75 Obsoletes:      amarok-xmms
76 # It should require mysql-embeded
77 Requires:       mysql >= 5.1.31-3
78 Conflicts:      mysql < 5.1.31-3
79 # sr@Latn vs. sr@latin
80 Conflicts:      glibc-misc < 6:2.7
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %description
84 A KDE audio player.
85
86 %description -l pl.UTF-8
87 Odtwarzacz audio dla KDE.
88
89 %package scripts
90 Summary:        amaroK scripts
91 Summary(pl.UTF-8):      Skrypty amaroKa
92 Group:          X11/Applications/Multimedia
93 Requires:       %{name} = %{version}-%{release}
94 Requires:       kde4-kdebase-kdialog
95
96 %description scripts
97 amaroK scripts allow you extend amaroK functionality.
98
99 You can learn more about scripts in amaroK from here:
100 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
101
102 %description scripts -l pl.UTF-8
103 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
104
105 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
106 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
107
108 %prep
109 %setup -q
110 %patch0 -p1
111
112 %build
113 install -d build
114 cd build
115 %cmake ..
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} -C build install \
123         DESTDIR=$RPM_BUILD_ROOT \
124         kde_htmldir=%{_kdedocdir} \
125         kde_libs_htmldir=%{_kdedocdir}
126
127 # remove bogus dir
128 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
129
130 # remove unsupported locale
131 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
132
133 # remove .so symlinks so that noone gets the stupid idea to package them
134 rm -f $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
135
136 %find_lang %{name} --all-name --with-kde
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post           -p /sbin/ldconfig
142 %postun         -p /sbin/ldconfig
143
144 %files -f %{name}.lang
145 %defattr(644,root,root,755)
146 %doc AUTHORS ChangeLog README
147 %attr(755,root,root) %{_bindir}/amarok
148 %attr(755,root,root) %{_bindir}/amarokpkg
149 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
150 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
151 %attr(755,root,root) %{_bindir}/amarok_afttagger
152 %attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
153 %attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
155 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
157 %attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
159 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
161 %attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libamarok-transcoding.so.?
163 %attr(755,root,root) %{_libdir}/libamarok-transcoding.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
165 %attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
166 %attr(755,root,root) %{_libdir}/libampache_account_login.so
167 %attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
168 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
169 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
170 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
171 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
172 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
173 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
174 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
175 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
176 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
177 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
178 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
179 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_labels.so
180 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
181 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
182 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_similarArtists.so
183 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_upcomingEvents.so
184 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
185 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
186 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
187 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
188 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_labels.so
189 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
190 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
191 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_similarArtists.so
192 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
193 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
194 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
195 %attr(755,root,root) %{_libdir}/kde4/amarok_massstorage-device.so
196 %attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
197 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
198 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
199 %attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
200 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
201 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
202 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
203 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
204 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
205 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
206 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
207 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-playdarcollection.so
208 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-upnpcollection.so
209 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_tabs.so
210 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_tabs.so
211 %dir %{_datadir}/apps/amarok
212 %dir %{_datadir}/apps/amarok/scripts
213 %{_datadir}/apps/amarok/data
214 %{_datadir}/apps/amarok/icons
215 %{_datadir}/apps/amarok/images
216 %{_datadir}/apps/amarok/amarok.notifyrc
217 %{_datadir}/apps/desktoptheme
218 %{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
219 %{_datadir}/config.kcfg/amarokconfig.kcfg
220 %{_datadir}/config/amarok.knsrc
221 %{_datadir}/config/amarokapplets.knsrc
222 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
223 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
224 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
225 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
226 %{_datadir}/dbus-1/interfaces/org.kde.amarok.App.xml
227 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
228 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
229 %{_datadir}/applications/kde4/amarok_containers.desktop
230 %{_datadir}/kde4/services/amarok.protocol
231 %{_datadir}/kde4/services/amaroklastfm.protocol
232 %{_datadir}/kde4/services/amarokitpc.protocol
233 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
234 %{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
235 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
236 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
237 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
238 %{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
239 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
240 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
241 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
242 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
243 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
244 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
245 %{_datadir}/kde4/services/amarok-context-applet-labels.desktop
246 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
247 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
248 %{_datadir}/kde4/services/amarok-context-applet-similarArtists.desktop
249 %{_datadir}/kde4/services/amarok-context-applet-upcomingEvents.desktop
250 %{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
251 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
252 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
253 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
254 %{_datadir}/kde4/services/amarok-data-engine-labels.desktop
255 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
256 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
257 %{_datadir}/kde4/services/amarok-data-engine-similarArtists.desktop
258 %{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
259 %{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
260 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
261 %{_datadir}/kde4/services/amarok_massstorage-device.desktop
262 %{_datadir}/kde4/services/amarok_service_ampache.desktop
263 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
264 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
265 %{_datadir}/kde4/services/amarok_service_lastfm.desktop
266 %{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
267 %{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
268 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
269 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
270 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
271 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
272 %{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
273 %{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
274 %{_datadir}/kde4/services/amarok-context-applet-tabs.desktop
275 %{_datadir}/kde4/services/amarok-data-engine-tabs.desktop
276 %{_datadir}/kde4/services/amarok_collection-playdarcollection.desktop
277 %{_datadir}/kde4/services/amarok_collection-upnpcollection.desktop
278 %{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
279 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
280 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
281 %{_datadir}/kde4/servicetypes/amarok_plugin.desktop
282 %{_desktopdir}/kde4/amarok.desktop
283 %{_iconsdir}/*/*/apps/amarok.*
284 %{_datadir}/config/amarok_homerc
285
286 %files scripts
287 %defattr(644,root,root,755)
288 %dir %{_datadir}/apps/amarok/scripts/radio_station_service
289 %{_datadir}/apps/amarok/scripts/radio_station_service/main.js
290 %{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
291 %dir %{_datadir}/apps/amarok/scripts/script_console
292 %{_datadir}/apps/amarok/scripts/script_console/main.js
293 %{_datadir}/apps/amarok/scripts/script_console/script.spec
294 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
295 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
296 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
297 %dir %{_datadir}/apps/amarok/scripts/librivox_service
298 %{_datadir}/apps/amarok/scripts/librivox_service/main.js
299 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
300 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
301 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
302 %{_datadir}/apps/amarok/scripts/librivox_service/script.spec
303 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
304 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
305 %{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
This page took 0.05428 seconds and 3 git commands to generate.