]> git.pld-linux.org Git - packages/amarok.git/blame - amarok.spec
- rpm-build-macros >= 1.600 required for fixed cmake macro
[packages/amarok.git] / amarok.spec
CommitLineData
a74cde9c 1# TODO
2# - try not to link with static mysql
3
4%define state stable
354c5f31 5%define qtver 4.7.0
ac4fcc4e 6%define kdever 4.5.0
b5eaa586 7
3dce540f 8Summary: A KDE audio player
78ae220a 9Summary(pl.UTF-8): Odtwarzacz audio dla KDE
3dce540f 10Name: amarok
1b86fd47
RT
11Version: 2.4.0
12Release: 1
3dce540f 13License: GPL
14Group: X11/Applications/Multimedia
d3b2a786 15Source0: ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
1b86fd47 16# Source0-md5: bdb6ddc8e38d0982a0786ff8ac96d923
d3b2a786 17Patch0: %{name}-disable_qtscriptbindings_check_fix.patch
567ab89c 18URL: http://amarok.kde.org/
a74cde9c 19BuildRequires: QtNetwork-devel >= %{qtver}
a74cde9c 20BuildRequires: QtSql-devel >= %{qtver}
3138c2ac 21BuildRequires: automoc4 >= 0.9.88
30124835 22BuildRequires: cmake >= 2.8.0
a74cde9c 23BuildRequires: curl-devel
f3a2739c 24BuildRequires: gettext-devel
a74cde9c 25BuildRequires: glib2-devel
63a59d76 26BuildRequires: kde4-kdelibs-devel >= %{kdever}
aa9500c3 27BuildRequires: kde4-kdemultimedia-devel >= %{kdever}
a74cde9c 28BuildRequires: libgpod-devel >= 0.7.0
214a918d 29BuildRequires: liblastfm-devel
a74cde9c 30BuildRequires: libmtp-devel >= 0.3.0
1b86fd47 31BuildRequires: libofa-devel
68864201 32BuildRequires: libwrap-devel
a74cde9c 33BuildRequires: loudmouth-devel
a74cde9c 34BuildRequires: mysql-devel >= 5.1.31-3
6fc2033f 35BuildRequires: pcre-devel
f0306acf 36BuildRequires: pkgconfig
5bb3705c 37BuildRequires: qca-devel
a74cde9c 38BuildRequires: qt4-build >= %{qtver}
39BuildRequires: qt4-qmake >= %{qtver}
40BuildRequires: qtscriptbindings
911fd182 41BuildRequires: rpmbuild(macros) >= 1.600
68864201 42BuildRequires: soprano-devel
30124835 43BuildRequires: strigi-devel >= 0.7.0
214a918d
SP
44BuildRequires: taglib-devel >= 1.6
45BuildRequires: taglib-extras-devel >= 1.0.0
a74cde9c 46BuildRequires: xorg-lib-libXpm-devel
47Requires(post,postun): /sbin/ldconfig
a74cde9c 48Requires: kde4-kdemultimedia-audiocd
49Requires: kde4-phonon
50Requires: qtscriptbindings
8028f5c0
PG
51Suggests: libvisual-plugin-actor-JESS
52Suggests: libvisual-plugin-actor-bumpscope
53Suggests: libvisual-plugin-actor-corona
54Suggests: libvisual-plugin-actor-flower
55Suggests: libvisual-plugin-actor-gdkpixbuf
56Suggests: libvisual-plugin-actor-gforce
a74cde9c 57Suggests: libvisual-plugin-actor-gstreamer
8028f5c0
PG
58Suggests: libvisual-plugin-actor-infinite
59Suggests: libvisual-plugin-actor-jakdaw
60Suggests: libvisual-plugin-actor-lv_analyzer
61Suggests: libvisual-plugin-actor-lv_gltest
62Suggests: libvisual-plugin-actor-lv_scope
63Suggests: libvisual-plugin-actor-madspin
64Suggests: libvisual-plugin-actor-nastyfft
65Suggests: libvisual-plugin-actor-oinksie
66Suggests: libvisual-plugin-input-alsa
67Suggests: libvisual-plugin-input-esd
68Suggests: libvisual-plugin-input-jack
69Suggests: libvisual-plugin-input-mplayer
70Suggests: libvisual-plugin-morph-alphablend
71Suggests: libvisual-plugin-morph-flash
72Suggests: libvisual-plugin-morph-slide
73Suggests: libvisual-plugin-morph-tentacle
86666641 74Obsoletes: amarok-arts
1581e7f4 75Obsoletes: amarok-xmms
a74cde9c 76# It should require mysql-embeded
77Requires: mysql >= 5.1.31-3
78Conflicts: mysql < 5.1.31-3
3be5e8cd 79# sr@Latn vs. sr@latin
80Conflicts: glibc-misc < 6:2.7
3dce540f 81BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83%description
84A KDE audio player.
85
86426fe7 86%description -l pl.UTF-8
3dce540f 87Odtwarzacz audio dla KDE.
88
9d393535
ER
89%package scripts
90Summary: amaroK scripts
78ae220a 91Summary(pl.UTF-8): Skrypty amaroKa
9d393535
ER
92Group: X11/Applications/Multimedia
93Requires: %{name} = %{version}-%{release}
a74cde9c 94Requires: kde4-kdebase-kdialog
9d393535
ER
95
96%description scripts
97amaroK scripts allow you extend amaroK functionality.
98
99You can learn more about scripts in amaroK from here:
2fde3dac 100<http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
9d393535 101
86426fe7
JR
102%description scripts -l pl.UTF-8
103Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
cb7dcc83 104
86426fe7 105Więcej o skryptach w amaroKu można dowiedzieć się stąd:
2fde3dac 106<http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
cb7dcc83 107
3dce540f 108%prep
d6f0ca1c 109%setup -q
d3b2a786 110%patch0 -p1
b5eaa586 111
3dce540f 112%build
a74cde9c 113install -d build
114cd build
68864201 115%cmake ..
3dce540f 116
9a083733 117%{__make}
3dce540f 118
119%install
120rm -rf $RPM_BUILD_ROOT
121
a74cde9c 122%{__make} -C build install \
3dce540f 123 DESTDIR=$RPM_BUILD_ROOT \
bd5fd9cb 124 kde_htmldir=%{_kdedocdir} \
125 kde_libs_htmldir=%{_kdedocdir}
43342c86 126
3248aa1e 127# remove bogus dir
128rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
129
d3b2a786 130# remove unsupported locale
b10a2a5e 131rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
d3b2a786 132
bcfb337c 133# remove .so symlinks so that noone gets the stupid idea to package them
8d9cb0f5 134rm -f $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
bcfb337c 135
d3b2a786 136%find_lang %{name} --all-name --with-kde
3dce540f 137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
a74cde9c 141%post -p /sbin/ldconfig
142%postun -p /sbin/ldconfig
b5eaa586 143
aed7613d 144%files -f %{name}.lang
3dce540f 145%defattr(644,root,root,755)
2f1d9ab2 146%doc AUTHORS ChangeLog README
d4535bda 147%attr(755,root,root) %{_bindir}/amarok
214a918d 148%attr(755,root,root) %{_bindir}/amarokpkg
b5eaa586 149%attr(755,root,root) %{_bindir}/amarokcollectionscanner
a74cde9c 150%attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
151%attr(755,root,root) %{_bindir}/amarok_afttagger
1712a7ec 152%attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
153%attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
1712a7ec 154%attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
155%attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
a74cde9c 156%attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
157%attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
a74cde9c 158%attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
159%attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
a19a7a80 160%attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
161%attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
1b86fd47
RT
162%attr(755,root,root) %ghost %{_libdir}/libamarok-transcoding.so.?
163%attr(755,root,root) %{_libdir}/libamarok-transcoding.so.*.*.*
164%attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
165%attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
8d9cb0f5 166%attr(755,root,root) %{_libdir}/libampache_account_login.so
1712a7ec 167%attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
168%attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
169%attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
170%attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
171%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
172%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
173%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
174%attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
a74cde9c 175%attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
1712a7ec 176%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
a74cde9c 177%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
1712a7ec 178%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
68864201 179%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_labels.so
a74cde9c 180%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
1712a7ec 181%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
a19a7a80 182%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_similarArtists.so
183%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_upcomingEvents.so
1712a7ec 184%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
185%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
a74cde9c 186%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
1712a7ec 187%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
68864201 188%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_labels.so
a74cde9c 189%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
1712a7ec 190%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
191%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_similarArtists.so
192%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
193%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
a74cde9c 194%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
1712a7ec 195%attr(755,root,root) %{_libdir}/kde4/amarok_massstorage-device.so
196%attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
a74cde9c 197%attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
198%attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
199%attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
200%attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
201%attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
a19a7a80 202%attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
a74cde9c 203%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
204%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
205%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
206%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
1b86fd47
RT
207%attr(755,root,root) %{_libdir}/kde4/amarok_collection-playdarcollection.so
208%attr(755,root,root) %{_libdir}/kde4/amarok_collection-upnpcollection.so
209%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_tabs.so
210%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_tabs.so
9d393535
ER
211%dir %{_datadir}/apps/amarok
212%dir %{_datadir}/apps/amarok/scripts
9d393535
ER
213%{_datadir}/apps/amarok/data
214%{_datadir}/apps/amarok/icons
215%{_datadir}/apps/amarok/images
5bb3705c 216%{_datadir}/apps/amarok/amarok.notifyrc
a74cde9c 217%{_datadir}/apps/desktoptheme
214a918d 218%{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
a74cde9c 219%{_datadir}/config.kcfg/amarokconfig.kcfg
220%{_datadir}/config/amarok.knsrc
214a918d 221%{_datadir}/config/amarokapplets.knsrc
a74cde9c 222%{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
223%{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
224%{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
214a918d 225%{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
1b86fd47
RT
226%{_datadir}/dbus-1/interfaces/org.kde.amarok.App.xml
227%{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
228%{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
229%{_datadir}/applications/kde4/amarok_containers.desktop
a74cde9c 230%{_datadir}/kde4/services/amarok.protocol
231%{_datadir}/kde4/services/amaroklastfm.protocol
d3b2a786 232%{_datadir}/kde4/services/amarokitpc.protocol
a74cde9c 233%{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
1712a7ec 234%{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
235%{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
236%{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
237%{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
238%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
239%{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
240%{_datadir}/kde4/services/amarok_collection-umscollection.desktop
a74cde9c 241%{_datadir}/kde4/services/amarok-containment-vertical.desktop
1712a7ec 242%{_datadir}/kde4/services/amarok-context-applet-albums.desktop
a74cde9c 243%{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
1712a7ec 244%{_datadir}/kde4/services/amarok-context-applet-info.desktop
68864201 245%{_datadir}/kde4/services/amarok-context-applet-labels.desktop
a74cde9c 246%{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
1712a7ec 247%{_datadir}/kde4/services/amarok-context-applet-photos.desktop
a19a7a80 248%{_datadir}/kde4/services/amarok-context-applet-similarArtists.desktop
249%{_datadir}/kde4/services/amarok-context-applet-upcomingEvents.desktop
1712a7ec 250%{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
251%{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
a74cde9c 252%{_datadir}/kde4/services/amarok-data-engine-current.desktop
1712a7ec 253%{_datadir}/kde4/services/amarok-data-engine-info.desktop
68864201 254%{_datadir}/kde4/services/amarok-data-engine-labels.desktop
a74cde9c 255%{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
1712a7ec 256%{_datadir}/kde4/services/amarok-data-engine-photos.desktop
257%{_datadir}/kde4/services/amarok-data-engine-similarArtists.desktop
258%{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
259%{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
a74cde9c 260%{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
1712a7ec 261%{_datadir}/kde4/services/amarok_massstorage-device.desktop
a74cde9c 262%{_datadir}/kde4/services/amarok_service_ampache.desktop
263%{_datadir}/kde4/services/amarok_service_ampache_config.desktop
264%{_datadir}/kde4/services/amarok_service_jamendo.desktop
265%{_datadir}/kde4/services/amarok_service_lastfm.desktop
266%{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
267%{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
268%{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
269%{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
270%{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
a74cde9c 271%{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
214a918d
SP
272%{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
273%{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
1b86fd47
RT
274%{_datadir}/kde4/services/amarok-context-applet-tabs.desktop
275%{_datadir}/kde4/services/amarok-data-engine-tabs.desktop
276%{_datadir}/kde4/services/amarok_collection-playdarcollection.desktop
277%{_datadir}/kde4/services/amarok_collection-upnpcollection.desktop
1712a7ec 278%{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
a74cde9c 279%{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
280%{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
281%{_datadir}/kde4/servicetypes/amarok_plugin.desktop
a74cde9c 282%{_desktopdir}/kde4/amarok.desktop
60b883ee 283%{_iconsdir}/*/*/apps/amarok.*
a74cde9c 284%{_datadir}/config/amarok_homerc
9d393535
ER
285
286%files scripts
287%defattr(644,root,root,755)
a74cde9c 288%dir %{_datadir}/apps/amarok/scripts/radio_station_service
289%{_datadir}/apps/amarok/scripts/radio_station_service/main.js
290%{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
291%dir %{_datadir}/apps/amarok/scripts/script_console
292%{_datadir}/apps/amarok/scripts/script_console/main.js
293%{_datadir}/apps/amarok/scripts/script_console/script.spec
294%dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
295%{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
296%{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
297%dir %{_datadir}/apps/amarok/scripts/librivox_service
298%{_datadir}/apps/amarok/scripts/librivox_service/main.js
299%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
214a918d 300%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
a74cde9c 301%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
302%{_datadir}/apps/amarok/scripts/librivox_service/script.spec
aed7613d 303%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
304%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
305%{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
This page took 0.150395 seconds and 4 git commands to generate.