]> git.pld-linux.org Git - packages/amarok.git/blame - amarok.spec
- updated BRs and Rs
[packages/amarok.git] / amarok.spec
CommitLineData
a74cde9c 1# TODO
2# - try not to link with static mysql
3
4%define state stable
c5257fed 5%define qtver 4.6.2
30124835 6%define kdever 4.4.4
b5eaa586 7
3dce540f 8Summary: A KDE audio player
78ae220a 9Summary(pl.UTF-8): Odtwarzacz audio dla KDE
3dce540f 10Name: amarok
30124835 11Version: 2.3.1
12Release: 1
3dce540f 13License: GPL
14Group: X11/Applications/Multimedia
d3b2a786 15Source0: ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
30124835 16# Source0-md5: 6679adaf5cc757b1515a9f03cdcb6066
d3b2a786 17Patch0: %{name}-disable_qtscriptbindings_check_fix.patch
567ab89c 18URL: http://amarok.kde.org/
a74cde9c 19BuildRequires: QtNetwork-devel >= %{qtver}
a74cde9c 20BuildRequires: QtSql-devel >= %{qtver}
3138c2ac 21BuildRequires: automoc4 >= 0.9.88
30124835 22BuildRequires: cmake >= 2.8.0
a74cde9c 23BuildRequires: curl-devel
f3a2739c 24BuildRequires: gettext-devel
a74cde9c 25BuildRequires: glib2-devel
63a59d76 26BuildRequires: kde4-kdelibs-devel >= %{kdever}
aa9500c3 27BuildRequires: kde4-kdemultimedia-devel >= %{kdever}
a74cde9c 28BuildRequires: libgpod-devel >= 0.7.0
214a918d 29BuildRequires: liblastfm-devel
a74cde9c 30BuildRequires: libmtp-devel >= 0.3.0
a74cde9c 31BuildRequires: loudmouth-devel
a74cde9c 32BuildRequires: mysql-devel >= 5.1.31-3
6fc2033f 33BuildRequires: pcre-devel
f0306acf 34BuildRequires: pkgconfig
5bb3705c 35BuildRequires: qca-devel
a74cde9c 36BuildRequires: qt4-build >= %{qtver}
37BuildRequires: qt4-qmake >= %{qtver}
38BuildRequires: qtscriptbindings
baa5dbe4 39BuildRequires: rpmbuild(macros) >= 1.129
30124835 40BuildRequires: strigi-devel >= 0.7.0
214a918d
SP
41BuildRequires: taglib-devel >= 1.6
42BuildRequires: taglib-extras-devel >= 1.0.0
a74cde9c 43BuildRequires: xorg-lib-libXpm-devel
44Requires(post,postun): /sbin/ldconfig
a74cde9c 45Requires: kde4-kdemultimedia-audiocd
46Requires: kde4-phonon
47Requires: qtscriptbindings
8028f5c0
PG
48Suggests: libvisual-plugin-actor-JESS
49Suggests: libvisual-plugin-actor-bumpscope
50Suggests: libvisual-plugin-actor-corona
51Suggests: libvisual-plugin-actor-flower
52Suggests: libvisual-plugin-actor-gdkpixbuf
53Suggests: libvisual-plugin-actor-gforce
a74cde9c 54Suggests: libvisual-plugin-actor-gstreamer
8028f5c0
PG
55Suggests: libvisual-plugin-actor-infinite
56Suggests: libvisual-plugin-actor-jakdaw
57Suggests: libvisual-plugin-actor-lv_analyzer
58Suggests: libvisual-plugin-actor-lv_gltest
59Suggests: libvisual-plugin-actor-lv_scope
60Suggests: libvisual-plugin-actor-madspin
61Suggests: libvisual-plugin-actor-nastyfft
62Suggests: libvisual-plugin-actor-oinksie
63Suggests: libvisual-plugin-input-alsa
64Suggests: libvisual-plugin-input-esd
65Suggests: libvisual-plugin-input-jack
66Suggests: libvisual-plugin-input-mplayer
67Suggests: libvisual-plugin-morph-alphablend
68Suggests: libvisual-plugin-morph-flash
69Suggests: libvisual-plugin-morph-slide
70Suggests: libvisual-plugin-morph-tentacle
86666641 71Obsoletes: amarok-arts
1581e7f4 72Obsoletes: amarok-xmms
a74cde9c 73# It should require mysql-embeded
74Requires: mysql >= 5.1.31-3
75Conflicts: mysql < 5.1.31-3
3be5e8cd 76# sr@Latn vs. sr@latin
77Conflicts: glibc-misc < 6:2.7
3dce540f 78BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80%description
81A KDE audio player.
82
86426fe7 83%description -l pl.UTF-8
3dce540f 84Odtwarzacz audio dla KDE.
85
9d393535
ER
86%package scripts
87Summary: amaroK scripts
78ae220a 88Summary(pl.UTF-8): Skrypty amaroKa
9d393535
ER
89Group: X11/Applications/Multimedia
90Requires: %{name} = %{version}-%{release}
a74cde9c 91Requires: kde4-kdebase-kdialog
9d393535
ER
92
93%description scripts
94amaroK scripts allow you extend amaroK functionality.
95
96You can learn more about scripts in amaroK from here:
2fde3dac 97<http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
9d393535 98
86426fe7
JR
99%description scripts -l pl.UTF-8
100Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
cb7dcc83 101
86426fe7 102Więcej o skryptach w amaroKu można dowiedzieć się stąd:
2fde3dac 103<http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
cb7dcc83 104
3dce540f 105%prep
d6f0ca1c 106%setup -q
d3b2a786 107%patch0 -p1
b5eaa586 108
3dce540f 109%build
a74cde9c 110install -d build
111cd build
112%cmake \
113 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
114 -DLIB_INSTALL_DIR=%{_libdir} \
50398d35 115 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
a74cde9c 116%if "%{_lib}" == "lib64"
117 -DLIB_SUFFIX=64 \
118%endif
119 ../
3dce540f 120
9a083733 121%{__make}
3dce540f 122
123%install
124rm -rf $RPM_BUILD_ROOT
125
a74cde9c 126%{__make} -C build install \
3dce540f 127 DESTDIR=$RPM_BUILD_ROOT \
bd5fd9cb 128 kde_htmldir=%{_kdedocdir} \
129 kde_libs_htmldir=%{_kdedocdir}
43342c86 130
3248aa1e 131# remove bogus dir
132rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
133
d3b2a786 134# remove unsupported locale
b10a2a5e 135rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
d3b2a786 136
137%find_lang %{name} --all-name --with-kde
3dce540f 138
139%clean
140rm -rf $RPM_BUILD_ROOT
141
a74cde9c 142%post -p /sbin/ldconfig
143%postun -p /sbin/ldconfig
b5eaa586 144
aed7613d 145%files -f %{name}.lang
3dce540f 146%defattr(644,root,root,755)
2f1d9ab2 147%doc AUTHORS ChangeLog README
d4535bda 148%attr(755,root,root) %{_bindir}/amarok
214a918d 149%attr(755,root,root) %{_bindir}/amarokpkg
b5eaa586 150%attr(755,root,root) %{_bindir}/amarokcollectionscanner
a74cde9c 151%attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
152%attr(755,root,root) %{_bindir}/amarok_afttagger
153%attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
154%attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
a74cde9c 155%attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
156%attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
a19a7a80 157%attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
158%attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
a74cde9c 159%attr(755,root,root) %{_libdir}/strigi/strigita_audible.so
160%attr(755,root,root) %{_libdir}/strigi/strigita_mp4.so
161%attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
a74cde9c 162%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
163%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
a74cde9c 164%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
165%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
a19a7a80 166%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_similarArtists.so
167%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_upcomingEvents.so
168%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_similarArtists.so
169%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
a74cde9c 170%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
171%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
a74cde9c 172%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
173%attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
174%attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
175%attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
176%attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
177%attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
a19a7a80 178%attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
a74cde9c 179%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
180%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
181%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
182%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
214a918d
SP
183%attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
184%attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
185%attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
186%attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
187%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
188%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
189%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
190%attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
191%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
192%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
193%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
194%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
195%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
196%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
197%attr(755,root,root) %{_libdir}/kde4/amarok_massstorage-device.so
198%attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
9d393535 199%dir %{_datadir}/apps/amarok
214a918d
SP
200%attr(755,root,root) %{_libdir}/libamaroklib.so
201%attr(755,root,root) %{_libdir}/libamarokocsclient.so
623f83d9 202%attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
203%attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
d3b2a786 204%attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so
205%attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
206%attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
214a918d 207%attr(755,root,root) %{_libdir}/libamarokpud.so
9d393535 208%dir %{_datadir}/apps/amarok/scripts
9d393535
ER
209%{_datadir}/apps/amarok/data
210%{_datadir}/apps/amarok/icons
211%{_datadir}/apps/amarok/images
5bb3705c 212%{_datadir}/apps/amarok/amarok.notifyrc
a74cde9c 213%{_datadir}/apps/desktoptheme
214a918d 214%{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
a74cde9c 215%{_datadir}/config.kcfg/amarokconfig.kcfg
216%{_datadir}/config/amarok.knsrc
214a918d 217%{_datadir}/config/amarokapplets.knsrc
a74cde9c 218%{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
219%{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
220%{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
214a918d
SP
221%{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
222%{_datadir}/dbus-1/interfaces/org.kde.amarok.SqlCollection.xml
a74cde9c 223%{_datadir}/kde4/services/amarok.protocol
224%{_datadir}/kde4/services/amaroklastfm.protocol
d3b2a786 225%{_datadir}/kde4/services/amarokitpc.protocol
a74cde9c 226%{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
227%{_datadir}/kde4/services/amarok-containment-vertical.desktop
a74cde9c 228%{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
229%{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
a74cde9c 230%{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
a74cde9c 231%{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
a19a7a80 232%{_datadir}/kde4/services/amarok-context-applet-similarArtists.desktop
233%{_datadir}/kde4/services/amarok-context-applet-upcomingEvents.desktop
234%{_datadir}/kde4/services/amarok-data-engine-similarArtists.desktop
235%{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
a74cde9c 236%{_datadir}/kde4/services/amarok-data-engine-current.desktop
237%{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
a74cde9c 238%{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
239%{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
a74cde9c 240%{_datadir}/kde4/services/amarok_service_ampache.desktop
241%{_datadir}/kde4/services/amarok_service_ampache_config.desktop
242%{_datadir}/kde4/services/amarok_service_jamendo.desktop
243%{_datadir}/kde4/services/amarok_service_lastfm.desktop
244%{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
245%{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
246%{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
247%{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
248%{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
a74cde9c 249%{_datadir}/kde4/services/amarok-context-applet-albums.desktop
250%{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
251%{_datadir}/kde4/services/amarok_massstorage-device.desktop
252%{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
214a918d
SP
253%{_datadir}/kde4/services/amarok-context-applet-info.desktop
254%{_datadir}/kde4/services/amarok-context-applet-photos.desktop
255%{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
256%{_datadir}/kde4/services/amarok-data-engine-info.desktop
257%{_datadir}/kde4/services/amarok-data-engine-photos.desktop
258%{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
259%{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
260%{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
261%{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
262%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
263%{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
264%{_datadir}/kde4/services/amarok_collection-umscollection.desktop
a74cde9c 265%{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
266%{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
267%{_datadir}/kde4/servicetypes/amarok_plugin.desktop
268%{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
269%{_desktopdir}/kde4/amarok.desktop
60b883ee 270%{_iconsdir}/*/*/apps/amarok.*
a74cde9c 271%{_datadir}/config/amarok_homerc
9d393535
ER
272
273%files scripts
274%defattr(644,root,root,755)
a74cde9c 275%dir %{_datadir}/apps/amarok/scripts/radio_station_service
276%{_datadir}/apps/amarok/scripts/radio_station_service/main.js
277%{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
278%dir %{_datadir}/apps/amarok/scripts/script_console
279%{_datadir}/apps/amarok/scripts/script_console/main.js
280%{_datadir}/apps/amarok/scripts/script_console/script.spec
281%dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
282%{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
283%{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
284%dir %{_datadir}/apps/amarok/scripts/librivox_service
285%{_datadir}/apps/amarok/scripts/librivox_service/main.js
286%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
214a918d 287%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
a74cde9c 288%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
289%{_datadir}/apps/amarok/scripts/librivox_service/script.spec
aed7613d 290%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
291%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
292%{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
This page took 0.088372 seconds and 4 git commands to generate.