]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
- fix swig perl build
[packages/amanda.git] / amanda.spec
1 #
2 # Conditional build:
3 %bcond_without  xfs     # without (possible) support for xfsdump
4 %bcond_without  samba   # without smbclient support
5 %bcond_without  client  # without client package
6 %bcond_without  server  # without server package
7
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        A network-capable tape backup solution
10 Summary(pl.UTF-8):      Sieciowo zorientowany system tworzenia kopii zapasowych
11 Name:           amanda
12 Version:        3.3.6
13 Release:        5
14 License:        BSD
15 Group:          Networking/Utilities
16 Source0:        http://downloads.sourceforge.net/amanda/%{name}-%{version}.tar.gz
17 # Source0-md5:  99559bd84b358701cf943fcc347d8914
18 Source1:        %{name}-srv.crontab
19 Source2:        %{name}.inetd
20 Source3:        %{name}idx.inetd
21 Source4:        amidxtape.inetd
22 Source5:        k5%{name}.inet
23 # http://amanda.svn.sourceforge.net/viewvc/amanda/amanda/branches/3_2/contrib/convert-zd-mtx-to-robot.sh
24 Source6:        convert-zd-mtx-to-robot.sh
25 Source7:        %{name}-ssh_config
26 # https://github.com/janekr/amlvm-snapshot
27 Source8:        amlvm-snapshot.conf
28 Source9:        amlvm-snapshot.pl
29 Source10:       amlvm-snapshot.README
30 Patch0:         %{name}-no_libnsl.patch
31 Patch1:         %{name}-chg-zd-mtx-sh.patch
32 Patch2:         %{name}-tar.patch
33 Patch3:         %{name}-common.patch
34 Patch4:         %{name}-as_needed.patch
35 Patch5:         %{name}-tapetypes.patch
36 Patch6:         %{name}-FHS.patch
37 Patch7:         %{name}-no-buildtime-ipv6.patch
38 Patch8:         %{name}-heimdal.patch
39 Patch9:         %{name}-ac.patch
40 Patch11:        %{name}-amstar-exclude-fix.patch
41 Patch12:        %{name}-krb5-auth.patch
42 Patch13:        %{name}-amstar-device.patch
43 Patch14:        swig.patch
44 URL:            http://www.amanda.org/
45 %{?with_samba:BuildRequires:    /usr/bin/smbclient}
46 BuildRequires:  autoconf >= 2.53
47 BuildRequires:  automake
48 BuildRequires:  curl-devel >= 7.10.0
49 BuildRequires:  dump
50 BuildRequires:  flex
51 BuildRequires:  glib2-devel
52 BuildRequires:  gnuplot
53 BuildRequires:  heimdal-devel
54 BuildRequires:  rpmbuild(macros) >= 1.654
55 # curl is broken, see curl-config --libs (c8cba693)
56 BuildRequires:  keyutils-devel
57 BuildRequires:  libtool
58 BuildRequires:  libxslt-progs
59 BuildRequires:  ncurses-devel
60 BuildRequires:  openssh-clients
61 BuildRequires:  openssl-devel
62 BuildRequires:  perl-devel >= 5.6.0
63 BuildRequires:  pkgconfig
64 BuildRequires:  readline-devel >= 4.2
65 BuildRequires:  rpm-perlprov
66 BuildRequires:  rpmbuild(macros) >= 1.654
67 BuildRequires:  swig
68 %{?with_xfs:BuildRequires:      xfsdump}
69 Conflicts:      pwdutils < 3.1.2-2
70 Conflicts:      shadow < 1:4.0.4.1-4
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 # for some unknown reason those get detected in R but not in P (Tie::StdHash comes from perl)
74 %define         _noautoreq_perl Tie::StdHash Amanda::Recovery::Clerk::Feedback Amanda::Taper::Scribe::Feedback
75
76 %define         _ulibdir        %{_prefix}/lib
77
78 %description
79 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
80 backup system that allows the administrator of a LAN to set up a
81 single master backup server to back up multiple hosts to a single
82 large capacity tape drive. AMANDA uses native dump and/or GNU tar
83 facilities and can back up a large number of workstations running
84 multiple versions of Unix. Newer versions of AMANDA (including this
85 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
86 The amanda package contains the core AMANDA programs and will need to
87 be installed on both AMANDA clients and AMANDA servers. Note that you
88 will have to install the amanda-client and amanda-server packages as
89 well.
90
91 %description -l pl.UTF-8
92 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
93 zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
94 hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
95 Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
96 Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
97 podstawowe pliki programu i powinien być zainstalowany zarówno na
98 serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
99 amanda-client i amanda-server!
100
101 %package common
102 Summary:        Amanda common files
103 Summary(pl.UTF-8):      Wspólne pliki pakietu amanda
104 Group:          Networking/Utilities
105 Requires(postun):       /usr/sbin/groupdel
106 Requires(postun):       /usr/sbin/userdel
107 Requires(pre):  /bin/id
108 Requires(pre):  /usr/bin/chsh
109 Requires(pre):  /usr/bin/getgid
110 Requires(pre):  /usr/sbin/groupadd
111 Requires(pre):  /usr/sbin/useradd
112 %requires_ge glib2
113 Requires:       setup >= 2.6.1-1
114 Provides:       group(amanda)
115 Provides:       user(amanda)
116 Obsoletes:      amanda-libs
117 Obsoletes:      amanda-perl
118
119 %description common
120 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
121 backup system that allows the administrator of a LAN to set up a
122 single master backup server to back up multiple hosts to a single
123 large capacity tape drive. AMANDA uses native dump and/or GNU tar
124 facilities and can back up a large number of workstations running
125 multiple versions of Unix. Newer versions of AMANDA (including this
126 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
127 The amanda package contains the core AMANDA programs and will need to
128 be installed on both AMANDA clients and AMANDA servers. Note that you
129 will have to install the amanda-client and amanda-server packages as
130 well.
131
132 Amanda common files.
133
134 %description common -l pl.UTF-8
135 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
136 zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
137 hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
138 Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
139 Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
140 podstawowe pliki programu i powinien być zainstalowany zarówno na
141 serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
142 amanda-client i amanda-server!
143
144 Wspólne pliki pakietu amanda.
145
146 %package client
147 Summary:        The client side of Amanda
148 Summary(pl.UTF-8):      Klient Amandy
149 Group:          Networking/Utilities
150 Requires(post): /bin/hostname
151 Requires(post): /usr/bin/ssh-keygen
152 Requires:       %{name}-common = %{version}-%{release}
153 Requires:       rc-inetd
154 Suggests:       gzip
155 Suggests:       openssh-clients
156 Suggests:       openssh-server
157 Suggests:       star
158 Suggests:       tar
159 Conflicts:      tar < 1.15
160
161 %description client
162 The Amanda-client package should be installed on any machine that will
163 be backed up by AMANDA (including the server if it also needs to be
164 backed up). You will also need to install the amanda package to each
165 AMANDA client. It requires at least one of dump and GNU tar installed.
166
167 %description client -l pl.UTF-8
168 Ten pakiet powinien być zainstalowany ma maszynach, z których
169 zawartości będą tworzone kopie zapasowe. Wymaga zainstalowanego co
170 najmniej jednego z pakietów dump i GNU tar.
171
172 %package server
173 Summary:        The server side of Amanda
174 Summary(pl.UTF-8):      Serwer Amandy
175 Group:          Networking/Utilities
176 Requires(post): /bin/hostname
177 Requires(post): /usr/bin/ssh-keygen
178 Requires:       %{name}-common = %{version}-%{release}
179 Requires:       /etc/cron.d
180 Requires:       crondaemon
181 Requires:       gnuplot
182 Requires:       mt-st
183 Requires:       mtx
184 Requires:       rc-inetd
185 Suggests:       openssh-clients
186 Suggests:       openssh-server
187 Obsoletes:      amanda
188 Obsoletes:      amanda-perl-server
189
190 %description server
191 The amanda-server package should be installed on the AMANDA server,
192 the machine attached to the device (such as a tape drive) where
193 backups will be written. You will also need to install the amanda
194 package to the AMANDA server. And, if the server is also to be backed
195 up, the server also needs to have the amanda-client package installed.
196
197 %description server -l pl.UTF-8
198 Ten pakiet powinien być zainstalowany na maszynach, na których będą
199 magazynowane kopie zapasowe (lub do których podpięte są urządzenia
200 typu streamer).
201
202 %prep
203 %setup -q
204 %patch0 -p1
205 %patch1 -p1
206 %patch2 -p1
207 %patch3 -p1
208 %patch4 -p1
209 %patch5 -p1
210 %patch6 -p1
211 %patch7 -p1
212 %patch8 -p1
213 %patch9 -p1
214 %patch11 -p1
215 %patch12 -p1
216 %patch13 -p1
217 %patch14 -p1
218 cp -a %{SOURCE10} .
219
220 find perl/ -name '*.swg' -print0 | xargs -0 touch
221
222 %build
223 %{__aclocal} -I config -I config/gettext-macros -I config/gnulib -I config/amanda -I config/macro-archive
224 %{__autoconf}
225 %{__automake}
226 %configure \
227         DUMP=/sbin/dump \
228         GZIP=/bin/gzip \
229         MAILER=/bin/mail \
230         MT=/bin/mt \
231         MTX=/usr/sbin/mtx \
232         PRINT=/usr/bin/lpr \
233         RESTORE=/sbin/restore \
234         %{?with_xfs:XFSDUMP=/sbin/xfsdump} \
235         %{?with_xfs:XFSRESTORE=/sbin/xfsrestore} \
236         --disable-static \
237         --enable-shared \
238         %{!?with_server:--without-server} \
239         %{!?with_client:--without-client} \
240         --with-index-server=localhost \
241         --with-user=amanda \
242         --with-group=amanda \
243         --with-tape-device=/dev/null \
244         --with-fqdn \
245         %{?with_samba:--with-smbclient=%{_bindir}/smbclient} \
246         --with-star=%{_bindir}/star \
247         --with-gnuplot=%{_bindir}/gnuplot \
248         --with-bsd-security \
249         --with-bsdtcp-security \
250         --with-ssh-security \
251         --with-krb5-security \
252         --with-buffered-dump \
253         --with-amandahosts \
254         --with-configdir=%{_sysconfdir}/amanda \
255         --with-gnutar-listdir=%{_sharedstatedir}/amanda/gnutar-lists \
256         --with-amandates=%{_sharedstatedir}/amanda/amandates \
257         --with-debugging=%{_sharedstatedir}/amanda/debug \
258         --with-tmpdir=/var/tmp/amanda \
259         --with-amperldir=%{perl_vendorarch} \
260         --with-ipv6 \
261         --with-readline \
262         --disable-installperms
263
264 %{__make}
265
266 %install
267 rm -rf $RPM_BUILD_ROOT
268 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{amanda,cron.d,sysconfig/rc-inetd} \
269         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/{.gnupg,.ssh,gnutar-lists} \
270         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/debug/{amandad,client,server}
271
272 %{__make} install \
273         DESTDIR=$RPM_BUILD_ROOT
274
275 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amanda-srv
276 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE2} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amanda
277 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE3} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amandaidx
278 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE4} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amidxtape
279 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE5} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/k5amanda
280
281 cp -p example/amanda.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
282 cp -p example/amanda-client.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
283 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.amandahosts
284
285 install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sbindir}/amconvert-zd-mtx-to-robot.sh
286
287 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/config
288 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/{,client_}authorized_keys
289 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amdump{,.pub}
290 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover{,.pub}
291
292 %if %{with server}
293 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/amanda/lvm-snapshot.conf
294 %endif
295
296 %if %{with client}
297 sed -e 's|@@PERL_VENDORARCH@@|%{perl_vendorarch}|' %{SOURCE9} >$RPM_BUILD_ROOT%{_libdir}/amanda/application/amlvm-snapshot
298 %endif
299
300 > $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/amandates
301
302 # Amanda tools generate ssh keys with embeded commands pointing to /usr/lib
303 # Tools can't be "fixed" because keys generated on server are to be used on client
304 if [ "%{_lib}" != "lib" ] ; then
305         install -d $RPM_BUILD_ROOT%{_ulibdir}
306         ln -s %{_libdir}/amanda $RPM_BUILD_ROOT%{_ulibdir}/amanda
307 fi
308
309 find $RPM_BUILD_ROOT -name \*.la | xargs rm -f
310
311 %{__rm} $RPM_BUILD_ROOT%{_datadir}/amanda/{COPYRIGHT,ChangeLog,NEWS,ReleaseNotes}
312 %{__rm} $RPM_BUILD_ROOT%{_datadir}/amanda/example/{chg-multi,chg-scsi}.conf
313
314 %clean
315 rm -rf $RPM_BUILD_ROOT
316
317 %triggerpostun common -- amanda-libs < 2.6.0p2-3
318 echo "Adding amanda to disk and tape groups"
319 /usr/sbin/usermod -G disk,tape amanda
320 echo "Setting amanda shell to /bin/sh"
321 /usr/bin/chsh -s /bin/sh amanda
322 if [ -f %{_sharedstatedir}/amanda/.amandahosts ]; then
323         echo "Fixing permissions of %{_sharedstatedir}/amanda/.amandahosts file"
324         chown amanda:amanda %{_sharedstatedir}/amanda/.amandahosts
325         chmod 600 %{_sharedstatedir}/amanda/.amandahosts
326 fi
327
328 %triggerpostun common -- amanda-common < 3.3
329 %banner %{name}-common -e << EOF
330 In amanda 3.3 the default auth has changed to "bsdtcp",
331 if you are using the default "bsd" then you must add it
332 to your configuration:
333
334  *   in amanda.conf
335  *   in amanda-client.conf
336  *   in dumptype/disklist
337  *   in inetd (if no '-auth' argument to amandad)
338 EOF
339
340 %pre common
341 %groupadd -P %{name}-common -g 80 amanda
342 %useradd -P %{name}-common -u 80 -G disk,tape -d /var/lib/amanda -s /bin/sh -c "Amanda Backup user" -g amanda amanda
343
344 %postun common
345 if [ "$1" = "0" ]; then
346         %userremove amanda
347         %groupremove amanda
348 fi
349
350 %post client
351 %service -q rc-inetd reload
352 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amrecover ] ; then
353         HOST="`/bin/hostname`"
354         FQDNHOST="`/bin/hostname -f`"
355         if [ -z "$HOST" ] ; then
356                 COMMENT="root@client"
357         else
358                 COMMENT="root@$HOST"
359         fi
360         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amrecover -N "" || :
361         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
362         chmod 600 /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
363         if [ -n "$FQDNHOST" ]; then
364                 echo -n "from=\"$FQDNHOST\",no-port-forwarding,no-X11-forwarding,no-agent-forwarding,command=\"%{_ulibdir}/amanda/amandad -auth=ssh amindexd amidxtaped\" " >/var/lib/amanda/.ssh/server_authorized_keys
365                 cat /var/lib/amanda/.ssh/id_rsa_amrecover.pub >>/var/lib/amanda/.ssh/server_authorized_keys
366
367                 echo "Remember to copy the contents of /var/lib/amanda/.ssh/server_authorized_keys to"
368                 echo "/var/lib/amanda/.ssh/authorized_keys on amanda server"
369         fi
370 fi
371
372 %postun client
373 if [ "$1" = 0 ]; then
374         %service -q rc-inetd reload
375 fi
376
377 %post server
378 %service -q rc-inetd reload
379 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amdump ] ; then
380         HOST="`/bin/hostname`"
381         if [ -z "$HOST" ] ; then
382                 COMMENT="amanda@server"
383         else
384                 COMMENT="amanda@$HOST"
385         fi
386         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amdump -N "" || :
387         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
388         chmod 600 /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
389 fi
390 if [ "$1" = "1" ]; then
391         echo "Don't forget to edit /etc/cron.d/amanda-srv." 1>&2
392 fi
393
394 %postun server
395 if [ "$1" = 0 ]; then
396         %service -q rc-inetd reload
397 fi
398
399 %triggerpostun server -- amanda-server < 3.2.0
400 %banner %{name} -e << EOF
401 Warning: Tape changer configuration has chaged, please read
402 %{_docdir}/%{name}-server-%{version}/ReleaseNotes.gz
403 and %{_docdir}/%{name}-server-%{version}/NEWS.gz for details.
404 You can use %{_sbindir}/amconvert-zd-mtx-to-robot.sh script
405 to upgrade to chg-robot.
406 EOF
407
408 %files common
409 %defattr(644,root,root,755)
410 %doc AUTHORS COPYRIGHT ChangeLog NEWS README ReleaseNotes UPGRADING amlvm-snapshot.README
411 %attr(755,root,root) %{_libdir}/amanda/libamanda*.so
412 %attr(755,root,root) %{_libdir}/amanda/libamar*.so
413 %attr(755,root,root) %{_libdir}/amanda/libamxfer*.so
414 %attr(755,root,root) %{_libdir}/amanda/libamglue*.so
415 %attr(755,root,root) %{_libdir}/amanda/libndmjob*.so
416 %attr(755,root,root) %{_libdir}/amanda/libndmlib*.so
417 %attr(755,root,root) %{_libdir}/amanda/amndmjob
418 %attr(755,root,root) %{_libdir}/amanda/ndmjob
419 %attr(750,amanda,amanda) %dir %{_sysconfdir}/amanda
420 %dir %{_libdir}/amanda
421 %if %{_lib} != "lib"
422 %{_ulibdir}/amanda
423 %endif
424 %{_libdir}/amanda/amanda-sh-lib.sh
425 %attr(755,root,root) %{_sbindir}/amaespipe
426 %attr(755,root,root) %{_sbindir}/amarchiver
427 %attr(755,root,root) %{_sbindir}/amcrypt*
428 %attr(755,root,root) %{_sbindir}/amgetconf
429 %attr(755,root,root) %{_sbindir}/amgpgcrypt
430 %attr(750,amanda,amanda) %dir %{_datadir}/amanda
431 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/example
432 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/example/label-templates
433 %attr(640,amanda,amanda) %{_datadir}/amanda/example/*amanda*
434 %attr(640,amanda,amanda) %{_datadir}/amanda/example/disklist
435 %attr(640,amanda,amanda) %{_datadir}/amanda/example/label-templates/*.ps
436 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/template.d
437 %attr(640,amanda,amanda) %{_datadir}/amanda/template.d/*
438 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda
439 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.ssh
440 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.gnupg
441 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug
442 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/amandad
443 %attr(600,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/.amandahosts
444 %attr(600,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/.ssh/config
445 # Commented out so it won't get removed on uninstall
446 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/authorized_keys
447 %{_mandir}/man5/amanda-archive-format.5*
448 %{_mandir}/man7/amanda-auth.7*
449 %{_mandir}/man7/amanda-match.7*
450 %{_mandir}/man7/amanda-scripts.7*
451 %{_mandir}/man8/amaespipe.8*
452 %{_mandir}/man8/amanda.8*
453 %{_mandir}/man8/amarchiver.8*
454 %{_mandir}/man8/amcrypt*.8*
455 %{_mandir}/man8/amgetconf.8*
456 %{_mandir}/man8/amgpgcrypt.8*
457 %{_mandir}/man8/script-email.8*
458
459 %dir %{perl_vendorarch}/Amanda
460 %dir %{perl_vendorarch}/Amanda/Config
461 %dir %{perl_vendorarch}/Amanda/IPC
462 %{perl_vendorarch}/Amanda/Archive.pm
463 %{perl_vendorarch}/Amanda/BigIntCompat.pm
464 %{perl_vendorarch}/Amanda/ClientService.pm
465 %{perl_vendorarch}/Amanda/Config.pm
466 %{perl_vendorarch}/Amanda/Config/FoldingHash.pm
467 %{perl_vendorarch}/Amanda/Constants.pm
468 %{perl_vendorarch}/Amanda/Debug.pm
469 %{perl_vendorarch}/Amanda/Feature.pm
470 %{perl_vendorarch}/Amanda/Header.pm
471 %{perl_vendorarch}/Amanda/IPC/Binary.pm
472 %{perl_vendorarch}/Amanda/IPC/LineProtocol.pm
473 %{perl_vendorarch}/Amanda/MainLoop.pm
474 %{perl_vendorarch}/Amanda/NDMP.pm
475 %{perl_vendorarch}/Amanda/Paths.pm
476 %{perl_vendorarch}/Amanda/Process.pm
477 %{perl_vendorarch}/Amanda/Script.pm
478 %{perl_vendorarch}/Amanda/Script_App.pm
479 %{perl_vendorarch}/Amanda/Tests.pm
480 %{perl_vendorarch}/Amanda/Util.pm
481 %{perl_vendorarch}/Amanda/Xfer.pm
482 %dir %{perl_vendorarch}/auto/Amanda
483 %dir %{perl_vendorarch}/auto/Amanda/Archive
484 %dir %{perl_vendorarch}/auto/Amanda/Config
485 %dir %{perl_vendorarch}/auto/Amanda/Debug
486 %dir %{perl_vendorarch}/auto/Amanda/Feature
487 %dir %{perl_vendorarch}/auto/Amanda/Header
488 %dir %{perl_vendorarch}/auto/Amanda/IPC
489 %dir %{perl_vendorarch}/auto/Amanda/IPC/Binary
490 %dir %{perl_vendorarch}/auto/Amanda/MainLoop
491 %dir %{perl_vendorarch}/auto/Amanda/NDMP
492 %dir %{perl_vendorarch}/auto/Amanda/Tests
493 %dir %{perl_vendorarch}/auto/Amanda/Util
494 %dir %{perl_vendorarch}/auto/Amanda/Xfer
495 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Archive/*.so
496 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Config/*.so
497 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Feature/*.so
498 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Header/*.so
499 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/IPC/Binary/*.so
500 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Debug/*.so
501 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/MainLoop/*.so
502 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/NDMP/*.so
503 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Tests/*.so
504 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Util/*.so
505 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Xfer/*.so
506
507 %if %{with server}
508 %files server
509 %defattr(644,root,root,755)
510 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amidxtape
511 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amandaidx
512
513 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/amanda.conf
514 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/lvm-snapshot.conf
515
516 # Commented out so it won't get removed on uninstall
517 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/client_authorized_keys
518 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amdump*
519
520 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/server
521
522 %config(noreplace) %attr(640,root,root) /etc/cron.d/amanda-srv
523
524 %attr(755,root,root) %{_libdir}/amanda/libamdevice*.so
525 %attr(755,root,root) %{_libdir}/amanda/libamserver*.so
526
527 %attr(755,root,root) %{_libdir}/amanda/amcat.awk
528 %attr(755,root,root) %{_libdir}/amanda/amcheck-device
529 %attr(755,root,root) %{_libdir}/amanda/amdumpd
530 %attr(755,root,root) %{_libdir}/amanda/amidxtaped
531 %attr(755,root,root) %{_libdir}/amanda/amindexd
532 %attr(755,root,root) %{_libdir}/amanda/amlogroll
533 %attr(755,root,root) %{_libdir}/amanda/amplot.awk
534 %attr(755,root,root) %{_libdir}/amanda/amplot.g
535 %attr(755,root,root) %{_libdir}/amanda/amplot.gp
536 %attr(755,root,root) %{_libdir}/amanda/amtrmidx
537 %attr(755,root,root) %{_libdir}/amanda/amtrmlog
538 %attr(755,root,root) %{_libdir}/amanda/chg-disk
539 %attr(755,root,root) %{_libdir}/amanda/chg-lib.sh
540 %attr(755,root,root) %{_libdir}/amanda/chg-manual
541 %attr(755,root,root) %{_libdir}/amanda/chg-multi
542 %attr(755,root,root) %{_libdir}/amanda/chg-zd-mtx
543 %attr(755,root,root) %{_libdir}/amanda/chunker
544 %attr(755,root,root) %{_libdir}/amanda/driver
545 %attr(4750,root,amanda) %{_libdir}/amanda/dumper
546 %attr(4750,root,amanda) %{_libdir}/amanda/planner
547 %attr(755,root,root) %{_libdir}/amanda/taper
548
549 %attr(755,root,root) %{_sbindir}/activate-devpay
550 %attr(755,root,root) %{_sbindir}/amaddclient
551 %attr(755,root,root) %{_sbindir}/amadmin
552 %attr(4750,root,amanda) %{_sbindir}/amcheck
553 %attr(755,root,root) %{_sbindir}/amcheckdb
554 %attr(755,root,root) %{_sbindir}/amcheckdump
555 %attr(755,root,root) %{_sbindir}/amcleanup
556 %attr(755,root,root) %{_sbindir}/amcleanupdisk
557 %attr(755,root,root) %{_sbindir}/amconvert-zd-mtx-to-robot.sh
558 %attr(755,root,root) %{_sbindir}/amdevcheck
559 %attr(755,root,root) %{_sbindir}/amdump
560 %attr(755,root,root) %{_sbindir}/amfetchdump
561 %attr(755,root,root) %{_sbindir}/amflush
562 %attr(755,root,root) %{_sbindir}/amlabel
563 %attr(755,root,root) %{_sbindir}/amoverview
564 %attr(755,root,root) %{_sbindir}/amplot
565 %attr(755,root,root) %{_sbindir}/amreport
566 %attr(755,root,root) %{_sbindir}/amrestore
567 %attr(755,root,root) %{_sbindir}/amrmtape
568 %attr(755,root,root) %{_sbindir}/amserverconfig
569 %attr(755,root,root) %{_sbindir}/amservice
570 %attr(755,root,root) %{_sbindir}/amstatus
571 %attr(755,root,root) %{_sbindir}/amtape
572 %attr(755,root,root) %{_sbindir}/amtapetype
573 %attr(755,root,root) %{_sbindir}/amtoc
574 %attr(755,root,root) %{_sbindir}/amvault
575 %{_mandir}/man5/amanda.conf.5*
576 %{_mandir}/man5/disklist.5*
577 %{_mandir}/man5/tapelist.5*
578 %{_mandir}/man7/amanda-changers.7*
579 %{_mandir}/man7/amanda-compatibility.7*
580 %{_mandir}/man7/amanda-devices.7*
581 %{_mandir}/man7/amanda-interactivity.7*
582 %{_mandir}/man7/amanda-taperscan.7*
583 %{_mandir}/man8/amaddclient.8*
584 %{_mandir}/man8/amadmin.8*
585 %{_mandir}/man8/amcheck.8*
586 %{_mandir}/man8/amcheckdb.8*
587 %{_mandir}/man8/amcheckdump.8*
588 %{_mandir}/man8/amcleanup.8*
589 %{_mandir}/man8/amcleanupdisk.8*
590 %{_mandir}/man8/amdevcheck.8*
591 %{_mandir}/man8/amdump.8*
592 %{_mandir}/man8/amfetchdump.8*
593 %{_mandir}/man8/amflush.8*
594 %{_mandir}/man8/amlabel.8*
595 %{_mandir}/man8/amoverview.8*
596 %{_mandir}/man8/amplot.8*
597 %{_mandir}/man8/amreport.8*
598 %{_mandir}/man8/amrestore.8*
599 %{_mandir}/man8/amrmtape.8*
600 %{_mandir}/man8/amserverconfig.8*
601 %{_mandir}/man8/amservice.8*
602 %{_mandir}/man8/amstatus.8*
603 %{_mandir}/man8/amtape.8*
604 %{_mandir}/man8/amtapetype.8*
605 %{_mandir}/man8/amtoc.8*
606 %{_mandir}/man8/amvault.8*
607
608 %{perl_vendorarch}/Amanda/Changer.pm
609 %dir %{perl_vendorarch}/Amanda/Changer
610 %{perl_vendorarch}/Amanda/Changer/*.pm
611 %{perl_vendorarch}/Amanda/Cmdline.pm
612 %{perl_vendorarch}/Amanda/Curinfo.pm
613 %dir %{perl_vendorarch}/Amanda/Curinfo
614 %{perl_vendorarch}/Amanda/Curinfo/*.pm
615 %dir %{perl_vendorarch}/Amanda/DB
616 %{perl_vendorarch}/Amanda/DB/*.pm
617 %{perl_vendorarch}/Amanda/Device.pm
618 %{perl_vendorarch}/Amanda/Extract.pm
619 %{perl_vendorarch}/Amanda/Disklist.pm
620 %{perl_vendorarch}/Amanda/Holding.pm
621 %{perl_vendorarch}/Amanda/Interactivity.pm
622 %dir %{perl_vendorarch}/Amanda/Interactivity
623 %{perl_vendorarch}/Amanda/Interactivity/*.pm
624 %{perl_vendorarch}/Amanda/Logfile.pm
625 %dir %{perl_vendorarch}/Amanda/Recovery
626 %{perl_vendorarch}/Amanda/Recovery/*.pm
627 %{perl_vendorarch}/Amanda/Report.pm
628 %dir %{perl_vendorarch}/Amanda/Report
629 %{perl_vendorarch}/Amanda/Report/*.pm
630 %{perl_vendorarch}/Amanda/ScanInventory.pm
631 %{perl_vendorarch}/Amanda/Tapelist.pm
632 %dir %{perl_vendorarch}/Amanda/Taper
633 %{perl_vendorarch}/Amanda/Taper/*.pm
634 %dir %{perl_vendorarch}/Amanda/Taper/Scan
635 %{perl_vendorarch}/Amanda/Taper/Scan/*.pm
636 %{perl_vendorarch}/Amanda/XferServer.pm
637 %dir %{perl_vendorarch}/auto/Amanda/Cmdline
638 %dir %{perl_vendorarch}/auto/Amanda/Device
639 %dir %{perl_vendorarch}/auto/Amanda/Disklist
640 %dir %{perl_vendorarch}/auto/Amanda/Logfile
641 %dir %{perl_vendorarch}/auto/Amanda/Tapelist
642 %dir %{perl_vendorarch}/auto/Amanda/XferServer
643 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Cmdline/*.so
644 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Device/*.so
645 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Disklist/*.so
646 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Logfile/*.so
647 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Tapelist/*.so
648 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/XferServer/*.so
649 %endif
650
651 %if %{with client}
652 %files client
653 %defattr(644,root,root,755)
654 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amanda
655 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/k5amanda
656 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,amanda) %{_sysconfdir}/amanda/amanda-client.conf
657 # Commented out so it won't get removed on uninstall
658 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover*
659 %attr(640,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/amandates
660
661 %dir %{_libdir}/amanda/application
662 %attr(4750,root,amanda) %{_libdir}/amanda/application/ambsdtar
663 %attr(4750,root,amanda) %{_libdir}/amanda/application/amgtar
664 %attr(755,root,root) %{_libdir}/amanda/application/amlog-script
665 %attr(755,root,root) %{_libdir}/amanda/application/amlvm-snapshot
666 %attr(755,root,root) %{_libdir}/amanda/application/ampgsql
667 %attr(755,root,root) %{_libdir}/amanda/application/amraw
668 %attr(755,root,root) %{_libdir}/amanda/application/amsamba
669 %attr(4750,root,amanda) %{_libdir}/amanda/application/amstar
670 %attr(755,root,root) %{_libdir}/amanda/application/amsuntar
671 %attr(755,root,root) %{_libdir}/amanda/application/amzfs*
672 %attr(755,root,root) %{_libdir}/amanda/application/script-email
673
674 %attr(755,root,root) %{_libdir}/amanda/libamclient*.so
675 %attr(755,root,root) %{_libdir}/amanda/amandad
676 %attr(755,root,root) %{_libdir}/amanda/noop
677 %attr(755,root,root) %{_libdir}/amanda/patch-system
678 %attr(755,root,root) %{_libdir}/amanda/sendbackup
679 %attr(755,root,root) %{_libdir}/amanda/sendsize
680 %attr(755,root,root) %{_libdir}/amanda/teecount
681 %attr(4750,root,amanda) %{_libdir}/amanda/calcsize
682 %attr(4750,root,amanda) %{_libdir}/amanda/killpgrp
683 %attr(4750,root,amanda) %{_libdir}/amanda/rundump
684 %attr(4750,root,amanda) %{_libdir}/amanda/runtar
685 %attr(755,root,root) %{_libdir}/amanda/selfcheck
686 %attr(755,root,root) %{_sbindir}/amdump_client
687 %attr(755,root,root) %{_sbindir}/amoldrecover
688 %attr(755,root,root) %{_sbindir}/amrecover
689 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/gnutar-lists
690 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/client
691 %{_mandir}/man7/amanda-applications.7*
692 %{_mandir}/man5/amanda-client.conf.5*
693 %{_mandir}/man8/amdump_client.8*
694 %{_mandir}/man8/ambsdtar.8*
695 %{_mandir}/man8/amgtar.8*
696 %{_mandir}/man8/ampgsql.8*
697 %{_mandir}/man8/amrecover.8*
698 %{_mandir}/man8/amraw.8*
699 %{_mandir}/man8/amsamba.8*
700 %{_mandir}/man8/amstar.8*
701 %{_mandir}/man8/amsuntar.8*
702 %{_mandir}/man8/amzfs*.8*
703
704 %{perl_vendorarch}/Amanda/Application.pm
705 %dir %{perl_vendorarch}/Amanda/Application
706 %{perl_vendorarch}/Amanda/Application/Zfs.pm
707 %dir %{perl_vendorarch}/auto/Amanda/Application
708 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Application/*.so
709 %endif
This page took 0.104815 seconds and 4 git commands to generate.