]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
- fix heimdal kerberos case
[packages/amanda.git] / amanda.spec
1 #
2 # Conditional build:
3 %bcond_without  xfs     # without (possible) support for xfsdump
4 %bcond_without  samba   # without smbclient support
5 %bcond_without  client  # without client package
6 %bcond_without  server  # without server package
7 #
8 Summary:        A network-capable tape backup solution
9 Summary(pl.UTF-8):      Sieciowo zorientowany system tworzenia kopii zapasowych
10 Name:           amanda
11 Version:        2.6.0
12 Release:        2
13 License:        BSD
14 Group:          Networking/Utilities
15 Source0:        http://dl.sourceforge.net/amanda/%{name}-%{version}.tar.gz
16 # Source0-md5:  c347c1e573c33018f234750ac6435156
17 Source1:        %{name}-srv.crontab
18 Source2:        %{name}.inetd
19 Source3:        %{name}idx.inetd
20 Source4:        amidxtape.inetd
21 Patch0:         %{name}-no_libnsl.patch
22 Patch1:         %{name}-chg-zd-mtx-sh.patch
23 Patch2:         %{name}-tar.patch
24 Patch3:         %{name}-bashizm.patch
25 Patch4:         %{name}-as_needed.patch
26 Patch5:         %{name}-tapetypes.patch
27 Patch6:         %{name}-FHS.patch
28 Patch7:         %{name}-no-buildtime-ipv6.patch
29 Patch8:         %{name}-heimdal.patch
30 URL:            http://www.amanda.org/
31 BuildRequires:  autoconf >= 2.53
32 BuildRequires:  automake
33 BuildRequires:  curl-devel >= 7.10.0
34 BuildRequires:  dump
35 BuildRequires:  flex
36 BuildRequires:  glib2-devel
37 # curl is broken, see curl-config --libs
38 BuildRequires:  keyutils-devel
39 BuildRequires:  krb5-devel >= 1.6-4
40 BuildRequires:  libtool
41 BuildRequires:  libxslt-progs
42 BuildRequires:  ncurses-devel
43 BuildRequires:  openssh-clients
44 BuildRequires:  openssl-devel
45 BuildRequires:  perl-devel >= 5.6.0
46 BuildRequires:  pkgconfig
47 BuildRequires:  readline-devel >= 4.2
48 BuildRequires:  rpmbuild(macros) >= 1.268
49 %{?with_samba:BuildRequires:    samba-client}
50 BuildRequires:  swig
51 %{?with_xfs:BuildRequires:      xfsdump}
52 Conflicts:      shadow < 1:4.0.4.1-4
53 Conflicts:      pwdutils < 3.1.2-2
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %define         _ulibdir        %{_prefix}/lib
57
58 %description
59 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
60 backup system that allows the administrator of a LAN to set up a
61 single master backup server to back up multiple hosts to a single
62 large capacity tape drive. AMANDA uses native dump and/or GNU tar
63 facilities and can back up a large number of workstations running
64 multiple versions of Unix. Newer versions of AMANDA (including this
65 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
66 The amanda package contains the core AMANDA programs and will need to
67 be installed on both AMANDA clients and AMANDA servers. Note that you
68 will have to install the amanda-client and amanda-server packages as
69 well.
70
71 %description -l pl.UTF-8
72 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
73 zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
74 hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
75 Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
76 Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
77 podstawowe pliki programu i powinien być zainstalowany zarówno na
78 serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
79 amanda-client i amanda-server!
80
81 %package libs
82 Summary:        Amanda shared libraries
83 Summary(pl.UTF-8):      Biblioteki współdzielone pakietu amanda
84 Group:          Networking/Utilities
85 Requires(postun):       /usr/sbin/groupdel
86 Requires(postun):       /usr/sbin/userdel
87 Requires(pre):  /bin/id
88 Requires(pre):  /usr/bin/chsh
89 Requires(pre):  /usr/bin/getgid
90 Requires(pre):  /usr/sbin/groupadd
91 Requires(pre):  /usr/sbin/useradd
92 Provides:       group(amanda)
93 Provides:       user(amanda)
94
95 %description libs
96 Amanda shared libraries.
97
98 %description libs -l pl.UTF-8
99 Biblioteki współdzielone pakietu amanda.
100
101 %package client
102 Summary:        The client side of Amanda
103 Summary(pl.UTF-8):      Klient Amandy
104 Group:          Networking/Utilities
105 Requires(post): /bin/hostname
106 Requires(post): /usr/bin/ssh-keygen
107 Requires:       %{name}-libs = %{version}-%{release}
108 Requires:       rc-inetd
109 Suggests:       openssh-clients
110 Suggests:       openssh-server
111 Suggests:       tar
112 Suggests:       gzip
113 Suggests:       star
114 Conflicts:      tar < 1.15
115
116 %description client
117 The Amanda-client package should be installed on any machine that will
118 be backed up by AMANDA (including the server if it also needs to be
119 backed up). You will also need to install the amanda package to each
120 AMANDA client. It requires at least one of dump and GNU tar installed.
121
122 %description client -l pl.UTF-8
123 Ten pakiet powinien być zainstalowany ma maszynach, z których
124 zawartości będą tworzone kopie zapasowe. Wymaga zainstalowanego co
125 najmniej jednego z pakietów dump i GNU tar.
126
127 %package server
128 Summary:        The server side of Amanda
129 Summary(pl.UTF-8):      Serwer Amandy
130 Group:          Networking/Utilities
131 Requires(post): /bin/hostname
132 Requires(post): /usr/bin/ssh-keygen
133 Requires:       %{name}-libs = %{version}-%{release}
134 Requires:       /etc/cron.d
135 Requires:       crondaemon
136 Requires:       gnuplot
137 Requires:       mt-st
138 Requires:       mtx
139 Requires:       rc-inetd
140 Suggests:       openssh-clients
141 Suggests:       openssh-server
142 Obsoletes:      amanda
143
144 %description server
145 The amanda-server package should be installed on the AMANDA server,
146 the machine attached to the device (such as a tape drive) where
147 backups will be written. You will also need to install the amanda
148 package to the AMANDA server. And, if the server is also to be backed
149 up, the server also needs to have the amanda-client package installed.
150
151 %description server -l pl.UTF-8
152 Ten pakiet powinien być zainstalowany na maszynach, na których będą
153 magazynowane kopie zapasowe (lub do których podpięte są urządzenia
154 typu streamer).
155
156 %package perl
157 Summary:        Perl bindings for amanda
158 Summary(pl.UTF-8):      Wiązania perla dla Amandy
159 Group:          Networking/Utilities
160 Requires:       %{name}-libs = %{version}-%{release}
161
162 %description perl
163 Perl bindings for amanda.
164
165 %description perl -l pl.UTF-8
166 Wiązania perla dla Amandy.
167
168 %package perl-server
169 Summary:        Perl bindings for amanda server
170 Summary(pl.UTF-8):      Wiązania perla dla serwera Amandy
171 Group:          Networking/Utilities
172 Requires:       %{name}-perl = %{version}-%{release}
173 Requires:       %{name}-server = %{version}-%{release}
174
175 %description perl-server
176 Perl bindings for amanda server.
177
178 %description perl-server -l pl.UTF-8
179 Wiązania perla dla serwera Amandy.
180
181 %prep
182 %setup -q
183 %patch0 -p1
184 %patch1 -p1
185 %patch2 -p1
186 %patch3 -p1
187 %patch4 -p1
188 %patch5 -p1
189 %patch6 -p1
190 %patch7 -p1
191 %patch8 -p1
192
193 %build
194 %{__libtoolize}
195 %{__aclocal} -I config -I config/gettext-macros -I config/gnulib -I config/amanda -I config/macro-archive
196 %{__autoconf}
197 %{__automake}
198 %configure \
199         DUMP=/sbin/dump \
200         GNUPLOT=/usr/bin/gnuplot \
201         GZIP=/bin/gzip \
202         MAILER=/bin/mail \
203         MT=/bin/mt \
204         MTX=/usr/sbin/mtx \
205         PRINT=/usr/bin/lpr \
206         RESTORE=/sbin/restore \
207         STAR=/usr/bin/star \
208         %{?with_xfs:XFSDUMP=/sbin/xfsdump} \
209         %{?with_xfs:XFSRESTORE=/sbin/xfsrestore} \
210         --disable-static \
211         --enable-shared \
212         %{!?with_server:--without-server} \
213         %{!?with_client:--without-client} \
214         --with-index-server=localhost \
215         --with-user=amanda \
216         --with-group=amanda \
217         --with-tape-device=/dev/null \
218         --with-ftape-rawdevice=/dev/null \
219         --with-changer-device=/dev/null \
220         --with-fqdn \
221         %{?with_samba:--with-smbclient=%{_bindir}/smbclient} \
222         --with-bsd-security \
223         --with-ssh-security \
224         --with-krb5-security \
225         --without-krb4-security \
226         --with-buffered-dump \
227         --with-amandahosts \
228         --with-configdir=%{_sysconfdir}/amanda \
229         --with-gnutar-listdir=%{_sharedstatedir}/amanda/gnutar-lists \
230         --with-amandates=%{_sharedstatedir}/amanda/amandates \
231         --with-debugging=%{_sharedstatedir}/amanda/debug \
232         --with-tmpdir=/var/tmp \
233         --with-amperldir=%{perl_vendorarch} \
234         --with-ipv6 \
235         --disable-installperms
236
237 %{__make}
238
239 %install
240 rm -rf $RPM_BUILD_ROOT
241 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{amanda,cron.d,sysconfig/rc-inetd} \
242         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/{.gnupg,.ssh,gnutar-lists} \
243         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/debug/{amandad,client,server}
244
245 %{__make} install \
246         DESTDIR=$RPM_BUILD_ROOT
247
248 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amanda-srv
249 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE2} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amanda
250 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE3} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amandaidx
251 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE4} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amidxtape
252
253 install example/amanda.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
254 install example/amanda-client.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
255 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.amandahosts
256
257 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/{,client_}authorized_keys
258 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amdump{,.pub}
259 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover{,.pub}
260
261 > $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/amandates
262
263 # Amanda tools generate ssh keys with embeded commands pointing to /usr/lib
264 # Tools can't be "fixed" because keys generated on server are to be used on client
265 if [ "%{_lib}" != "lib" ] ; then
266         install -d $RPM_BUILD_ROOT%{_ulibdir}
267         ln -s %{_libdir}/amanda $RPM_BUILD_ROOT%{_ulibdir}/amanda
268 fi
269
270 find $RPM_BUILD_ROOT -name \*.la | xargs rm -f
271
272 %clean
273 rm -rf $RPM_BUILD_ROOT
274
275 %triggerpostun libs -- %{name}-libs < 2.5.1p2-1
276 echo "Adding amanda to disk and backup groups"
277 /usr/sbin/usermod -G disk,backup amanda
278 echo "Setting amanda shell to /bin/sh"
279 /usr/bin/chsh -s /bin/sh amanda
280 if [ -f %{_sharedstatedir}/amanda/.amandahosts ]; then
281         echo "Fixing permissions of %{_sharedstatedir}/amanda/.amandahosts file"
282         chown amanda:amanda %{_sharedstatedir}/amanda/.amandahosts
283         chmod 600 %{_sharedstatedir}/amanda/.amandahosts
284 fi
285
286 %pre libs
287 %groupadd -P %{name}-libs -g 80 amanda
288 %useradd -P %{name}-libs -u 80 -G disk,backup -d /var/lib/amanda -s /bin/sh -c "Amanda Backup user" -g amanda amanda
289
290 %postun libs
291 if [ "$1" = "0" ]; then
292         %userremove amanda
293         %groupremove amanda
294 fi
295
296 %post client
297 %service -q rc-inetd reload
298 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amrecover ] ; then
299         HOST="`/bin/hostname`"
300         if [ -z "$HOST" ] ; then
301                 COMMENT="root@client"
302         else
303                 COMMENT="root@$HOST"
304         fi
305         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amrecover -N "" || :
306         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
307         chmod 600 /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
308 fi
309
310 %postun client
311 if [ "$1" = 0 ]; then
312         %service -q rc-inetd reload
313 fi
314
315 %post server
316 %service -q rc-inetd reload
317 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amdump ] ; then
318         HOST="`/bin/hostname`"
319         if [ -z "$HOST" ] ; then
320                 COMMENT="amanda@server"
321         else
322                 COMMENT="amanda@$HOST"
323         fi
324         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amdump -N "" || :
325         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
326         chmod 600 /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
327 fi
328 if [ "$1" = "1" ]; then
329         echo "Don't forget to edit /etc/cron.d/amanda-srv." 1>&2
330 fi
331
332 %postun server
333 if [ "$1" = 0 ]; then
334         %service -q rc-inetd reload
335 fi
336
337 %files libs
338 %defattr(644,root,root,755)
339 %doc AUTHORS COPYRIGHT ChangeLog NEWS README ReleaseNotes UPGRADING
340 %attr(755,root,root) %{_libdir}/amanda/libamanda*.so
341 %attr(750,amanda,amanda) %dir %{_sysconfdir}/amanda
342 %dir %{_libdir}/amanda
343 %if %{_lib} != "lib"
344 %{_ulibdir}/amanda
345 %endif
346 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda
347 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.ssh
348 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.gnupg
349 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug
350 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/amandad
351 %attr(600,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/.amandahosts
352 # Commented out so it won't get removed on uninstall
353 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/authorized_keys
354
355 %if %{with server}
356 %files server
357 %defattr(644,root,root,755)
358 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amidxtape
359 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amandaidx
360
361 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/amanda.conf
362
363 # Commented out so it won't get removed on uninstall
364 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/client_authorized_keys
365 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amdump*
366
367 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/example
368 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/example/label-templates
369 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/template.d
370 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/server
371 %attr(640,amanda,amanda) %{_sharedstatedir}/amanda/example/*amanda*
372 %attr(640,amanda,amanda) %{_sharedstatedir}/amanda/example/label-templates/*.ps
373 %attr(640,amanda,amanda) %{_sharedstatedir}/amanda/template.d/*
374
375 %config(noreplace) %attr(640,root,root) /etc/cron.d/amanda-srv
376
377 %dir %{_libdir}/amanda/application
378 %attr(755,root,root) %{_libdir}/amanda/application/amgtar
379 %attr(644,root,root) %{_libdir}/amanda/application/generic-dumper
380
381 %attr(755,root,root) %{_libdir}/amanda/libamdevice*.so
382 %attr(755,root,root) %{_libdir}/amanda/libamserver*.so
383 %attr(755,root,root) %{_libdir}/amanda/libamtape*.so
384 %attr(755,root,root) %{_libdir}/amanda/librestore*.so
385
386 %{_libdir}/amanda/amanda-sh-lib.sh
387 %attr(755,root,root) %{_libdir}/amanda/amcat.awk
388 %attr(755,root,root) %{_libdir}/amanda/amcleanupdisk
389 %attr(755,root,root) %{_libdir}/amanda/amidxtaped
390 %attr(755,root,root) %{_libdir}/amanda/amindexd
391 %attr(755,root,root) %{_libdir}/amanda/amlogroll
392 %attr(755,root,root) %{_libdir}/amanda/amplot.awk
393 %attr(755,root,root) %{_libdir}/amanda/amplot.g
394 %attr(755,root,root) %{_libdir}/amanda/amplot.gp
395 %attr(755,root,root) %{_libdir}/amanda/amtrmidx
396 %attr(755,root,root) %{_libdir}/amanda/amtrmlog
397 %attr(755,root,root) %{_libdir}/amanda/chg-chio
398 %attr(755,root,root) %{_libdir}/amanda/chg-chs
399 %attr(755,root,root) %{_libdir}/amanda/chg-disk
400 %attr(755,root,root) %{_libdir}/amanda/chg-iomega
401 %attr(755,root,root) %{_libdir}/amanda/chg-juke
402 %attr(755,root,root) %{_libdir}/amanda/chg-lib.sh
403 %attr(755,root,root) %{_libdir}/amanda/chg-manual
404 %attr(755,root,root) %{_libdir}/amanda/chg-mcutil
405 %attr(755,root,root) %{_libdir}/amanda/chg-mtx
406 %attr(755,root,root) %{_libdir}/amanda/chg-multi
407 %attr(755,root,root) %{_libdir}/amanda/chg-null
408 %attr(755,root,root) %{_libdir}/amanda/chg-rait
409 %attr(755,root,root) %{_libdir}/amanda/chg-rth
410 %attr(755,root,root) %{_libdir}/amanda/chg-scsi
411 %attr(755,root,root) %{_libdir}/amanda/chg-zd-mtx
412 %attr(755,root,root) %{_libdir}/amanda/chunker
413 %attr(755,root,root) %{_libdir}/amanda/driver
414 %attr(4750,root,amanda) %{_libdir}/amanda/dumper
415 %attr(755,root,root) %{_libdir}/amanda/patch-system
416 %attr(4750,root,amanda) %{_libdir}/amanda/planner
417 %attr(755,root,root) %{_libdir}/amanda/taper
418
419 %attr(755,root,root) %{_sbindir}/amaddclient
420 %attr(755,root,root) %{_sbindir}/amadmin
421 %attr(755,root,root) %{_sbindir}/amaespipe
422 %attr(4750,root,amanda) %{_sbindir}/amcheck
423 %attr(755,root,root) %{_sbindir}/amcheckdb
424 %attr(755,root,root) %{_sbindir}/amcheckdump
425 %attr(755,root,root) %{_sbindir}/amcleanup
426 %attr(755,root,root) %{_sbindir}/amcrypt*
427 %attr(755,root,root) %{_sbindir}/amdd
428 %attr(755,root,root) %{_sbindir}/amdevcheck
429 %attr(755,root,root) %{_sbindir}/amdump
430 %attr(755,root,root) %{_sbindir}/amfetchdump
431 %attr(755,root,root) %{_sbindir}/amflush
432 %attr(755,root,root) %{_sbindir}/amgetconf
433 %attr(755,root,root) %{_sbindir}/amgpgcrypt
434 %attr(755,root,root) %{_sbindir}/amlabel
435 %attr(755,root,root) %{_sbindir}/ammt
436 %attr(755,root,root) %{_sbindir}/amoverview
437 %attr(755,root,root) %{_sbindir}/amplot
438 %attr(755,root,root) %{_sbindir}/amreport
439 %attr(755,root,root) %{_sbindir}/amrestore
440 %attr(755,root,root) %{_sbindir}/amrmtape
441 %attr(755,root,root) %{_sbindir}/amserverconfig
442 %attr(755,root,root) %{_sbindir}/amstatus
443 %attr(755,root,root) %{_sbindir}/amtape
444 %attr(755,root,root) %{_sbindir}/amtapetype
445 %attr(755,root,root) %{_sbindir}/amtoc
446 %attr(755,root,root) %{_sbindir}/amverify
447 %attr(755,root,root) %{_sbindir}/amverifyrun
448 %{_mandir}/man5/amanda.conf.5*
449 %{_mandir}/man8/amaddclient.8*
450 %{_mandir}/man8/amadmin.8*
451 %{_mandir}/man8/amaespipe.8*
452 %{_mandir}/man8/amanda.8*
453 %{_mandir}/man8/amcheck.8*
454 %{_mandir}/man8/amcheckdb.8*
455 %{_mandir}/man8/amcheckdump.8*
456 %{_mandir}/man8/amcleanup.8*
457 %{_mandir}/man8/amcrypt*.8*
458 %{_mandir}/man8/amdd.8*
459 %{_mandir}/man8/amdevcheck.8*
460 %{_mandir}/man8/amdump.8*
461 %{_mandir}/man8/amfetchdump.8*
462 %{_mandir}/man8/amflush.8*
463 %{_mandir}/man8/amgetconf.8*
464 %{_mandir}/man8/amgpgcrypt.8*
465 %{_mandir}/man8/amlabel.8*
466 %{_mandir}/man8/ammt.8*
467 %{_mandir}/man8/amoverview.8*
468 %{_mandir}/man8/amplot.8*
469 %{_mandir}/man8/amreport.8*
470 %{_mandir}/man8/amrestore.8*
471 %{_mandir}/man8/amrmtape.8*
472 %{_mandir}/man8/amserverconfig.8*
473 %{_mandir}/man8/amstatus.8*
474 %{_mandir}/man8/amtape.8*
475 %{_mandir}/man8/amtapetype.8*
476 %{_mandir}/man8/amtoc.8*
477 %{_mandir}/man8/amverify.8*
478 %{_mandir}/man8/amverifyrun.8*
479 %endif
480
481 %if %{with client}
482 %files client
483 %defattr(644,root,root,755)
484 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amanda
485 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,amanda) %{_sysconfdir}/amanda/amanda-client.conf
486 # Commented out so it won't get removed on uninstall
487 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover*
488 %attr(640,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/amandates
489 %attr(755,root,root) %{_libdir}/amanda/libamclient*.so
490 %attr(755,root,root) %{_libdir}/amanda/amandad
491 %attr(755,root,root) %{_libdir}/amanda/noop
492 %attr(755,root,root) %{_libdir}/amanda/sendbackup
493 %attr(755,root,root) %{_libdir}/amanda/sendsize
494 %attr(755,root,root) %{_libdir}/amanda/versionsuffix
495 %attr(4750,root,amanda) %{_libdir}/amanda/calcsize
496 %attr(4750,root,amanda) %{_libdir}/amanda/killpgrp
497 %attr(4750,root,amanda) %{_libdir}/amanda/rundump
498 %attr(4750,root,amanda) %{_libdir}/amanda/runtar
499 %attr(755,root,root) %{_libdir}/amanda/selfcheck
500 %attr(755,root,root) %{_sbindir}/amoldrecover
501 %attr(755,root,root) %{_sbindir}/amrecover
502 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/gnutar-lists
503 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/client
504 %{_mandir}/man5/amanda-client.conf.5*
505 %{_mandir}/man8/amrecover.8*
506 %endif
507
508 %files perl
509 %defattr(644,root,root,755)
510 %attr(755,root,root) %{_libdir}/amanda/libamglue*.so
511 %dir %{perl_vendorarch}/Amanda
512 %{perl_vendorarch}/Amanda/Config.pm
513 %{perl_vendorarch}/Amanda/Debug.pm
514 %{perl_vendorarch}/Amanda/Paths.pm
515 %{perl_vendorarch}/Amanda/Types.pm
516 %{perl_vendorarch}/Amanda/Util.pm
517 %dir %{perl_vendorarch}/auto/Amanda
518 %dir %{perl_vendorarch}/auto/Amanda/Config
519 %dir %{perl_vendorarch}/auto/Amanda/Debug
520 %dir %{perl_vendorarch}/auto/Amanda/Types
521 %dir %{perl_vendorarch}/auto/Amanda/Util
522 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Config/*.so
523 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Debug/*.so
524 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Types/*.so
525 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Util/*.so
526
527 %files perl-server
528 %defattr(644,root,root,755)
529 %{perl_vendorarch}/Amanda/Changer.pm
530 %{perl_vendorarch}/Amanda/Cmdline.pm
531 %{perl_vendorarch}/Amanda/Device.pm
532 %{perl_vendorarch}/Amanda/Logfile.pm
533 %{perl_vendorarch}/Amanda/Tapefile.pm
534 %dir %{perl_vendorarch}/auto/Amanda/Cmdline
535 %dir %{perl_vendorarch}/auto/Amanda/Device
536 %dir %{perl_vendorarch}/auto/Amanda/Logfile
537 %dir %{perl_vendorarch}/auto/Amanda/Tapefile
538 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Cmdline/*.so
539 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Device/*.so
540 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Logfile/*.so
541 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Tapefile/*.so
This page took 0.072656 seconds and 4 git commands to generate.