]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
- use extended noautoreq macro
[packages/amanda.git] / amanda.spec
1 #
2 # Conditional build:
3 %bcond_without  xfs     # without (possible) support for xfsdump
4 %bcond_without  samba   # without smbclient support
5 %bcond_without  client  # without client package
6 %bcond_without  server  # without server package
7 #
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        A network-capable tape backup solution
10 Summary(pl.UTF-8):      Sieciowo zorientowany system tworzenia kopii zapasowych
11 Name:           amanda
12 Version:        3.3.2
13 Release:        2
14 License:        BSD
15 Group:          Networking/Utilities
16 Source0:        http://downloads.sourceforge.net/amanda/%{name}-%{version}.tar.gz
17 # Source0-md5:  1a6cfe47eaee121f22540ac5fa58c366
18 Source1:        %{name}-srv.crontab
19 Source2:        %{name}.inetd
20 Source3:        %{name}idx.inetd
21 Source4:        amidxtape.inetd
22 Source5:        k5%{name}.inet
23 # http://amanda.svn.sourceforge.net/viewvc/amanda/amanda/branches/3_2/contrib/convert-zd-mtx-to-robot.sh
24 Source6:        convert-zd-mtx-to-robot.sh
25 Source7:        %{name}-ssh_config
26 # https://github.com/janekr/amlvm-snapshot
27 Source8:        amlvm-snapshot.conf
28 Source9:        amlvm-snapshot.pl
29 Source10:       amlvm-snapshot.README
30 Patch0:         %{name}-no_libnsl.patch
31 Patch1:         %{name}-chg-zd-mtx-sh.patch
32 Patch2:         %{name}-tar.patch
33 Patch3:         %{name}-common.patch
34 Patch4:         %{name}-as_needed.patch
35 Patch5:         %{name}-tapetypes.patch
36 Patch6:         %{name}-FHS.patch
37 Patch7:         %{name}-no-buildtime-ipv6.patch
38 Patch8:         %{name}-heimdal.patch
39 Patch9:         %{name}-ac.patch
40 Patch11:        %{name}-amstar-exclude-fix.patch
41 Patch12:        %{name}-krb5-auth.patch
42 Patch13:        %{name}-stdio.patch
43 Patch14:        %{name}-amstar-device.patch
44 URL:            http://www.amanda.org/
45 BuildRequires:  autoconf >= 2.53
46 BuildRequires:  automake
47 BuildRequires:  curl-devel >= 7.10.0
48 BuildRequires:  dump
49 BuildRequires:  flex
50 BuildRequires:  glib2-devel
51 BuildRequires:  gnuplot
52 # curl is broken, see curl-config --libs
53 BuildRequires:  keyutils-devel
54 BuildRequires:  heimdal-devel
55 BuildRequires:  libtool
56 BuildRequires:  libxslt-progs
57 BuildRequires:  ncurses-devel
58 BuildRequires:  openssh-clients
59 BuildRequires:  openssl-devel
60 BuildRequires:  perl-devel >= 5.6.0
61 BuildRequires:  pkgconfig
62 BuildRequires:  readline-devel >= 4.2
63 BuildRequires:  rpmbuild(macros) >= 1.654
64 BuildRequires:  rpm-perlprov
65 %{?with_samba:BuildRequires:    samba-client}
66 BuildRequires:  swig
67 %{?with_xfs:BuildRequires:      xfsdump}
68 Conflicts:      shadow < 1:4.0.4.1-4
69 Conflicts:      pwdutils < 3.1.2-2
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 # for some unknown reason those get detected in R but not in P (Tie::StdHash comes from perl)
73 %define         _noautoreq_perl 'perl(Tie::StdHash)' 'perl(Amanda::Recovery::Clerk::Feedback)' 'perl(Amanda::Taper::Scribe::Feedback)'
74
75 %define         _ulibdir        %{_prefix}/lib
76
77 %description
78 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
79 backup system that allows the administrator of a LAN to set up a
80 single master backup server to back up multiple hosts to a single
81 large capacity tape drive. AMANDA uses native dump and/or GNU tar
82 facilities and can back up a large number of workstations running
83 multiple versions of Unix. Newer versions of AMANDA (including this
84 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
85 The amanda package contains the core AMANDA programs and will need to
86 be installed on both AMANDA clients and AMANDA servers. Note that you
87 will have to install the amanda-client and amanda-server packages as
88 well.
89
90 %description -l pl.UTF-8
91 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
92 zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
93 hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
94 Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
95 Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
96 podstawowe pliki programu i powinien być zainstalowany zarówno na
97 serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
98 amanda-client i amanda-server!
99
100 %package common
101 Summary:        Amanda common files
102 Summary(pl.UTF-8):      Wspólne pliki pakietu amanda
103 Group:          Networking/Utilities
104 Requires(postun):       /usr/sbin/groupdel
105 Requires(postun):       /usr/sbin/userdel
106 Requires(pre):  /bin/id
107 Requires(pre):  /usr/bin/chsh
108 Requires(pre):  /usr/bin/getgid
109 Requires(pre):  /usr/sbin/groupadd
110 Requires(pre):  /usr/sbin/useradd
111 %requires_ge    glib2
112 Requires:       setup >= 2.6.1-1
113 Provides:       group(amanda)
114 Provides:       user(amanda)
115 Obsoletes:      amanda-libs
116 Obsoletes:      amanda-perl
117
118 %description common
119 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
120 backup system that allows the administrator of a LAN to set up a
121 single master backup server to back up multiple hosts to a single
122 large capacity tape drive. AMANDA uses native dump and/or GNU tar
123 facilities and can back up a large number of workstations running
124 multiple versions of Unix. Newer versions of AMANDA (including this
125 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
126 The amanda package contains the core AMANDA programs and will need to
127 be installed on both AMANDA clients and AMANDA servers. Note that you
128 will have to install the amanda-client and amanda-server packages as
129 well.
130
131 Amanda common files.
132
133 %description common -l pl.UTF-8
134 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
135 zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
136 hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
137 Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
138 Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
139 podstawowe pliki programu i powinien być zainstalowany zarówno na
140 serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
141 amanda-client i amanda-server!
142
143 Wspólne pliki pakietu amanda.
144
145 %package client
146 Summary:        The client side of Amanda
147 Summary(pl.UTF-8):      Klient Amandy
148 Group:          Networking/Utilities
149 Requires(post): /bin/hostname
150 Requires(post): /usr/bin/ssh-keygen
151 Requires:       %{name}-common = %{version}-%{release}
152 Requires:       rc-inetd
153 Suggests:       openssh-clients
154 Suggests:       openssh-server
155 Suggests:       tar
156 Suggests:       gzip
157 Suggests:       star
158 Conflicts:      tar < 1.15
159
160 %description client
161 The Amanda-client package should be installed on any machine that will
162 be backed up by AMANDA (including the server if it also needs to be
163 backed up). You will also need to install the amanda package to each
164 AMANDA client. It requires at least one of dump and GNU tar installed.
165
166 %description client -l pl.UTF-8
167 Ten pakiet powinien być zainstalowany ma maszynach, z których
168 zawartości będą tworzone kopie zapasowe. Wymaga zainstalowanego co
169 najmniej jednego z pakietów dump i GNU tar.
170
171 %package server
172 Summary:        The server side of Amanda
173 Summary(pl.UTF-8):      Serwer Amandy
174 Group:          Networking/Utilities
175 Requires(post): /bin/hostname
176 Requires(post): /usr/bin/ssh-keygen
177 Requires:       %{name}-common = %{version}-%{release}
178 Requires:       /etc/cron.d
179 Requires:       crondaemon
180 Requires:       gnuplot
181 Requires:       mt-st
182 Requires:       mtx
183 Requires:       rc-inetd
184 Suggests:       openssh-clients
185 Suggests:       openssh-server
186 Obsoletes:      amanda
187 Obsoletes:      amanda-perl-server
188
189 %description server
190 The amanda-server package should be installed on the AMANDA server,
191 the machine attached to the device (such as a tape drive) where
192 backups will be written. You will also need to install the amanda
193 package to the AMANDA server. And, if the server is also to be backed
194 up, the server also needs to have the amanda-client package installed.
195
196 %description server -l pl.UTF-8
197 Ten pakiet powinien być zainstalowany na maszynach, na których będą
198 magazynowane kopie zapasowe (lub do których podpięte są urządzenia
199 typu streamer).
200
201 %prep
202 %setup -q
203 %patch0 -p1
204 %patch1 -p1
205 %patch2 -p1
206 %patch3 -p1
207 %patch4 -p1
208 %patch5 -p1
209 %patch6 -p1
210 %patch7 -p1
211 %patch8 -p1
212 %patch9 -p1
213 %patch11 -p1
214 %patch12 -p1
215 %patch13 -p1
216 %patch14 -p1
217 cp -a %{SOURCE10} .
218
219 %build
220 %{__aclocal} -I config -I config/gettext-macros -I config/gnulib -I config/amanda -I config/macro-archive
221 %{__autoconf}
222 %{__automake}
223 %configure \
224         DUMP=/sbin/dump \
225         GZIP=/bin/gzip \
226         MAILER=/bin/mail \
227         MT=/bin/mt \
228         MTX=/usr/sbin/mtx \
229         PRINT=/usr/bin/lpr \
230         RESTORE=/sbin/restore \
231         %{?with_xfs:XFSDUMP=/sbin/xfsdump} \
232         %{?with_xfs:XFSRESTORE=/sbin/xfsrestore} \
233         --disable-static \
234         --enable-shared \
235         %{!?with_server:--without-server} \
236         %{!?with_client:--without-client} \
237         --with-index-server=localhost \
238         --with-user=amanda \
239         --with-group=amanda \
240         --with-tape-device=/dev/null \
241         --with-fqdn \
242         %{?with_samba:--with-smbclient=%{_bindir}/smbclient} \
243         --with-star=%{_bindir}/star \
244         --with-gnuplot=%{_bindir}/gnuplot \
245         --with-bsd-security \
246         --with-bsdtcp-security \
247         --with-ssh-security \
248         --with-krb5-security \
249         --with-buffered-dump \
250         --with-amandahosts \
251         --with-configdir=%{_sysconfdir}/amanda \
252         --with-gnutar-listdir=%{_sharedstatedir}/amanda/gnutar-lists \
253         --with-amandates=%{_sharedstatedir}/amanda/amandates \
254         --with-debugging=%{_sharedstatedir}/amanda/debug \
255         --with-tmpdir=/var/tmp/amanda \
256         --with-amperldir=%{perl_vendorarch} \
257         --with-ipv6 \
258         --with-readline \
259         --disable-installperms
260
261 %{__make}
262
263 %install
264 rm -rf $RPM_BUILD_ROOT
265 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{amanda,cron.d,sysconfig/rc-inetd} \
266         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/{.gnupg,.ssh,gnutar-lists} \
267         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/debug/{amandad,client,server}
268
269 %{__make} install \
270         DESTDIR=$RPM_BUILD_ROOT
271
272 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amanda-srv
273 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE2} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amanda
274 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE3} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amandaidx
275 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE4} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amidxtape
276 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE5} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/k5amanda
277
278 install example/amanda.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
279 install example/amanda-client.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
280 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.amandahosts
281
282 install %{SOURCE6} $RPM_BUILD_ROOT%{_sbindir}/amconvert-zd-mtx-to-robot.sh
283
284 install %{SOURCE7} $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/config
285 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/{,client_}authorized_keys
286 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amdump{,.pub}
287 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover{,.pub}
288
289 %if %{with server}
290 install -p %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/amanda/lvm-snapshot.conf
291 %endif
292
293 %if %{with client}
294 sed -e 's|@@PERL_VENDORARCH@@|%{perl_vendorarch}|' %{SOURCE9} >$RPM_BUILD_ROOT%{_libdir}/amanda/application/amlvm-snapshot
295 %endif
296
297 > $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/amandates
298
299 # Amanda tools generate ssh keys with embeded commands pointing to /usr/lib
300 # Tools can't be "fixed" because keys generated on server are to be used on client
301 if [ "%{_lib}" != "lib" ] ; then
302         install -d $RPM_BUILD_ROOT%{_ulibdir}
303         ln -s %{_libdir}/amanda $RPM_BUILD_ROOT%{_ulibdir}/amanda
304 fi
305
306 find $RPM_BUILD_ROOT -name \*.la | xargs rm -f
307
308 %{__rm} $RPM_BUILD_ROOT%{_datadir}/amanda/{COPYRIGHT,ChangeLog,NEWS,ReleaseNotes}
309 %{__rm} $RPM_BUILD_ROOT%{_datadir}/amanda/example/{chg-multi,chg-scsi}.conf
310
311 %clean
312 rm -rf $RPM_BUILD_ROOT
313
314 %triggerpostun common -- amanda-libs < 2.6.0p2-3
315 echo "Adding amanda to disk and tape groups"
316 /usr/sbin/usermod -G disk,tape amanda
317 echo "Setting amanda shell to /bin/sh"
318 /usr/bin/chsh -s /bin/sh amanda
319 if [ -f %{_sharedstatedir}/amanda/.amandahosts ]; then
320         echo "Fixing permissions of %{_sharedstatedir}/amanda/.amandahosts file"
321         chown amanda:amanda %{_sharedstatedir}/amanda/.amandahosts
322         chmod 600 %{_sharedstatedir}/amanda/.amandahosts
323 fi
324
325 %triggerpostun common -- amanda-common < 3.3
326 %banner %{name}-common -e << EOF
327 In amanda 3.3 the default auth has changed to "bsdtcp",
328 if you are using the default "bsd" then you must add it
329 to your configuration:
330
331  *   in amanda.conf
332  *   in amanda-client.conf
333  *   in dumptype/disklist
334  *   in inetd (if no '-auth' argument to amandad)
335 EOF
336                 
337 %pre common
338 %groupadd -P %{name}-common -g 80 amanda
339 %useradd -P %{name}-common -u 80 -G disk,tape -d /var/lib/amanda -s /bin/sh -c "Amanda Backup user" -g amanda amanda
340
341 %postun common
342 if [ "$1" = "0" ]; then
343         %userremove amanda
344         %groupremove amanda
345 fi
346
347 %post client
348 %service -q rc-inetd reload
349 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amrecover ] ; then
350         HOST="`/bin/hostname`"
351         FQDNHOST="`/bin/hostname -f`"
352         if [ -z "$HOST" ] ; then
353                 COMMENT="root@client"
354         else
355                 COMMENT="root@$HOST"
356         fi
357         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amrecover -N "" || :
358         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
359         chmod 600 /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
360         if [ -n "$FQDNHOST" ]; then
361                 echo -n "from=\"$FQDNHOST\",no-port-forwarding,no-X11-forwarding,no-agent-forwarding,command=\"%{_ulibdir}/amanda/amandad -auth=ssh amindexd amidxtaped\" " >/var/lib/amanda/.ssh/server_authorized_keys
362                 cat /var/lib/amanda/.ssh/id_rsa_amrecover.pub >>/var/lib/amanda/.ssh/server_authorized_keys
363
364                 echo "Remember to copy the contents of /var/lib/amanda/.ssh/server_authorized_keys to"
365                 echo "/var/lib/amanda/.ssh/authorized_keys on amanda server"
366         fi
367 fi
368
369 %postun client
370 if [ "$1" = 0 ]; then
371         %service -q rc-inetd reload
372 fi
373
374 %post server
375 %service -q rc-inetd reload
376 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amdump ] ; then
377         HOST="`/bin/hostname`"
378         if [ -z "$HOST" ] ; then
379                 COMMENT="amanda@server"
380         else
381                 COMMENT="amanda@$HOST"
382         fi
383         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amdump -N "" || :
384         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
385         chmod 600 /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
386 fi
387 if [ "$1" = "1" ]; then
388         echo "Don't forget to edit /etc/cron.d/amanda-srv." 1>&2
389 fi
390
391 %postun server
392 if [ "$1" = 0 ]; then
393         %service -q rc-inetd reload
394 fi
395
396 %triggerpostun server -- amanda-server < 3.2.0
397 %banner %{name} -e << EOF
398 Warning: Tape changer configuration has chaged, please read
399 %{_docdir}/%{name}-server-%{version}/ReleaseNotes.gz
400 and %{_docdir}/%{name}-server-%{version}/NEWS.gz for details.
401 You can use %{_sbindir}/amconvert-zd-mtx-to-robot.sh script
402 to upgrade to chg-robot.
403 EOF
404
405 %files common
406 %defattr(644,root,root,755)
407 %doc AUTHORS COPYRIGHT ChangeLog NEWS README ReleaseNotes UPGRADING amlvm-snapshot.README
408 %attr(755,root,root) %{_libdir}/amanda/libamanda*.so
409 %attr(755,root,root) %{_libdir}/amanda/libamar*.so
410 %attr(755,root,root) %{_libdir}/amanda/libamxfer*.so
411 %attr(755,root,root) %{_libdir}/amanda/libamglue*.so
412 %attr(755,root,root) %{_libdir}/amanda/libndmjob*.so
413 %attr(755,root,root) %{_libdir}/amanda/libndmlib*.so
414 %attr(755,root,root) %{_libdir}/amanda/amndmjob
415 %attr(755,root,root) %{_libdir}/amanda/ndmjob
416 %attr(750,amanda,amanda) %dir %{_sysconfdir}/amanda
417 %dir %{_libdir}/amanda
418 %if %{_lib} != "lib"
419 %{_ulibdir}/amanda
420 %endif
421 %{_libdir}/amanda/amanda-sh-lib.sh
422 %attr(755,root,root) %{_sbindir}/amaespipe
423 %attr(755,root,root) %{_sbindir}/amarchiver
424 %attr(755,root,root) %{_sbindir}/amcrypt*
425 %attr(755,root,root) %{_sbindir}/amgetconf
426 %attr(755,root,root) %{_sbindir}/amgpgcrypt
427 %attr(750,amanda,amanda) %dir %{_datadir}/amanda
428 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/example
429 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/example/label-templates
430 %attr(640,amanda,amanda) %{_datadir}/amanda/example/*amanda*
431 %attr(640,amanda,amanda) %{_datadir}/amanda/example/disklist
432 %attr(640,amanda,amanda) %{_datadir}/amanda/example/label-templates/*.ps
433 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/template.d
434 %attr(640,amanda,amanda) %{_datadir}/amanda/template.d/*
435 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda
436 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.ssh
437 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.gnupg
438 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug
439 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/amandad
440 %attr(600,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/.amandahosts
441 %attr(600,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/.ssh/config
442 # Commented out so it won't get removed on uninstall
443 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/authorized_keys
444 %{_mandir}/man5/amanda-archive-format.5*
445 %{_mandir}/man7/amanda-auth.7*
446 %{_mandir}/man7/amanda-match.7*
447 %{_mandir}/man7/amanda-scripts.7*
448 %{_mandir}/man8/amaespipe.8*
449 %{_mandir}/man8/amanda.8*
450 %{_mandir}/man8/amarchiver.8*
451 %{_mandir}/man8/amcrypt*.8*
452 %{_mandir}/man8/amgetconf.8*
453 %{_mandir}/man8/amgpgcrypt.8*
454 %{_mandir}/man8/script-email.8*
455
456 %dir %{perl_vendorarch}/Amanda
457 %dir %{perl_vendorarch}/Amanda/Config
458 %dir %{perl_vendorarch}/Amanda/IPC
459 %{perl_vendorarch}/Amanda/Archive.pm
460 %{perl_vendorarch}/Amanda/BigIntCompat.pm
461 %{perl_vendorarch}/Amanda/ClientService.pm
462 %{perl_vendorarch}/Amanda/Config.pm
463 %{perl_vendorarch}/Amanda/Config/FoldingHash.pm
464 %{perl_vendorarch}/Amanda/Constants.pm
465 %{perl_vendorarch}/Amanda/Debug.pm
466 %{perl_vendorarch}/Amanda/Feature.pm
467 %{perl_vendorarch}/Amanda/Header.pm
468 %{perl_vendorarch}/Amanda/IPC/Binary.pm
469 %{perl_vendorarch}/Amanda/IPC/LineProtocol.pm
470 %{perl_vendorarch}/Amanda/MainLoop.pm
471 %{perl_vendorarch}/Amanda/NDMP.pm
472 %{perl_vendorarch}/Amanda/Paths.pm
473 %{perl_vendorarch}/Amanda/Process.pm
474 %{perl_vendorarch}/Amanda/Script.pm
475 %{perl_vendorarch}/Amanda/Script_App.pm
476 %{perl_vendorarch}/Amanda/Tests.pm
477 %{perl_vendorarch}/Amanda/Util.pm
478 %{perl_vendorarch}/Amanda/Xfer.pm
479 %dir %{perl_vendorarch}/auto/Amanda
480 %dir %{perl_vendorarch}/auto/Amanda/Archive
481 %dir %{perl_vendorarch}/auto/Amanda/Config
482 %dir %{perl_vendorarch}/auto/Amanda/Debug
483 %dir %{perl_vendorarch}/auto/Amanda/Feature
484 %dir %{perl_vendorarch}/auto/Amanda/Header
485 %dir %{perl_vendorarch}/auto/Amanda/IPC
486 %dir %{perl_vendorarch}/auto/Amanda/IPC/Binary
487 %dir %{perl_vendorarch}/auto/Amanda/MainLoop
488 %dir %{perl_vendorarch}/auto/Amanda/NDMP
489 %dir %{perl_vendorarch}/auto/Amanda/Tests
490 %dir %{perl_vendorarch}/auto/Amanda/Util
491 %dir %{perl_vendorarch}/auto/Amanda/Xfer
492 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Archive/*.so
493 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Config/*.so
494 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Feature/*.so
495 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Header/*.so
496 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/IPC/Binary/*.so
497 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Debug/*.so
498 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/MainLoop/*.so
499 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/NDMP/*.so
500 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Tests/*.so
501 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Util/*.so
502 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Xfer/*.so
503
504 %if %{with server}
505 %files server
506 %defattr(644,root,root,755)
507 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amidxtape
508 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amandaidx
509
510 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/amanda.conf
511 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/lvm-snapshot.conf
512
513 # Commented out so it won't get removed on uninstall
514 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/client_authorized_keys
515 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amdump*
516
517 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/server
518
519 %config(noreplace) %attr(640,root,root) /etc/cron.d/amanda-srv
520
521 %attr(755,root,root) %{_libdir}/amanda/libamdevice*.so
522 %attr(755,root,root) %{_libdir}/amanda/libamserver*.so
523
524 %attr(755,root,root) %{_libdir}/amanda/amcat.awk
525 %attr(755,root,root) %{_libdir}/amanda/amcheck-device
526 %attr(755,root,root) %{_libdir}/amanda/amdumpd
527 %attr(755,root,root) %{_libdir}/amanda/amidxtaped
528 %attr(755,root,root) %{_libdir}/amanda/amindexd
529 %attr(755,root,root) %{_libdir}/amanda/amlogroll
530 %attr(755,root,root) %{_libdir}/amanda/amplot.awk
531 %attr(755,root,root) %{_libdir}/amanda/amplot.g
532 %attr(755,root,root) %{_libdir}/amanda/amplot.gp
533 %attr(755,root,root) %{_libdir}/amanda/amtrmidx
534 %attr(755,root,root) %{_libdir}/amanda/amtrmlog
535 %attr(755,root,root) %{_libdir}/amanda/chg-disk
536 %attr(755,root,root) %{_libdir}/amanda/chg-lib.sh
537 %attr(755,root,root) %{_libdir}/amanda/chg-manual
538 %attr(755,root,root) %{_libdir}/amanda/chg-multi
539 %attr(755,root,root) %{_libdir}/amanda/chg-zd-mtx
540 %attr(755,root,root) %{_libdir}/amanda/chunker
541 %attr(755,root,root) %{_libdir}/amanda/driver
542 %attr(4750,root,amanda) %{_libdir}/amanda/dumper
543 %attr(4750,root,amanda) %{_libdir}/amanda/planner
544 %attr(755,root,root) %{_libdir}/amanda/taper
545
546 %attr(755,root,root) %{_sbindir}/activate-devpay
547 %attr(755,root,root) %{_sbindir}/amaddclient
548 %attr(755,root,root) %{_sbindir}/amadmin
549 %attr(4750,root,amanda) %{_sbindir}/amcheck
550 %attr(755,root,root) %{_sbindir}/amcheckdb
551 %attr(755,root,root) %{_sbindir}/amcheckdump
552 %attr(755,root,root) %{_sbindir}/amcleanup
553 %attr(755,root,root) %{_sbindir}/amcleanupdisk
554 %attr(755,root,root) %{_sbindir}/amconvert-zd-mtx-to-robot.sh
555 %attr(755,root,root) %{_sbindir}/amdevcheck
556 %attr(755,root,root) %{_sbindir}/amdump
557 %attr(755,root,root) %{_sbindir}/amfetchdump
558 %attr(755,root,root) %{_sbindir}/amflush
559 %attr(755,root,root) %{_sbindir}/amlabel
560 %attr(755,root,root) %{_sbindir}/amoverview
561 %attr(755,root,root) %{_sbindir}/amplot
562 %attr(755,root,root) %{_sbindir}/amreport
563 %attr(755,root,root) %{_sbindir}/amrestore
564 %attr(755,root,root) %{_sbindir}/amrmtape
565 %attr(755,root,root) %{_sbindir}/amserverconfig
566 %attr(755,root,root) %{_sbindir}/amservice
567 %attr(755,root,root) %{_sbindir}/amstatus
568 %attr(755,root,root) %{_sbindir}/amtape
569 %attr(755,root,root) %{_sbindir}/amtapetype
570 %attr(755,root,root) %{_sbindir}/amtoc
571 %attr(755,root,root) %{_sbindir}/amvault
572 %{_mandir}/man5/amanda.conf.5*
573 %{_mandir}/man5/disklist.5*
574 %{_mandir}/man5/tapelist.5*
575 %{_mandir}/man7/amanda-changers.7*
576 %{_mandir}/man7/amanda-compatibility.7*
577 %{_mandir}/man7/amanda-devices.7*
578 %{_mandir}/man7/amanda-interactivity.7*
579 %{_mandir}/man7/amanda-taperscan.7*
580 %{_mandir}/man8/amaddclient.8*
581 %{_mandir}/man8/amadmin.8*
582 %{_mandir}/man8/amcheck.8*
583 %{_mandir}/man8/amcheckdb.8*
584 %{_mandir}/man8/amcheckdump.8*
585 %{_mandir}/man8/amcleanup.8*
586 %{_mandir}/man8/amcleanupdisk.8*
587 %{_mandir}/man8/amdevcheck.8*
588 %{_mandir}/man8/amdump.8*
589 %{_mandir}/man8/amfetchdump.8*
590 %{_mandir}/man8/amflush.8*
591 %{_mandir}/man8/amlabel.8*
592 %{_mandir}/man8/amoverview.8*
593 %{_mandir}/man8/amplot.8*
594 %{_mandir}/man8/amreport.8*
595 %{_mandir}/man8/amrestore.8*
596 %{_mandir}/man8/amrmtape.8*
597 %{_mandir}/man8/amserverconfig.8*
598 %{_mandir}/man8/amservice.8*
599 %{_mandir}/man8/amstatus.8*
600 %{_mandir}/man8/amtape.8*
601 %{_mandir}/man8/amtapetype.8*
602 %{_mandir}/man8/amtoc.8*
603 %{_mandir}/man8/amvault.8*
604
605 %{perl_vendorarch}/Amanda/Changer.pm
606 %dir %{perl_vendorarch}/Amanda/Changer
607 %{perl_vendorarch}/Amanda/Changer/*.pm
608 %{perl_vendorarch}/Amanda/Cmdline.pm
609 %{perl_vendorarch}/Amanda/Curinfo.pm
610 %dir %{perl_vendorarch}/Amanda/Curinfo
611 %{perl_vendorarch}/Amanda/Curinfo/*.pm
612 %dir %{perl_vendorarch}/Amanda/DB
613 %{perl_vendorarch}/Amanda/DB/*.pm
614 %{perl_vendorarch}/Amanda/Device.pm
615 %{perl_vendorarch}/Amanda/Disklist.pm
616 %{perl_vendorarch}/Amanda/Holding.pm
617 %{perl_vendorarch}/Amanda/Interactivity.pm
618 %dir %{perl_vendorarch}/Amanda/Interactivity
619 %{perl_vendorarch}/Amanda/Interactivity/*.pm
620 %{perl_vendorarch}/Amanda/Logfile.pm
621 %dir %{perl_vendorarch}/Amanda/Recovery
622 %{perl_vendorarch}/Amanda/Recovery/*.pm
623 %{perl_vendorarch}/Amanda/Report.pm
624 %dir %{perl_vendorarch}/Amanda/Report
625 %{perl_vendorarch}/Amanda/Report/*.pm
626 %{perl_vendorarch}/Amanda/ScanInventory.pm
627 %{perl_vendorarch}/Amanda/Tapelist.pm
628 %dir %{perl_vendorarch}/Amanda/Taper
629 %{perl_vendorarch}/Amanda/Taper/*.pm
630 %dir %{perl_vendorarch}/Amanda/Taper/Scan
631 %{perl_vendorarch}/Amanda/Taper/Scan/*.pm
632 %{perl_vendorarch}/Amanda/XferServer.pm
633 %dir %{perl_vendorarch}/auto/Amanda/Cmdline
634 %dir %{perl_vendorarch}/auto/Amanda/Device
635 %dir %{perl_vendorarch}/auto/Amanda/Disklist
636 %dir %{perl_vendorarch}/auto/Amanda/Logfile
637 %dir %{perl_vendorarch}/auto/Amanda/Tapelist
638 %dir %{perl_vendorarch}/auto/Amanda/XferServer
639 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Cmdline/*.so
640 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Device/*.so
641 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Disklist/*.so
642 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Logfile/*.so
643 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Tapelist/*.so
644 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/XferServer/*.so
645 %endif
646
647 %if %{with client}
648 %files client
649 %defattr(644,root,root,755)
650 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amanda
651 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/k5amanda
652 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,amanda) %{_sysconfdir}/amanda/amanda-client.conf
653 # Commented out so it won't get removed on uninstall
654 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover*
655 %attr(640,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/amandates
656
657 %dir %{_libdir}/amanda/application
658 %attr(4750,root,amanda) %{_libdir}/amanda/application/amgtar
659 %attr(755,root,root) %{_libdir}/amanda/application/amlog-script
660 %attr(755,root,root) %{_libdir}/amanda/application/amlvm-snapshot
661 %attr(755,root,root) %{_libdir}/amanda/application/ampgsql
662 %attr(755,root,root) %{_libdir}/amanda/application/amraw
663 %attr(755,root,root) %{_libdir}/amanda/application/amsamba
664 %attr(4750,root,amanda) %{_libdir}/amanda/application/amstar
665 %attr(755,root,root) %{_libdir}/amanda/application/amsuntar
666 %attr(755,root,root) %{_libdir}/amanda/application/amzfs*
667 %attr(755,root,root) %{_libdir}/amanda/application/script-email
668
669 %attr(755,root,root) %{_libdir}/amanda/libamclient*.so
670 %attr(755,root,root) %{_libdir}/amanda/amandad
671 %attr(755,root,root) %{_libdir}/amanda/noop
672 %attr(755,root,root) %{_libdir}/amanda/patch-system
673 %attr(755,root,root) %{_libdir}/amanda/sendbackup
674 %attr(755,root,root) %{_libdir}/amanda/sendsize
675 %attr(755,root,root) %{_libdir}/amanda/teecount
676 %attr(4750,root,amanda) %{_libdir}/amanda/calcsize
677 %attr(4750,root,amanda) %{_libdir}/amanda/killpgrp
678 %attr(4750,root,amanda) %{_libdir}/amanda/rundump
679 %attr(4750,root,amanda) %{_libdir}/amanda/runtar
680 %attr(755,root,root) %{_libdir}/amanda/selfcheck
681 %attr(755,root,root) %{_sbindir}/amdump_client
682 %attr(755,root,root) %{_sbindir}/amoldrecover
683 %attr(755,root,root) %{_sbindir}/amrecover
684 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/gnutar-lists
685 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/client
686 %{_mandir}/man7/amanda-applications.7*
687 %{_mandir}/man5/amanda-client.conf.5*
688 %{_mandir}/man8/amdump_client.8*
689 %{_mandir}/man8/amgtar.8*
690 %{_mandir}/man8/ampgsql.8*
691 %{_mandir}/man8/amrecover.8*
692 %{_mandir}/man8/amraw.8*
693 %{_mandir}/man8/amsamba.8*
694 %{_mandir}/man8/amstar.8*
695 %{_mandir}/man8/amsuntar.8*
696 %{_mandir}/man8/amzfs*.8*
697
698 %{perl_vendorarch}/Amanda/Application.pm
699 %dir %{perl_vendorarch}/Amanda/Application
700 %{perl_vendorarch}/Amanda/Application/Zfs.pm
701 %dir %{perl_vendorarch}/auto/Amanda/Application
702 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Application/*.so
703 %endif
This page took 0.100142 seconds and 4 git commands to generate.