]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/amanda.git] / amanda.spec
1 # TODO:
2 #  - init/service for client 'restore' service
3 #  - untangle client/server perl deps for 'restore' service
4 #
5 # Conditional build:
6 %bcond_without  xfs     # without (possible) support for xfsdump
7 %bcond_without  samba   # without smbclient support
8 %bcond_without  client  # without client package
9 %bcond_without  server  # without server package
10
11 Summary:        A network-capable tape backup solution
12 Summary(pl.UTF-8):      Sieciowo zorientowany system tworzenia kopii zapasowych
13 Name:           amanda
14 Version:        3.5.1
15 Release:        3
16 License:        BSD
17 Group:          Networking/Utilities
18 Source0:        http://downloads.sourceforge.net/amanda/%{name}-%{version}.tar.gz
19 # Source0-md5:  f57307959f79e722b1dcb3f985ebb0d0
20 Source1:        %{name}-srv.crontab
21 Source2:        %{name}.inetd
22 Source3:        %{name}idx.inetd
23 Source4:        amidxtape.inetd
24 Source5:        k5%{name}.inet
25 # http://amanda.svn.sourceforge.net/viewvc/amanda/amanda/branches/3_2/contrib/convert-zd-mtx-to-robot.sh
26 Source6:        convert-zd-mtx-to-robot.sh
27 Source7:        %{name}-ssh_config
28 # https://github.com/janekr/amlvm-snapshot
29 Source8:        amlvm-snapshot.conf
30 Source9:        amlvm-snapshot.pl
31 Source10:       amlvm-snapshot.README
32 Patch0:         %{name}-no_libnsl.patch
33
34 Patch2:         %{name}-tar.patch
35 Patch3:         %{name}-common.patch
36 Patch4:         %{name}-as_needed.patch
37 Patch5:         %{name}-tapetypes.patch
38 Patch6:         %{name}-FHS.patch
39 Patch7:         %{name}-no-buildtime-ipv6.patch
40 Patch8:         %{name}-heimdal.patch
41 Patch9:         %{name}-ac.patch
42
43 Patch12:        %{name}-krb5-auth.patch
44
45 Patch14:        swig.patch
46 Patch15:        krb5-ac.patch
47 URL:            http://www.amanda.org/
48 %{?with_samba:BuildRequires:    /usr/bin/smbclient}
49 BuildRequires:  autoconf >= 2.64
50 BuildRequires:  automake
51 BuildRequires:  curl-devel >= 7.10.0
52 BuildRequires:  dump
53 BuildRequires:  flex
54 BuildRequires:  glib2-devel
55 BuildRequires:  gnuplot
56 BuildRequires:  heimdal-devel
57 BuildRequires:  rpmbuild(macros) >= 1.654
58 # curl is broken, see curl-config --libs (c8cba693)
59 BuildRequires:  keyutils-devel
60 BuildRequires:  libtool
61 BuildRequires:  libxslt-progs
62 BuildRequires:  ncurses-devel
63 BuildRequires:  openssh-clients
64 BuildRequires:  openssl-devel
65 BuildRequires:  perl-devel >= 5.6.0
66 BuildRequires:  pkgconfig
67 BuildRequires:  readline-devel >= 4.2
68 BuildRequires:  rpm-perlprov
69 BuildRequires:  rpmbuild(macros) >= 1.654
70 BuildRequires:  swig
71 %{?with_xfs:BuildRequires:      xfsdump}
72 Conflicts:      pwdutils < 3.1.2-2
73 Conflicts:      shadow < 1:4.0.4.1-4
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 # for some unknown reason those get detected in R but not in P (Tie::StdHash comes from perl)
77 %define         _noautoreq_perl Tie::StdHash Amanda::Recovery::Clerk::Feedback Amanda::Taper::Scribe::Feedback
78
79 %define         _ulibdir        %{_prefix}/lib
80
81 %description
82 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
83 backup system that allows the administrator of a LAN to set up a
84 single master backup server to back up multiple hosts to a single
85 large capacity tape drive. AMANDA uses native dump and/or GNU tar
86 facilities and can back up a large number of workstations running
87 multiple versions of Unix. Newer versions of AMANDA (including this
88 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
89 The amanda package contains the core AMANDA programs and will need to
90 be installed on both AMANDA clients and AMANDA servers. Note that you
91 will have to install the amanda-client and amanda-server packages as
92 well.
93
94 %description -l pl.UTF-8
95 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
96 zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
97 hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
98 Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
99 Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
100 podstawowe pliki programu i powinien być zainstalowany zarówno na
101 serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
102 amanda-client i amanda-server!
103
104 %package common
105 Summary:        Amanda common files
106 Summary(pl.UTF-8):      Wspólne pliki pakietu amanda
107 Group:          Networking/Utilities
108 Requires(postun):       /usr/sbin/groupdel
109 Requires(postun):       /usr/sbin/userdel
110 Requires(pre):  /bin/id
111 Requires(pre):  /usr/bin/chsh
112 Requires(pre):  /usr/bin/getgid
113 Requires(pre):  /usr/sbin/groupadd
114 Requires(pre):  /usr/sbin/useradd
115 %requires_ge glib2
116 Requires:       setup >= 2.6.1-1
117 Provides:       group(amanda)
118 Provides:       user(amanda)
119 Obsoletes:      amanda-libs
120 Obsoletes:      amanda-perl
121
122 %description common
123 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
124 backup system that allows the administrator of a LAN to set up a
125 single master backup server to back up multiple hosts to a single
126 large capacity tape drive. AMANDA uses native dump and/or GNU tar
127 facilities and can back up a large number of workstations running
128 multiple versions of Unix. Newer versions of AMANDA (including this
129 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
130 The amanda package contains the core AMANDA programs and will need to
131 be installed on both AMANDA clients and AMANDA servers. Note that you
132 will have to install the amanda-client and amanda-server packages as
133 well.
134
135 Amanda common files.
136
137 %description common -l pl.UTF-8
138 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
139 zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
140 hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
141 Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
142 Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
143 podstawowe pliki programu i powinien być zainstalowany zarówno na
144 serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
145 amanda-client i amanda-server!
146
147 Wspólne pliki pakietu amanda.
148
149 %package client
150 Summary:        The client side of Amanda
151 Summary(pl.UTF-8):      Klient Amandy
152 Group:          Networking/Utilities
153 Requires(post): /bin/hostname
154 Requires(post): /usr/bin/ssh-keygen
155 Requires:       %{name}-common = %{version}-%{release}
156 Requires:       rc-inetd
157 Suggests:       gzip
158 Suggests:       openssh-clients
159 Suggests:       openssh-server
160 Suggests:       star
161 Suggests:       tar
162 Conflicts:      tar < 1.15
163
164 %description client
165 The Amanda-client package should be installed on any machine that will
166 be backed up by AMANDA (including the server if it also needs to be
167 backed up). You will also need to install the amanda package to each
168 AMANDA client. It requires at least one of dump and GNU tar installed.
169
170 %description client -l pl.UTF-8
171 Ten pakiet powinien być zainstalowany ma maszynach, z których
172 zawartości będą tworzone kopie zapasowe. Wymaga zainstalowanego co
173 najmniej jednego z pakietów dump i GNU tar.
174
175 %package server
176 Summary:        The server side of Amanda
177 Summary(pl.UTF-8):      Serwer Amandy
178 Group:          Networking/Utilities
179 Requires(post): /bin/hostname
180 Requires(post): /usr/bin/ssh-keygen
181 Requires:       %{name}-common = %{version}-%{release}
182 Requires:       /etc/cron.d
183 Requires:       crondaemon
184 Requires:       gnuplot
185 Requires:       mt-st
186 Requires:       mtx
187 Requires:       rc-inetd
188 Suggests:       openssh-clients
189 Suggests:       openssh-server
190 Obsoletes:      amanda
191 Obsoletes:      amanda-perl-server
192
193 %description server
194 The amanda-server package should be installed on the AMANDA server,
195 the machine attached to the device (such as a tape drive) where
196 backups will be written. You will also need to install the amanda
197 package to the AMANDA server. And, if the server is also to be backed
198 up, the server also needs to have the amanda-client package installed.
199
200 %description server -l pl.UTF-8
201 Ten pakiet powinien być zainstalowany na maszynach, na których będą
202 magazynowane kopie zapasowe (lub do których podpięte są urządzenia
203 typu streamer).
204
205 %prep
206 %setup -q
207 %patch0 -p1
208
209 %patch2 -p1
210 %patch3 -p1
211 %patch4 -p1
212 %patch5 -p1
213 %patch6 -p1
214 %patch7 -p1
215 %patch8 -p1
216 %patch9 -p1
217
218 %patch12 -p1
219
220 %patch14 -p1
221 %patch15 -p1
222 cp -a %{SOURCE10} .
223
224 find perl/ -name '*.swg' -print0 | xargs -0 touch
225
226 %build
227 %{__libtoolize}
228 %{__aclocal} -I config -I config/gettext-macros -I config/gnulib -I config/amanda -I config/macro-archive
229 %{__autoconf}
230 %{__automake}
231 %configure \
232         DUMP=/sbin/dump \
233         GZIP=/bin/gzip \
234         MAILER=/bin/mail \
235         MT=/bin/mt \
236         MTX=/usr/sbin/mtx \
237         PRINT=/usr/bin/lpr \
238         RESTORE=/sbin/restore \
239         %{?with_xfs:XFSDUMP=/sbin/xfsdump} \
240         %{?with_xfs:XFSRESTORE=/sbin/xfsrestore} \
241         --disable-static \
242         --enable-shared \
243         %{!?with_server:--without-server} \
244         %{!?with_client:--without-client} \
245         --with-index-server=localhost \
246         --with-user=amanda \
247         --with-group=amanda \
248         --with-tape-device=/dev/null \
249         --with-fqdn \
250         %{?with_samba:--with-smbclient=%{_bindir}/smbclient} \
251         --with-star=%{_bindir}/star \
252         --with-gnuplot=%{_bindir}/gnuplot \
253         --with-bsd-security \
254         --with-bsdtcp-security \
255         --with-ssh-security \
256         --with-krb5-security \
257         --with-buffered-dump \
258         --with-amandahosts \
259         --with-configdir=%{_sysconfdir}/amanda \
260         --with-gnutar-listdir=%{_sharedstatedir}/amanda/gnutar-lists \
261         --with-amandates=%{_sharedstatedir}/amanda/amandates \
262         --with-debugging=%{_sharedstatedir}/amanda/debug \
263         --with-tmpdir=/var/tmp/amanda \
264         --with-amperldir=%{perl_vendorarch} \
265         --with-ipv6 \
266         --with-readline \
267         --disable-installperms
268
269 %{__make}
270
271 %install
272 rm -rf $RPM_BUILD_ROOT
273 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{amanda,cron.d,sysconfig/rc-inetd} \
274         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/{.gnupg,.ssh,gnutar-lists} \
275         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/debug/{amandad,client,server}
276
277 %{__make} install \
278         DESTDIR=$RPM_BUILD_ROOT
279
280 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amanda-srv
281 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE2} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amanda
282 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE3} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amandaidx
283 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE4} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amidxtape
284 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE5} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/k5amanda
285
286 cp -p example/amanda.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
287 cp -p example/amanda-client.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
288 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.amandahosts
289
290 install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sbindir}/amconvert-zd-mtx-to-robot.sh
291
292 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/config
293 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/{,client_}authorized_keys
294 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amdump{,.pub}
295 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover{,.pub}
296
297 %if %{with server}
298 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/amanda/lvm-snapshot.conf
299 %endif
300
301 %if %{with client}
302 sed -e 's|@@PERL_VENDORARCH@@|%{perl_vendorarch}|' %{SOURCE9} >$RPM_BUILD_ROOT%{_libexecdir}/amanda/application/amlvm-snapshot
303 %endif
304
305 > $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/amandates
306
307 # Amanda tools generate ssh keys with embeded commands pointing to /usr/lib
308 # Tools can't be "fixed" because keys generated on server are to be used on client
309 if [ "%{_lib}" != "lib" ] ; then
310         install -d $RPM_BUILD_ROOT%{_ulibdir}
311         ln -s %{_libdir}/amanda $RPM_BUILD_ROOT%{_ulibdir}/amanda
312 fi
313
314 find $RPM_BUILD_ROOT -name \*.la | xargs rm -f
315
316 %{__rm} $RPM_BUILD_ROOT%{_datadir}/amanda/{COPYRIGHT,ChangeLog,NEWS,ReleaseNotes}
317 %{__rm} $RPM_BUILD_ROOT%{_datadir}/amanda/example/{chg-multi,chg-scsi}.conf
318
319 %clean
320 rm -rf $RPM_BUILD_ROOT
321
322 %triggerpostun common -- amanda-libs < 2.6.0p2-3
323 echo "Adding amanda to disk and tape groups"
324 /usr/sbin/usermod -G disk,tape amanda
325 echo "Setting amanda shell to /bin/sh"
326 /usr/bin/chsh -s /bin/sh amanda
327 if [ -f %{_sharedstatedir}/amanda/.amandahosts ]; then
328         echo "Fixing permissions of %{_sharedstatedir}/amanda/.amandahosts file"
329         chown amanda:amanda %{_sharedstatedir}/amanda/.amandahosts
330         chmod 600 %{_sharedstatedir}/amanda/.amandahosts
331 fi
332
333 %triggerpostun common -- amanda-common < 3.3
334 %banner %{name}-common -e << EOF
335 In amanda 3.3 the default auth has changed to "bsdtcp",
336 if you are using the default "bsd" then you must add it
337 to your configuration:
338
339  *   in amanda.conf
340  *   in amanda-client.conf
341  *   in dumptype/disklist
342  *   in inetd (if no '-auth' argument to amandad)
343 EOF
344
345 %pre common
346 %groupadd -P %{name}-common -g 80 amanda
347 %useradd -P %{name}-common -u 80 -G disk,tape -d /var/lib/amanda -s /bin/sh -c "Amanda Backup user" -g amanda amanda
348
349 %postun common
350 if [ "$1" = "0" ]; then
351         %userremove amanda
352         %groupremove amanda
353 fi
354
355 %post client
356 %service -q rc-inetd reload
357 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amrecover ] ; then
358         HOST="`/bin/hostname`"
359         FQDNHOST="`/bin/hostname -f`"
360         if [ -z "$HOST" ] ; then
361                 COMMENT="root@client"
362         else
363                 COMMENT="root@$HOST"
364         fi
365         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amrecover -N "" || :
366         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
367         chmod 600 /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
368         if [ -n "$FQDNHOST" ]; then
369                 echo -n "from=\"$FQDNHOST\",no-port-forwarding,no-X11-forwarding,no-agent-forwarding,command=\"%{_ulibdir}/amanda/amandad -auth=ssh amindexd amidxtaped\" " >/var/lib/amanda/.ssh/server_authorized_keys
370                 cat /var/lib/amanda/.ssh/id_rsa_amrecover.pub >>/var/lib/amanda/.ssh/server_authorized_keys
371
372                 echo "Remember to copy the contents of /var/lib/amanda/.ssh/server_authorized_keys to"
373                 echo "/var/lib/amanda/.ssh/authorized_keys on amanda server"
374         fi
375 fi
376
377 %postun client
378 if [ "$1" = 0 ]; then
379         %service -q rc-inetd reload
380 fi
381
382 %post server
383 %service -q rc-inetd reload
384 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amdump ] ; then
385         HOST="`/bin/hostname`"
386         if [ -z "$HOST" ] ; then
387                 COMMENT="amanda@server"
388         else
389                 COMMENT="amanda@$HOST"
390         fi
391         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amdump -N "" || :
392         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
393         chmod 600 /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
394 fi
395 if [ "$1" = "1" ]; then
396         echo "Don't forget to edit /etc/cron.d/amanda-srv." 1>&2
397 fi
398
399 %postun server
400 if [ "$1" = 0 ]; then
401         %service -q rc-inetd reload
402 fi
403
404 %triggerpostun server -- amanda-server < 3.2.0
405 %banner %{name} -e << EOF
406 Warning: Tape changer configuration has chaged, please read
407 %{_docdir}/%{name}-server-%{version}/ReleaseNotes.gz
408 and %{_docdir}/%{name}-server-%{version}/NEWS.gz for details.
409 You can use %{_sbindir}/amconvert-zd-mtx-to-robot.sh script
410 to upgrade to chg-robot.
411 EOF
412
413 %files common
414 %defattr(644,root,root,755)
415 %doc AUTHORS COPYRIGHT ChangeLog NEWS README ReleaseNotes UPGRADING amlvm-snapshot.README
416 %attr(755,root,root) %{_libdir}/amanda/libamanda*.so
417 %attr(755,root,root) %{_libdir}/amanda/libamar*.so
418 %attr(755,root,root) %{_libdir}/amanda/libamdevice*.so
419 %attr(755,root,root) %{_libdir}/amanda/libamglue*.so
420 %attr(755,root,root) %{_libdir}/amanda/libamserver*.so
421 %attr(755,root,root) %{_libdir}/amanda/libamxfer*.so
422 %attr(755,root,root) %{_libdir}/amanda/libndmjob*.so
423 %attr(755,root,root) %{_libdir}/amanda/libndmlib*.so
424 %attr(750,amanda,amanda) %dir %{_sysconfdir}/amanda
425 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/amanda-security.conf
426 %dir %{_libdir}/amanda
427 %if %{_lib} != "lib"
428 %{_ulibdir}/amanda
429 %endif
430 %dir %{_libexecdir}/amanda
431 %{_libexecdir}/amanda/amanda-sh-lib.sh
432 %attr(4750,root,amanda) %{_libexecdir}/amanda/ambind
433 %attr(755,root,root) %{_libexecdir}/amanda/amcat.awk
434 %attr(755,root,root) %{_libexecdir}/amanda/amndmjob
435 %attr(755,root,root) %{_libexecdir}/amanda/amplot.awk
436 %attr(755,root,root) %{_libexecdir}/amanda/amplot.g
437 %attr(755,root,root) %{_libexecdir}/amanda/amplot.gp
438 %attr(755,root,root) %{_libexecdir}/amanda/ndmjob
439 %attr(755,root,root) %{_sbindir}/amaespipe
440 %attr(755,root,root) %{_sbindir}/amarchiver
441 %attr(755,root,root) %{_sbindir}/amcrypt*
442 %attr(755,root,root) %{_sbindir}/amgetconf
443 %attr(755,root,root) %{_sbindir}/amgpgcrypt
444 %attr(755,root,root) %{_sbindir}/amplot
445 %attr(755,root,root) %{_sbindir}/amservice
446 %attr(755,root,root) %{_sbindir}/amssl
447 %attr(750,amanda,amanda) %dir %{_datadir}/amanda
448 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/example
449 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/example/label-templates
450 %attr(640,amanda,amanda) %{_datadir}/amanda/example/*amanda*
451 %attr(640,amanda,amanda) %{_datadir}/amanda/example/disklist
452 %attr(640,amanda,amanda) %{_datadir}/amanda/example/label-templates/*.ps
453 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/template.d
454 %attr(640,amanda,amanda) %{_datadir}/amanda/template.d/*
455 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda
456 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.ssh
457 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.gnupg
458 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug
459 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/amandad
460 %attr(600,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/.amandahosts
461 %attr(600,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/.ssh/config
462 # Commented out so it won't get removed on uninstall
463 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/authorized_keys
464 %{_mandir}/man5/amanda-archive-format.5*
465 %{_mandir}/man5/amanda-security.conf.5*
466 %{_mandir}/man7/amanda-auth.7*
467 %{_mandir}/man7/amanda-auth-ssl.7*
468 %{_mandir}/man7/amanda-match.7*
469 %{_mandir}/man7/amanda-scripts.7*
470 %{_mandir}/man8/amanda.8*
471 %{_mandir}/man8/amaespipe.8*
472 %{_mandir}/man8/amarchiver.8*
473 %{_mandir}/man8/amcrypt*.8*
474 %{_mandir}/man8/amgetconf.8*
475 %{_mandir}/man8/amgpgcrypt.8*
476 %{_mandir}/man8/amplot.8*
477 %{_mandir}/man8/amservice.8*
478 %{_mandir}/man8/amssl.8*
479 %{_mandir}/man8/script-email.8*
480
481 %dir %{perl_vendorarch}/Amanda
482 %dir %{perl_vendorarch}/Amanda/Config
483 %dir %{perl_vendorarch}/Amanda/IPC
484 %{perl_vendorarch}/Amanda/Amservice.pm
485 %{perl_vendorarch}/Amanda/Archive.pm
486 %{perl_vendorarch}/Amanda/BigIntCompat.pm
487 %{perl_vendorarch}/Amanda/Changer.pm
488 %dir %{perl_vendorarch}/Amanda/Changer
489 %{perl_vendorarch}/Amanda/Changer/*.pm
490 %{perl_vendorarch}/Amanda/ClientService.pm
491 %{perl_vendorarch}/Amanda/Cmdline.pm
492 %{perl_vendorarch}/Amanda/Cmdfile.pm
493 %{perl_vendorarch}/Amanda/Config.pm
494 %{perl_vendorarch}/Amanda/Config/FoldingHash.pm
495 %{perl_vendorarch}/Amanda/Constants.pm
496 %{perl_vendorarch}/Amanda/DB.pm
497 %dir %{perl_vendorarch}/Amanda/DB
498 %{perl_vendorarch}/Amanda/DB/*.pm
499 %{perl_vendorarch}/Amanda/Debug.pm
500 %{perl_vendorarch}/Amanda/Device.pm
501 %{perl_vendorarch}/Amanda/Disklist.pm
502 %{perl_vendorarch}/Amanda/Extract.pm
503 %{perl_vendorarch}/Amanda/Feature.pm
504 %{perl_vendorarch}/Amanda/FetchDump.pm
505 %dir %{perl_vendorarch}/Amanda/FetchDump
506 %{perl_vendorarch}/Amanda/FetchDump/*.pm
507 %{perl_vendorarch}/Amanda/Header.pm
508 %{perl_vendorarch}/Amanda/Holding.pm
509 %{perl_vendorarch}/Amanda/IPC/Binary.pm
510 %{perl_vendorarch}/Amanda/IPC/LineProtocol.pm
511 %{perl_vendorarch}/Amanda/Interactivity.pm
512 %dir %{perl_vendorarch}/Amanda/Interactivity
513 %{perl_vendorarch}/Amanda/Interactivity/*.pm
514 %{perl_vendorarch}/Amanda/Logfile.pm
515 %{perl_vendorarch}/Amanda/MainLoop.pm
516 %{perl_vendorarch}/Amanda/Message.pm
517 %{perl_vendorarch}/Amanda/NDMP.pm
518 %{perl_vendorarch}/Amanda/Paths.pm
519 %{perl_vendorarch}/Amanda/Policy.pm
520 %{perl_vendorarch}/Amanda/Process.pm
521 %{perl_vendorarch}/Amanda/Recovery.pm
522 %dir %{perl_vendorarch}/Amanda/Recovery
523 %{perl_vendorarch}/Amanda/Recovery/*.pm
524 %{perl_vendorarch}/Amanda/Restore.pm
525 %{perl_vendorarch}/Amanda/Script.pm
526 %{perl_vendorarch}/Amanda/Script_App.pm
527 %{perl_vendorarch}/Amanda/Service.pm
528 %dir %{perl_vendorarch}/Amanda/Service
529 %{perl_vendorarch}/Amanda/Storage.pm
530 %{perl_vendorarch}/Amanda/Tapelist.pm
531 %{perl_vendorarch}/Amanda/Tests.pm
532 %{perl_vendorarch}/Amanda/Util.pm
533 %{perl_vendorarch}/Amanda/Xfer.pm
534 %dir %{perl_vendorarch}/auto/Amanda
535 %dir %{perl_vendorarch}/auto/Amanda/Archive
536 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Archive/*.so
537 %dir %{perl_vendorarch}/auto/Amanda/Cmdfile
538 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Cmdfile/*.so
539 %dir %{perl_vendorarch}/auto/Amanda/Cmdline
540 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Cmdline/*.so
541 %dir %{perl_vendorarch}/auto/Amanda/Config
542 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Config/*.so
543 %dir %{perl_vendorarch}/auto/Amanda/Debug
544 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Debug/*.so
545 %dir %{perl_vendorarch}/auto/Amanda/Device
546 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Device/*.so
547 %dir %{perl_vendorarch}/auto/Amanda/Disklist
548 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Disklist/*.so
549 %dir %{perl_vendorarch}/auto/Amanda/Feature
550 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Feature/*.so
551 %dir %{perl_vendorarch}/auto/Amanda/Header
552 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Header/*.so
553 %dir %{perl_vendorarch}/auto/Amanda/IPC
554 %dir %{perl_vendorarch}/auto/Amanda/IPC/Binary
555 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/IPC/Binary/*.so
556 %dir %{perl_vendorarch}/auto/Amanda/Logfile
557 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Logfile/*.so
558 %dir %{perl_vendorarch}/auto/Amanda/MainLoop
559 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/MainLoop/*.so
560 %dir %{perl_vendorarch}/auto/Amanda/NDMP
561 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/NDMP/*.so
562 %dir %{perl_vendorarch}/auto/Amanda/Tapelist
563 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Tapelist/*.so
564 %dir %{perl_vendorarch}/auto/Amanda/Tests
565 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Tests/*.so
566 %dir %{perl_vendorarch}/auto/Amanda/Util
567 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Util/*.so
568 %dir %{perl_vendorarch}/auto/Amanda/Xfer
569 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Xfer/*.so
570
571 %if %{with server}
572 %files server
573 %defattr(644,root,root,755)
574 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amidxtape
575 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amandaidx
576
577 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/amanda.conf
578 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/lvm-snapshot.conf
579
580 # Commented out so it won't get removed on uninstall
581 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/client_authorized_keys
582 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amdump*
583
584 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/server
585
586 %config(noreplace) %attr(640,root,root) /etc/cron.d/amanda-srv
587
588 %attr(755,root,root) %{_libexecdir}/amanda/amadmin_perl
589 %attr(755,root,root) %{_libexecdir}/amanda/ambackupd
590 %attr(755,root,root) %{_libexecdir}/amanda/amcheck-device
591 %attr(755,root,root) %{_libexecdir}/amanda/amdumpd
592 %attr(755,root,root) %{_libexecdir}/amanda/amidxtaped
593 %attr(755,root,root) %{_libexecdir}/amanda/amindexd
594 %attr(755,root,root) %{_libexecdir}/amanda/amlogroll
595 %attr(755,root,root) %{_libexecdir}/amanda/amtrmidx
596 %attr(755,root,root) %{_libexecdir}/amanda/amtrmlog
597 %attr(755,root,root) %{_libexecdir}/amanda/chunker
598 %attr(755,root,root) %{_libexecdir}/amanda/driver
599 %attr(755,root,root) %{_libexecdir}/amanda/dumper
600 %attr(755,root,root) %{_libexecdir}/amanda/planner
601 %attr(755,root,root) %{_libexecdir}/amanda/taper
602
603 %dir %{_libexecdir}/amanda/rest-server
604 %dir %{_libexecdir}/amanda/rest-server/bin
605 %attr(755,root,root) %{_libexecdir}/amanda/rest-server/bin/app-dancer2.pl
606 %attr(755,root,root) %{_libexecdir}/amanda/rest-server/bin/app.pl
607 %{_libexecdir}/amanda/rest-server/config-dancer
608 %{_libexecdir}/amanda/rest-server/config.yml
609 %{_libexecdir}/amanda/rest-server/environments
610 %dir %{_libexecdir}/amanda/rest-server/lib
611 %dir %{_libexecdir}/amanda/rest-server/lib/Amanda
612 %{_libexecdir}/amanda/rest-server/lib/Amanda/Rest.pm
613 %dir %{_libexecdir}/amanda/rest-server/public
614 %{_libexecdir}/amanda/rest-server/public/*.html
615 %{_libexecdir}/amanda/rest-server/public/css
616 %{_libexecdir}/amanda/rest-server/public/dispatch.cgi
617 %{_libexecdir}/amanda/rest-server/public/dispatch.fcgi
618 %{_libexecdir}/amanda/rest-server/public/favicon.ico
619 %{_libexecdir}/amanda/rest-server/public/images
620 %{_libexecdir}/amanda/rest-server/public/javascripts
621 %{_libexecdir}/amanda/rest-server/views
622
623 %attr(755,root,root) %{_sbindir}/activate-devpay
624 %attr(755,root,root) %{_sbindir}/amaddclient
625 %attr(755,root,root) %{_sbindir}/amadmin
626 %attr(755,root,root) %{_sbindir}/amanda-rest-server
627 %attr(755,root,root) %{_sbindir}/amcheck
628 %attr(755,root,root) %{_sbindir}/amcheckdb
629 %attr(755,root,root) %{_sbindir}/amcheckdump
630 %attr(755,root,root) %{_sbindir}/amcleanup
631 %attr(755,root,root) %{_sbindir}/amcleanupdisk
632 %attr(755,root,root) %{_sbindir}/amconvert-zd-mtx-to-robot.sh
633 %attr(755,root,root) %{_sbindir}/amdevcheck
634 %attr(755,root,root) %{_sbindir}/amdump
635 %attr(755,root,root) %{_sbindir}/amfetchdump
636 %attr(755,root,root) %{_sbindir}/amflush
637 %attr(755,root,root) %{_sbindir}/amlabel
638 %attr(755,root,root) %{_sbindir}/amoverview
639 %attr(755,root,root) %{_sbindir}/amreindex
640 %attr(755,root,root) %{_sbindir}/amreport
641 %attr(755,root,root) %{_sbindir}/amrestore
642 %attr(755,root,root) %{_sbindir}/amrmtape
643 %attr(755,root,root) %{_sbindir}/amserverconfig
644 %attr(755,root,root) %{_sbindir}/amstatus
645 %attr(755,root,root) %{_sbindir}/amtape
646 %attr(755,root,root) %{_sbindir}/amtapetype
647 %attr(755,root,root) %{_sbindir}/amtoc
648 %attr(755,root,root) %{_sbindir}/amvault
649 %{_mandir}/man5/amanda.conf.5*
650 %{_mandir}/man5/amanda-command-file.5*
651 %{_mandir}/man5/disklist.5*
652 %{_mandir}/man5/tapelist.5*
653 %{_mandir}/man7/amanda-changers.7*
654 %{_mandir}/man7/amanda-compatibility.7*
655 %{_mandir}/man7/amanda-devices.7*
656 %{_mandir}/man7/amanda-interactivity.7*
657 %{_mandir}/man7/amanda-taperscan.7*
658 %{_mandir}/man8/amaddclient.8*
659 %{_mandir}/man8/amadmin.8*
660 %{_mandir}/man8/amanda-rest-server.8*
661 %{_mandir}/man8/amcheck.8*
662 %{_mandir}/man8/amcheckdb.8*
663 %{_mandir}/man8/amcheckdump.8*
664 %{_mandir}/man8/amcleanup.8*
665 %{_mandir}/man8/amcleanupdisk.8*
666 %{_mandir}/man8/amdevcheck.8*
667 %{_mandir}/man8/amdump.8*
668 %{_mandir}/man8/amfetchdump.8*
669 %{_mandir}/man8/amflush.8*
670 %{_mandir}/man8/amlabel.8*
671 %{_mandir}/man8/amoverview.8*
672 %{_mandir}/man8/amreindex.8*
673 %{_mandir}/man8/amreport.8*
674 %{_mandir}/man8/amrestore.8*
675 %{_mandir}/man8/amrmtape.8*
676 %{_mandir}/man8/amserverconfig.8*
677 %{_mandir}/man8/amstatus.8*
678 %{_mandir}/man8/amtape.8*
679 %{_mandir}/man8/amtapetype.8*
680 %{_mandir}/man8/amtoc.8*
681 %{_mandir}/man8/amvault.8*
682
683 %{perl_vendorarch}/Amanda/Amdump.pm
684 %{perl_vendorarch}/Amanda/Amflush.pm
685 %{perl_vendorarch}/Amanda/CheckDump.pm
686 %dir %{perl_vendorarch}/Amanda/Chunker
687 %{perl_vendorarch}/Amanda/Chunker/*.pm
688 %{perl_vendorarch}/Amanda/Cleanup.pm
689 %{perl_vendorarch}/Amanda/Curinfo.pm
690 %dir %{perl_vendorarch}/Amanda/Curinfo
691 %{perl_vendorarch}/Amanda/Curinfo/*.pm
692 %{perl_vendorarch}/Amanda/Index.pm
693 %{perl_vendorarch}/Amanda/Label.pm
694 %{perl_vendorarch}/Amanda/Report.pm
695 %dir %{perl_vendorarch}/Amanda/Report
696 %{perl_vendorarch}/Amanda/Report/*.pm
697 %dir %{perl_vendorarch}/Amanda/Rest
698 %{perl_vendorarch}/Amanda/Rest/*.pm
699 %dir %{perl_vendorarch}/Amanda/Rest/Storages
700 %{perl_vendorarch}/Amanda/Rest/Storages/*.pm
701 %{perl_vendorarch}/Amanda/ScanInventory.pm
702 %{perl_vendorarch}/Amanda/Service/Amidxtaped.pm
703 %{perl_vendorarch}/Amanda/Status.pm
704 %dir %{perl_vendorarch}/Amanda/Taper
705 %{perl_vendorarch}/Amanda/Taper/*.pm
706 %dir %{perl_vendorarch}/Amanda/Taper/Scan
707 %{perl_vendorarch}/Amanda/Taper/Scan/*.pm
708 %{perl_vendorarch}/Amanda/Vault.pm
709 %{perl_vendorarch}/Amanda/XferServer.pm
710 %dir %{perl_vendorarch}/auto/Amanda/XferServer
711 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/XferServer/*.so
712 %endif
713
714 %if %{with client}
715 %files client
716 %defattr(644,root,root,755)
717 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amanda
718 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/k5amanda
719 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,amanda) %{_sysconfdir}/amanda/amanda-client.conf
720 # Commented out so it won't get removed on uninstall
721 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover*
722 %attr(640,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/amandates
723
724 %dir %{_libexecdir}/amanda/application
725 %attr(4750,root,amanda) %{_libexecdir}/amanda/application/ambsdtar
726 %attr(4750,root,amanda) %{_libexecdir}/amanda/application/amgtar
727 %attr(755,root,root) %{_libexecdir}/amanda/application/amlog-script
728 %attr(755,root,root) %{_libexecdir}/amanda/application/amlvm-snapshot
729 %attr(755,root,root) %{_libexecdir}/amanda/application/ampgsql
730 %attr(755,root,root) %{_libexecdir}/amanda/application/amrandom
731 %attr(755,root,root) %{_libexecdir}/amanda/application/amraw
732 %attr(755,root,root) %{_libexecdir}/amanda/application/amsamba
733 %attr(4750,root,amanda) %{_libexecdir}/amanda/application/amstar
734 %attr(755,root,root) %{_libexecdir}/amanda/application/amsuntar
735 %attr(755,root,root) %{_libexecdir}/amanda/application/amzfs*
736 %attr(755,root,root) %{_libexecdir}/amanda/application/script-email
737 %attr(755,root,root) %{_libexecdir}/amanda/application/script-fail
738
739 %attr(755,root,root) %{_libdir}/amanda/libamclient*.so
740 %attr(755,root,root) %{_libexecdir}/amanda/amandad
741 %attr(755,root,root) %{_libexecdir}/amanda/noop
742 %attr(755,root,root) %{_libexecdir}/amanda/patch-system
743 %attr(755,root,root) %{_libexecdir}/amanda/restore
744 %attr(755,root,root) %{_libexecdir}/amanda/sendbackup
745 %attr(755,root,root) %{_libexecdir}/amanda/senddiscover
746 %attr(755,root,root) %{_libexecdir}/amanda/sendsize
747 %attr(755,root,root) %{_libexecdir}/amanda/teecount
748 %attr(4750,root,amanda) %{_libexecdir}/amanda/calcsize
749 %attr(4750,root,amanda) %{_libexecdir}/amanda/killpgrp
750 %attr(4750,root,amanda) %{_libexecdir}/amanda/rundump
751 %attr(4750,root,amanda) %{_libexecdir}/amanda/runtar
752 %attr(755,root,root) %{_libexecdir}/amanda/selfcheck
753 %attr(755,root,root) %{_sbindir}/ambackup
754 %attr(755,root,root) %{_sbindir}/amdump_client
755 %attr(755,root,root) %{_sbindir}/amoldrecover
756 %attr(755,root,root) %{_sbindir}/amrecover
757 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/gnutar-lists
758 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/client
759 %{_mandir}/man7/amanda-applications.7*
760 %{_mandir}/man5/amanda-client.conf.5*
761 %{_mandir}/man8/amdump_client.8*
762 %{_mandir}/man8/ambackup.8*
763 %{_mandir}/man8/ambsdtar.8*
764 %{_mandir}/man8/amgtar.8*
765 %{_mandir}/man8/ampgsql.8*
766 %{_mandir}/man8/amrecover.8*
767 %{_mandir}/man8/amraw.8*
768 %{_mandir}/man8/amsamba.8*
769 %{_mandir}/man8/amstar.8*
770 %{_mandir}/man8/amsuntar.8*
771 %{_mandir}/man8/amzfs*.8*
772
773 %{perl_vendorarch}/Amanda/Application.pm
774 %dir %{perl_vendorarch}/Amanda/Application
775 %{perl_vendorarch}/Amanda/Application/Zfs.pm
776 %{perl_vendorarch}/Amanda/Service/Restore.pm
777 %dir %{perl_vendorarch}/auto/Amanda/Application
778 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Application/*.so
779 %endif
This page took 0.081954 seconds and 4 git commands to generate.