]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
rebuild with perl 5.34.0
[packages/amanda.git] / amanda.spec
1 # TODO:
2 #  - init/service for client 'restore' service
3 #  - untangle client/server perl deps for 'restore' service
4 #
5 # Conditional build:
6 %bcond_without  xfs     # without (possible) support for xfsdump
7 %bcond_without  samba   # without smbclient support
8 %bcond_without  client  # without client package
9 %bcond_without  server  # without server package
10
11 Summary:        A network-capable tape backup solution
12 Summary(pl.UTF-8):      Sieciowo zorientowany system tworzenia kopii zapasowych
13 Name:           amanda
14 Version:        3.5.1
15 Release:        6
16 License:        BSD
17 Group:          Networking/Utilities
18 Source0:        http://downloads.sourceforge.net/amanda/%{name}-%{version}.tar.gz
19 # Source0-md5:  f57307959f79e722b1dcb3f985ebb0d0
20 Source1:        %{name}-srv.crontab
21 Source2:        %{name}.inetd
22 Source3:        %{name}idx.inetd
23 Source4:        amidxtape.inetd
24 Source5:        k5%{name}.inet
25 # http://amanda.svn.sourceforge.net/viewvc/amanda/amanda/branches/3_2/contrib/convert-zd-mtx-to-robot.sh
26 Source6:        convert-zd-mtx-to-robot.sh
27 Source7:        %{name}-ssh_config
28 # https://github.com/janekr/amlvm-snapshot
29 Source8:        amlvm-snapshot.conf
30 Source9:        amlvm-snapshot.pl
31 Source10:       amlvm-snapshot.README
32 Patch0:         %{name}-no_libnsl.patch
33 Patch1:         %{name}-tar.patch
34 Patch2:         %{name}-common.patch
35 Patch3:         %{name}-as_needed.patch
36 Patch4:         %{name}-tapetypes.patch
37 Patch5:         %{name}-FHS.patch
38 Patch6:         %{name}-no-buildtime-ipv6.patch
39 Patch7:         %{name}-heimdal.patch
40 Patch8:         %{name}-ac.patch
41 Patch9:         %{name}-krb5-auth.patch
42 Patch10:        swig.patch
43 Patch11:        krb5-ac.patch
44 Patch12:        missing-extern.patch
45 Patch13:        tirpc.patch
46 URL:            http://www.amanda.org/
47 %{?with_samba:BuildRequires:    /usr/bin/smbclient}
48 BuildRequires:  autoconf >= 2.64
49 BuildRequires:  automake
50 BuildRequires:  curl-devel >= 7.10.0
51 BuildRequires:  dump
52 BuildRequires:  flex
53 BuildRequires:  glib2-devel
54 BuildRequires:  gnuplot
55 BuildRequires:  heimdal-devel
56 BuildRequires:  rpmbuild(macros) >= 1.654
57 # curl is broken, see curl-config --libs (c8cba693)
58 BuildRequires:  keyutils-devel
59 BuildRequires:  libtirpc-devel
60 BuildRequires:  libtool
61 BuildRequires:  libxslt-progs
62 BuildRequires:  ncurses-devel
63 BuildRequires:  openssh-clients
64 BuildRequires:  openssl-devel
65 BuildRequires:  perl-devel >= 5.6.0
66 BuildRequires:  pkgconfig
67 BuildRequires:  readline-devel >= 4.2
68 BuildRequires:  rpm-perlprov
69 BuildRequires:  rpmbuild(macros) >= 1.654
70 BuildRequires:  swig
71 %{?with_xfs:BuildRequires:      xfsdump}
72 Conflicts:      pwdutils < 3.1.2-2
73 Conflicts:      shadow < 1:4.0.4.1-4
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 # for some unknown reason those get detected in R but not in P (Tie::StdHash comes from perl)
77 %define         _noautoreq_perl Tie::StdHash Amanda::Recovery::Clerk::Feedback Amanda::Taper::Scribe::Feedback
78
79 %define         _ulibdir        %{_prefix}/lib
80
81 %description
82 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
83 backup system that allows the administrator of a LAN to set up a
84 single master backup server to back up multiple hosts to a single
85 large capacity tape drive. AMANDA uses native dump and/or GNU tar
86 facilities and can back up a large number of workstations running
87 multiple versions of Unix. Newer versions of AMANDA (including this
88 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
89 The amanda package contains the core AMANDA programs and will need to
90 be installed on both AMANDA clients and AMANDA servers. Note that you
91 will have to install the amanda-client and amanda-server packages as
92 well.
93
94 %description -l pl.UTF-8
95 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
96 zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
97 hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
98 Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
99 Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
100 podstawowe pliki programu i powinien być zainstalowany zarówno na
101 serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
102 amanda-client i amanda-server!
103
104 %package common
105 Summary:        Amanda common files
106 Summary(pl.UTF-8):      Wspólne pliki pakietu amanda
107 Group:          Networking/Utilities
108 Requires(postun):       /usr/sbin/groupdel
109 Requires(postun):       /usr/sbin/userdel
110 Requires(pre):  /bin/id
111 Requires(pre):  /usr/bin/chsh
112 Requires(pre):  /usr/bin/getgid
113 Requires(pre):  /usr/sbin/groupadd
114 Requires(pre):  /usr/sbin/useradd
115 %requires_ge glib2
116 Requires:       setup >= 2.6.1-1
117 Provides:       group(amanda)
118 Provides:       user(amanda)
119 Obsoletes:      amanda-libs
120 Obsoletes:      amanda-perl
121
122 %description common
123 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
124 backup system that allows the administrator of a LAN to set up a
125 single master backup server to back up multiple hosts to a single
126 large capacity tape drive. AMANDA uses native dump and/or GNU tar
127 facilities and can back up a large number of workstations running
128 multiple versions of Unix. Newer versions of AMANDA (including this
129 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
130 The amanda package contains the core AMANDA programs and will need to
131 be installed on both AMANDA clients and AMANDA servers. Note that you
132 will have to install the amanda-client and amanda-server packages as
133 well.
134
135 Amanda common files.
136
137 %description common -l pl.UTF-8
138 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
139 zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
140 hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
141 Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
142 Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
143 podstawowe pliki programu i powinien być zainstalowany zarówno na
144 serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
145 amanda-client i amanda-server!
146
147 Wspólne pliki pakietu amanda.
148
149 %package client
150 Summary:        The client side of Amanda
151 Summary(pl.UTF-8):      Klient Amandy
152 Group:          Networking/Utilities
153 Requires(post): /bin/hostname
154 Requires(post): /usr/bin/ssh-keygen
155 Requires:       %{name}-common = %{version}-%{release}
156 Requires:       rc-inetd
157 Suggests:       gzip
158 Suggests:       openssh-clients
159 Suggests:       openssh-server
160 Suggests:       star
161 Suggests:       tar
162 Conflicts:      tar < 1.15
163
164 %description client
165 The Amanda-client package should be installed on any machine that will
166 be backed up by AMANDA (including the server if it also needs to be
167 backed up). You will also need to install the amanda package to each
168 AMANDA client. It requires at least one of dump and GNU tar installed.
169
170 %description client -l pl.UTF-8
171 Ten pakiet powinien być zainstalowany ma maszynach, z których
172 zawartości będą tworzone kopie zapasowe. Wymaga zainstalowanego co
173 najmniej jednego z pakietów dump i GNU tar.
174
175 %package server
176 Summary:        The server side of Amanda
177 Summary(pl.UTF-8):      Serwer Amandy
178 Group:          Networking/Utilities
179 Requires(post): /bin/hostname
180 Requires(post): /usr/bin/ssh-keygen
181 Requires:       %{name}-common = %{version}-%{release}
182 Requires:       /etc/cron.d
183 Requires:       crondaemon
184 Requires:       gnuplot
185 Requires:       mt-st
186 Requires:       mtx
187 Requires:       rc-inetd
188 Suggests:       openssh-clients
189 Suggests:       openssh-server
190 Obsoletes:      amanda
191 Obsoletes:      amanda-perl-server
192
193 %description server
194 The amanda-server package should be installed on the AMANDA server,
195 the machine attached to the device (such as a tape drive) where
196 backups will be written. You will also need to install the amanda
197 package to the AMANDA server. And, if the server is also to be backed
198 up, the server also needs to have the amanda-client package installed.
199
200 %description server -l pl.UTF-8
201 Ten pakiet powinien być zainstalowany na maszynach, na których będą
202 magazynowane kopie zapasowe (lub do których podpięte są urządzenia
203 typu streamer).
204
205 %prep
206 %setup -q
207 %patch0 -p1
208 %patch1 -p1
209 %patch2 -p1
210 %patch3 -p1
211 %patch4 -p1
212 %patch5 -p1
213 %patch6 -p1
214 %patch7 -p1
215 %patch8 -p1
216 %patch9 -p1
217 %patch10 -p1
218 %patch11 -p1
219 %patch12 -p1
220 %patch13 -p1
221 cp -a %{SOURCE10} .
222
223 find perl/ -name '*.swg' -print0 | xargs -0 touch
224
225 %build
226 %{__libtoolize}
227 %{__aclocal} -I config -I config/gettext-macros -I config/gnulib -I config/amanda -I config/macro-archive
228 %{__autoconf}
229 %{__automake}
230 %configure \
231         DUMP=/sbin/dump \
232         GZIP=/bin/gzip \
233         MAILER=/bin/mail \
234         MT=/bin/mt \
235         MTX=/usr/sbin/mtx \
236         PRINT=/usr/bin/lpr \
237         RESTORE=/sbin/restore \
238         %{?with_xfs:XFSDUMP=/sbin/xfsdump} \
239         %{?with_xfs:XFSRESTORE=/sbin/xfsrestore} \
240         --disable-static \
241         --enable-shared \
242         %{!?with_server:--without-server} \
243         %{!?with_client:--without-client} \
244         --with-index-server=localhost \
245         --with-user=amanda \
246         --with-group=amanda \
247         --with-tape-device=/dev/null \
248         --with-fqdn \
249         %{?with_samba:--with-smbclient=%{_bindir}/smbclient} \
250         --with-star=%{_bindir}/star \
251         --with-gnuplot=%{_bindir}/gnuplot \
252         --with-bsd-security \
253         --with-bsdtcp-security \
254         --with-ssh-security \
255         --with-krb5-security \
256         --with-buffered-dump \
257         --with-amandahosts \
258         --with-configdir=%{_sysconfdir}/amanda \
259         --with-gnutar-listdir=%{_sharedstatedir}/amanda/gnutar-lists \
260         --with-amandates=%{_sharedstatedir}/amanda/amandates \
261         --with-debugging=%{_sharedstatedir}/amanda/debug \
262         --with-tmpdir=/var/tmp/amanda \
263         --with-amperldir=%{perl_vendorarch} \
264         --with-ipv6 \
265         --with-readline \
266         --disable-installperms
267
268 %{__make}
269
270 %install
271 rm -rf $RPM_BUILD_ROOT
272 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{amanda,cron.d,sysconfig/rc-inetd} \
273         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/{.gnupg,.ssh,gnutar-lists} \
274         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/debug/{amandad,client,server}
275
276 %{__make} install \
277         DESTDIR=$RPM_BUILD_ROOT
278
279 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amanda-srv
280 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE2} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amanda
281 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE3} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amandaidx
282 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE4} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amidxtape
283 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE5} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/k5amanda
284
285 cp -p example/amanda.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
286 cp -p example/amanda-client.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
287 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.amandahosts
288
289 install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sbindir}/amconvert-zd-mtx-to-robot.sh
290
291 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/config
292 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/{,client_}authorized_keys
293 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amdump{,.pub}
294 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover{,.pub}
295
296 %if %{with server}
297 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/amanda/lvm-snapshot.conf
298 %endif
299
300 %if %{with client}
301 sed -e 's|@@PERL_VENDORARCH@@|%{perl_vendorarch}|' %{SOURCE9} >$RPM_BUILD_ROOT%{_libexecdir}/amanda/application/amlvm-snapshot
302 %endif
303
304 > $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/amandates
305
306 # Amanda tools generate ssh keys with embeded commands pointing to /usr/lib
307 # Tools can't be "fixed" because keys generated on server are to be used on client
308 if [ "%{_lib}" != "lib" ] ; then
309         install -d $RPM_BUILD_ROOT%{_ulibdir}
310         ln -s %{_libdir}/amanda $RPM_BUILD_ROOT%{_ulibdir}/amanda
311 fi
312
313 find $RPM_BUILD_ROOT -name \*.la | xargs rm -f
314
315 %{__rm} $RPM_BUILD_ROOT%{_datadir}/amanda/{COPYRIGHT,ChangeLog,NEWS,ReleaseNotes}
316 %{__rm} $RPM_BUILD_ROOT%{_datadir}/amanda/example/{chg-multi,chg-scsi}.conf
317
318 %clean
319 rm -rf $RPM_BUILD_ROOT
320
321 %triggerpostun common -- amanda-libs < 2.6.0p2-3
322 echo "Adding amanda to disk and tape groups"
323 /usr/sbin/usermod -G disk,tape amanda
324 echo "Setting amanda shell to /bin/sh"
325 /usr/bin/chsh -s /bin/sh amanda
326 if [ -f %{_sharedstatedir}/amanda/.amandahosts ]; then
327         echo "Fixing permissions of %{_sharedstatedir}/amanda/.amandahosts file"
328         chown amanda:amanda %{_sharedstatedir}/amanda/.amandahosts
329         chmod 600 %{_sharedstatedir}/amanda/.amandahosts
330 fi
331
332 %triggerpostun common -- amanda-common < 3.3
333 %banner %{name}-common -e << EOF
334 In amanda 3.3 the default auth has changed to "bsdtcp",
335 if you are using the default "bsd" then you must add it
336 to your configuration:
337
338  *   in amanda.conf
339  *   in amanda-client.conf
340  *   in dumptype/disklist
341  *   in inetd (if no '-auth' argument to amandad)
342 EOF
343
344 %pre common
345 %groupadd -P %{name}-common -g 80 amanda
346 %useradd -P %{name}-common -u 80 -G disk,tape -d /var/lib/amanda -s /bin/sh -c "Amanda Backup user" -g amanda amanda
347
348 %postun common
349 if [ "$1" = "0" ]; then
350         %userremove amanda
351         %groupremove amanda
352 fi
353
354 %post client
355 %service -q rc-inetd reload
356 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amrecover ] ; then
357         HOST="`/bin/hostname`"
358         FQDNHOST="`/bin/hostname -f`"
359         if [ -z "$HOST" ] ; then
360                 COMMENT="root@client"
361         else
362                 COMMENT="root@$HOST"
363         fi
364         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amrecover -N "" || :
365         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
366         chmod 600 /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
367         if [ -n "$FQDNHOST" ]; then
368                 echo -n "from=\"$FQDNHOST\",no-port-forwarding,no-X11-forwarding,no-agent-forwarding,command=\"%{_ulibdir}/amanda/amandad -auth=ssh amindexd amidxtaped\" " >/var/lib/amanda/.ssh/server_authorized_keys
369                 cat /var/lib/amanda/.ssh/id_rsa_amrecover.pub >>/var/lib/amanda/.ssh/server_authorized_keys
370
371                 echo "Remember to copy the contents of /var/lib/amanda/.ssh/server_authorized_keys to"
372                 echo "/var/lib/amanda/.ssh/authorized_keys on amanda server"
373         fi
374 fi
375
376 %postun client
377 if [ "$1" = 0 ]; then
378         %service -q rc-inetd reload
379 fi
380
381 %post server
382 %service -q rc-inetd reload
383 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amdump ] ; then
384         HOST="`/bin/hostname`"
385         if [ -z "$HOST" ] ; then
386                 COMMENT="amanda@server"
387         else
388                 COMMENT="amanda@$HOST"
389         fi
390         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amdump -N "" || :
391         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
392         chmod 600 /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
393 fi
394 if [ "$1" = "1" ]; then
395         echo "Don't forget to edit /etc/cron.d/amanda-srv." 1>&2
396 fi
397
398 %postun server
399 if [ "$1" = 0 ]; then
400         %service -q rc-inetd reload
401 fi
402
403 %triggerpostun server -- amanda-server < 3.2.0
404 %banner %{name} -e << EOF
405 Warning: Tape changer configuration has chaged, please read
406 %{_docdir}/%{name}-server-%{version}/ReleaseNotes.gz
407 and %{_docdir}/%{name}-server-%{version}/NEWS.gz for details.
408 You can use %{_sbindir}/amconvert-zd-mtx-to-robot.sh script
409 to upgrade to chg-robot.
410 EOF
411
412 %files common
413 %defattr(644,root,root,755)
414 %doc AUTHORS COPYRIGHT ChangeLog NEWS README ReleaseNotes UPGRADING amlvm-snapshot.README
415 %attr(755,root,root) %{_libdir}/amanda/libamanda*.so
416 %attr(755,root,root) %{_libdir}/amanda/libamar*.so
417 %attr(755,root,root) %{_libdir}/amanda/libamdevice*.so
418 %attr(755,root,root) %{_libdir}/amanda/libamglue*.so
419 %attr(755,root,root) %{_libdir}/amanda/libamserver*.so
420 %attr(755,root,root) %{_libdir}/amanda/libamxfer*.so
421 %attr(755,root,root) %{_libdir}/amanda/libndmjob*.so
422 %attr(755,root,root) %{_libdir}/amanda/libndmlib*.so
423 %attr(750,amanda,amanda) %dir %{_sysconfdir}/amanda
424 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/amanda-security.conf
425 %dir %{_libdir}/amanda
426 %if "%{_lib}" != "lib"
427 %{_ulibdir}/amanda
428 %endif
429 %dir %{_libexecdir}/amanda
430 %{_libexecdir}/amanda/amanda-sh-lib.sh
431 %attr(4750,root,amanda) %{_libexecdir}/amanda/ambind
432 %attr(755,root,root) %{_libexecdir}/amanda/amcat.awk
433 %attr(755,root,root) %{_libexecdir}/amanda/amndmjob
434 %attr(755,root,root) %{_libexecdir}/amanda/amplot.awk
435 %attr(755,root,root) %{_libexecdir}/amanda/amplot.g
436 %attr(755,root,root) %{_libexecdir}/amanda/amplot.gp
437 %attr(755,root,root) %{_libexecdir}/amanda/ndmjob
438 %attr(755,root,root) %{_sbindir}/amaespipe
439 %attr(755,root,root) %{_sbindir}/amarchiver
440 %attr(755,root,root) %{_sbindir}/amcrypt*
441 %attr(755,root,root) %{_sbindir}/amgetconf
442 %attr(755,root,root) %{_sbindir}/amgpgcrypt
443 %attr(755,root,root) %{_sbindir}/amplot
444 %attr(755,root,root) %{_sbindir}/amservice
445 %attr(755,root,root) %{_sbindir}/amssl
446 %attr(750,amanda,amanda) %dir %{_datadir}/amanda
447 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/example
448 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/example/label-templates
449 %attr(640,amanda,amanda) %{_datadir}/amanda/example/*amanda*
450 %attr(640,amanda,amanda) %{_datadir}/amanda/example/disklist
451 %attr(640,amanda,amanda) %{_datadir}/amanda/example/label-templates/*.ps
452 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/template.d
453 %attr(640,amanda,amanda) %{_datadir}/amanda/template.d/*
454 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda
455 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.ssh
456 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.gnupg
457 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug
458 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/amandad
459 %attr(600,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/.amandahosts
460 %attr(600,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/.ssh/config
461 # Commented out so it won't get removed on uninstall
462 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/authorized_keys
463 %{_mandir}/man5/amanda-archive-format.5*
464 %{_mandir}/man5/amanda-security.conf.5*
465 %{_mandir}/man7/amanda-auth.7*
466 %{_mandir}/man7/amanda-auth-ssl.7*
467 %{_mandir}/man7/amanda-match.7*
468 %{_mandir}/man7/amanda-scripts.7*
469 %{_mandir}/man8/amanda.8*
470 %{_mandir}/man8/amaespipe.8*
471 %{_mandir}/man8/amarchiver.8*
472 %{_mandir}/man8/amcrypt*.8*
473 %{_mandir}/man8/amgetconf.8*
474 %{_mandir}/man8/amgpgcrypt.8*
475 %{_mandir}/man8/amplot.8*
476 %{_mandir}/man8/amservice.8*
477 %{_mandir}/man8/amssl.8*
478 %{_mandir}/man8/script-email.8*
479
480 %dir %{perl_vendorarch}/Amanda
481 %dir %{perl_vendorarch}/Amanda/Config
482 %dir %{perl_vendorarch}/Amanda/IPC
483 %{perl_vendorarch}/Amanda/Amservice.pm
484 %{perl_vendorarch}/Amanda/Archive.pm
485 %{perl_vendorarch}/Amanda/BigIntCompat.pm
486 %{perl_vendorarch}/Amanda/Changer.pm
487 %dir %{perl_vendorarch}/Amanda/Changer
488 %{perl_vendorarch}/Amanda/Changer/*.pm
489 %{perl_vendorarch}/Amanda/ClientService.pm
490 %{perl_vendorarch}/Amanda/Cmdline.pm
491 %{perl_vendorarch}/Amanda/Cmdfile.pm
492 %{perl_vendorarch}/Amanda/Config.pm
493 %{perl_vendorarch}/Amanda/Config/FoldingHash.pm
494 %{perl_vendorarch}/Amanda/Constants.pm
495 %{perl_vendorarch}/Amanda/DB.pm
496 %dir %{perl_vendorarch}/Amanda/DB
497 %{perl_vendorarch}/Amanda/DB/*.pm
498 %{perl_vendorarch}/Amanda/Debug.pm
499 %{perl_vendorarch}/Amanda/Device.pm
500 %{perl_vendorarch}/Amanda/Disklist.pm
501 %{perl_vendorarch}/Amanda/Extract.pm
502 %{perl_vendorarch}/Amanda/Feature.pm
503 %{perl_vendorarch}/Amanda/FetchDump.pm
504 %dir %{perl_vendorarch}/Amanda/FetchDump
505 %{perl_vendorarch}/Amanda/FetchDump/*.pm
506 %{perl_vendorarch}/Amanda/Header.pm
507 %{perl_vendorarch}/Amanda/Holding.pm
508 %{perl_vendorarch}/Amanda/IPC/Binary.pm
509 %{perl_vendorarch}/Amanda/IPC/LineProtocol.pm
510 %{perl_vendorarch}/Amanda/Interactivity.pm
511 %dir %{perl_vendorarch}/Amanda/Interactivity
512 %{perl_vendorarch}/Amanda/Interactivity/*.pm
513 %{perl_vendorarch}/Amanda/Logfile.pm
514 %{perl_vendorarch}/Amanda/MainLoop.pm
515 %{perl_vendorarch}/Amanda/Message.pm
516 %{perl_vendorarch}/Amanda/NDMP.pm
517 %{perl_vendorarch}/Amanda/Paths.pm
518 %{perl_vendorarch}/Amanda/Policy.pm
519 %{perl_vendorarch}/Amanda/Process.pm
520 %{perl_vendorarch}/Amanda/Recovery.pm
521 %dir %{perl_vendorarch}/Amanda/Recovery
522 %{perl_vendorarch}/Amanda/Recovery/*.pm
523 %{perl_vendorarch}/Amanda/Restore.pm
524 %{perl_vendorarch}/Amanda/Script.pm
525 %{perl_vendorarch}/Amanda/Script_App.pm
526 %{perl_vendorarch}/Amanda/Service.pm
527 %dir %{perl_vendorarch}/Amanda/Service
528 %{perl_vendorarch}/Amanda/Storage.pm
529 %{perl_vendorarch}/Amanda/Tapelist.pm
530 %{perl_vendorarch}/Amanda/Tests.pm
531 %{perl_vendorarch}/Amanda/Util.pm
532 %{perl_vendorarch}/Amanda/Xfer.pm
533 %dir %{perl_vendorarch}/auto/Amanda
534 %dir %{perl_vendorarch}/auto/Amanda/Archive
535 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Archive/*.so
536 %dir %{perl_vendorarch}/auto/Amanda/Cmdfile
537 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Cmdfile/*.so
538 %dir %{perl_vendorarch}/auto/Amanda/Cmdline
539 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Cmdline/*.so
540 %dir %{perl_vendorarch}/auto/Amanda/Config
541 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Config/*.so
542 %dir %{perl_vendorarch}/auto/Amanda/Debug
543 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Debug/*.so
544 %dir %{perl_vendorarch}/auto/Amanda/Device
545 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Device/*.so
546 %dir %{perl_vendorarch}/auto/Amanda/Disklist
547 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Disklist/*.so
548 %dir %{perl_vendorarch}/auto/Amanda/Feature
549 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Feature/*.so
550 %dir %{perl_vendorarch}/auto/Amanda/Header
551 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Header/*.so
552 %dir %{perl_vendorarch}/auto/Amanda/IPC
553 %dir %{perl_vendorarch}/auto/Amanda/IPC/Binary
554 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/IPC/Binary/*.so
555 %dir %{perl_vendorarch}/auto/Amanda/Logfile
556 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Logfile/*.so
557 %dir %{perl_vendorarch}/auto/Amanda/MainLoop
558 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/MainLoop/*.so
559 %dir %{perl_vendorarch}/auto/Amanda/NDMP
560 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/NDMP/*.so
561 %dir %{perl_vendorarch}/auto/Amanda/Tapelist
562 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Tapelist/*.so
563 %dir %{perl_vendorarch}/auto/Amanda/Tests
564 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Tests/*.so
565 %dir %{perl_vendorarch}/auto/Amanda/Util
566 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Util/*.so
567 %dir %{perl_vendorarch}/auto/Amanda/Xfer
568 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Xfer/*.so
569
570 %if %{with server}
571 %files server
572 %defattr(644,root,root,755)
573 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amidxtape
574 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amandaidx
575
576 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/amanda.conf
577 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/lvm-snapshot.conf
578
579 # Commented out so it won't get removed on uninstall
580 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/client_authorized_keys
581 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amdump*
582
583 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/server
584
585 %config(noreplace) %attr(640,root,root) /etc/cron.d/amanda-srv
586
587 %attr(755,root,root) %{_libexecdir}/amanda/amadmin_perl
588 %attr(755,root,root) %{_libexecdir}/amanda/ambackupd
589 %attr(755,root,root) %{_libexecdir}/amanda/amcheck-device
590 %attr(755,root,root) %{_libexecdir}/amanda/amdumpd
591 %attr(755,root,root) %{_libexecdir}/amanda/amidxtaped
592 %attr(755,root,root) %{_libexecdir}/amanda/amindexd
593 %attr(755,root,root) %{_libexecdir}/amanda/amlogroll
594 %attr(755,root,root) %{_libexecdir}/amanda/amtrmidx
595 %attr(755,root,root) %{_libexecdir}/amanda/amtrmlog
596 %attr(755,root,root) %{_libexecdir}/amanda/chunker
597 %attr(755,root,root) %{_libexecdir}/amanda/driver
598 %attr(755,root,root) %{_libexecdir}/amanda/dumper
599 %attr(755,root,root) %{_libexecdir}/amanda/planner
600 %attr(755,root,root) %{_libexecdir}/amanda/taper
601
602 %dir %{_libexecdir}/amanda/rest-server
603 %dir %{_libexecdir}/amanda/rest-server/bin
604 %attr(755,root,root) %{_libexecdir}/amanda/rest-server/bin/app-dancer2.pl
605 %attr(755,root,root) %{_libexecdir}/amanda/rest-server/bin/app.pl
606 %{_libexecdir}/amanda/rest-server/config-dancer
607 %{_libexecdir}/amanda/rest-server/config.yml
608 %{_libexecdir}/amanda/rest-server/environments
609 %dir %{_libexecdir}/amanda/rest-server/lib
610 %dir %{_libexecdir}/amanda/rest-server/lib/Amanda
611 %{_libexecdir}/amanda/rest-server/lib/Amanda/Rest.pm
612 %dir %{_libexecdir}/amanda/rest-server/public
613 %{_libexecdir}/amanda/rest-server/public/*.html
614 %{_libexecdir}/amanda/rest-server/public/css
615 %{_libexecdir}/amanda/rest-server/public/dispatch.cgi
616 %{_libexecdir}/amanda/rest-server/public/dispatch.fcgi
617 %{_libexecdir}/amanda/rest-server/public/favicon.ico
618 %{_libexecdir}/amanda/rest-server/public/images
619 %{_libexecdir}/amanda/rest-server/public/javascripts
620 %{_libexecdir}/amanda/rest-server/views
621
622 %attr(755,root,root) %{_sbindir}/activate-devpay
623 %attr(755,root,root) %{_sbindir}/amaddclient
624 %attr(755,root,root) %{_sbindir}/amadmin
625 %attr(755,root,root) %{_sbindir}/amanda-rest-server
626 %attr(755,root,root) %{_sbindir}/amcheck
627 %attr(755,root,root) %{_sbindir}/amcheckdb
628 %attr(755,root,root) %{_sbindir}/amcheckdump
629 %attr(755,root,root) %{_sbindir}/amcleanup
630 %attr(755,root,root) %{_sbindir}/amcleanupdisk
631 %attr(755,root,root) %{_sbindir}/amconvert-zd-mtx-to-robot.sh
632 %attr(755,root,root) %{_sbindir}/amdevcheck
633 %attr(755,root,root) %{_sbindir}/amdump
634 %attr(755,root,root) %{_sbindir}/amfetchdump
635 %attr(755,root,root) %{_sbindir}/amflush
636 %attr(755,root,root) %{_sbindir}/amlabel
637 %attr(755,root,root) %{_sbindir}/amoverview
638 %attr(755,root,root) %{_sbindir}/amreindex
639 %attr(755,root,root) %{_sbindir}/amreport
640 %attr(755,root,root) %{_sbindir}/amrestore
641 %attr(755,root,root) %{_sbindir}/amrmtape
642 %attr(755,root,root) %{_sbindir}/amserverconfig
643 %attr(755,root,root) %{_sbindir}/amstatus
644 %attr(755,root,root) %{_sbindir}/amtape
645 %attr(755,root,root) %{_sbindir}/amtapetype
646 %attr(755,root,root) %{_sbindir}/amtoc
647 %attr(755,root,root) %{_sbindir}/amvault
648 %{_mandir}/man5/amanda.conf.5*
649 %{_mandir}/man5/amanda-command-file.5*
650 %{_mandir}/man5/disklist.5*
651 %{_mandir}/man5/tapelist.5*
652 %{_mandir}/man7/amanda-changers.7*
653 %{_mandir}/man7/amanda-compatibility.7*
654 %{_mandir}/man7/amanda-devices.7*
655 %{_mandir}/man7/amanda-interactivity.7*
656 %{_mandir}/man7/amanda-taperscan.7*
657 %{_mandir}/man8/amaddclient.8*
658 %{_mandir}/man8/amadmin.8*
659 %{_mandir}/man8/amanda-rest-server.8*
660 %{_mandir}/man8/amcheck.8*
661 %{_mandir}/man8/amcheckdb.8*
662 %{_mandir}/man8/amcheckdump.8*
663 %{_mandir}/man8/amcleanup.8*
664 %{_mandir}/man8/amcleanupdisk.8*
665 %{_mandir}/man8/amdevcheck.8*
666 %{_mandir}/man8/amdump.8*
667 %{_mandir}/man8/amfetchdump.8*
668 %{_mandir}/man8/amflush.8*
669 %{_mandir}/man8/amlabel.8*
670 %{_mandir}/man8/amoverview.8*
671 %{_mandir}/man8/amreindex.8*
672 %{_mandir}/man8/amreport.8*
673 %{_mandir}/man8/amrestore.8*
674 %{_mandir}/man8/amrmtape.8*
675 %{_mandir}/man8/amserverconfig.8*
676 %{_mandir}/man8/amstatus.8*
677 %{_mandir}/man8/amtape.8*
678 %{_mandir}/man8/amtapetype.8*
679 %{_mandir}/man8/amtoc.8*
680 %{_mandir}/man8/amvault.8*
681
682 %{perl_vendorarch}/Amanda/Amdump.pm
683 %{perl_vendorarch}/Amanda/Amflush.pm
684 %{perl_vendorarch}/Amanda/CheckDump.pm
685 %dir %{perl_vendorarch}/Amanda/Chunker
686 %{perl_vendorarch}/Amanda/Chunker/*.pm
687 %{perl_vendorarch}/Amanda/Cleanup.pm
688 %{perl_vendorarch}/Amanda/Curinfo.pm
689 %dir %{perl_vendorarch}/Amanda/Curinfo
690 %{perl_vendorarch}/Amanda/Curinfo/*.pm
691 %{perl_vendorarch}/Amanda/Index.pm
692 %{perl_vendorarch}/Amanda/Label.pm
693 %{perl_vendorarch}/Amanda/Report.pm
694 %dir %{perl_vendorarch}/Amanda/Report
695 %{perl_vendorarch}/Amanda/Report/*.pm
696 %dir %{perl_vendorarch}/Amanda/Rest
697 %{perl_vendorarch}/Amanda/Rest/*.pm
698 %dir %{perl_vendorarch}/Amanda/Rest/Storages
699 %{perl_vendorarch}/Amanda/Rest/Storages/*.pm
700 %{perl_vendorarch}/Amanda/ScanInventory.pm
701 %{perl_vendorarch}/Amanda/Service/Amidxtaped.pm
702 %{perl_vendorarch}/Amanda/Status.pm
703 %dir %{perl_vendorarch}/Amanda/Taper
704 %{perl_vendorarch}/Amanda/Taper/*.pm
705 %dir %{perl_vendorarch}/Amanda/Taper/Scan
706 %{perl_vendorarch}/Amanda/Taper/Scan/*.pm
707 %{perl_vendorarch}/Amanda/Vault.pm
708 %{perl_vendorarch}/Amanda/XferServer.pm
709 %dir %{perl_vendorarch}/auto/Amanda/XferServer
710 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/XferServer/*.so
711 %endif
712
713 %if %{with client}
714 %files client
715 %defattr(644,root,root,755)
716 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amanda
717 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/k5amanda
718 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,amanda) %{_sysconfdir}/amanda/amanda-client.conf
719 # Commented out so it won't get removed on uninstall
720 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover*
721 %attr(640,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/amandates
722
723 %dir %{_libexecdir}/amanda/application
724 %attr(4750,root,amanda) %{_libexecdir}/amanda/application/ambsdtar
725 %attr(4750,root,amanda) %{_libexecdir}/amanda/application/amgtar
726 %attr(755,root,root) %{_libexecdir}/amanda/application/amlog-script
727 %attr(755,root,root) %{_libexecdir}/amanda/application/amlvm-snapshot
728 %attr(755,root,root) %{_libexecdir}/amanda/application/ampgsql
729 %attr(755,root,root) %{_libexecdir}/amanda/application/amrandom
730 %attr(755,root,root) %{_libexecdir}/amanda/application/amraw
731 %attr(755,root,root) %{_libexecdir}/amanda/application/amsamba
732 %attr(4750,root,amanda) %{_libexecdir}/amanda/application/amstar
733 %attr(755,root,root) %{_libexecdir}/amanda/application/amsuntar
734 %attr(755,root,root) %{_libexecdir}/amanda/application/amzfs*
735 %attr(755,root,root) %{_libexecdir}/amanda/application/script-email
736 %attr(755,root,root) %{_libexecdir}/amanda/application/script-fail
737
738 %attr(755,root,root) %{_libdir}/amanda/libamclient*.so
739 %attr(755,root,root) %{_libexecdir}/amanda/amandad
740 %attr(755,root,root) %{_libexecdir}/amanda/noop
741 %attr(755,root,root) %{_libexecdir}/amanda/patch-system
742 %attr(755,root,root) %{_libexecdir}/amanda/restore
743 %attr(755,root,root) %{_libexecdir}/amanda/sendbackup
744 %attr(755,root,root) %{_libexecdir}/amanda/senddiscover
745 %attr(755,root,root) %{_libexecdir}/amanda/sendsize
746 %attr(755,root,root) %{_libexecdir}/amanda/teecount
747 %attr(4750,root,amanda) %{_libexecdir}/amanda/calcsize
748 %attr(4750,root,amanda) %{_libexecdir}/amanda/killpgrp
749 %attr(4750,root,amanda) %{_libexecdir}/amanda/rundump
750 %attr(4750,root,amanda) %{_libexecdir}/amanda/runtar
751 %attr(755,root,root) %{_libexecdir}/amanda/selfcheck
752 %attr(755,root,root) %{_sbindir}/ambackup
753 %attr(755,root,root) %{_sbindir}/amdump_client
754 %attr(755,root,root) %{_sbindir}/amoldrecover
755 %attr(755,root,root) %{_sbindir}/amrecover
756 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/gnutar-lists
757 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/client
758 %{_mandir}/man7/amanda-applications.7*
759 %{_mandir}/man5/amanda-client.conf.5*
760 %{_mandir}/man8/amdump_client.8*
761 %{_mandir}/man8/ambackup.8*
762 %{_mandir}/man8/ambsdtar.8*
763 %{_mandir}/man8/amgtar.8*
764 %{_mandir}/man8/ampgsql.8*
765 %{_mandir}/man8/amrecover.8*
766 %{_mandir}/man8/amraw.8*
767 %{_mandir}/man8/amsamba.8*
768 %{_mandir}/man8/amstar.8*
769 %{_mandir}/man8/amsuntar.8*
770 %{_mandir}/man8/amzfs*.8*
771
772 %{perl_vendorarch}/Amanda/Application.pm
773 %dir %{perl_vendorarch}/Amanda/Application
774 %{perl_vendorarch}/Amanda/Application/Zfs.pm
775 %{perl_vendorarch}/Amanda/Service/Restore.pm
776 %dir %{perl_vendorarch}/auto/Amanda/Application
777 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Application/*.so
778 %endif
This page took 0.142005 seconds and 4 git commands to generate.