]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
- spaces->tabs
[packages/amanda.git] / amanda.spec
1 #
2 # Conditional build:
3 %bcond_with xfs         # with support for xfsdump 
4 #
5 Summary:        A network-capable tape backup solution
6 Summary(pl):    Sieciowo zorientowany system tworzenia kopii zapasowych
7 Name:           amanda
8 Version:        2.4.4p2
9 Release:        3
10 License:        BSD
11 Group:          Networking/Utilities
12 Source0:        http://dl.sourceforge.net/amanda/%{name}-%{version}.tar.gz
13 # Source0-md5:  95f772203801999bd4b96606859f8910
14 Source1:        %{name}-srv.crontab
15 Source2:        %{name}.inetd
16 Source3:        %{name}idx.inetd
17 Source4:        amidxtape.inetd
18 Source5:        %{name}.conf
19 Patch0:         %{name}-no_libnsl.patch
20 Patch1:         %{name}-no_private_libtool.m4.patch
21 Patch2:         %{name}-ac25x.patch
22 Patch3:         %{name}-chg-zd-mtx-sh.patch
23 Patch4:         %{name}-tar.patch
24 URL:            http://www.amanda.org/
25 BuildRequires:  autoconf >= 2.53
26 BuildRequires:  automake
27 BuildRequires:  cpio
28 BuildRequires:  dump
29 BuildRequires:  flex
30 BuildRequires:  gnuplot
31 BuildRequires:  libtool
32 BuildRequires:  readline-devel >= 4.2
33 BuildRequires:  rpmbuild(macros) >= 1.159
34 BuildRequires:  tar
35 %{?with_xfs:BuildRequires:      xfsdump}
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _localstatedir  /var/lib
39 %define         _libexecdir     %{_libdir}/amanda
40
41 %description
42 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
43 backup system that allows the administrator of a LAN to set up a
44 single master backup server to back up multiple hosts to a single
45 large capacity tape drive. AMANDA uses native dump and/or GNU tar
46 facilities and can back up a large number of workstations running
47 multiple versions of Unix. Newer versions of AMANDA (including this
48 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
49 The amanda package contains the core AMANDA programs and will need to
50 be installed on both AMANDA clients and AMANDA servers. Note that you
51 will have to install the amanda-client and amanda-server packages as
52 well.
53
54 %description -l pl
55 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
56 zapasowych. Umo¿liwia administratorowi sieci tworzenie kopii z kilku
57 hostów na jednej maszynie wyposa¿onej w pojemny dysk lub streamer.
58 Nowsze wersje programu umo¿liwiaj± zabezpieczanie zasobów Microsoft
59 Windows 95/98/NT/2000 przy u¿yciu protoko³u Samba. Ten pakiet zawiera
60 podstawowe pliki programu i powinien byæ zainstalowany zarówno na
61 serwerze jak i na kliencie. Pamiêtaj tak¿e o instalacji pakietów
62 amanda-client i amanda-server!
63
64 %package libs
65 Summary:        Amanda shared libraries
66 Summary(pl):    Biblioteki wspó³dzielone pakietu amanda
67 Group:          Networking/Utilities
68 Requires(pre):  /bin/id
69 Requires(pre):  /usr/bin/getgid
70 Requires(pre):  /usr/sbin/groupadd
71 Requires(pre):  /usr/sbin/useradd
72 Requires(postun):       /usr/sbin/groupdel
73 Requires(postun):       /usr/sbin/userdel
74 Requires(postun):       /sbin/ldconfig
75 Provides:       group(amanda)
76 Provides:       user(amanda)
77
78 %description libs
79 Amanda shared libraries.
80
81 %description libs -l pl
82 Biblioteki wspó³dzielone pakietu amanda.
83
84 %package client
85 Summary:        The client side of Amanda
86 Summary(pl):    Klient Amandy
87 Group:          Networking/Utilities
88 PreReq:         %{name}-libs = %{version}
89 PreReq:         rc-inetd
90 Requires(post,postun):  /sbin/ldconfig
91 Conflicts:      tar < 1.13
92
93 %description client
94 The Amanda-client package should be installed on any machine that will
95 be backed up by AMANDA (including the server if it also needs to be
96 backed up). You will also need to install the amanda package to each
97 AMANDA client. It requires at least one of dump and GNU tar installed.
98
99 %description client -l pl
100 Ten pakiet powinien byæ zainstalowany ma maszynach, z których
101 zawarto¶ci bêd± tworzone kopie zapasowe. Wymaga zainstalowanego co
102 najmniej jednego z pakietów dump i GNU tar.
103
104 %package server
105 Summary:        The server side of Amanda
106 Summary(pl):    Serwer Amandy
107 Group:          Networking/Utilities
108 PreReq:         %{name}-libs = %{version}
109 PreReq:         rc-inetd
110 Requires(post,postun):  /sbin/ldconfig
111 Requires:       gnuplot
112 Requires:       crondaemon
113 Requires:       /etc/cron.d
114 Requires:       mt-st
115 Requires:       mtx
116
117 %description server
118 The amanda-server package should be installed on the AMANDA server,
119 the machine attached to the device (such as a tape drive) where
120 backups will be written. You will also need to install the amanda
121 package to the AMANDA server. And, if the server is also to be backed
122 up, the server also needs to have the amanda-client package installed.
123
124 %description server -l pl
125 Ten pakiet powinien byæ zainstalowanych na maszynach, na których bêd±
126 magazynowane kopie zapasowe (lub do których podpiête s± urz±dzenia
127 typu streamer).
128
129 %prep
130 %setup -q
131 %patch0 -p1
132 %patch1 -p1
133 %patch2 -p1
134 %patch3 -p1
135 %patch4 -p1
136
137 %build
138 %{__libtoolize}
139 %{__aclocal}
140 %{__autoconf}
141 %{__automake}
142 %configure \
143         --disable-static \
144         --enable-shared \
145         --with-index-server=localhost \
146         --with-user=amanda \
147         --with-group=amanda \
148         --with-tape-device=/dev/null \
149         --with-ftape-rawdevice=/dev/null \
150         --with-changer-device=/dev/null \
151         --with-fqdn \
152         --with-smbclient=%{_bindir}/smbclient \
153         --with-bsd-security \
154         --with-buffered-dump \
155         --with-amandahosts \
156         --with-debugging=%{_localstatedir}/amanda/debug \
157         --with-gnutar-listdir=%{_localstatedir}/amanda/gnutar-lists \
158         --with-tmpdir=/var/tmp
159
160 %{__make}
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{amanda,cron.d,sysconfig/rc-inetd} \
165         $RPM_BUILD_ROOT%{_localstatedir}/amanda/gnutar-lists \
166         $RPM_BUILD_ROOT%{_mandir}/man1
167
168 %{__make} install \
169         DESTDIR=$RPM_BUILD_ROOT \
170         SETUID_GROUP=`id -g`
171
172 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amanda-srv
173 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amanda
174 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amandaidx
175 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amidxtape
176
177 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/amanda
178 install example/*.ps $RPM_BUILD_ROOT%{_localstatedir}/amanda
179
180 > $RPM_BUILD_ROOT%{_sysconfdir}/amandates
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %triggerpostun -- amanda-libs < 2.4.2p2-3
186 /usr/sbin/chsh -s /bin/sh amanda
187
188 %triggerpostun -- amanda-libs < 2.4.2p2-12
189 /usr/sbin/usermod -G disk amanda
190
191 %pre libs
192 if [ -n "`/usr/bin/getgid amanda`" ]; then
193         if [ "`/usr/bin/getgid amanda`" != 80 ]; then
194                 echo "Error: group amanda doesn't have gid=80. Correct this before installing amanda-libs." 1>&2
195                 exit 1
196         fi
197 else
198         /usr/sbin/groupadd -g 80 amanda
199 fi
200 if [ -n "`/bin/id -u amanda 2>/dev/null`" ]; then
201         if [ "`/bin/id -u amanda`" != 80 ]; then
202                 echo "Error: user amanda doesn't have uid=80. Correct this before installing amanda-libs." 1>&2
203                 exit 1
204         fi
205 else
206         /usr/sbin/useradd -u 80 -G disk -d /var/lib/amanda -s /bin/sh \
207                 -c "Amanda Backup user" -g amanda amanda 1>&2
208 fi
209
210 %post   libs -p /sbin/ldconfig
211
212 %postun libs
213 /sbin/ldconfig
214 if [ "$1" = "0" ]; then
215         %userremove amanda
216         %groupremove amanda
217 fi
218
219 %post client
220 /sbin/ldconfig
221 if [ -f /var/lock/subsys/rc-inetd ]; then
222         /etc/rc.d/init.d/rc-inetd restart 1>&2
223 else
224         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server." 1>&2
225 fi
226
227 %postun client
228 /sbin/ldconfig
229 if [ -f /var/lock/subsys/rc-inetd ]; then
230         /etc/rc.d/init.d/rc-inetd restart
231 fi
232
233 %post server
234 /sbin/ldconfig
235 if [ -f /var/lock/subsys/rc-inetd ]; then
236         /etc/rc.d/init.d/rc-inetd restart 1>&2
237 else
238         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server." 1>&2
239 fi
240 if [ "$1" = "1" ]; then
241         echo "Don't forget to edit /etc/cron.d/amanda-srv." 1>&2
242 fi
243
244 %postun server
245 /sbin/ldconfig
246 if [ -f /var/lock/subsys/rc-inetd ]; then
247         /etc/rc.d/init.d/rc-inetd restart
248 fi
249
250 %files libs
251 %defattr(644,root,root,755)
252 %attr(755,root,root) %{_libdir}/libamanda*.so
253 %attr(755,root,root) %{_libdir}/libamtape*.so
254 %attr(770,amanda,amanda) %dir %{_libexecdir}
255 %attr(770,amanda,amanda) %dir %{_localstatedir}/amanda
256
257 %files server
258 %defattr(644,root,root,755)
259 %doc docs/*
260 %config(noreplace) /etc/sysconfig/rc-inetd/amidxtape
261 %config(noreplace) /etc/sysconfig/rc-inetd/amandaidx
262
263 %attr(750,amanda,amanda) %dir %{_sysconfdir}/amanda
264 %config(noreplace) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/*
265
266 %attr(664,amanda,amanda) %{_localstatedir}/amanda/*.ps
267
268 %config(noreplace) %attr(640,root,root) /etc/cron.d/amanda-srv
269
270 %attr(755,root,root) %{_libdir}/libamserver*.so
271 %attr(755,root,root) %{_libexecdir}/amindexd
272 %attr(755,root,root) %{_libexecdir}/amtrmidx
273 %attr(755,root,root) %{_libexecdir}/driver
274 %attr(4754,root,amanda) %{_libexecdir}/dumper
275 %attr(4754,root,amanda) %{_libexecdir}/planner
276 %attr(755,root,root) %{_libexecdir}/amcat.awk
277 %attr(755,root,root) %{_libexecdir}/amcleanupdisk
278 %attr(755,root,root) %{_libexecdir}/amidxtaped
279 %attr(755,root,root) %{_libexecdir}/amlogroll
280 %attr(755,root,root) %{_libexecdir}/amplot.awk
281 %attr(755,root,root) %{_libexecdir}/amplot.g
282 %attr(755,root,root) %{_libexecdir}/amplot.gp
283 %attr(755,root,root) %{_libexecdir}/amtrmlog
284 %attr(755,root,root) %{_libexecdir}/chg-chio
285 %attr(755,root,root) %{_libexecdir}/chg-chs
286 %attr(755,root,root) %{_libexecdir}/chg-juke
287 %attr(755,root,root) %{_libexecdir}/chg-manual
288 %attr(755,root,root) %{_libexecdir}/chg-mtx
289 %attr(755,root,root) %{_libexecdir}/chg-multi
290 %attr(755,root,root) %{_libexecdir}/chg-rait
291 %attr(755,root,root) %{_libexecdir}/chg-rth
292 %attr(755,root,root) %{_libexecdir}/chg-scsi
293 %attr(755,root,root) %{_libexecdir}/chg-zd-mtx
294 %attr(755,root,root) %{_libexecdir}/taper
295 %attr(755,root,root) %{_sbindir}/amadmin
296 %attr(4754,root,amanda) %{_sbindir}/amcheck
297 %attr(755,root,root) %{_sbindir}/amcheckdb
298 %attr(755,root,root) %{_sbindir}/amcleanup
299 %attr(755,root,root) %{_sbindir}/amdump
300 %attr(755,root,root) %{_sbindir}/amflush
301 %attr(755,root,root) %{_sbindir}/amgetconf
302 %attr(755,root,root) %{_sbindir}/amlabel
303 %attr(755,root,root) %{_sbindir}/amoverview
304 %attr(755,root,root) %{_sbindir}/amplot
305 %attr(755,root,root) %{_sbindir}/amreport
306 %attr(755,root,root) %{_sbindir}/amrmtape
307 %attr(755,root,root) %{_sbindir}/amstatus
308 %attr(755,root,root) %{_sbindir}/amtape
309 %attr(755,root,root) %{_sbindir}/amtapetype
310 %attr(755,root,root) %{_sbindir}/amtoc
311 %attr(755,root,root) %{_sbindir}/amverify
312 %attr(755,root,root) %{_sbindir}/amverifyrun
313 %{_mandir}/man8/amadmin.8*
314 %{_mandir}/man8/amanda.8*
315 %{_mandir}/man8/amcheck.8*
316 %{_mandir}/man8/amcheckdb.8*
317 %{_mandir}/man8/amcleanup.8*
318 %{_mandir}/man8/amdump.8*
319 %{_mandir}/man8/amflush.8*
320 %{_mandir}/man8/amgetconf.8*
321 %{_mandir}/man8/amlabel.8*
322 %{_mandir}/man8/amoverview.8*
323 %{_mandir}/man8/amplot.8*
324 %{_mandir}/man8/amreport.8*
325 %{_mandir}/man8/amrmtape.8*
326 %{_mandir}/man8/amstatus.8*
327 %{_mandir}/man8/amtape.8*
328 %{_mandir}/man8/amtapetype.8*
329 %{_mandir}/man8/amtoc.8*
330 %{_mandir}/man8/amverify.8*
331 %{_mandir}/man8/amverifyrun.8*
332
333 %files client
334 %defattr(644,root,root,755)
335 %config(noreplace) /etc/sysconfig/rc-inetd/amanda
336 %attr(664,root,amanda) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/amandates
337 %attr(755,root,root) %{_libdir}/libamclient*.so
338 %attr(755,root,root) %{_libexecdir}/versionsuffix
339 %attr(755,root,root) %{_libexecdir}/amandad
340 %attr(4754,root,amanda) %{_libexecdir}/calcsize
341 %attr(4754,root,amanda) %{_libexecdir}/rundump
342 %attr(4754,root,amanda) %{_libexecdir}/runtar
343 %attr(4754,root,amanda) %{_libexecdir}/selfcheck
344 %attr(755,root,root) %{_libexecdir}/sendbackup
345 %attr(755,root,root) %{_libexecdir}/sendsize
346 %attr(755,root,root) %{_libexecdir}/patch-system
347 %attr(4754,root,amanda) %{_libexecdir}/killpgrp
348 %attr(755,root,root) %{_sbindir}/amdd
349 %attr(755,root,root) %{_sbindir}/ammt
350 %attr(755,root,root) %{_sbindir}/amrecover
351 %attr(755,root,root) %{_sbindir}/amrestore
352 %attr(770,amanda,amanda) %dir %{_localstatedir}/amanda/gnutar-lists
353 %{_mandir}/man8/amdd.8*
354 %{_mandir}/man8/ammt.8*
355 %{_mandir}/man8/amrecover.8*
356 %{_mandir}/man8/amrestore.8*
This page took 0.536703 seconds and 4 git commands to generate.