]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
- unified rc-inetd usage (via %service), adapterized
[packages/amanda.git] / amanda.spec
1 #
2 # Conditional build:
3 %bcond_with     xfs     # with support for xfsdump
4 #
5 Summary:        A network-capable tape backup solution
6 Summary(pl):    Sieciowo zorientowany system tworzenia kopii zapasowych
7 Name:           amanda
8 Version:        2.4.5
9 Release:        4
10 License:        BSD
11 Group:          Networking/Utilities
12 Source0:        http://dl.sourceforge.net/amanda/%{name}-%{version}.tar.gz
13 # Source0-md5:  1960b7875424e412d042bc92a1548d7f
14 Source1:        %{name}-srv.crontab
15 Source2:        %{name}.inetd
16 Source3:        %{name}idx.inetd
17 Source4:        amidxtape.inetd
18 Source5:        %{name}.conf
19 Patch0:         %{name}-no_libnsl.patch
20 Patch1:         %{name}-ac25x.patch
21 Patch2:         %{name}-chg-zd-mtx-sh.patch
22 Patch3:         %{name}-tar.patch
23 URL:            http://www.amanda.org/
24 BuildRequires:  autoconf >= 2.53
25 BuildRequires:  automake
26 BuildRequires:  dump
27 BuildRequires:  flex
28 BuildRequires:  libtool
29 BuildRequires:  readline-devel >= 4.2
30 BuildRequires:  rpmbuild(macros) >= 1.268
31 %{?with_xfs:BuildRequires:      xfsdump}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _localstatedir  /var/lib
35 %define         _libexecdir     %{_libdir}/amanda
36
37 %description
38 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
39 backup system that allows the administrator of a LAN to set up a
40 single master backup server to back up multiple hosts to a single
41 large capacity tape drive. AMANDA uses native dump and/or GNU tar
42 facilities and can back up a large number of workstations running
43 multiple versions of Unix. Newer versions of AMANDA (including this
44 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
45 The amanda package contains the core AMANDA programs and will need to
46 be installed on both AMANDA clients and AMANDA servers. Note that you
47 will have to install the amanda-client and amanda-server packages as
48 well.
49
50 %description -l pl
51 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
52 zapasowych. Umo¿liwia administratorowi sieci tworzenie kopii z kilku
53 hostów na jednej maszynie wyposa¿onej w pojemny dysk lub streamer.
54 Nowsze wersje programu umo¿liwiaj± zabezpieczanie zasobów Microsoft
55 Windows 95/98/NT/2000 przy u¿yciu protoko³u Samba. Ten pakiet zawiera
56 podstawowe pliki programu i powinien byæ zainstalowany zarówno na
57 serwerze jak i na kliencie. Pamiêtaj tak¿e o instalacji pakietów
58 amanda-client i amanda-server!
59
60 %package libs
61 Summary:        Amanda shared libraries
62 Summary(pl):    Biblioteki wspó³dzielone pakietu amanda
63 Group:          Networking/Utilities
64 Requires(postun):       /sbin/ldconfig
65 Requires(postun):       /usr/sbin/groupdel
66 Requires(postun):       /usr/sbin/userdel
67 Requires(pre):  /bin/id
68 Requires(pre):  /usr/bin/getgid
69 Requires(pre):  /usr/sbin/groupadd
70 Requires(pre):  /usr/sbin/useradd
71 Provides:       group(amanda)
72 Provides:       user(amanda)
73
74 %description libs
75 Amanda shared libraries.
76
77 %description libs -l pl
78 Biblioteki wspó³dzielone pakietu amanda.
79
80 %package client
81 Summary:        The client side of Amanda
82 Summary(pl):    Klient Amandy
83 Group:          Networking/Utilities
84 Requires(post,postun):  /sbin/ldconfig
85 Requires:       %{name}-libs = %{version}-%{release}
86 Requires:       rc-inetd
87 Conflicts:      tar < 1.13
88
89 %description client
90 The Amanda-client package should be installed on any machine that will
91 be backed up by AMANDA (including the server if it also needs to be
92 backed up). You will also need to install the amanda package to each
93 AMANDA client. It requires at least one of dump and GNU tar installed.
94
95 %description client -l pl
96 Ten pakiet powinien byæ zainstalowany ma maszynach, z których
97 zawarto¶ci bêd± tworzone kopie zapasowe. Wymaga zainstalowanego co
98 najmniej jednego z pakietów dump i GNU tar.
99
100 %package server
101 Summary:        The server side of Amanda
102 Summary(pl):    Serwer Amandy
103 Group:          Networking/Utilities
104 Requires(post,postun):  /sbin/ldconfig
105 Requires:       %{name}-libs = %{version}-%{release}
106 Requires:       /etc/cron.d
107 Requires:       crondaemon
108 Requires:       gnuplot
109 Requires:       mt-st
110 Requires:       mtx
111 Requires:       rc-inetd
112 Obsoletes:      amanda
113
114 %description server
115 The amanda-server package should be installed on the AMANDA server,
116 the machine attached to the device (such as a tape drive) where
117 backups will be written. You will also need to install the amanda
118 package to the AMANDA server. And, if the server is also to be backed
119 up, the server also needs to have the amanda-client package installed.
120
121 %description server -l pl
122 Ten pakiet powinien byæ zainstalowany na maszynach, na których bêd±
123 magazynowane kopie zapasowe (lub do których podpiête s± urz±dzenia
124 typu streamer).
125
126 %prep
127 %setup -q
128 %patch0 -p1
129 %patch1 -p1
130 %patch2 -p1
131 %patch3 -p1
132
133 # kill libtool.m4 copy
134 head -n 1039 acinclude.m4 > acinc.tmp
135 mv -f acinc.tmp acinclude.m4
136
137 %build
138 %{__libtoolize}
139 %{__aclocal}
140 %{__autoconf}
141 %{__automake}
142 %configure \
143         GNUPLOT=/usr/bin/gnuplot \
144         MAILER=/bin/mail \
145         PRINT=/usr/bin/lpr \
146         DUMP=/sbin/dump \
147         RESTORE=/sbin/restore \
148         XFSDUMP=/sbin/xfsdump \
149         XFSRESTORE=/sbin/xfsrestore \
150         --disable-static \
151         --enable-shared \
152         --with-index-server=localhost \
153         --with-user=amanda \
154         --with-group=amanda \
155         --with-tape-device=/dev/null \
156         --with-ftape-rawdevice=/dev/null \
157         --with-changer-device=/dev/null \
158         --with-fqdn \
159         --with-smbclient=%{_bindir}/smbclient \
160         --with-bsd-security \
161         --with-buffered-dump \
162         --with-amandahosts \
163         --with-debugging=%{_localstatedir}/amanda/debug \
164         --with-gnutar-listdir=%{_localstatedir}/amanda/gnutar-lists \
165         --with-tmpdir=/var/tmp
166
167 %{__make}
168
169 %install
170 rm -rf $RPM_BUILD_ROOT
171 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{amanda,cron.d,sysconfig/rc-inetd} \
172         $RPM_BUILD_ROOT%{_localstatedir}/amanda/gnutar-lists \
173         $RPM_BUILD_ROOT%{_mandir}/man1
174
175 %{__make} install \
176         DESTDIR=$RPM_BUILD_ROOT \
177         SETUID_GROUP=`id -g`
178
179 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amanda-srv
180 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE2} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amanda
181 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE3} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amandaidx
182 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE4} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amidxtape
183
184 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/amanda
185 install example/*.ps $RPM_BUILD_ROOT%{_localstatedir}/amanda
186 touch $RPM_BUILD_ROOT%{_localstatedir}/amanda/.amandahosts
187
188 > $RPM_BUILD_ROOT%{_sysconfdir}/amandates
189
190 %clean
191 rm -rf $RPM_BUILD_ROOT
192
193 %triggerpostun -- amanda-libs < 2.4.2p2-3
194 /usr/sbin/chsh -s /bin/sh amanda
195
196 %triggerpostun -- amanda-libs < 2.4.2p2-12
197 /usr/sbin/usermod -G disk amanda
198
199 %pre libs
200 %groupadd -P %{name}-libs -g 80 amanda
201 %useradd -P %{name}-libs -u 80 -G disk -d /var/lib/amanda -s /bin/sh -c "Amanda Backup user" -g amanda amanda
202
203 %post   libs -p /sbin/ldconfig
204
205 %postun libs
206 /sbin/ldconfig
207 if [ "$1" = "0" ]; then
208         %userremove amanda
209         %groupremove amanda
210 fi
211
212 %post client
213 /sbin/ldconfig
214 %service -q rc-inetd reload
215
216 %postun client
217 /sbin/ldconfig
218 if [ "$1" = 0 ]; then
219         %service -q rc-inetd reload
220 fi
221
222 %post server
223 /sbin/ldconfig
224 %service -q rc-inetd reload
225 if [ "$1" = "1" ]; then
226         echo "Don't forget to edit /etc/cron.d/amanda-srv." 1>&2
227 fi
228
229 %postun server
230 /sbin/ldconfig
231 if [ "$1" = 0 ]; then
232         %service -q rc-inetd reload
233 fi
234
235 %files libs
236 %defattr(644,root,root,755)
237 %attr(755,root,root) %{_libdir}/libamanda*.so
238 %attr(755,root,root) %{_libdir}/libamtape*.so
239 %dir %{_libexecdir}
240 %attr(770,root,amanda) %dir %{_localstatedir}/amanda
241 %attr(640,root,amanda) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/amanda/.amandahosts
242
243 %files server
244 %defattr(644,root,root,755)
245 %doc docs/*
246 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amidxtape
247 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amandaidx
248
249 %attr(750,root,amanda) %dir %{_sysconfdir}/amanda
250 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,amanda) %{_sysconfdir}/amanda/*
251
252 %attr(664,root,amanda) %{_localstatedir}/amanda/*.ps
253
254 %config(noreplace) %attr(640,root,root) /etc/cron.d/amanda-srv
255
256 %attr(755,root,root) %{_libdir}/libamserver*.so
257 %attr(755,root,root) %{_libexecdir}/amindexd
258 %attr(755,root,root) %{_libexecdir}/amtrmidx
259 %attr(755,root,root) %{_libexecdir}/driver
260 %attr(4754,root,amanda) %{_libexecdir}/dumper
261 %attr(4754,root,amanda) %{_libexecdir}/planner
262 %attr(755,root,root) %{_libexecdir}/amcat.awk
263 %attr(755,root,root) %{_libexecdir}/amcleanupdisk
264 %attr(755,root,root) %{_libexecdir}/amidxtaped
265 %attr(755,root,root) %{_libexecdir}/amlogroll
266 %attr(755,root,root) %{_libexecdir}/amplot.awk
267 %attr(755,root,root) %{_libexecdir}/amplot.g
268 %attr(755,root,root) %{_libexecdir}/amplot.gp
269 %attr(755,root,root) %{_libexecdir}/amtrmlog
270 %attr(755,root,root) %{_libexecdir}/chg-chio
271 %attr(755,root,root) %{_libexecdir}/chg-chs
272 %attr(755,root,root) %{_libexecdir}/chg-disk
273 %attr(755,root,root) %{_libexecdir}/chg-iomega
274 %attr(755,root,root) %{_libexecdir}/chg-juke
275 %attr(755,root,root) %{_libexecdir}/chg-manual
276 %attr(755,root,root) %{_libexecdir}/chg-mcutil
277 %attr(755,root,root) %{_libexecdir}/chg-mtx
278 %attr(755,root,root) %{_libexecdir}/chg-multi
279 %attr(755,root,root) %{_libexecdir}/chg-null
280 %attr(755,root,root) %{_libexecdir}/chg-rait
281 %attr(755,root,root) %{_libexecdir}/chg-rth
282 %attr(755,root,root) %{_libexecdir}/chg-scsi
283 %attr(755,root,root) %{_libexecdir}/chg-zd-mtx
284 %attr(755,root,root) %{_libexecdir}/taper
285 %attr(755,root,root) %{_sbindir}/amadmin
286 %attr(4754,root,amanda) %{_sbindir}/amcheck
287 %attr(755,root,root) %{_sbindir}/amcheckdb
288 %attr(755,root,root) %{_sbindir}/amcleanup
289 %attr(755,root,root) %{_sbindir}/amdump
290 %attr(755,root,root) %{_sbindir}/amflush
291 %attr(755,root,root) %{_sbindir}/amgetconf
292 %attr(755,root,root) %{_sbindir}/amlabel
293 %attr(755,root,root) %{_sbindir}/amoverview
294 %attr(755,root,root) %{_sbindir}/amplot
295 %attr(755,root,root) %{_sbindir}/amreport
296 %attr(755,root,root) %{_sbindir}/amrmtape
297 %attr(755,root,root) %{_sbindir}/amstatus
298 %attr(755,root,root) %{_sbindir}/amtape
299 %attr(755,root,root) %{_sbindir}/amtapetype
300 %attr(755,root,root) %{_sbindir}/amtoc
301 %attr(755,root,root) %{_sbindir}/amverify
302 %attr(755,root,root) %{_sbindir}/amverifyrun
303 %{_mandir}/man8/amadmin.8*
304 %{_mandir}/man8/amanda.8*
305 %{_mandir}/man8/amcheck.8*
306 %{_mandir}/man8/amcheckdb.8*
307 %{_mandir}/man8/amcleanup.8*
308 %{_mandir}/man8/amdump.8*
309 %{_mandir}/man8/amflush.8*
310 %{_mandir}/man8/amgetconf.8*
311 %{_mandir}/man8/amlabel.8*
312 %{_mandir}/man8/amoverview.8*
313 %{_mandir}/man8/amplot.8*
314 %{_mandir}/man8/amreport.8*
315 %{_mandir}/man8/amrmtape.8*
316 %{_mandir}/man8/amstatus.8*
317 %{_mandir}/man8/amtape.8*
318 %{_mandir}/man8/amtapetype.8*
319 %{_mandir}/man8/amtoc.8*
320 %{_mandir}/man8/amverify.8*
321 %{_mandir}/man8/amverifyrun.8*
322
323 %files client
324 %defattr(644,root,root,755)
325 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amanda
326 %attr(664,root,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/amandates
327 %attr(755,root,root) %{_libdir}/libamclient*.so
328 %attr(755,root,root) %{_libexecdir}/versionsuffix
329 %attr(755,root,root) %{_libexecdir}/amandad
330 %attr(4754,root,amanda) %{_libexecdir}/amqde
331 %attr(4754,root,amanda) %{_libexecdir}/calcsize
332 %attr(4754,root,amanda) %{_libexecdir}/killpgrp
333 %attr(755,root,root) %{_libexecdir}/patch-system
334 %attr(4754,root,amanda) %{_libexecdir}/rundump
335 %attr(4754,root,amanda) %{_libexecdir}/runtar
336 %attr(4754,root,amanda) %{_libexecdir}/selfcheck
337 %attr(755,root,root) %{_libexecdir}/sendbackup
338 %attr(755,root,root) %{_libexecdir}/sendsize
339 %attr(755,root,root) %{_sbindir}/amdd
340 %attr(755,root,root) %{_sbindir}/ammt
341 %attr(755,root,root) %{_sbindir}/amrecover
342 %attr(755,root,root) %{_sbindir}/amrestore
343 %attr(770,root,amanda) %dir %{_localstatedir}/amanda/gnutar-lists
344 %{_mandir}/man8/amdd.8*
345 %{_mandir}/man8/ammt.8*
346 %{_mandir}/man8/amrecover.8*
347 %{_mandir}/man8/amrestore.8*
This page took 0.638144 seconds and 4 git commands to generate.