]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
- use proper syntax for _noautoreq_perl
[packages/amanda.git] / amanda.spec
1 #
2 # Conditional build:
3 %bcond_without  xfs     # without (possible) support for xfsdump
4 %bcond_without  samba   # without smbclient support
5 %bcond_without  client  # without client package
6 %bcond_without  server  # without server package
7
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        A network-capable tape backup solution
10 Summary(pl.UTF-8):      Sieciowo zorientowany system tworzenia kopii zapasowych
11 Name:           amanda
12 Version:        3.3.2
13 Release:        3
14 License:        BSD
15 Group:          Networking/Utilities
16 Source0:        http://downloads.sourceforge.net/amanda/%{name}-%{version}.tar.gz
17 # Source0-md5:  1a6cfe47eaee121f22540ac5fa58c366
18 Source1:        %{name}-srv.crontab
19 Source2:        %{name}.inetd
20 Source3:        %{name}idx.inetd
21 Source4:        amidxtape.inetd
22 Source5:        k5%{name}.inet
23 # http://amanda.svn.sourceforge.net/viewvc/amanda/amanda/branches/3_2/contrib/convert-zd-mtx-to-robot.sh
24 Source6:        convert-zd-mtx-to-robot.sh
25 Source7:        %{name}-ssh_config
26 # https://github.com/janekr/amlvm-snapshot
27 Source8:        amlvm-snapshot.conf
28 Source9:        amlvm-snapshot.pl
29 Source10:       amlvm-snapshot.README
30 Patch0:         %{name}-no_libnsl.patch
31 Patch1:         %{name}-chg-zd-mtx-sh.patch
32 Patch2:         %{name}-tar.patch
33 Patch3:         %{name}-common.patch
34 Patch4:         %{name}-as_needed.patch
35 Patch5:         %{name}-tapetypes.patch
36 Patch6:         %{name}-FHS.patch
37 Patch7:         %{name}-no-buildtime-ipv6.patch
38 Patch8:         %{name}-heimdal.patch
39 Patch9:         %{name}-ac.patch
40 Patch11:        %{name}-amstar-exclude-fix.patch
41 Patch12:        %{name}-krb5-auth.patch
42 Patch13:        %{name}-stdio.patch
43 Patch14:        %{name}-amstar-device.patch
44 URL:            http://www.amanda.org/
45 BuildRequires:  autoconf >= 2.53
46 BuildRequires:  automake
47 BuildRequires:  curl-devel >= 7.10.0
48 BuildRequires:  dump
49 BuildRequires:  flex
50 BuildRequires:  glib2-devel
51 BuildRequires:  gnuplot
52 BuildRequires:  rpmbuild(macros) >= 1.654
53 # curl is broken, see curl-config --libs
54 BuildRequires:  heimdal-devel
55 BuildRequires:  keyutils-devel
56 BuildRequires:  libtool
57 BuildRequires:  libxslt-progs
58 BuildRequires:  ncurses-devel
59 BuildRequires:  openssh-clients
60 BuildRequires:  openssl-devel
61 BuildRequires:  perl-devel >= 5.6.0
62 BuildRequires:  pkgconfig
63 BuildRequires:  readline-devel >= 4.2
64 BuildRequires:  rpm-perlprov
65 BuildRequires:  rpmbuild(macros) >= 1.654
66 %{?with_samba:BuildRequires:    samba-client}
67 BuildRequires:  swig
68 %{?with_xfs:BuildRequires:      xfsdump}
69 Conflicts:      pwdutils < 3.1.2-2
70 Conflicts:      shadow < 1:4.0.4.1-4
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 # for some unknown reason those get detected in R but not in P (Tie::StdHash comes from perl)
74 %define         _noautoreq_perl Tie::StdHash Amanda::Recovery::Clerk::Feedback Amanda::Taper::Scribe::Feedback
75
76 %define         _ulibdir        %{_prefix}/lib
77
78 %description
79 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
80 backup system that allows the administrator of a LAN to set up a
81 single master backup server to back up multiple hosts to a single
82 large capacity tape drive. AMANDA uses native dump and/or GNU tar
83 facilities and can back up a large number of workstations running
84 multiple versions of Unix. Newer versions of AMANDA (including this
85 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
86 The amanda package contains the core AMANDA programs and will need to
87 be installed on both AMANDA clients and AMANDA servers. Note that you
88 will have to install the amanda-client and amanda-server packages as
89 well.
90
91 %description -l pl.UTF-8
92 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
93 zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
94 hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
95 Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
96 Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
97 podstawowe pliki programu i powinien być zainstalowany zarówno na
98 serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
99 amanda-client i amanda-server!
100
101 %package common
102 Summary:        Amanda common files
103 Summary(pl.UTF-8):      Wspólne pliki pakietu amanda
104 Group:          Networking/Utilities
105 Requires(postun):       /usr/sbin/groupdel
106 Requires(postun):       /usr/sbin/userdel
107 Requires(pre):  /bin/id
108 Requires(pre):  /usr/bin/chsh
109 Requires(pre):  /usr/bin/getgid
110 Requires(pre):  /usr/sbin/groupadd
111 Requires(pre):  /usr/sbin/useradd
112 %requires_ge    glib2
113 Requires:       setup >= 2.6.1-1
114 Provides:       group(amanda)
115 Provides:       user(amanda)
116 Obsoletes:      amanda-libs
117 Obsoletes:      amanda-perl
118
119 %description common
120 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
121 backup system that allows the administrator of a LAN to set up a
122 single master backup server to back up multiple hosts to a single
123 large capacity tape drive. AMANDA uses native dump and/or GNU tar
124 facilities and can back up a large number of workstations running
125 multiple versions of Unix. Newer versions of AMANDA (including this
126 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
127 The amanda package contains the core AMANDA programs and will need to
128 be installed on both AMANDA clients and AMANDA servers. Note that you
129 will have to install the amanda-client and amanda-server packages as
130 well.
131
132 Amanda common files.
133
134 %description common -l pl.UTF-8
135 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
136 zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
137 hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
138 Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
139 Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
140 podstawowe pliki programu i powinien być zainstalowany zarówno na
141 serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
142 amanda-client i amanda-server!
143
144 Wspólne pliki pakietu amanda.
145
146 %package client
147 Summary:        The client side of Amanda
148 Summary(pl.UTF-8):      Klient Amandy
149 Group:          Networking/Utilities
150 Requires(post): /bin/hostname
151 Requires(post): /usr/bin/ssh-keygen
152 Requires:       %{name}-common = %{version}-%{release}
153 Requires:       rc-inetd
154 Suggests:       gzip
155 Suggests:       openssh-clients
156 Suggests:       openssh-server
157 Suggests:       star
158 Suggests:       tar
159 Conflicts:      tar < 1.15
160
161 %description client
162 The Amanda-client package should be installed on any machine that will
163 be backed up by AMANDA (including the server if it also needs to be
164 backed up). You will also need to install the amanda package to each
165 AMANDA client. It requires at least one of dump and GNU tar installed.
166
167 %description client -l pl.UTF-8
168 Ten pakiet powinien być zainstalowany ma maszynach, z których
169 zawartości będą tworzone kopie zapasowe. Wymaga zainstalowanego co
170 najmniej jednego z pakietów dump i GNU tar.
171
172 %package server
173 Summary:        The server side of Amanda
174 Summary(pl.UTF-8):      Serwer Amandy
175 Group:          Networking/Utilities
176 Requires(post): /bin/hostname
177 Requires(post): /usr/bin/ssh-keygen
178 Requires:       %{name}-common = %{version}-%{release}
179 Requires:       /etc/cron.d
180 Requires:       crondaemon
181 Requires:       gnuplot
182 Requires:       mt-st
183 Requires:       mtx
184 Requires:       rc-inetd
185 Suggests:       openssh-clients
186 Suggests:       openssh-server
187 Obsoletes:      amanda
188 Obsoletes:      amanda-perl-server
189
190 %description server
191 The amanda-server package should be installed on the AMANDA server,
192 the machine attached to the device (such as a tape drive) where
193 backups will be written. You will also need to install the amanda
194 package to the AMANDA server. And, if the server is also to be backed
195 up, the server also needs to have the amanda-client package installed.
196
197 %description server -l pl.UTF-8
198 Ten pakiet powinien być zainstalowany na maszynach, na których będą
199 magazynowane kopie zapasowe (lub do których podpięte są urządzenia
200 typu streamer).
201
202 %prep
203 %setup -q
204 %patch0 -p1
205 %patch1 -p1
206 %patch2 -p1
207 %patch3 -p1
208 %patch4 -p1
209 %patch5 -p1
210 %patch6 -p1
211 %patch7 -p1
212 %patch8 -p1
213 %patch9 -p1
214 %patch11 -p1
215 %patch12 -p1
216 %patch13 -p1
217 %patch14 -p1
218 cp -a %{SOURCE10} .
219
220 %build
221 %{__aclocal} -I config -I config/gettext-macros -I config/gnulib -I config/amanda -I config/macro-archive
222 %{__autoconf}
223 %{__automake}
224 %configure \
225         DUMP=/sbin/dump \
226         GZIP=/bin/gzip \
227         MAILER=/bin/mail \
228         MT=/bin/mt \
229         MTX=/usr/sbin/mtx \
230         PRINT=/usr/bin/lpr \
231         RESTORE=/sbin/restore \
232         %{?with_xfs:XFSDUMP=/sbin/xfsdump} \
233         %{?with_xfs:XFSRESTORE=/sbin/xfsrestore} \
234         --disable-static \
235         --enable-shared \
236         %{!?with_server:--without-server} \
237         %{!?with_client:--without-client} \
238         --with-index-server=localhost \
239         --with-user=amanda \
240         --with-group=amanda \
241         --with-tape-device=/dev/null \
242         --with-fqdn \
243         %{?with_samba:--with-smbclient=%{_bindir}/smbclient} \
244         --with-star=%{_bindir}/star \
245         --with-gnuplot=%{_bindir}/gnuplot \
246         --with-bsd-security \
247         --with-bsdtcp-security \
248         --with-ssh-security \
249         --with-krb5-security \
250         --with-buffered-dump \
251         --with-amandahosts \
252         --with-configdir=%{_sysconfdir}/amanda \
253         --with-gnutar-listdir=%{_sharedstatedir}/amanda/gnutar-lists \
254         --with-amandates=%{_sharedstatedir}/amanda/amandates \
255         --with-debugging=%{_sharedstatedir}/amanda/debug \
256         --with-tmpdir=/var/tmp/amanda \
257         --with-amperldir=%{perl_vendorarch} \
258         --with-ipv6 \
259         --with-readline \
260         --disable-installperms
261
262 %{__make}
263
264 %install
265 rm -rf $RPM_BUILD_ROOT
266 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{amanda,cron.d,sysconfig/rc-inetd} \
267         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/{.gnupg,.ssh,gnutar-lists} \
268         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/debug/{amandad,client,server}
269
270 %{__make} install \
271         DESTDIR=$RPM_BUILD_ROOT
272
273 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amanda-srv
274 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE2} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amanda
275 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE3} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amandaidx
276 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE4} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amidxtape
277 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE5} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/k5amanda
278
279 install example/amanda.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
280 install example/amanda-client.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
281 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.amandahosts
282
283 install %{SOURCE6} $RPM_BUILD_ROOT%{_sbindir}/amconvert-zd-mtx-to-robot.sh
284
285 install %{SOURCE7} $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/config
286 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/{,client_}authorized_keys
287 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amdump{,.pub}
288 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover{,.pub}
289
290 %if %{with server}
291 install -p %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/amanda/lvm-snapshot.conf
292 %endif
293
294 %if %{with client}
295 sed -e 's|@@PERL_VENDORARCH@@|%{perl_vendorarch}|' %{SOURCE9} >$RPM_BUILD_ROOT%{_libdir}/amanda/application/amlvm-snapshot
296 %endif
297
298 > $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/amandates
299
300 # Amanda tools generate ssh keys with embeded commands pointing to /usr/lib
301 # Tools can't be "fixed" because keys generated on server are to be used on client
302 if [ "%{_lib}" != "lib" ] ; then
303         install -d $RPM_BUILD_ROOT%{_ulibdir}
304         ln -s %{_libdir}/amanda $RPM_BUILD_ROOT%{_ulibdir}/amanda
305 fi
306
307 find $RPM_BUILD_ROOT -name \*.la | xargs rm -f
308
309 %{__rm} $RPM_BUILD_ROOT%{_datadir}/amanda/{COPYRIGHT,ChangeLog,NEWS,ReleaseNotes}
310 %{__rm} $RPM_BUILD_ROOT%{_datadir}/amanda/example/{chg-multi,chg-scsi}.conf
311
312 %clean
313 rm -rf $RPM_BUILD_ROOT
314
315 %triggerpostun common -- amanda-libs < 2.6.0p2-3
316 echo "Adding amanda to disk and tape groups"
317 /usr/sbin/usermod -G disk,tape amanda
318 echo "Setting amanda shell to /bin/sh"
319 /usr/bin/chsh -s /bin/sh amanda
320 if [ -f %{_sharedstatedir}/amanda/.amandahosts ]; then
321         echo "Fixing permissions of %{_sharedstatedir}/amanda/.amandahosts file"
322         chown amanda:amanda %{_sharedstatedir}/amanda/.amandahosts
323         chmod 600 %{_sharedstatedir}/amanda/.amandahosts
324 fi
325
326 %triggerpostun common -- amanda-common < 3.3
327 %banner %{name}-common -e << EOF
328 In amanda 3.3 the default auth has changed to "bsdtcp",
329 if you are using the default "bsd" then you must add it
330 to your configuration:
331
332  *   in amanda.conf
333  *   in amanda-client.conf
334  *   in dumptype/disklist
335  *   in inetd (if no '-auth' argument to amandad)
336 EOF
337
338 %pre common
339 %groupadd -P %{name}-common -g 80 amanda
340 %useradd -P %{name}-common -u 80 -G disk,tape -d /var/lib/amanda -s /bin/sh -c "Amanda Backup user" -g amanda amanda
341
342 %postun common
343 if [ "$1" = "0" ]; then
344         %userremove amanda
345         %groupremove amanda
346 fi
347
348 %post client
349 %service -q rc-inetd reload
350 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amrecover ] ; then
351         HOST="`/bin/hostname`"
352         FQDNHOST="`/bin/hostname -f`"
353         if [ -z "$HOST" ] ; then
354                 COMMENT="root@client"
355         else
356                 COMMENT="root@$HOST"
357         fi
358         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amrecover -N "" || :
359         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
360         chmod 600 /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
361         if [ -n "$FQDNHOST" ]; then
362                 echo -n "from=\"$FQDNHOST\",no-port-forwarding,no-X11-forwarding,no-agent-forwarding,command=\"%{_ulibdir}/amanda/amandad -auth=ssh amindexd amidxtaped\" " >/var/lib/amanda/.ssh/server_authorized_keys
363                 cat /var/lib/amanda/.ssh/id_rsa_amrecover.pub >>/var/lib/amanda/.ssh/server_authorized_keys
364
365                 echo "Remember to copy the contents of /var/lib/amanda/.ssh/server_authorized_keys to"
366                 echo "/var/lib/amanda/.ssh/authorized_keys on amanda server"
367         fi
368 fi
369
370 %postun client
371 if [ "$1" = 0 ]; then
372         %service -q rc-inetd reload
373 fi
374
375 %post server
376 %service -q rc-inetd reload
377 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amdump ] ; then
378         HOST="`/bin/hostname`"
379         if [ -z "$HOST" ] ; then
380                 COMMENT="amanda@server"
381         else
382                 COMMENT="amanda@$HOST"
383         fi
384         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amdump -N "" || :
385         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
386         chmod 600 /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
387 fi
388 if [ "$1" = "1" ]; then
389         echo "Don't forget to edit /etc/cron.d/amanda-srv." 1>&2
390 fi
391
392 %postun server
393 if [ "$1" = 0 ]; then
394         %service -q rc-inetd reload
395 fi
396
397 %triggerpostun server -- amanda-server < 3.2.0
398 %banner %{name} -e << EOF
399 Warning: Tape changer configuration has chaged, please read
400 %{_docdir}/%{name}-server-%{version}/ReleaseNotes.gz
401 and %{_docdir}/%{name}-server-%{version}/NEWS.gz for details.
402 You can use %{_sbindir}/amconvert-zd-mtx-to-robot.sh script
403 to upgrade to chg-robot.
404 EOF
405
406 %files common
407 %defattr(644,root,root,755)
408 %doc AUTHORS COPYRIGHT ChangeLog NEWS README ReleaseNotes UPGRADING amlvm-snapshot.README
409 %attr(755,root,root) %{_libdir}/amanda/libamanda*.so
410 %attr(755,root,root) %{_libdir}/amanda/libamar*.so
411 %attr(755,root,root) %{_libdir}/amanda/libamxfer*.so
412 %attr(755,root,root) %{_libdir}/amanda/libamglue*.so
413 %attr(755,root,root) %{_libdir}/amanda/libndmjob*.so
414 %attr(755,root,root) %{_libdir}/amanda/libndmlib*.so
415 %attr(755,root,root) %{_libdir}/amanda/amndmjob
416 %attr(755,root,root) %{_libdir}/amanda/ndmjob
417 %attr(750,amanda,amanda) %dir %{_sysconfdir}/amanda
418 %dir %{_libdir}/amanda
419 %if %{_lib} != "lib"
420 %{_ulibdir}/amanda
421 %endif
422 %{_libdir}/amanda/amanda-sh-lib.sh
423 %attr(755,root,root) %{_sbindir}/amaespipe
424 %attr(755,root,root) %{_sbindir}/amarchiver
425 %attr(755,root,root) %{_sbindir}/amcrypt*
426 %attr(755,root,root) %{_sbindir}/amgetconf
427 %attr(755,root,root) %{_sbindir}/amgpgcrypt
428 %attr(750,amanda,amanda) %dir %{_datadir}/amanda
429 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/example
430 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/example/label-templates
431 %attr(640,amanda,amanda) %{_datadir}/amanda/example/*amanda*
432 %attr(640,amanda,amanda) %{_datadir}/amanda/example/disklist
433 %attr(640,amanda,amanda) %{_datadir}/amanda/example/label-templates/*.ps
434 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/template.d
435 %attr(640,amanda,amanda) %{_datadir}/amanda/template.d/*
436 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda
437 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.ssh
438 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.gnupg
439 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug
440 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/amandad
441 %attr(600,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/.amandahosts
442 %attr(600,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/.ssh/config
443 # Commented out so it won't get removed on uninstall
444 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/authorized_keys
445 %{_mandir}/man5/amanda-archive-format.5*
446 %{_mandir}/man7/amanda-auth.7*
447 %{_mandir}/man7/amanda-match.7*
448 %{_mandir}/man7/amanda-scripts.7*
449 %{_mandir}/man8/amaespipe.8*
450 %{_mandir}/man8/amanda.8*
451 %{_mandir}/man8/amarchiver.8*
452 %{_mandir}/man8/amcrypt*.8*
453 %{_mandir}/man8/amgetconf.8*
454 %{_mandir}/man8/amgpgcrypt.8*
455 %{_mandir}/man8/script-email.8*
456
457 %dir %{perl_vendorarch}/Amanda
458 %dir %{perl_vendorarch}/Amanda/Config
459 %dir %{perl_vendorarch}/Amanda/IPC
460 %{perl_vendorarch}/Amanda/Archive.pm
461 %{perl_vendorarch}/Amanda/BigIntCompat.pm
462 %{perl_vendorarch}/Amanda/ClientService.pm
463 %{perl_vendorarch}/Amanda/Config.pm
464 %{perl_vendorarch}/Amanda/Config/FoldingHash.pm
465 %{perl_vendorarch}/Amanda/Constants.pm
466 %{perl_vendorarch}/Amanda/Debug.pm
467 %{perl_vendorarch}/Amanda/Feature.pm
468 %{perl_vendorarch}/Amanda/Header.pm
469 %{perl_vendorarch}/Amanda/IPC/Binary.pm
470 %{perl_vendorarch}/Amanda/IPC/LineProtocol.pm
471 %{perl_vendorarch}/Amanda/MainLoop.pm
472 %{perl_vendorarch}/Amanda/NDMP.pm
473 %{perl_vendorarch}/Amanda/Paths.pm
474 %{perl_vendorarch}/Amanda/Process.pm
475 %{perl_vendorarch}/Amanda/Script.pm
476 %{perl_vendorarch}/Amanda/Script_App.pm
477 %{perl_vendorarch}/Amanda/Tests.pm
478 %{perl_vendorarch}/Amanda/Util.pm
479 %{perl_vendorarch}/Amanda/Xfer.pm
480 %dir %{perl_vendorarch}/auto/Amanda
481 %dir %{perl_vendorarch}/auto/Amanda/Archive
482 %dir %{perl_vendorarch}/auto/Amanda/Config
483 %dir %{perl_vendorarch}/auto/Amanda/Debug
484 %dir %{perl_vendorarch}/auto/Amanda/Feature
485 %dir %{perl_vendorarch}/auto/Amanda/Header
486 %dir %{perl_vendorarch}/auto/Amanda/IPC
487 %dir %{perl_vendorarch}/auto/Amanda/IPC/Binary
488 %dir %{perl_vendorarch}/auto/Amanda/MainLoop
489 %dir %{perl_vendorarch}/auto/Amanda/NDMP
490 %dir %{perl_vendorarch}/auto/Amanda/Tests
491 %dir %{perl_vendorarch}/auto/Amanda/Util
492 %dir %{perl_vendorarch}/auto/Amanda/Xfer
493 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Archive/*.so
494 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Config/*.so
495 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Feature/*.so
496 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Header/*.so
497 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/IPC/Binary/*.so
498 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Debug/*.so
499 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/MainLoop/*.so
500 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/NDMP/*.so
501 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Tests/*.so
502 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Util/*.so
503 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Xfer/*.so
504
505 %if %{with server}
506 %files server
507 %defattr(644,root,root,755)
508 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amidxtape
509 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amandaidx
510
511 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/amanda.conf
512 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/lvm-snapshot.conf
513
514 # Commented out so it won't get removed on uninstall
515 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/client_authorized_keys
516 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amdump*
517
518 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/server
519
520 %config(noreplace) %attr(640,root,root) /etc/cron.d/amanda-srv
521
522 %attr(755,root,root) %{_libdir}/amanda/libamdevice*.so
523 %attr(755,root,root) %{_libdir}/amanda/libamserver*.so
524
525 %attr(755,root,root) %{_libdir}/amanda/amcat.awk
526 %attr(755,root,root) %{_libdir}/amanda/amcheck-device
527 %attr(755,root,root) %{_libdir}/amanda/amdumpd
528 %attr(755,root,root) %{_libdir}/amanda/amidxtaped
529 %attr(755,root,root) %{_libdir}/amanda/amindexd
530 %attr(755,root,root) %{_libdir}/amanda/amlogroll
531 %attr(755,root,root) %{_libdir}/amanda/amplot.awk
532 %attr(755,root,root) %{_libdir}/amanda/amplot.g
533 %attr(755,root,root) %{_libdir}/amanda/amplot.gp
534 %attr(755,root,root) %{_libdir}/amanda/amtrmidx
535 %attr(755,root,root) %{_libdir}/amanda/amtrmlog
536 %attr(755,root,root) %{_libdir}/amanda/chg-disk
537 %attr(755,root,root) %{_libdir}/amanda/chg-lib.sh
538 %attr(755,root,root) %{_libdir}/amanda/chg-manual
539 %attr(755,root,root) %{_libdir}/amanda/chg-multi
540 %attr(755,root,root) %{_libdir}/amanda/chg-zd-mtx
541 %attr(755,root,root) %{_libdir}/amanda/chunker
542 %attr(755,root,root) %{_libdir}/amanda/driver
543 %attr(4750,root,amanda) %{_libdir}/amanda/dumper
544 %attr(4750,root,amanda) %{_libdir}/amanda/planner
545 %attr(755,root,root) %{_libdir}/amanda/taper
546
547 %attr(755,root,root) %{_sbindir}/activate-devpay
548 %attr(755,root,root) %{_sbindir}/amaddclient
549 %attr(755,root,root) %{_sbindir}/amadmin
550 %attr(4750,root,amanda) %{_sbindir}/amcheck
551 %attr(755,root,root) %{_sbindir}/amcheckdb
552 %attr(755,root,root) %{_sbindir}/amcheckdump
553 %attr(755,root,root) %{_sbindir}/amcleanup
554 %attr(755,root,root) %{_sbindir}/amcleanupdisk
555 %attr(755,root,root) %{_sbindir}/amconvert-zd-mtx-to-robot.sh
556 %attr(755,root,root) %{_sbindir}/amdevcheck
557 %attr(755,root,root) %{_sbindir}/amdump
558 %attr(755,root,root) %{_sbindir}/amfetchdump
559 %attr(755,root,root) %{_sbindir}/amflush
560 %attr(755,root,root) %{_sbindir}/amlabel
561 %attr(755,root,root) %{_sbindir}/amoverview
562 %attr(755,root,root) %{_sbindir}/amplot
563 %attr(755,root,root) %{_sbindir}/amreport
564 %attr(755,root,root) %{_sbindir}/amrestore
565 %attr(755,root,root) %{_sbindir}/amrmtape
566 %attr(755,root,root) %{_sbindir}/amserverconfig
567 %attr(755,root,root) %{_sbindir}/amservice
568 %attr(755,root,root) %{_sbindir}/amstatus
569 %attr(755,root,root) %{_sbindir}/amtape
570 %attr(755,root,root) %{_sbindir}/amtapetype
571 %attr(755,root,root) %{_sbindir}/amtoc
572 %attr(755,root,root) %{_sbindir}/amvault
573 %{_mandir}/man5/amanda.conf.5*
574 %{_mandir}/man5/disklist.5*
575 %{_mandir}/man5/tapelist.5*
576 %{_mandir}/man7/amanda-changers.7*
577 %{_mandir}/man7/amanda-compatibility.7*
578 %{_mandir}/man7/amanda-devices.7*
579 %{_mandir}/man7/amanda-interactivity.7*
580 %{_mandir}/man7/amanda-taperscan.7*
581 %{_mandir}/man8/amaddclient.8*
582 %{_mandir}/man8/amadmin.8*
583 %{_mandir}/man8/amcheck.8*
584 %{_mandir}/man8/amcheckdb.8*
585 %{_mandir}/man8/amcheckdump.8*
586 %{_mandir}/man8/amcleanup.8*
587 %{_mandir}/man8/amcleanupdisk.8*
588 %{_mandir}/man8/amdevcheck.8*
589 %{_mandir}/man8/amdump.8*
590 %{_mandir}/man8/amfetchdump.8*
591 %{_mandir}/man8/amflush.8*
592 %{_mandir}/man8/amlabel.8*
593 %{_mandir}/man8/amoverview.8*
594 %{_mandir}/man8/amplot.8*
595 %{_mandir}/man8/amreport.8*
596 %{_mandir}/man8/amrestore.8*
597 %{_mandir}/man8/amrmtape.8*
598 %{_mandir}/man8/amserverconfig.8*
599 %{_mandir}/man8/amservice.8*
600 %{_mandir}/man8/amstatus.8*
601 %{_mandir}/man8/amtape.8*
602 %{_mandir}/man8/amtapetype.8*
603 %{_mandir}/man8/amtoc.8*
604 %{_mandir}/man8/amvault.8*
605
606 %{perl_vendorarch}/Amanda/Changer.pm
607 %dir %{perl_vendorarch}/Amanda/Changer
608 %{perl_vendorarch}/Amanda/Changer/*.pm
609 %{perl_vendorarch}/Amanda/Cmdline.pm
610 %{perl_vendorarch}/Amanda/Curinfo.pm
611 %dir %{perl_vendorarch}/Amanda/Curinfo
612 %{perl_vendorarch}/Amanda/Curinfo/*.pm
613 %dir %{perl_vendorarch}/Amanda/DB
614 %{perl_vendorarch}/Amanda/DB/*.pm
615 %{perl_vendorarch}/Amanda/Device.pm
616 %{perl_vendorarch}/Amanda/Disklist.pm
617 %{perl_vendorarch}/Amanda/Holding.pm
618 %{perl_vendorarch}/Amanda/Interactivity.pm
619 %dir %{perl_vendorarch}/Amanda/Interactivity
620 %{perl_vendorarch}/Amanda/Interactivity/*.pm
621 %{perl_vendorarch}/Amanda/Logfile.pm
622 %dir %{perl_vendorarch}/Amanda/Recovery
623 %{perl_vendorarch}/Amanda/Recovery/*.pm
624 %{perl_vendorarch}/Amanda/Report.pm
625 %dir %{perl_vendorarch}/Amanda/Report
626 %{perl_vendorarch}/Amanda/Report/*.pm
627 %{perl_vendorarch}/Amanda/ScanInventory.pm
628 %{perl_vendorarch}/Amanda/Tapelist.pm
629 %dir %{perl_vendorarch}/Amanda/Taper
630 %{perl_vendorarch}/Amanda/Taper/*.pm
631 %dir %{perl_vendorarch}/Amanda/Taper/Scan
632 %{perl_vendorarch}/Amanda/Taper/Scan/*.pm
633 %{perl_vendorarch}/Amanda/XferServer.pm
634 %dir %{perl_vendorarch}/auto/Amanda/Cmdline
635 %dir %{perl_vendorarch}/auto/Amanda/Device
636 %dir %{perl_vendorarch}/auto/Amanda/Disklist
637 %dir %{perl_vendorarch}/auto/Amanda/Logfile
638 %dir %{perl_vendorarch}/auto/Amanda/Tapelist
639 %dir %{perl_vendorarch}/auto/Amanda/XferServer
640 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Cmdline/*.so
641 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Device/*.so
642 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Disklist/*.so
643 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Logfile/*.so
644 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Tapelist/*.so
645 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/XferServer/*.so
646 %endif
647
648 %if %{with client}
649 %files client
650 %defattr(644,root,root,755)
651 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amanda
652 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/k5amanda
653 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,amanda) %{_sysconfdir}/amanda/amanda-client.conf
654 # Commented out so it won't get removed on uninstall
655 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover*
656 %attr(640,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/amandates
657
658 %dir %{_libdir}/amanda/application
659 %attr(4750,root,amanda) %{_libdir}/amanda/application/amgtar
660 %attr(755,root,root) %{_libdir}/amanda/application/amlog-script
661 %attr(755,root,root) %{_libdir}/amanda/application/amlvm-snapshot
662 %attr(755,root,root) %{_libdir}/amanda/application/ampgsql
663 %attr(755,root,root) %{_libdir}/amanda/application/amraw
664 %attr(755,root,root) %{_libdir}/amanda/application/amsamba
665 %attr(4750,root,amanda) %{_libdir}/amanda/application/amstar
666 %attr(755,root,root) %{_libdir}/amanda/application/amsuntar
667 %attr(755,root,root) %{_libdir}/amanda/application/amzfs*
668 %attr(755,root,root) %{_libdir}/amanda/application/script-email
669
670 %attr(755,root,root) %{_libdir}/amanda/libamclient*.so
671 %attr(755,root,root) %{_libdir}/amanda/amandad
672 %attr(755,root,root) %{_libdir}/amanda/noop
673 %attr(755,root,root) %{_libdir}/amanda/patch-system
674 %attr(755,root,root) %{_libdir}/amanda/sendbackup
675 %attr(755,root,root) %{_libdir}/amanda/sendsize
676 %attr(755,root,root) %{_libdir}/amanda/teecount
677 %attr(4750,root,amanda) %{_libdir}/amanda/calcsize
678 %attr(4750,root,amanda) %{_libdir}/amanda/killpgrp
679 %attr(4750,root,amanda) %{_libdir}/amanda/rundump
680 %attr(4750,root,amanda) %{_libdir}/amanda/runtar
681 %attr(755,root,root) %{_libdir}/amanda/selfcheck
682 %attr(755,root,root) %{_sbindir}/amdump_client
683 %attr(755,root,root) %{_sbindir}/amoldrecover
684 %attr(755,root,root) %{_sbindir}/amrecover
685 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/gnutar-lists
686 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/client
687 %{_mandir}/man7/amanda-applications.7*
688 %{_mandir}/man5/amanda-client.conf.5*
689 %{_mandir}/man8/amdump_client.8*
690 %{_mandir}/man8/amgtar.8*
691 %{_mandir}/man8/ampgsql.8*
692 %{_mandir}/man8/amrecover.8*
693 %{_mandir}/man8/amraw.8*
694 %{_mandir}/man8/amsamba.8*
695 %{_mandir}/man8/amstar.8*
696 %{_mandir}/man8/amsuntar.8*
697 %{_mandir}/man8/amzfs*.8*
698
699 %{perl_vendorarch}/Amanda/Application.pm
700 %dir %{perl_vendorarch}/Amanda/Application
701 %{perl_vendorarch}/Amanda/Application/Zfs.pm
702 %dir %{perl_vendorarch}/auto/Amanda/Application
703 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Application/*.so
704 %endif
This page took 0.088931 seconds and 4 git commands to generate.