]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
- rel 1
[packages/amanda.git] / amanda.spec
1 # TODO:
2 #  - init/service for client 'restore' service
3 #  - untangle client/server perl deps for 'restore' service
4 #
5 # Conditional build:
6 %bcond_without  xfs     # without (possible) support for xfsdump
7 %bcond_without  samba   # without smbclient support
8 %bcond_without  client  # without client package
9 %bcond_without  server  # without server package
10
11 %include        /usr/lib/rpm/macros.perl
12 Summary:        A network-capable tape backup solution
13 Summary(pl.UTF-8):      Sieciowo zorientowany system tworzenia kopii zapasowych
14 Name:           amanda
15 Version:        3.5.1
16 Release:        1
17 License:        BSD
18 Group:          Networking/Utilities
19 Source0:        http://downloads.sourceforge.net/amanda/%{name}-%{version}.tar.gz
20 # Source0-md5:  f57307959f79e722b1dcb3f985ebb0d0
21 Source1:        %{name}-srv.crontab
22 Source2:        %{name}.inetd
23 Source3:        %{name}idx.inetd
24 Source4:        amidxtape.inetd
25 Source5:        k5%{name}.inet
26 # http://amanda.svn.sourceforge.net/viewvc/amanda/amanda/branches/3_2/contrib/convert-zd-mtx-to-robot.sh
27 Source6:        convert-zd-mtx-to-robot.sh
28 Source7:        %{name}-ssh_config
29 # https://github.com/janekr/amlvm-snapshot
30 Source8:        amlvm-snapshot.conf
31 Source9:        amlvm-snapshot.pl
32 Source10:       amlvm-snapshot.README
33 Patch0:         %{name}-no_libnsl.patch
34
35 Patch2:         %{name}-tar.patch
36 Patch3:         %{name}-common.patch
37 Patch4:         %{name}-as_needed.patch
38 Patch5:         %{name}-tapetypes.patch
39 Patch6:         %{name}-FHS.patch
40 Patch7:         %{name}-no-buildtime-ipv6.patch
41 Patch8:         %{name}-heimdal.patch
42 Patch9:         %{name}-ac.patch
43
44 Patch12:        %{name}-krb5-auth.patch
45
46 Patch14:        swig.patch
47 Patch15:        krb5-ac.patch
48 URL:            http://www.amanda.org/
49 %{?with_samba:BuildRequires:    /usr/bin/smbclient}
50 BuildRequires:  autoconf >= 2.64
51 BuildRequires:  automake
52 BuildRequires:  curl-devel >= 7.10.0
53 BuildRequires:  dump
54 BuildRequires:  flex
55 BuildRequires:  glib2-devel
56 BuildRequires:  gnuplot
57 BuildRequires:  heimdal-devel
58 BuildRequires:  rpmbuild(macros) >= 1.654
59 # curl is broken, see curl-config --libs (c8cba693)
60 BuildRequires:  keyutils-devel
61 BuildRequires:  libtool
62 BuildRequires:  libxslt-progs
63 BuildRequires:  ncurses-devel
64 BuildRequires:  openssh-clients
65 BuildRequires:  openssl-devel
66 BuildRequires:  perl-devel >= 5.6.0
67 BuildRequires:  pkgconfig
68 BuildRequires:  readline-devel >= 4.2
69 BuildRequires:  rpm-perlprov
70 BuildRequires:  rpmbuild(macros) >= 1.654
71 BuildRequires:  swig
72 %{?with_xfs:BuildRequires:      xfsdump}
73 Conflicts:      pwdutils < 3.1.2-2
74 Conflicts:      shadow < 1:4.0.4.1-4
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 # for some unknown reason those get detected in R but not in P (Tie::StdHash comes from perl)
78 %define         _noautoreq_perl Tie::StdHash Amanda::Recovery::Clerk::Feedback Amanda::Taper::Scribe::Feedback
79
80 %define         _ulibdir        %{_prefix}/lib
81
82 %description
83 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
84 backup system that allows the administrator of a LAN to set up a
85 single master backup server to back up multiple hosts to a single
86 large capacity tape drive. AMANDA uses native dump and/or GNU tar
87 facilities and can back up a large number of workstations running
88 multiple versions of Unix. Newer versions of AMANDA (including this
89 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
90 The amanda package contains the core AMANDA programs and will need to
91 be installed on both AMANDA clients and AMANDA servers. Note that you
92 will have to install the amanda-client and amanda-server packages as
93 well.
94
95 %description -l pl.UTF-8
96 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
97 zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
98 hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
99 Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
100 Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
101 podstawowe pliki programu i powinien być zainstalowany zarówno na
102 serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
103 amanda-client i amanda-server!
104
105 %package common
106 Summary:        Amanda common files
107 Summary(pl.UTF-8):      Wspólne pliki pakietu amanda
108 Group:          Networking/Utilities
109 Requires(postun):       /usr/sbin/groupdel
110 Requires(postun):       /usr/sbin/userdel
111 Requires(pre):  /bin/id
112 Requires(pre):  /usr/bin/chsh
113 Requires(pre):  /usr/bin/getgid
114 Requires(pre):  /usr/sbin/groupadd
115 Requires(pre):  /usr/sbin/useradd
116 %requires_ge glib2
117 Requires:       setup >= 2.6.1-1
118 Provides:       group(amanda)
119 Provides:       user(amanda)
120 Obsoletes:      amanda-libs
121 Obsoletes:      amanda-perl
122
123 %description common
124 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
125 backup system that allows the administrator of a LAN to set up a
126 single master backup server to back up multiple hosts to a single
127 large capacity tape drive. AMANDA uses native dump and/or GNU tar
128 facilities and can back up a large number of workstations running
129 multiple versions of Unix. Newer versions of AMANDA (including this
130 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
131 The amanda package contains the core AMANDA programs and will need to
132 be installed on both AMANDA clients and AMANDA servers. Note that you
133 will have to install the amanda-client and amanda-server packages as
134 well.
135
136 Amanda common files.
137
138 %description common -l pl.UTF-8
139 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
140 zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
141 hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
142 Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
143 Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
144 podstawowe pliki programu i powinien być zainstalowany zarówno na
145 serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
146 amanda-client i amanda-server!
147
148 Wspólne pliki pakietu amanda.
149
150 %package client
151 Summary:        The client side of Amanda
152 Summary(pl.UTF-8):      Klient Amandy
153 Group:          Networking/Utilities
154 Requires(post): /bin/hostname
155 Requires(post): /usr/bin/ssh-keygen
156 Requires:       %{name}-common = %{version}-%{release}
157 Requires:       rc-inetd
158 Suggests:       gzip
159 Suggests:       openssh-clients
160 Suggests:       openssh-server
161 Suggests:       star
162 Suggests:       tar
163 Conflicts:      tar < 1.15
164
165 %description client
166 The Amanda-client package should be installed on any machine that will
167 be backed up by AMANDA (including the server if it also needs to be
168 backed up). You will also need to install the amanda package to each
169 AMANDA client. It requires at least one of dump and GNU tar installed.
170
171 %description client -l pl.UTF-8
172 Ten pakiet powinien być zainstalowany ma maszynach, z których
173 zawartości będą tworzone kopie zapasowe. Wymaga zainstalowanego co
174 najmniej jednego z pakietów dump i GNU tar.
175
176 %package server
177 Summary:        The server side of Amanda
178 Summary(pl.UTF-8):      Serwer Amandy
179 Group:          Networking/Utilities
180 Requires(post): /bin/hostname
181 Requires(post): /usr/bin/ssh-keygen
182 Requires:       %{name}-common = %{version}-%{release}
183 Requires:       /etc/cron.d
184 Requires:       crondaemon
185 Requires:       gnuplot
186 Requires:       mt-st
187 Requires:       mtx
188 Requires:       rc-inetd
189 Suggests:       openssh-clients
190 Suggests:       openssh-server
191 Obsoletes:      amanda
192 Obsoletes:      amanda-perl-server
193
194 %description server
195 The amanda-server package should be installed on the AMANDA server,
196 the machine attached to the device (such as a tape drive) where
197 backups will be written. You will also need to install the amanda
198 package to the AMANDA server. And, if the server is also to be backed
199 up, the server also needs to have the amanda-client package installed.
200
201 %description server -l pl.UTF-8
202 Ten pakiet powinien być zainstalowany na maszynach, na których będą
203 magazynowane kopie zapasowe (lub do których podpięte są urządzenia
204 typu streamer).
205
206 %prep
207 %setup -q
208 %patch0 -p1
209
210 %patch2 -p1
211 %patch3 -p1
212 %patch4 -p1
213 %patch5 -p1
214 %patch6 -p1
215 %patch7 -p1
216 %patch8 -p1
217 %patch9 -p1
218
219 %patch12 -p1
220
221 %patch14 -p1
222 %patch15 -p1
223 cp -a %{SOURCE10} .
224
225 find perl/ -name '*.swg' -print0 | xargs -0 touch
226
227 %build
228 %{__libtoolize}
229 %{__aclocal} -I config -I config/gettext-macros -I config/gnulib -I config/amanda -I config/macro-archive
230 %{__autoconf}
231 %{__automake}
232 %configure \
233         DUMP=/sbin/dump \
234         GZIP=/bin/gzip \
235         MAILER=/bin/mail \
236         MT=/bin/mt \
237         MTX=/usr/sbin/mtx \
238         PRINT=/usr/bin/lpr \
239         RESTORE=/sbin/restore \
240         %{?with_xfs:XFSDUMP=/sbin/xfsdump} \
241         %{?with_xfs:XFSRESTORE=/sbin/xfsrestore} \
242         --disable-static \
243         --enable-shared \
244         %{!?with_server:--without-server} \
245         %{!?with_client:--without-client} \
246         --with-index-server=localhost \
247         --with-user=amanda \
248         --with-group=amanda \
249         --with-tape-device=/dev/null \
250         --with-fqdn \
251         %{?with_samba:--with-smbclient=%{_bindir}/smbclient} \
252         --with-star=%{_bindir}/star \
253         --with-gnuplot=%{_bindir}/gnuplot \
254         --with-bsd-security \
255         --with-bsdtcp-security \
256         --with-ssh-security \
257         --with-krb5-security \
258         --with-buffered-dump \
259         --with-amandahosts \
260         --with-configdir=%{_sysconfdir}/amanda \
261         --with-gnutar-listdir=%{_sharedstatedir}/amanda/gnutar-lists \
262         --with-amandates=%{_sharedstatedir}/amanda/amandates \
263         --with-debugging=%{_sharedstatedir}/amanda/debug \
264         --with-tmpdir=/var/tmp/amanda \
265         --with-amperldir=%{perl_vendorarch} \
266         --with-ipv6 \
267         --with-readline \
268         --disable-installperms
269
270 %{__make}
271
272 %install
273 rm -rf $RPM_BUILD_ROOT
274 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{amanda,cron.d,sysconfig/rc-inetd} \
275         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/{.gnupg,.ssh,gnutar-lists} \
276         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/debug/{amandad,client,server}
277
278 %{__make} install \
279         DESTDIR=$RPM_BUILD_ROOT
280
281 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amanda-srv
282 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE2} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amanda
283 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE3} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amandaidx
284 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE4} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amidxtape
285 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE5} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/k5amanda
286
287 cp -p example/amanda.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
288 cp -p example/amanda-client.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
289 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.amandahosts
290
291 install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sbindir}/amconvert-zd-mtx-to-robot.sh
292
293 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/config
294 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/{,client_}authorized_keys
295 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amdump{,.pub}
296 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover{,.pub}
297
298 %if %{with server}
299 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/amanda/lvm-snapshot.conf
300 %endif
301
302 %if %{with client}
303 sed -e 's|@@PERL_VENDORARCH@@|%{perl_vendorarch}|' %{SOURCE9} >$RPM_BUILD_ROOT%{_libexecdir}/amanda/application/amlvm-snapshot
304 %endif
305
306 > $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/amandates
307
308 # Amanda tools generate ssh keys with embeded commands pointing to /usr/lib
309 # Tools can't be "fixed" because keys generated on server are to be used on client
310 if [ "%{_lib}" != "lib" ] ; then
311         install -d $RPM_BUILD_ROOT%{_ulibdir}
312         ln -s %{_libdir}/amanda $RPM_BUILD_ROOT%{_ulibdir}/amanda
313 fi
314
315 find $RPM_BUILD_ROOT -name \*.la | xargs rm -f
316
317 %{__rm} $RPM_BUILD_ROOT%{_datadir}/amanda/{COPYRIGHT,ChangeLog,NEWS,ReleaseNotes}
318 %{__rm} $RPM_BUILD_ROOT%{_datadir}/amanda/example/{chg-multi,chg-scsi}.conf
319
320 %clean
321 rm -rf $RPM_BUILD_ROOT
322
323 %triggerpostun common -- amanda-libs < 2.6.0p2-3
324 echo "Adding amanda to disk and tape groups"
325 /usr/sbin/usermod -G disk,tape amanda
326 echo "Setting amanda shell to /bin/sh"
327 /usr/bin/chsh -s /bin/sh amanda
328 if [ -f %{_sharedstatedir}/amanda/.amandahosts ]; then
329         echo "Fixing permissions of %{_sharedstatedir}/amanda/.amandahosts file"
330         chown amanda:amanda %{_sharedstatedir}/amanda/.amandahosts
331         chmod 600 %{_sharedstatedir}/amanda/.amandahosts
332 fi
333
334 %triggerpostun common -- amanda-common < 3.3
335 %banner %{name}-common -e << EOF
336 In amanda 3.3 the default auth has changed to "bsdtcp",
337 if you are using the default "bsd" then you must add it
338 to your configuration:
339
340  *   in amanda.conf
341  *   in amanda-client.conf
342  *   in dumptype/disklist
343  *   in inetd (if no '-auth' argument to amandad)
344 EOF
345
346 %pre common
347 %groupadd -P %{name}-common -g 80 amanda
348 %useradd -P %{name}-common -u 80 -G disk,tape -d /var/lib/amanda -s /bin/sh -c "Amanda Backup user" -g amanda amanda
349
350 %postun common
351 if [ "$1" = "0" ]; then
352         %userremove amanda
353         %groupremove amanda
354 fi
355
356 %post client
357 %service -q rc-inetd reload
358 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amrecover ] ; then
359         HOST="`/bin/hostname`"
360         FQDNHOST="`/bin/hostname -f`"
361         if [ -z "$HOST" ] ; then
362                 COMMENT="root@client"
363         else
364                 COMMENT="root@$HOST"
365         fi
366         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amrecover -N "" || :
367         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
368         chmod 600 /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
369         if [ -n "$FQDNHOST" ]; then
370                 echo -n "from=\"$FQDNHOST\",no-port-forwarding,no-X11-forwarding,no-agent-forwarding,command=\"%{_ulibdir}/amanda/amandad -auth=ssh amindexd amidxtaped\" " >/var/lib/amanda/.ssh/server_authorized_keys
371                 cat /var/lib/amanda/.ssh/id_rsa_amrecover.pub >>/var/lib/amanda/.ssh/server_authorized_keys
372
373                 echo "Remember to copy the contents of /var/lib/amanda/.ssh/server_authorized_keys to"
374                 echo "/var/lib/amanda/.ssh/authorized_keys on amanda server"
375         fi
376 fi
377
378 %postun client
379 if [ "$1" = 0 ]; then
380         %service -q rc-inetd reload
381 fi
382
383 %post server
384 %service -q rc-inetd reload
385 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amdump ] ; then
386         HOST="`/bin/hostname`"
387         if [ -z "$HOST" ] ; then
388                 COMMENT="amanda@server"
389         else
390                 COMMENT="amanda@$HOST"
391         fi
392         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amdump -N "" || :
393         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
394         chmod 600 /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
395 fi
396 if [ "$1" = "1" ]; then
397         echo "Don't forget to edit /etc/cron.d/amanda-srv." 1>&2
398 fi
399
400 %postun server
401 if [ "$1" = 0 ]; then
402         %service -q rc-inetd reload
403 fi
404
405 %triggerpostun server -- amanda-server < 3.2.0
406 %banner %{name} -e << EOF
407 Warning: Tape changer configuration has chaged, please read
408 %{_docdir}/%{name}-server-%{version}/ReleaseNotes.gz
409 and %{_docdir}/%{name}-server-%{version}/NEWS.gz for details.
410 You can use %{_sbindir}/amconvert-zd-mtx-to-robot.sh script
411 to upgrade to chg-robot.
412 EOF
413
414 %files common
415 %defattr(644,root,root,755)
416 %doc AUTHORS COPYRIGHT ChangeLog NEWS README ReleaseNotes UPGRADING amlvm-snapshot.README
417 %attr(755,root,root) %{_libdir}/amanda/libamanda*.so
418 %attr(755,root,root) %{_libdir}/amanda/libamar*.so
419 %attr(755,root,root) %{_libdir}/amanda/libamdevice*.so
420 %attr(755,root,root) %{_libdir}/amanda/libamglue*.so
421 %attr(755,root,root) %{_libdir}/amanda/libamserver*.so
422 %attr(755,root,root) %{_libdir}/amanda/libamxfer*.so
423 %attr(755,root,root) %{_libdir}/amanda/libndmjob*.so
424 %attr(755,root,root) %{_libdir}/amanda/libndmlib*.so
425 %attr(750,amanda,amanda) %dir %{_sysconfdir}/amanda
426 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/amanda-security.conf
427 %dir %{_libdir}/amanda
428 %if %{_lib} != "lib"
429 %{_ulibdir}/amanda
430 %endif
431 %dir %{_libexecdir}/amanda
432 %{_libexecdir}/amanda/amanda-sh-lib.sh
433 %attr(4750,root,amanda) %{_libexecdir}/amanda/ambind
434 %attr(755,root,root) %{_libexecdir}/amanda/amcat.awk
435 %attr(755,root,root) %{_libexecdir}/amanda/amndmjob
436 %attr(755,root,root) %{_libexecdir}/amanda/amplot.awk
437 %attr(755,root,root) %{_libexecdir}/amanda/amplot.g
438 %attr(755,root,root) %{_libexecdir}/amanda/amplot.gp
439 %attr(755,root,root) %{_libexecdir}/amanda/ndmjob
440 %attr(755,root,root) %{_sbindir}/amaespipe
441 %attr(755,root,root) %{_sbindir}/amarchiver
442 %attr(755,root,root) %{_sbindir}/amcrypt*
443 %attr(755,root,root) %{_sbindir}/amgetconf
444 %attr(755,root,root) %{_sbindir}/amgpgcrypt
445 %attr(755,root,root) %{_sbindir}/amplot
446 %attr(755,root,root) %{_sbindir}/amservice
447 %attr(755,root,root) %{_sbindir}/amssl
448 %attr(750,amanda,amanda) %dir %{_datadir}/amanda
449 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/example
450 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/example/label-templates
451 %attr(640,amanda,amanda) %{_datadir}/amanda/example/*amanda*
452 %attr(640,amanda,amanda) %{_datadir}/amanda/example/disklist
453 %attr(640,amanda,amanda) %{_datadir}/amanda/example/label-templates/*.ps
454 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/template.d
455 %attr(640,amanda,amanda) %{_datadir}/amanda/template.d/*
456 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda
457 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.ssh
458 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.gnupg
459 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug
460 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/amandad
461 %attr(600,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/.amandahosts
462 %attr(600,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/.ssh/config
463 # Commented out so it won't get removed on uninstall
464 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/authorized_keys
465 %{_mandir}/man5/amanda-archive-format.5*
466 %{_mandir}/man5/amanda-security.conf.5*
467 %{_mandir}/man7/amanda-auth.7*
468 %{_mandir}/man7/amanda-auth-ssl.7*
469 %{_mandir}/man7/amanda-match.7*
470 %{_mandir}/man7/amanda-scripts.7*
471 %{_mandir}/man8/amanda.8*
472 %{_mandir}/man8/amaespipe.8*
473 %{_mandir}/man8/amarchiver.8*
474 %{_mandir}/man8/amcrypt*.8*
475 %{_mandir}/man8/amgetconf.8*
476 %{_mandir}/man8/amgpgcrypt.8*
477 %{_mandir}/man8/amplot.8*
478 %{_mandir}/man8/amservice.8*
479 %{_mandir}/man8/amssl.8*
480 %{_mandir}/man8/script-email.8*
481
482 %dir %{perl_vendorarch}/Amanda
483 %dir %{perl_vendorarch}/Amanda/Config
484 %dir %{perl_vendorarch}/Amanda/IPC
485 %{perl_vendorarch}/Amanda/Amservice.pm
486 %{perl_vendorarch}/Amanda/Archive.pm
487 %{perl_vendorarch}/Amanda/BigIntCompat.pm
488 %{perl_vendorarch}/Amanda/Changer.pm
489 %dir %{perl_vendorarch}/Amanda/Changer
490 %{perl_vendorarch}/Amanda/Changer/*.pm
491 %{perl_vendorarch}/Amanda/ClientService.pm
492 %{perl_vendorarch}/Amanda/Cmdline.pm
493 %{perl_vendorarch}/Amanda/Cmdfile.pm
494 %{perl_vendorarch}/Amanda/Config.pm
495 %{perl_vendorarch}/Amanda/Config/FoldingHash.pm
496 %{perl_vendorarch}/Amanda/Constants.pm
497 %{perl_vendorarch}/Amanda/DB.pm
498 %dir %{perl_vendorarch}/Amanda/DB
499 %{perl_vendorarch}/Amanda/DB/*.pm
500 %{perl_vendorarch}/Amanda/Debug.pm
501 %{perl_vendorarch}/Amanda/Device.pm
502 %{perl_vendorarch}/Amanda/Disklist.pm
503 %{perl_vendorarch}/Amanda/Extract.pm
504 %{perl_vendorarch}/Amanda/Feature.pm
505 %{perl_vendorarch}/Amanda/FetchDump.pm
506 %dir %{perl_vendorarch}/Amanda/FetchDump
507 %{perl_vendorarch}/Amanda/FetchDump/*.pm
508 %{perl_vendorarch}/Amanda/Header.pm
509 %{perl_vendorarch}/Amanda/Holding.pm
510 %{perl_vendorarch}/Amanda/IPC/Binary.pm
511 %{perl_vendorarch}/Amanda/IPC/LineProtocol.pm
512 %{perl_vendorarch}/Amanda/Interactivity.pm
513 %dir %{perl_vendorarch}/Amanda/Interactivity
514 %{perl_vendorarch}/Amanda/Interactivity/*.pm
515 %{perl_vendorarch}/Amanda/Logfile.pm
516 %{perl_vendorarch}/Amanda/MainLoop.pm
517 %{perl_vendorarch}/Amanda/Message.pm
518 %{perl_vendorarch}/Amanda/NDMP.pm
519 %{perl_vendorarch}/Amanda/Paths.pm
520 %{perl_vendorarch}/Amanda/Policy.pm
521 %{perl_vendorarch}/Amanda/Process.pm
522 %{perl_vendorarch}/Amanda/Recovery.pm
523 %dir %{perl_vendorarch}/Amanda/Recovery
524 %{perl_vendorarch}/Amanda/Recovery/*.pm
525 %{perl_vendorarch}/Amanda/Restore.pm
526 %{perl_vendorarch}/Amanda/Script.pm
527 %{perl_vendorarch}/Amanda/Script_App.pm
528 %{perl_vendorarch}/Amanda/Service.pm
529 %dir %{perl_vendorarch}/Amanda/Service
530 %{perl_vendorarch}/Amanda/Storage.pm
531 %{perl_vendorarch}/Amanda/Tapelist.pm
532 %{perl_vendorarch}/Amanda/Tests.pm
533 %{perl_vendorarch}/Amanda/Util.pm
534 %{perl_vendorarch}/Amanda/Xfer.pm
535 %dir %{perl_vendorarch}/auto/Amanda
536 %dir %{perl_vendorarch}/auto/Amanda/Archive
537 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Archive/*.so
538 %dir %{perl_vendorarch}/auto/Amanda/Cmdfile
539 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Cmdfile/*.so
540 %dir %{perl_vendorarch}/auto/Amanda/Cmdline
541 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Cmdline/*.so
542 %dir %{perl_vendorarch}/auto/Amanda/Config
543 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Config/*.so
544 %dir %{perl_vendorarch}/auto/Amanda/Debug
545 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Debug/*.so
546 %dir %{perl_vendorarch}/auto/Amanda/Device
547 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Device/*.so
548 %dir %{perl_vendorarch}/auto/Amanda/Disklist
549 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Disklist/*.so
550 %dir %{perl_vendorarch}/auto/Amanda/Feature
551 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Feature/*.so
552 %dir %{perl_vendorarch}/auto/Amanda/Header
553 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Header/*.so
554 %dir %{perl_vendorarch}/auto/Amanda/IPC
555 %dir %{perl_vendorarch}/auto/Amanda/IPC/Binary
556 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/IPC/Binary/*.so
557 %dir %{perl_vendorarch}/auto/Amanda/Logfile
558 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Logfile/*.so
559 %dir %{perl_vendorarch}/auto/Amanda/MainLoop
560 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/MainLoop/*.so
561 %dir %{perl_vendorarch}/auto/Amanda/NDMP
562 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/NDMP/*.so
563 %dir %{perl_vendorarch}/auto/Amanda/Tapelist
564 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Tapelist/*.so
565 %dir %{perl_vendorarch}/auto/Amanda/Tests
566 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Tests/*.so
567 %dir %{perl_vendorarch}/auto/Amanda/Util
568 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Util/*.so
569 %dir %{perl_vendorarch}/auto/Amanda/Xfer
570 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Xfer/*.so
571
572 %if %{with server}
573 %files server
574 %defattr(644,root,root,755)
575 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amidxtape
576 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amandaidx
577
578 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/amanda.conf
579 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/lvm-snapshot.conf
580
581 # Commented out so it won't get removed on uninstall
582 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/client_authorized_keys
583 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amdump*
584
585 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/server
586
587 %config(noreplace) %attr(640,root,root) /etc/cron.d/amanda-srv
588
589 %attr(755,root,root) %{_libexecdir}/amanda/amadmin_perl
590 %attr(755,root,root) %{_libexecdir}/amanda/ambackupd
591 %attr(755,root,root) %{_libexecdir}/amanda/amcheck-device
592 %attr(755,root,root) %{_libexecdir}/amanda/amdumpd
593 %attr(755,root,root) %{_libexecdir}/amanda/amidxtaped
594 %attr(755,root,root) %{_libexecdir}/amanda/amindexd
595 %attr(755,root,root) %{_libexecdir}/amanda/amlogroll
596 %attr(755,root,root) %{_libexecdir}/amanda/amtrmidx
597 %attr(755,root,root) %{_libexecdir}/amanda/amtrmlog
598 %attr(755,root,root) %{_libexecdir}/amanda/chunker
599 %attr(755,root,root) %{_libexecdir}/amanda/driver
600 %attr(755,root,root) %{_libexecdir}/amanda/dumper
601 %attr(755,root,root) %{_libexecdir}/amanda/planner
602 %attr(755,root,root) %{_libexecdir}/amanda/taper
603
604 %dir %{_libexecdir}/amanda/rest-server
605 %dir %{_libexecdir}/amanda/rest-server/bin
606 %attr(755,root,root) %{_libexecdir}/amanda/rest-server/bin/app-dancer2.pl
607 %attr(755,root,root) %{_libexecdir}/amanda/rest-server/bin/app.pl
608 %{_libexecdir}/amanda/rest-server/config-dancer
609 %{_libexecdir}/amanda/rest-server/config.yml
610 %{_libexecdir}/amanda/rest-server/environments
611 %dir %{_libexecdir}/amanda/rest-server/lib
612 %dir %{_libexecdir}/amanda/rest-server/lib/Amanda
613 %{_libexecdir}/amanda/rest-server/lib/Amanda/Rest.pm
614 %dir %{_libexecdir}/amanda/rest-server/public
615 %{_libexecdir}/amanda/rest-server/public/*.html
616 %{_libexecdir}/amanda/rest-server/public/css
617 %{_libexecdir}/amanda/rest-server/public/dispatch.cgi
618 %{_libexecdir}/amanda/rest-server/public/dispatch.fcgi
619 %{_libexecdir}/amanda/rest-server/public/favicon.ico
620 %{_libexecdir}/amanda/rest-server/public/images
621 %{_libexecdir}/amanda/rest-server/public/javascripts
622 %{_libexecdir}/amanda/rest-server/views
623
624 %attr(755,root,root) %{_sbindir}/activate-devpay
625 %attr(755,root,root) %{_sbindir}/amaddclient
626 %attr(755,root,root) %{_sbindir}/amadmin
627 %attr(755,root,root) %{_sbindir}/amanda-rest-server
628 %attr(755,root,root) %{_sbindir}/amcheck
629 %attr(755,root,root) %{_sbindir}/amcheckdb
630 %attr(755,root,root) %{_sbindir}/amcheckdump
631 %attr(755,root,root) %{_sbindir}/amcleanup
632 %attr(755,root,root) %{_sbindir}/amcleanupdisk
633 %attr(755,root,root) %{_sbindir}/amconvert-zd-mtx-to-robot.sh
634 %attr(755,root,root) %{_sbindir}/amdevcheck
635 %attr(755,root,root) %{_sbindir}/amdump
636 %attr(755,root,root) %{_sbindir}/amfetchdump
637 %attr(755,root,root) %{_sbindir}/amflush
638 %attr(755,root,root) %{_sbindir}/amlabel
639 %attr(755,root,root) %{_sbindir}/amoverview
640 %attr(755,root,root) %{_sbindir}/amreindex
641 %attr(755,root,root) %{_sbindir}/amreport
642 %attr(755,root,root) %{_sbindir}/amrestore
643 %attr(755,root,root) %{_sbindir}/amrmtape
644 %attr(755,root,root) %{_sbindir}/amserverconfig
645 %attr(755,root,root) %{_sbindir}/amstatus
646 %attr(755,root,root) %{_sbindir}/amtape
647 %attr(755,root,root) %{_sbindir}/amtapetype
648 %attr(755,root,root) %{_sbindir}/amtoc
649 %attr(755,root,root) %{_sbindir}/amvault
650 %{_mandir}/man5/amanda.conf.5*
651 %{_mandir}/man5/amanda-command-file.5*
652 %{_mandir}/man5/disklist.5*
653 %{_mandir}/man5/tapelist.5*
654 %{_mandir}/man7/amanda-changers.7*
655 %{_mandir}/man7/amanda-compatibility.7*
656 %{_mandir}/man7/amanda-devices.7*
657 %{_mandir}/man7/amanda-interactivity.7*
658 %{_mandir}/man7/amanda-taperscan.7*
659 %{_mandir}/man8/amaddclient.8*
660 %{_mandir}/man8/amadmin.8*
661 %{_mandir}/man8/amanda-rest-server.8*
662 %{_mandir}/man8/amcheck.8*
663 %{_mandir}/man8/amcheckdb.8*
664 %{_mandir}/man8/amcheckdump.8*
665 %{_mandir}/man8/amcleanup.8*
666 %{_mandir}/man8/amcleanupdisk.8*
667 %{_mandir}/man8/amdevcheck.8*
668 %{_mandir}/man8/amdump.8*
669 %{_mandir}/man8/amfetchdump.8*
670 %{_mandir}/man8/amflush.8*
671 %{_mandir}/man8/amlabel.8*
672 %{_mandir}/man8/amoverview.8*
673 %{_mandir}/man8/amreindex.8*
674 %{_mandir}/man8/amreport.8*
675 %{_mandir}/man8/amrestore.8*
676 %{_mandir}/man8/amrmtape.8*
677 %{_mandir}/man8/amserverconfig.8*
678 %{_mandir}/man8/amstatus.8*
679 %{_mandir}/man8/amtape.8*
680 %{_mandir}/man8/amtapetype.8*
681 %{_mandir}/man8/amtoc.8*
682 %{_mandir}/man8/amvault.8*
683
684 %{perl_vendorarch}/Amanda/Amdump.pm
685 %{perl_vendorarch}/Amanda/Amflush.pm
686 %{perl_vendorarch}/Amanda/CheckDump.pm
687 %dir %{perl_vendorarch}/Amanda/Chunker
688 %{perl_vendorarch}/Amanda/Chunker/*.pm
689 %{perl_vendorarch}/Amanda/Cleanup.pm
690 %{perl_vendorarch}/Amanda/Curinfo.pm
691 %dir %{perl_vendorarch}/Amanda/Curinfo
692 %{perl_vendorarch}/Amanda/Curinfo/*.pm
693 %{perl_vendorarch}/Amanda/Index.pm
694 %{perl_vendorarch}/Amanda/Label.pm
695 %{perl_vendorarch}/Amanda/Report.pm
696 %dir %{perl_vendorarch}/Amanda/Report
697 %{perl_vendorarch}/Amanda/Report/*.pm
698 %dir %{perl_vendorarch}/Amanda/Rest
699 %{perl_vendorarch}/Amanda/Rest/*.pm
700 %dir %{perl_vendorarch}/Amanda/Rest/Storages
701 %{perl_vendorarch}/Amanda/Rest/Storages/*.pm
702 %{perl_vendorarch}/Amanda/ScanInventory.pm
703 %{perl_vendorarch}/Amanda/Service/Amidxtaped.pm
704 %{perl_vendorarch}/Amanda/Status.pm
705 %dir %{perl_vendorarch}/Amanda/Taper
706 %{perl_vendorarch}/Amanda/Taper/*.pm
707 %dir %{perl_vendorarch}/Amanda/Taper/Scan
708 %{perl_vendorarch}/Amanda/Taper/Scan/*.pm
709 %{perl_vendorarch}/Amanda/Vault.pm
710 %{perl_vendorarch}/Amanda/XferServer.pm
711 %dir %{perl_vendorarch}/auto/Amanda/XferServer
712 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/XferServer/*.so
713 %endif
714
715 %if %{with client}
716 %files client
717 %defattr(644,root,root,755)
718 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amanda
719 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/k5amanda
720 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,amanda) %{_sysconfdir}/amanda/amanda-client.conf
721 # Commented out so it won't get removed on uninstall
722 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover*
723 %attr(640,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/amandates
724
725 %dir %{_libexecdir}/amanda/application
726 %attr(4750,root,amanda) %{_libexecdir}/amanda/application/ambsdtar
727 %attr(4750,root,amanda) %{_libexecdir}/amanda/application/amgtar
728 %attr(755,root,root) %{_libexecdir}/amanda/application/amlog-script
729 %attr(755,root,root) %{_libexecdir}/amanda/application/amlvm-snapshot
730 %attr(755,root,root) %{_libexecdir}/amanda/application/ampgsql
731 %attr(755,root,root) %{_libexecdir}/amanda/application/amrandom
732 %attr(755,root,root) %{_libexecdir}/amanda/application/amraw
733 %attr(755,root,root) %{_libexecdir}/amanda/application/amsamba
734 %attr(4750,root,amanda) %{_libexecdir}/amanda/application/amstar
735 %attr(755,root,root) %{_libexecdir}/amanda/application/amsuntar
736 %attr(755,root,root) %{_libexecdir}/amanda/application/amzfs*
737 %attr(755,root,root) %{_libexecdir}/amanda/application/script-email
738 %attr(755,root,root) %{_libexecdir}/amanda/application/script-fail
739
740 %attr(755,root,root) %{_libdir}/amanda/libamclient*.so
741 %attr(755,root,root) %{_libexecdir}/amanda/amandad
742 %attr(755,root,root) %{_libexecdir}/amanda/noop
743 %attr(755,root,root) %{_libexecdir}/amanda/patch-system
744 %attr(755,root,root) %{_libexecdir}/amanda/restore
745 %attr(755,root,root) %{_libexecdir}/amanda/sendbackup
746 %attr(755,root,root) %{_libexecdir}/amanda/senddiscover
747 %attr(755,root,root) %{_libexecdir}/amanda/sendsize
748 %attr(755,root,root) %{_libexecdir}/amanda/teecount
749 %attr(4750,root,amanda) %{_libexecdir}/amanda/calcsize
750 %attr(4750,root,amanda) %{_libexecdir}/amanda/killpgrp
751 %attr(4750,root,amanda) %{_libexecdir}/amanda/rundump
752 %attr(4750,root,amanda) %{_libexecdir}/amanda/runtar
753 %attr(755,root,root) %{_libexecdir}/amanda/selfcheck
754 %attr(755,root,root) %{_sbindir}/ambackup
755 %attr(755,root,root) %{_sbindir}/amdump_client
756 %attr(755,root,root) %{_sbindir}/amoldrecover
757 %attr(755,root,root) %{_sbindir}/amrecover
758 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/gnutar-lists
759 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/client
760 %{_mandir}/man7/amanda-applications.7*
761 %{_mandir}/man5/amanda-client.conf.5*
762 %{_mandir}/man8/amdump_client.8*
763 %{_mandir}/man8/ambackup.8*
764 %{_mandir}/man8/ambsdtar.8*
765 %{_mandir}/man8/amgtar.8*
766 %{_mandir}/man8/ampgsql.8*
767 %{_mandir}/man8/amrecover.8*
768 %{_mandir}/man8/amraw.8*
769 %{_mandir}/man8/amsamba.8*
770 %{_mandir}/man8/amstar.8*
771 %{_mandir}/man8/amsuntar.8*
772 %{_mandir}/man8/amzfs*.8*
773
774 %{perl_vendorarch}/Amanda/Application.pm
775 %dir %{perl_vendorarch}/Amanda/Application
776 %{perl_vendorarch}/Amanda/Application/Zfs.pm
777 %{perl_vendorarch}/Amanda/Service/Restore.pm
778 %dir %{perl_vendorarch}/auto/Amanda/Application
779 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Application/*.so
780 %endif
This page took 0.179429 seconds and 4 git commands to generate.