]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
- libtoolize for as-needed to work (to avoid propagating dozens of curl dependencies)
[packages/amanda.git] / amanda.spec
1 #
2 # Conditional build:
3 %bcond_without  xfs     # without (possible) support for xfsdump
4 %bcond_without  samba   # without smbclient support
5 %bcond_without  client  # without client package
6 %bcond_without  server  # without server package
7
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        A network-capable tape backup solution
10 Summary(pl.UTF-8):      Sieciowo zorientowany system tworzenia kopii zapasowych
11 Name:           amanda
12 Version:        3.3.6
13 Release:        7
14 License:        BSD
15 Group:          Networking/Utilities
16 Source0:        http://downloads.sourceforge.net/amanda/%{name}-%{version}.tar.gz
17 # Source0-md5:  99559bd84b358701cf943fcc347d8914
18 Source1:        %{name}-srv.crontab
19 Source2:        %{name}.inetd
20 Source3:        %{name}idx.inetd
21 Source4:        amidxtape.inetd
22 Source5:        k5%{name}.inet
23 # http://amanda.svn.sourceforge.net/viewvc/amanda/amanda/branches/3_2/contrib/convert-zd-mtx-to-robot.sh
24 Source6:        convert-zd-mtx-to-robot.sh
25 Source7:        %{name}-ssh_config
26 # https://github.com/janekr/amlvm-snapshot
27 Source8:        amlvm-snapshot.conf
28 Source9:        amlvm-snapshot.pl
29 Source10:       amlvm-snapshot.README
30 Patch0:         %{name}-no_libnsl.patch
31 Patch1:         %{name}-chg-zd-mtx-sh.patch
32 Patch2:         %{name}-tar.patch
33 Patch3:         %{name}-common.patch
34 Patch4:         %{name}-as_needed.patch
35 Patch5:         %{name}-tapetypes.patch
36 Patch6:         %{name}-FHS.patch
37 Patch7:         %{name}-no-buildtime-ipv6.patch
38 Patch8:         %{name}-heimdal.patch
39 Patch9:         %{name}-ac.patch
40 Patch11:        %{name}-amstar-exclude-fix.patch
41 Patch12:        %{name}-krb5-auth.patch
42 Patch13:        %{name}-amstar-device.patch
43 Patch14:        swig.patch
44 Patch15:        krb5-ac.patch
45 URL:            http://www.amanda.org/
46 %{?with_samba:BuildRequires:    /usr/bin/smbclient}
47 BuildRequires:  autoconf >= 2.64
48 BuildRequires:  automake
49 BuildRequires:  curl-devel >= 7.10.0
50 BuildRequires:  dump
51 BuildRequires:  flex
52 BuildRequires:  glib2-devel
53 BuildRequires:  gnuplot
54 BuildRequires:  heimdal-devel
55 BuildRequires:  rpmbuild(macros) >= 1.654
56 # curl is broken, see curl-config --libs (c8cba693)
57 BuildRequires:  keyutils-devel
58 BuildRequires:  libtool
59 BuildRequires:  libxslt-progs
60 BuildRequires:  ncurses-devel
61 BuildRequires:  openssh-clients
62 BuildRequires:  openssl-devel
63 BuildRequires:  perl-devel >= 5.6.0
64 BuildRequires:  pkgconfig
65 BuildRequires:  readline-devel >= 4.2
66 BuildRequires:  rpm-perlprov
67 BuildRequires:  rpmbuild(macros) >= 1.654
68 BuildRequires:  swig
69 %{?with_xfs:BuildRequires:      xfsdump}
70 Conflicts:      pwdutils < 3.1.2-2
71 Conflicts:      shadow < 1:4.0.4.1-4
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 # for some unknown reason those get detected in R but not in P (Tie::StdHash comes from perl)
75 %define         _noautoreq_perl Tie::StdHash Amanda::Recovery::Clerk::Feedback Amanda::Taper::Scribe::Feedback
76
77 %define         _ulibdir        %{_prefix}/lib
78
79 %description
80 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
81 backup system that allows the administrator of a LAN to set up a
82 single master backup server to back up multiple hosts to a single
83 large capacity tape drive. AMANDA uses native dump and/or GNU tar
84 facilities and can back up a large number of workstations running
85 multiple versions of Unix. Newer versions of AMANDA (including this
86 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
87 The amanda package contains the core AMANDA programs and will need to
88 be installed on both AMANDA clients and AMANDA servers. Note that you
89 will have to install the amanda-client and amanda-server packages as
90 well.
91
92 %description -l pl.UTF-8
93 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
94 zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
95 hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
96 Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
97 Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
98 podstawowe pliki programu i powinien być zainstalowany zarówno na
99 serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
100 amanda-client i amanda-server!
101
102 %package common
103 Summary:        Amanda common files
104 Summary(pl.UTF-8):      Wspólne pliki pakietu amanda
105 Group:          Networking/Utilities
106 Requires(postun):       /usr/sbin/groupdel
107 Requires(postun):       /usr/sbin/userdel
108 Requires(pre):  /bin/id
109 Requires(pre):  /usr/bin/chsh
110 Requires(pre):  /usr/bin/getgid
111 Requires(pre):  /usr/sbin/groupadd
112 Requires(pre):  /usr/sbin/useradd
113 %requires_ge glib2
114 Requires:       setup >= 2.6.1-1
115 Provides:       group(amanda)
116 Provides:       user(amanda)
117 Obsoletes:      amanda-libs
118 Obsoletes:      amanda-perl
119
120 %description common
121 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
122 backup system that allows the administrator of a LAN to set up a
123 single master backup server to back up multiple hosts to a single
124 large capacity tape drive. AMANDA uses native dump and/or GNU tar
125 facilities and can back up a large number of workstations running
126 multiple versions of Unix. Newer versions of AMANDA (including this
127 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
128 The amanda package contains the core AMANDA programs and will need to
129 be installed on both AMANDA clients and AMANDA servers. Note that you
130 will have to install the amanda-client and amanda-server packages as
131 well.
132
133 Amanda common files.
134
135 %description common -l pl.UTF-8
136 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
137 zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
138 hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
139 Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
140 Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
141 podstawowe pliki programu i powinien być zainstalowany zarówno na
142 serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
143 amanda-client i amanda-server!
144
145 Wspólne pliki pakietu amanda.
146
147 %package client
148 Summary:        The client side of Amanda
149 Summary(pl.UTF-8):      Klient Amandy
150 Group:          Networking/Utilities
151 Requires(post): /bin/hostname
152 Requires(post): /usr/bin/ssh-keygen
153 Requires:       %{name}-common = %{version}-%{release}
154 Requires:       rc-inetd
155 Suggests:       gzip
156 Suggests:       openssh-clients
157 Suggests:       openssh-server
158 Suggests:       star
159 Suggests:       tar
160 Conflicts:      tar < 1.15
161
162 %description client
163 The Amanda-client package should be installed on any machine that will
164 be backed up by AMANDA (including the server if it also needs to be
165 backed up). You will also need to install the amanda package to each
166 AMANDA client. It requires at least one of dump and GNU tar installed.
167
168 %description client -l pl.UTF-8
169 Ten pakiet powinien być zainstalowany ma maszynach, z których
170 zawartości będą tworzone kopie zapasowe. Wymaga zainstalowanego co
171 najmniej jednego z pakietów dump i GNU tar.
172
173 %package server
174 Summary:        The server side of Amanda
175 Summary(pl.UTF-8):      Serwer Amandy
176 Group:          Networking/Utilities
177 Requires(post): /bin/hostname
178 Requires(post): /usr/bin/ssh-keygen
179 Requires:       %{name}-common = %{version}-%{release}
180 Requires:       /etc/cron.d
181 Requires:       crondaemon
182 Requires:       gnuplot
183 Requires:       mt-st
184 Requires:       mtx
185 Requires:       rc-inetd
186 Suggests:       openssh-clients
187 Suggests:       openssh-server
188 Obsoletes:      amanda
189 Obsoletes:      amanda-perl-server
190
191 %description server
192 The amanda-server package should be installed on the AMANDA server,
193 the machine attached to the device (such as a tape drive) where
194 backups will be written. You will also need to install the amanda
195 package to the AMANDA server. And, if the server is also to be backed
196 up, the server also needs to have the amanda-client package installed.
197
198 %description server -l pl.UTF-8
199 Ten pakiet powinien być zainstalowany na maszynach, na których będą
200 magazynowane kopie zapasowe (lub do których podpięte są urządzenia
201 typu streamer).
202
203 %prep
204 %setup -q
205 %patch0 -p1
206 %patch1 -p1
207 %patch2 -p1
208 %patch3 -p1
209 %patch4 -p1
210 %patch5 -p1
211 %patch6 -p1
212 %patch7 -p1
213 %patch8 -p1
214 %patch9 -p1
215 %patch11 -p1
216 %patch12 -p1
217 %patch13 -p1
218 %patch14 -p1
219 %patch15 -p1
220 cp -a %{SOURCE10} .
221
222 find perl/ -name '*.swg' -print0 | xargs -0 touch
223
224 %build
225 %{__libtoolize}
226 %{__aclocal} -I config -I config/gettext-macros -I config/gnulib -I config/amanda -I config/macro-archive
227 %{__autoconf}
228 %{__automake}
229 %configure \
230         DUMP=/sbin/dump \
231         GZIP=/bin/gzip \
232         MAILER=/bin/mail \
233         MT=/bin/mt \
234         MTX=/usr/sbin/mtx \
235         PRINT=/usr/bin/lpr \
236         RESTORE=/sbin/restore \
237         %{?with_xfs:XFSDUMP=/sbin/xfsdump} \
238         %{?with_xfs:XFSRESTORE=/sbin/xfsrestore} \
239         --disable-static \
240         --enable-shared \
241         %{!?with_server:--without-server} \
242         %{!?with_client:--without-client} \
243         --with-index-server=localhost \
244         --with-user=amanda \
245         --with-group=amanda \
246         --with-tape-device=/dev/null \
247         --with-fqdn \
248         %{?with_samba:--with-smbclient=%{_bindir}/smbclient} \
249         --with-star=%{_bindir}/star \
250         --with-gnuplot=%{_bindir}/gnuplot \
251         --with-bsd-security \
252         --with-bsdtcp-security \
253         --with-ssh-security \
254         --with-krb5-security \
255         --with-buffered-dump \
256         --with-amandahosts \
257         --with-configdir=%{_sysconfdir}/amanda \
258         --with-gnutar-listdir=%{_sharedstatedir}/amanda/gnutar-lists \
259         --with-amandates=%{_sharedstatedir}/amanda/amandates \
260         --with-debugging=%{_sharedstatedir}/amanda/debug \
261         --with-tmpdir=/var/tmp/amanda \
262         --with-amperldir=%{perl_vendorarch} \
263         --with-ipv6 \
264         --with-readline \
265         --disable-installperms
266
267 %{__make}
268
269 %install
270 rm -rf $RPM_BUILD_ROOT
271 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{amanda,cron.d,sysconfig/rc-inetd} \
272         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/{.gnupg,.ssh,gnutar-lists} \
273         $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/debug/{amandad,client,server}
274
275 %{__make} install \
276         DESTDIR=$RPM_BUILD_ROOT
277
278 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amanda-srv
279 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE2} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amanda
280 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE3} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amandaidx
281 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE4} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amidxtape
282 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE5} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/k5amanda
283
284 cp -p example/amanda.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
285 cp -p example/amanda-client.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
286 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.amandahosts
287
288 install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sbindir}/amconvert-zd-mtx-to-robot.sh
289
290 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/config
291 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/{,client_}authorized_keys
292 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amdump{,.pub}
293 touch $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover{,.pub}
294
295 %if %{with server}
296 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/amanda/lvm-snapshot.conf
297 %endif
298
299 %if %{with client}
300 sed -e 's|@@PERL_VENDORARCH@@|%{perl_vendorarch}|' %{SOURCE9} >$RPM_BUILD_ROOT%{_libdir}/amanda/application/amlvm-snapshot
301 %endif
302
303 > $RPM_BUILD_ROOT%{_sharedstatedir}/amanda/amandates
304
305 # Amanda tools generate ssh keys with embeded commands pointing to /usr/lib
306 # Tools can't be "fixed" because keys generated on server are to be used on client
307 if [ "%{_lib}" != "lib" ] ; then
308         install -d $RPM_BUILD_ROOT%{_ulibdir}
309         ln -s %{_libdir}/amanda $RPM_BUILD_ROOT%{_ulibdir}/amanda
310 fi
311
312 find $RPM_BUILD_ROOT -name \*.la | xargs rm -f
313
314 %{__rm} $RPM_BUILD_ROOT%{_datadir}/amanda/{COPYRIGHT,ChangeLog,NEWS,ReleaseNotes}
315 %{__rm} $RPM_BUILD_ROOT%{_datadir}/amanda/example/{chg-multi,chg-scsi}.conf
316
317 %clean
318 rm -rf $RPM_BUILD_ROOT
319
320 %triggerpostun common -- amanda-libs < 2.6.0p2-3
321 echo "Adding amanda to disk and tape groups"
322 /usr/sbin/usermod -G disk,tape amanda
323 echo "Setting amanda shell to /bin/sh"
324 /usr/bin/chsh -s /bin/sh amanda
325 if [ -f %{_sharedstatedir}/amanda/.amandahosts ]; then
326         echo "Fixing permissions of %{_sharedstatedir}/amanda/.amandahosts file"
327         chown amanda:amanda %{_sharedstatedir}/amanda/.amandahosts
328         chmod 600 %{_sharedstatedir}/amanda/.amandahosts
329 fi
330
331 %triggerpostun common -- amanda-common < 3.3
332 %banner %{name}-common -e << EOF
333 In amanda 3.3 the default auth has changed to "bsdtcp",
334 if you are using the default "bsd" then you must add it
335 to your configuration:
336
337  *   in amanda.conf
338  *   in amanda-client.conf
339  *   in dumptype/disklist
340  *   in inetd (if no '-auth' argument to amandad)
341 EOF
342
343 %pre common
344 %groupadd -P %{name}-common -g 80 amanda
345 %useradd -P %{name}-common -u 80 -G disk,tape -d /var/lib/amanda -s /bin/sh -c "Amanda Backup user" -g amanda amanda
346
347 %postun common
348 if [ "$1" = "0" ]; then
349         %userremove amanda
350         %groupremove amanda
351 fi
352
353 %post client
354 %service -q rc-inetd reload
355 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amrecover ] ; then
356         HOST="`/bin/hostname`"
357         FQDNHOST="`/bin/hostname -f`"
358         if [ -z "$HOST" ] ; then
359                 COMMENT="root@client"
360         else
361                 COMMENT="root@$HOST"
362         fi
363         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amrecover -N "" || :
364         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
365         chmod 600 /var/lib/amanda/.ssh/id_rsa_amrecover{,.pub} || :
366         if [ -n "$FQDNHOST" ]; then
367                 echo -n "from=\"$FQDNHOST\",no-port-forwarding,no-X11-forwarding,no-agent-forwarding,command=\"%{_ulibdir}/amanda/amandad -auth=ssh amindexd amidxtaped\" " >/var/lib/amanda/.ssh/server_authorized_keys
368                 cat /var/lib/amanda/.ssh/id_rsa_amrecover.pub >>/var/lib/amanda/.ssh/server_authorized_keys
369
370                 echo "Remember to copy the contents of /var/lib/amanda/.ssh/server_authorized_keys to"
371                 echo "/var/lib/amanda/.ssh/authorized_keys on amanda server"
372         fi
373 fi
374
375 %postun client
376 if [ "$1" = 0 ]; then
377         %service -q rc-inetd reload
378 fi
379
380 %post server
381 %service -q rc-inetd reload
382 if [ ! -e /var/lib/amanda/.ssh/id_rsa_amdump ] ; then
383         HOST="`/bin/hostname`"
384         if [ -z "$HOST" ] ; then
385                 COMMENT="amanda@server"
386         else
387                 COMMENT="amanda@$HOST"
388         fi
389         /usr/bin/ssh-keygen -t rsa -C $COMMENT -f /var/lib/amanda/.ssh/id_rsa_amdump -N "" || :
390         chown amanda:amanda /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
391         chmod 600 /var/lib/amanda/.ssh/id_rsa_amdump{,.pub} || :
392 fi
393 if [ "$1" = "1" ]; then
394         echo "Don't forget to edit /etc/cron.d/amanda-srv." 1>&2
395 fi
396
397 %postun server
398 if [ "$1" = 0 ]; then
399         %service -q rc-inetd reload
400 fi
401
402 %triggerpostun server -- amanda-server < 3.2.0
403 %banner %{name} -e << EOF
404 Warning: Tape changer configuration has chaged, please read
405 %{_docdir}/%{name}-server-%{version}/ReleaseNotes.gz
406 and %{_docdir}/%{name}-server-%{version}/NEWS.gz for details.
407 You can use %{_sbindir}/amconvert-zd-mtx-to-robot.sh script
408 to upgrade to chg-robot.
409 EOF
410
411 %files common
412 %defattr(644,root,root,755)
413 %doc AUTHORS COPYRIGHT ChangeLog NEWS README ReleaseNotes UPGRADING amlvm-snapshot.README
414 %attr(755,root,root) %{_libdir}/amanda/libamanda*.so
415 %attr(755,root,root) %{_libdir}/amanda/libamar*.so
416 %attr(755,root,root) %{_libdir}/amanda/libamxfer*.so
417 %attr(755,root,root) %{_libdir}/amanda/libamglue*.so
418 %attr(755,root,root) %{_libdir}/amanda/libndmjob*.so
419 %attr(755,root,root) %{_libdir}/amanda/libndmlib*.so
420 %attr(755,root,root) %{_libdir}/amanda/amndmjob
421 %attr(755,root,root) %{_libdir}/amanda/ndmjob
422 %attr(750,amanda,amanda) %dir %{_sysconfdir}/amanda
423 %dir %{_libdir}/amanda
424 %if %{_lib} != "lib"
425 %{_ulibdir}/amanda
426 %endif
427 %{_libdir}/amanda/amanda-sh-lib.sh
428 %attr(755,root,root) %{_sbindir}/amaespipe
429 %attr(755,root,root) %{_sbindir}/amarchiver
430 %attr(755,root,root) %{_sbindir}/amcrypt*
431 %attr(755,root,root) %{_sbindir}/amgetconf
432 %attr(755,root,root) %{_sbindir}/amgpgcrypt
433 %attr(750,amanda,amanda) %dir %{_datadir}/amanda
434 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/example
435 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/example/label-templates
436 %attr(640,amanda,amanda) %{_datadir}/amanda/example/*amanda*
437 %attr(640,amanda,amanda) %{_datadir}/amanda/example/disklist
438 %attr(640,amanda,amanda) %{_datadir}/amanda/example/label-templates/*.ps
439 %attr(750,amanda,amanda) %dir %{_datadir}/amanda/template.d
440 %attr(640,amanda,amanda) %{_datadir}/amanda/template.d/*
441 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda
442 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.ssh
443 %attr(700,amanda,amanda) %dir %{_sharedstatedir}/amanda/.gnupg
444 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug
445 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/amandad
446 %attr(600,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/.amandahosts
447 %attr(600,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/.ssh/config
448 # Commented out so it won't get removed on uninstall
449 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/authorized_keys
450 %{_mandir}/man5/amanda-archive-format.5*
451 %{_mandir}/man7/amanda-auth.7*
452 %{_mandir}/man7/amanda-match.7*
453 %{_mandir}/man7/amanda-scripts.7*
454 %{_mandir}/man8/amaespipe.8*
455 %{_mandir}/man8/amanda.8*
456 %{_mandir}/man8/amarchiver.8*
457 %{_mandir}/man8/amcrypt*.8*
458 %{_mandir}/man8/amgetconf.8*
459 %{_mandir}/man8/amgpgcrypt.8*
460 %{_mandir}/man8/script-email.8*
461
462 %dir %{perl_vendorarch}/Amanda
463 %dir %{perl_vendorarch}/Amanda/Config
464 %dir %{perl_vendorarch}/Amanda/IPC
465 %{perl_vendorarch}/Amanda/Archive.pm
466 %{perl_vendorarch}/Amanda/BigIntCompat.pm
467 %{perl_vendorarch}/Amanda/ClientService.pm
468 %{perl_vendorarch}/Amanda/Config.pm
469 %{perl_vendorarch}/Amanda/Config/FoldingHash.pm
470 %{perl_vendorarch}/Amanda/Constants.pm
471 %{perl_vendorarch}/Amanda/Debug.pm
472 %{perl_vendorarch}/Amanda/Feature.pm
473 %{perl_vendorarch}/Amanda/Header.pm
474 %{perl_vendorarch}/Amanda/IPC/Binary.pm
475 %{perl_vendorarch}/Amanda/IPC/LineProtocol.pm
476 %{perl_vendorarch}/Amanda/MainLoop.pm
477 %{perl_vendorarch}/Amanda/NDMP.pm
478 %{perl_vendorarch}/Amanda/Paths.pm
479 %{perl_vendorarch}/Amanda/Process.pm
480 %{perl_vendorarch}/Amanda/Script.pm
481 %{perl_vendorarch}/Amanda/Script_App.pm
482 %{perl_vendorarch}/Amanda/Tests.pm
483 %{perl_vendorarch}/Amanda/Util.pm
484 %{perl_vendorarch}/Amanda/Xfer.pm
485 %dir %{perl_vendorarch}/auto/Amanda
486 %dir %{perl_vendorarch}/auto/Amanda/Archive
487 %dir %{perl_vendorarch}/auto/Amanda/Config
488 %dir %{perl_vendorarch}/auto/Amanda/Debug
489 %dir %{perl_vendorarch}/auto/Amanda/Feature
490 %dir %{perl_vendorarch}/auto/Amanda/Header
491 %dir %{perl_vendorarch}/auto/Amanda/IPC
492 %dir %{perl_vendorarch}/auto/Amanda/IPC/Binary
493 %dir %{perl_vendorarch}/auto/Amanda/MainLoop
494 %dir %{perl_vendorarch}/auto/Amanda/NDMP
495 %dir %{perl_vendorarch}/auto/Amanda/Tests
496 %dir %{perl_vendorarch}/auto/Amanda/Util
497 %dir %{perl_vendorarch}/auto/Amanda/Xfer
498 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Archive/*.so
499 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Config/*.so
500 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Feature/*.so
501 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Header/*.so
502 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/IPC/Binary/*.so
503 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Debug/*.so
504 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/MainLoop/*.so
505 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/NDMP/*.so
506 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Tests/*.so
507 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Util/*.so
508 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Xfer/*.so
509
510 %if %{with server}
511 %files server
512 %defattr(644,root,root,755)
513 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amidxtape
514 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amandaidx
515
516 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/amanda.conf
517 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/lvm-snapshot.conf
518
519 # Commented out so it won't get removed on uninstall
520 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/client_authorized_keys
521 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amdump*
522
523 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/server
524
525 %config(noreplace) %attr(640,root,root) /etc/cron.d/amanda-srv
526
527 %attr(755,root,root) %{_libdir}/amanda/libamdevice*.so
528 %attr(755,root,root) %{_libdir}/amanda/libamserver*.so
529
530 %attr(755,root,root) %{_libdir}/amanda/amcat.awk
531 %attr(755,root,root) %{_libdir}/amanda/amcheck-device
532 %attr(755,root,root) %{_libdir}/amanda/amdumpd
533 %attr(755,root,root) %{_libdir}/amanda/amidxtaped
534 %attr(755,root,root) %{_libdir}/amanda/amindexd
535 %attr(755,root,root) %{_libdir}/amanda/amlogroll
536 %attr(755,root,root) %{_libdir}/amanda/amplot.awk
537 %attr(755,root,root) %{_libdir}/amanda/amplot.g
538 %attr(755,root,root) %{_libdir}/amanda/amplot.gp
539 %attr(755,root,root) %{_libdir}/amanda/amtrmidx
540 %attr(755,root,root) %{_libdir}/amanda/amtrmlog
541 %attr(755,root,root) %{_libdir}/amanda/chg-disk
542 %attr(755,root,root) %{_libdir}/amanda/chg-lib.sh
543 %attr(755,root,root) %{_libdir}/amanda/chg-manual
544 %attr(755,root,root) %{_libdir}/amanda/chg-multi
545 %attr(755,root,root) %{_libdir}/amanda/chg-zd-mtx
546 %attr(755,root,root) %{_libdir}/amanda/chunker
547 %attr(755,root,root) %{_libdir}/amanda/driver
548 %attr(4750,root,amanda) %{_libdir}/amanda/dumper
549 %attr(4750,root,amanda) %{_libdir}/amanda/planner
550 %attr(755,root,root) %{_libdir}/amanda/taper
551
552 %attr(755,root,root) %{_sbindir}/activate-devpay
553 %attr(755,root,root) %{_sbindir}/amaddclient
554 %attr(755,root,root) %{_sbindir}/amadmin
555 %attr(4750,root,amanda) %{_sbindir}/amcheck
556 %attr(755,root,root) %{_sbindir}/amcheckdb
557 %attr(755,root,root) %{_sbindir}/amcheckdump
558 %attr(755,root,root) %{_sbindir}/amcleanup
559 %attr(755,root,root) %{_sbindir}/amcleanupdisk
560 %attr(755,root,root) %{_sbindir}/amconvert-zd-mtx-to-robot.sh
561 %attr(755,root,root) %{_sbindir}/amdevcheck
562 %attr(755,root,root) %{_sbindir}/amdump
563 %attr(755,root,root) %{_sbindir}/amfetchdump
564 %attr(755,root,root) %{_sbindir}/amflush
565 %attr(755,root,root) %{_sbindir}/amlabel
566 %attr(755,root,root) %{_sbindir}/amoverview
567 %attr(755,root,root) %{_sbindir}/amplot
568 %attr(755,root,root) %{_sbindir}/amreport
569 %attr(755,root,root) %{_sbindir}/amrestore
570 %attr(755,root,root) %{_sbindir}/amrmtape
571 %attr(755,root,root) %{_sbindir}/amserverconfig
572 %attr(755,root,root) %{_sbindir}/amservice
573 %attr(755,root,root) %{_sbindir}/amstatus
574 %attr(755,root,root) %{_sbindir}/amtape
575 %attr(755,root,root) %{_sbindir}/amtapetype
576 %attr(755,root,root) %{_sbindir}/amtoc
577 %attr(755,root,root) %{_sbindir}/amvault
578 %{_mandir}/man5/amanda.conf.5*
579 %{_mandir}/man5/disklist.5*
580 %{_mandir}/man5/tapelist.5*
581 %{_mandir}/man7/amanda-changers.7*
582 %{_mandir}/man7/amanda-compatibility.7*
583 %{_mandir}/man7/amanda-devices.7*
584 %{_mandir}/man7/amanda-interactivity.7*
585 %{_mandir}/man7/amanda-taperscan.7*
586 %{_mandir}/man8/amaddclient.8*
587 %{_mandir}/man8/amadmin.8*
588 %{_mandir}/man8/amcheck.8*
589 %{_mandir}/man8/amcheckdb.8*
590 %{_mandir}/man8/amcheckdump.8*
591 %{_mandir}/man8/amcleanup.8*
592 %{_mandir}/man8/amcleanupdisk.8*
593 %{_mandir}/man8/amdevcheck.8*
594 %{_mandir}/man8/amdump.8*
595 %{_mandir}/man8/amfetchdump.8*
596 %{_mandir}/man8/amflush.8*
597 %{_mandir}/man8/amlabel.8*
598 %{_mandir}/man8/amoverview.8*
599 %{_mandir}/man8/amplot.8*
600 %{_mandir}/man8/amreport.8*
601 %{_mandir}/man8/amrestore.8*
602 %{_mandir}/man8/amrmtape.8*
603 %{_mandir}/man8/amserverconfig.8*
604 %{_mandir}/man8/amservice.8*
605 %{_mandir}/man8/amstatus.8*
606 %{_mandir}/man8/amtape.8*
607 %{_mandir}/man8/amtapetype.8*
608 %{_mandir}/man8/amtoc.8*
609 %{_mandir}/man8/amvault.8*
610
611 %{perl_vendorarch}/Amanda/Changer.pm
612 %dir %{perl_vendorarch}/Amanda/Changer
613 %{perl_vendorarch}/Amanda/Changer/*.pm
614 %{perl_vendorarch}/Amanda/Cmdline.pm
615 %{perl_vendorarch}/Amanda/Curinfo.pm
616 %dir %{perl_vendorarch}/Amanda/Curinfo
617 %{perl_vendorarch}/Amanda/Curinfo/*.pm
618 %dir %{perl_vendorarch}/Amanda/DB
619 %{perl_vendorarch}/Amanda/DB/*.pm
620 %{perl_vendorarch}/Amanda/Device.pm
621 %{perl_vendorarch}/Amanda/Extract.pm
622 %{perl_vendorarch}/Amanda/Disklist.pm
623 %{perl_vendorarch}/Amanda/Holding.pm
624 %{perl_vendorarch}/Amanda/Interactivity.pm
625 %dir %{perl_vendorarch}/Amanda/Interactivity
626 %{perl_vendorarch}/Amanda/Interactivity/*.pm
627 %{perl_vendorarch}/Amanda/Logfile.pm
628 %dir %{perl_vendorarch}/Amanda/Recovery
629 %{perl_vendorarch}/Amanda/Recovery/*.pm
630 %{perl_vendorarch}/Amanda/Report.pm
631 %dir %{perl_vendorarch}/Amanda/Report
632 %{perl_vendorarch}/Amanda/Report/*.pm
633 %{perl_vendorarch}/Amanda/ScanInventory.pm
634 %{perl_vendorarch}/Amanda/Tapelist.pm
635 %dir %{perl_vendorarch}/Amanda/Taper
636 %{perl_vendorarch}/Amanda/Taper/*.pm
637 %dir %{perl_vendorarch}/Amanda/Taper/Scan
638 %{perl_vendorarch}/Amanda/Taper/Scan/*.pm
639 %{perl_vendorarch}/Amanda/XferServer.pm
640 %dir %{perl_vendorarch}/auto/Amanda/Cmdline
641 %dir %{perl_vendorarch}/auto/Amanda/Device
642 %dir %{perl_vendorarch}/auto/Amanda/Disklist
643 %dir %{perl_vendorarch}/auto/Amanda/Logfile
644 %dir %{perl_vendorarch}/auto/Amanda/Tapelist
645 %dir %{perl_vendorarch}/auto/Amanda/XferServer
646 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Cmdline/*.so
647 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Device/*.so
648 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Disklist/*.so
649 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Logfile/*.so
650 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Tapelist/*.so
651 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/XferServer/*.so
652 %endif
653
654 %if %{with client}
655 %files client
656 %defattr(644,root,root,755)
657 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amanda
658 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/k5amanda
659 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,amanda) %{_sysconfdir}/amanda/amanda-client.conf
660 # Commented out so it won't get removed on uninstall
661 #%attr(600,amanda,amanda) %ghost %{_sharedstatedir}/amanda/.ssh/id_rsa_amrecover*
662 %attr(640,amanda,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/amanda/amandates
663
664 %dir %{_libdir}/amanda/application
665 %attr(4750,root,amanda) %{_libdir}/amanda/application/ambsdtar
666 %attr(4750,root,amanda) %{_libdir}/amanda/application/amgtar
667 %attr(755,root,root) %{_libdir}/amanda/application/amlog-script
668 %attr(755,root,root) %{_libdir}/amanda/application/amlvm-snapshot
669 %attr(755,root,root) %{_libdir}/amanda/application/ampgsql
670 %attr(755,root,root) %{_libdir}/amanda/application/amraw
671 %attr(755,root,root) %{_libdir}/amanda/application/amsamba
672 %attr(4750,root,amanda) %{_libdir}/amanda/application/amstar
673 %attr(755,root,root) %{_libdir}/amanda/application/amsuntar
674 %attr(755,root,root) %{_libdir}/amanda/application/amzfs*
675 %attr(755,root,root) %{_libdir}/amanda/application/script-email
676
677 %attr(755,root,root) %{_libdir}/amanda/libamclient*.so
678 %attr(755,root,root) %{_libdir}/amanda/amandad
679 %attr(755,root,root) %{_libdir}/amanda/noop
680 %attr(755,root,root) %{_libdir}/amanda/patch-system
681 %attr(755,root,root) %{_libdir}/amanda/sendbackup
682 %attr(755,root,root) %{_libdir}/amanda/sendsize
683 %attr(755,root,root) %{_libdir}/amanda/teecount
684 %attr(4750,root,amanda) %{_libdir}/amanda/calcsize
685 %attr(4750,root,amanda) %{_libdir}/amanda/killpgrp
686 %attr(4750,root,amanda) %{_libdir}/amanda/rundump
687 %attr(4750,root,amanda) %{_libdir}/amanda/runtar
688 %attr(755,root,root) %{_libdir}/amanda/selfcheck
689 %attr(755,root,root) %{_sbindir}/amdump_client
690 %attr(755,root,root) %{_sbindir}/amoldrecover
691 %attr(755,root,root) %{_sbindir}/amrecover
692 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/gnutar-lists
693 %attr(750,amanda,amanda) %dir %{_sharedstatedir}/amanda/debug/client
694 %{_mandir}/man7/amanda-applications.7*
695 %{_mandir}/man5/amanda-client.conf.5*
696 %{_mandir}/man8/amdump_client.8*
697 %{_mandir}/man8/ambsdtar.8*
698 %{_mandir}/man8/amgtar.8*
699 %{_mandir}/man8/ampgsql.8*
700 %{_mandir}/man8/amrecover.8*
701 %{_mandir}/man8/amraw.8*
702 %{_mandir}/man8/amsamba.8*
703 %{_mandir}/man8/amstar.8*
704 %{_mandir}/man8/amsuntar.8*
705 %{_mandir}/man8/amzfs*.8*
706
707 %{perl_vendorarch}/Amanda/Application.pm
708 %dir %{perl_vendorarch}/Amanda/Application
709 %{perl_vendorarch}/Amanda/Application/Zfs.pm
710 %dir %{perl_vendorarch}/auto/Amanda/Application
711 %attr(755,root,root) %{perl_vendorarch}/auto/Amanda/Application/*.so
712 %endif
This page took 0.192419 seconds and 4 git commands to generate.