]> git.pld-linux.org Git - packages/aircrack-ng.git/blob - aircrack-ng.spec
added use_standard_sleep.patch; added Requires for airmon-ng script; rel. 0.2
[packages/aircrack-ng.git] / aircrack-ng.spec
1 #
2 # TODO:
3 # - PLD it more
4 # - sbin/bin - change to bin?
5 # - finish ext_scripts bcond:
6 # -- check python related BR and R
7 # -- fix packaging python releated stuff
8 # -- create subpackage for airoscript
9 # -- fix directory for airoscript*.conf files
10 # -- fix installation of airoscript desktop files
11 #
12 # Conditional build:
13 %bcond_without  sqlite                  # build without sqlite support
14 %bcond_without  pcre                    # build without pcre support
15 %bcond_without  experimental
16 %bcond_with     ext_scripts             # build with extra scripts (NFY)
17
18 %define subver  rc2
19 %define rel     0.2
20 Summary:        Reliable 802.11 (wireless) sniffer and WEP/WPA-PSK key cracker
21 Summary(pl.UTF-8):      Pewny sniffer 802.11 (sieci bezprzewodowe) i łamacz kluczy WEP/WPA-PSK
22 Name:           aircrack-ng
23 Version:        1.2
24 Release:        %{subver}.%{rel}
25 License:        GPL
26 Group:          Applications/Networking
27 Source0:        http://download.aircrack-ng.org/%{name}-%{version}-%{subver}.tar.gz
28 # Source0-md5:  ebe9d537f06f4d6956213af09c4476da
29 URL:            http://www.aircrack-ng.org/
30 Patch0:         install.patch
31 Patch1:         pldflags.patch
32 Patch2:         install_besside_manual.patch
33 Patch3:         use_standard_sleep.patch
34 BuildRequires:  libnl-devel
35 BuildRequires:  openssl-devel
36 %{?with_pcre:BuildRequires:     pcre-devel}
37 BuildRequires:  pkgconfig
38 %{?with_sqlite:BuildRequires:   sqlite3-devel}
39 BuildRequires:  zlib-devel
40 Requires:       ethtool
41 Requires:       grep
42 Requires:       iw
43 Requires:       usbutils
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 aircrack-ng is a set of tools for auditing wireless networks. It's an
48 enhanced/reborn version of aircrack. It consists of airodump-ng (an
49 802.11 packet capture program), aireplay-ng (an 802.11 packet
50 injection program), aircrack (static WEP and WPA-PSK cracking),
51 airdecap-ng (decrypts WEP/WPA capture files), and some tools to handle
52 capture files (merge, convert, etc.).
53
54 %description -l pl.UTF-8
55 aircrack-ng jest zestawem narzędzi do audytów sieci bezprzewodowych.
56 Jest to ulepszona/odnowiona wersja aircracka. Składa sie z programów
57 airodump-ng (do przechwytywania pakietów 802.11), aireplay-ng (do
58 wstrzykiwania pakietów 802.11), aircrack (do statycznego łamania WEP i
59 WPA-PSK), airdecap-ng (do odszyfrowywania przechwyconych plików
60 WEP/WPA) i paru narzędzi do obsługi plików przechwytów (merge,
61 convert, etc.).
62
63 %prep
64 %setup -q -n %{name}-%{version}-%{subver}
65 %patch0 -p1
66 %patch1 -p1
67 %patch2 -p1
68 %patch3 -p1
69
70 %build
71 %{__make} -j1 \
72         %{?with_experimental: experimental=true} \
73         %{?with_ext_scripts: ext_scripts=true} \
74         %{?with_pcre: pcre=true} \
75         %{?with_sqlite: sqlite=true} \
76         CC="%{__cc}" \
77         PLDFLAGS="%{rpmcppflags} %{rpmcflags}"
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
82
83 %{__make} install \
84         %{?with_experimental: experimental=true} \
85         %{?with_ext_scripts: ext_scripts=true} \
86         %{?with_pcre: pcre=true} \
87         %{?with_sqlite: sqlite=true} \
88         prefix=%{_prefix} \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(644,root,root,755)
96 %doc AUTHORS ChangeLog README test patches
97 %attr(755,root,root) %{_bindir}/aircrack-ng
98 %attr(755,root,root) %{_bindir}/airdecap-ng
99 %attr(755,root,root) %{_bindir}/airdecloak-ng
100 %{?with_sqlite:%attr(755,root,root) %{_bindir}/airolib-ng}
101 %attr(755,root,root) %{_bindir}/ivstools
102 %attr(755,root,root) %{_bindir}/kstats
103 %attr(755,root,root) %{_bindir}/makeivs-ng
104 %attr(755,root,root) %{_bindir}/packetforge-ng
105 %attr(755,root,root) %{_bindir}/wpaclean
106 %attr(755,root,root) %{_sbindir}/airbase-ng
107 %attr(755,root,root) %{_sbindir}/aireplay-ng
108 %attr(755,root,root) %{_sbindir}/airmon-ng
109 %attr(755,root,root) %{_sbindir}/airodump-ng
110 %attr(755,root,root) %{_sbindir}/airodump-ng-oui-update
111 %attr(755,root,root) %{_sbindir}/airserv-ng
112 %attr(755,root,root) %{_sbindir}/airtun-ng
113 %{_mandir}/man1/aircrack-ng.1*
114 %{_mandir}/man1/airdecap-ng.1*
115 %{_mandir}/man1/airdecloak-ng.1*
116 %{?with_sqlite:%{_mandir}/man1/airolib-ng.1*}
117 %{_mandir}/man1/besside-ng-crawler.1*
118 %{_mandir}/man1/ivstools.1*
119 %{_mandir}/man1/kstats.1*
120 %{_mandir}/man1/makeivs-ng.1*
121 %{_mandir}/man1/packetforge-ng.1*
122 %{_mandir}/man1/wpaclean.1*
123 %{_mandir}/man8/airbase-ng.8*
124 %{_mandir}/man8/aireplay-ng.8*
125 %{_mandir}/man8/airmon-ng.8*
126 %{_mandir}/man8/airodump-ng-oui-update.8*
127 %{_mandir}/man8/airodump-ng.8*
128 %{_mandir}/man8/airserv-ng.8*
129 %{_mandir}/man8/airtun-ng.8*
130
131 %if %{with experimental}
132 %attr(755,root,root) %{_bindir}/buddy-ng
133 %attr(755,root,root) %{_sbindir}/besside-ng
134 %attr(755,root,root) %{_sbindir}/easside-ng
135 %attr(755,root,root) %{_sbindir}/tkiptun-ng
136 %attr(755,root,root) %{_sbindir}/wesside-ng
137 %{_mandir}/man1/buddy-ng.1*
138 %{_mandir}/man8/besside-ng.8*
139 %{_mandir}/man8/easside-ng.8*
140 %{_mandir}/man8/tkiptun-ng.8*
141 %{_mandir}/man8/wesside-ng.8*
142 %endif
This page took 0.066697 seconds and 3 git commands to generate.