]> git.pld-linux.org Git - packages/aircrack-ng.git/blob - aircrack-ng.spec
- upgradable release
[packages/aircrack-ng.git] / aircrack-ng.spec
1 #
2 # TODO:
3 # - PLD it more
4 # - sbin/bin - change to bin?
5 # - finish ext_scripts bcond:
6 # -- check python related BR and R
7 # -- fix packaging python releated stuff
8 # -- create subpackage for airoscript
9 # -- fix directory for airoscript*.conf files
10 # -- fix installation of airoscript desktop files
11 #
12 # Conditional build:
13 %bcond_without  sqlite                  # build without sqlite support
14 %bcond_without  pcre                    # build without pcre support
15 %bcond_without  experimental
16 %bcond_with     ext_scripts             # build with extra scripts (NFY)
17
18 %define subver  rc4
19 %define rel     1
20 Summary:        Reliable 802.11 (wireless) sniffer and WEP/WPA-PSK key cracker
21 Summary(pl.UTF-8):      Pewny sniffer 802.11 (sieci bezprzewodowe) i łamacz kluczy WEP/WPA-PSK
22 Name:           aircrack-ng
23 Version:        1.2
24 Release:        0.%{subver}.%{rel}
25 License:        GPL
26 Group:          Applications/Networking
27 Source0:        http://download.aircrack-ng.org/%{name}-%{version}-%{subver}.tar.gz
28 # Source0-md5:  3bbc7d5035a98ec01e78774d05c3fcce
29 URL:            http://www.aircrack-ng.org/
30 Patch0:         install.patch
31 Patch1:         pldflags.patch
32 Patch2:         install_besside_manual.patch
33 BuildRequires:  libnl-devel
34 BuildRequires:  openssl-devel
35 %{?with_pcre:BuildRequires:     pcre-devel}
36 BuildRequires:  pkgconfig
37 %{?with_sqlite:BuildRequires:   sqlite3-devel}
38 BuildRequires:  zlib-devel
39 Requires:       ethtool
40 Requires:       grep
41 Requires:       iw
42 Requires:       usbutils
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 aircrack-ng is a set of tools for auditing wireless networks. It's an
47 enhanced/reborn version of aircrack. It consists of airodump-ng (an
48 802.11 packet capture program), aireplay-ng (an 802.11 packet
49 injection program), aircrack (static WEP and WPA-PSK cracking),
50 airdecap-ng (decrypts WEP/WPA capture files), and some tools to handle
51 capture files (merge, convert, etc.).
52
53 %description -l pl.UTF-8
54 aircrack-ng jest zestawem narzędzi do audytów sieci bezprzewodowych.
55 Jest to ulepszona/odnowiona wersja aircracka. Składa sie z programów
56 airodump-ng (do przechwytywania pakietów 802.11), aireplay-ng (do
57 wstrzykiwania pakietów 802.11), aircrack (do statycznego łamania WEP i
58 WPA-PSK), airdecap-ng (do odszyfrowywania przechwyconych plików
59 WEP/WPA) i paru narzędzi do obsługi plików przechwytów (merge,
60 convert, etc.).
61
62 %prep
63 %setup -q -n %{name}-%{version}-%{subver}
64 %patch0 -p1
65 %patch1 -p1
66 %patch2 -p1
67
68 %build
69 %{__make} -j1 \
70         %{?with_experimental: experimental=true} \
71         %{?with_ext_scripts: ext_scripts=true} \
72         %{?with_pcre: pcre=true} \
73         %{?with_sqlite: sqlite=true} \
74         CC="%{__cc}" \
75         PLDFLAGS="%{rpmcflags}"
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
80
81 %{__make} install \
82         %{?with_experimental: experimental=true} \
83         %{?with_ext_scripts: ext_scripts=true} \
84         %{?with_pcre: pcre=true} \
85         %{?with_sqlite: sqlite=true} \
86         prefix=%{_prefix} \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc AUTHORS ChangeLog README test patches
95 %attr(755,root,root) %{_bindir}/aircrack-ng
96 %attr(755,root,root) %{_bindir}/airdecap-ng
97 %attr(755,root,root) %{_bindir}/airdecloak-ng
98 %{?with_sqlite:%attr(755,root,root) %{_bindir}/airolib-ng}
99 %attr(755,root,root) %{_bindir}/ivstools
100 %attr(755,root,root) %{_bindir}/kstats
101 %attr(755,root,root) %{_bindir}/makeivs-ng
102 %attr(755,root,root) %{_bindir}/packetforge-ng
103 %attr(755,root,root) %{_bindir}/wpaclean
104 %attr(755,root,root) %{_sbindir}/airbase-ng
105 %attr(755,root,root) %{_sbindir}/aireplay-ng
106 %attr(755,root,root) %{_sbindir}/airmon-ng
107 %attr(755,root,root) %{_sbindir}/airodump-ng
108 %attr(755,root,root) %{_sbindir}/airodump-ng-oui-update
109 %attr(755,root,root) %{_sbindir}/airserv-ng
110 %attr(755,root,root) %{_sbindir}/airtun-ng
111 %{_mandir}/man1/aircrack-ng.1*
112 %{_mandir}/man1/airdecap-ng.1*
113 %{_mandir}/man1/airdecloak-ng.1*
114 %{?with_sqlite:%{_mandir}/man1/airolib-ng.1*}
115 %{_mandir}/man1/besside-ng-crawler.1*
116 %{_mandir}/man1/ivstools.1*
117 %{_mandir}/man1/kstats.1*
118 %{_mandir}/man1/makeivs-ng.1*
119 %{_mandir}/man1/packetforge-ng.1*
120 %{_mandir}/man1/wpaclean.1*
121 %{_mandir}/man8/airbase-ng.8*
122 %{_mandir}/man8/aireplay-ng.8*
123 %{_mandir}/man8/airmon-ng.8*
124 %{_mandir}/man8/airodump-ng-oui-update.8*
125 %{_mandir}/man8/airodump-ng.8*
126 %{_mandir}/man8/airserv-ng.8*
127 %{_mandir}/man8/airtun-ng.8*
128
129 %if %{with experimental}
130 %attr(755,root,root) %{_bindir}/besside-ng-crawler
131 %attr(755,root,root) %{_bindir}/buddy-ng
132 %attr(755,root,root) %{_sbindir}/besside-ng
133 %attr(755,root,root) %{_sbindir}/easside-ng
134 %attr(755,root,root) %{_sbindir}/tkiptun-ng
135 %attr(755,root,root) %{_sbindir}/wesside-ng
136 %{_mandir}/man1/buddy-ng.1*
137 %{_mandir}/man8/besside-ng.8*
138 %{_mandir}/man8/easside-ng.8*
139 %{_mandir}/man8/tkiptun-ng.8*
140 %{_mandir}/man8/wesside-ng.8*
141 %endif
This page took 0.063439 seconds and 3 git commands to generate.