]> git.pld-linux.org Git - packages/aircrack-ng.git/blob - aircrack-ng.spec
TODO about find more deps done
[packages/aircrack-ng.git] / aircrack-ng.spec
1 #
2 # TODO:
3 # - PLD it more
4 # - sbin/bin - change to bin?
5 # - package airdrop-ng and airgraph-ng
6 #
7 # Conditional build:
8 %bcond_without  sqlite                  # build without sqlite support
9 %bcond_without  pcre                    # build without pcre support
10 %bcond_without  experimental
11 %bcond_with     ext_scripts             # build with extra scripts (NFY)
12 #
13 Summary:        Reliable 802.11 (wireless) sniffer and WEP/WPA-PSK key cracker
14 Summary(pl.UTF-8):      Pewny sniffer 802.11 (sieci bezprzewodowe) i łamacz kluczy WEP/WPA-PSK
15 Name:           aircrack-ng
16 Version:        1.2
17 %define subver  rc2
18 %define rel     0.1
19 Release:        %{subver}.%{rel}
20 License:        GPL
21 Group:          Applications/Networking
22 Source0:        http://download.aircrack-ng.org/%{name}-%{version}-%{subver}.tar.gz
23 # Source0-md5:  ebe9d537f06f4d6956213af09c4476da
24 URL:            http://www.aircrack-ng.org/
25 Patch0:         install.patch
26 Patch1:         pldflags.patch
27 BuildRequires:  libnl-devel
28 BuildRequires:  openssl-devel
29 BuildRequires:  pkgconfig
30 %{?with_pcre:BuildRequires:     pcre-devel}
31 %{?with_sqlite:BuildRequires:   sqlite3-devel}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 aircrack-ng is a set of tools for auditing wireless networks. It's an
36 enhanced/reborn version of aircrack. It consists of airodump-ng (an
37 802.11 packet capture program), aireplay-ng (an 802.11 packet
38 injection program), aircrack (static WEP and WPA-PSK cracking),
39 airdecap-ng (decrypts WEP/WPA capture files), and some tools to handle
40 capture files (merge, convert, etc.).
41
42 %description -l pl.UTF-8
43 aircrack-ng jest zestawem narzędzi do audytów sieci bezprzewodowych.
44 Jest to ulepszona/odnowiona wersja aircracka. Składa sie z programów
45 airodump-ng (do przechwytywania pakietów 802.11), aireplay-ng (do
46 wstrzykiwania pakietów 802.11), aircrack (do statycznego łamania WEP i
47 WPA-PSK), airdecap-ng (do odszyfrowywania przechwyconych plików
48 WEP/WPA) i paru narzędzi do obsługi plików przechwytów (merge,
49 convert, etc.).
50
51 %prep
52 %setup -q -n %{name}-%{version}-%{subver}
53 %patch0 -p1
54 %patch1 -p1
55
56 %build
57 %{__make} -j1 \
58         %{?with_experimental: experimental=true} \
59         %{?with_ext_scripts: ext_scripts=true} \
60         %{?with_pcre: pcre=true} \
61         %{?with_sqlite: sqlite=true} \
62         CC="%{__cc}" \
63         PLDFLAGS="%{rpmcppflags} %{rpmcflags}"
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
68
69 %{__make} install \
70         %{?with_experimental: experimental=true} \
71         %{?with_ext_scripts: ext_scripts=true} \
72         %{?with_pcre: pcre=true} \
73         %{?with_sqlite: sqlite=true} \
74         prefix=%{_prefix} \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc AUTHORS ChangeLog README test patches
83 %attr(755,root,root) %{_bindir}/aircrack-ng
84 %attr(755,root,root) %{_bindir}/airdecap-ng
85 %attr(755,root,root) %{_bindir}/airdecloak-ng
86 %{?with_sqlite:%attr(755,root,root) %{_bindir}/airolib-ng}
87 %attr(755,root,root) %{_bindir}/ivstools
88 %attr(755,root,root) %{_bindir}/kstats
89 %attr(755,root,root) %{_bindir}/makeivs-ng
90 %attr(755,root,root) %{_bindir}/packetforge-ng
91 %attr(755,root,root) %{_bindir}/wpaclean
92 %attr(755,root,root) %{_sbindir}/airbase-ng
93 %attr(755,root,root) %{_sbindir}/aireplay-ng
94 %attr(755,root,root) %{_sbindir}/airmon-ng
95 %attr(755,root,root) %{_sbindir}/airodump-ng
96 %attr(755,root,root) %{_sbindir}/airodump-ng-oui-update
97 %attr(755,root,root) %{_sbindir}/airserv-ng
98 %attr(755,root,root) %{_sbindir}/airtun-ng
99 %{_mandir}/man1/aircrack-ng.1*
100 %{_mandir}/man1/airdecap-ng.1*
101 %{_mandir}/man1/airdecloak-ng.1*
102 %{?with_sqlite:%{_mandir}/man1/airolib-ng.1*}
103 %{_mandir}/man1/besside-ng-crawler.1*
104 %{_mandir}/man1/ivstools.1*
105 %{_mandir}/man1/kstats.1*
106 %{_mandir}/man1/makeivs-ng.1*
107 %{_mandir}/man1/packetforge-ng.1*
108 %{_mandir}/man1/wpaclean.1*
109 %{_mandir}/man8/airbase-ng.8*
110 %{_mandir}/man8/aireplay-ng.8*
111 %{_mandir}/man8/airmon-ng.8*
112 %{_mandir}/man8/airodump-ng-oui-update.8*
113 %{_mandir}/man8/airodump-ng.8*
114 %{_mandir}/man8/airserv-ng.8*
115 %{_mandir}/man8/airtun-ng.8*
116 %{_mandir}/man8/besside-ng.8*
117
118 %if %{with experimental}
119 %attr(755,root,root) %{_bindir}/buddy-ng
120 %attr(755,root,root) %{_sbindir}/besside-ng
121 %attr(755,root,root) %{_sbindir}/easside-ng
122 %attr(755,root,root) %{_sbindir}/tkiptun-ng
123 %attr(755,root,root) %{_sbindir}/wesside-ng
124 %{_mandir}/man1/buddy-ng.1*
125 %{_mandir}/man8/easside-ng.8*
126 %{_mandir}/man8/tkiptun-ng.8*
127 %{_mandir}/man8/wesside-ng.8*
128 %endif
This page took 0.115883 seconds and 3 git commands to generate.