]> git.pld-linux.org Git - packages/aegisub.git/blame - aegisub.spec
icu+boost rebuild
[packages/aegisub.git] / aegisub.spec
CommitLineData
05156a5d 1# TODO
fc87a4b8
ER
2# - unvendor vendor/luabins
3# - unvendor vendor/luajit
4# - unvendor vendor/universalchardet
f9d70368 5# - our cxxflags
05156a5d
ER
6
7# Conditional build:
1987c5f6 8%bcond_without ffms2 # build ffms2 A/V provider
05156a5d 9
b23cdd31
JR
10%define snap 85f711f
11%define gitrev 85f711fccc75f01fd44f25537b8777df10c4b3d1
12
05156a5d 13Summary: Subtitle editor
553a2ba3 14Summary(pl.UTF-8): Edytor napisów
05156a5d 15Name: aegisub
5fdef24d 16Version: 3.2.2
2a40e321 17Release: 21
05156a5d
ER
18License: BSD
19Group: X11/Applications
b23cdd31
JR
20#Source0: http://ftp.aegisub.org/pub/releases/%{name}-%{version}.tar.xz
21Source0: https://github.com/Aegisub/Aegisub/archive/%{snap}/%{name}-%{version}-%{snap}.tar.gz
22# Source0-md5: ecb9b5441ead4135c9b1baec0abdec49
23Patch0: make-4.3.patch
456c2089 24Patch1: boost181.patch
fb56d99b 25URL: http://www.aegisub.org/
553a2ba3
JB
26# AC_AGI_COMPILE tries to run test program which tries to open device and most likely fails
27#BuildRequires: OpenAL-devel >= 0.0.8
28BuildRequires: OpenGL-devel
05156a5d 29BuildRequires: alsa-lib-devel
553a2ba3
JB
30BuildRequires: boost-devel >= 1.50.0
31%{?with_ffms2:BuildRequires: ffms2-devel >= 2.16}
05156a5d
ER
32BuildRequires: fftw3-devel >= 3.3
33BuildRequires: fontconfig-devel >= 1:2.4
553a2ba3
JB
34# pkgconfig(freetype2) >= 9.7.0
35BuildRequires: freetype-devel >= 1:2.1.9
bebc09b5 36BuildRequires: gettext-tools
05156a5d
ER
37BuildRequires: hunspell-devel >= 1.2.0
38BuildRequires: intltool
553a2ba3
JB
39BuildRequires: libass-devel >= 0.9.7
40BuildRequires: libicu-devel >= 4.8.1.1
05156a5d
ER
41BuildRequires: libstdc++-devel
42BuildRequires: lua51-devel
553a2ba3
JB
43BuildRequires: pkgconfig >= 1:0.20
44BuildRequires: portaudio-devel >= 19
05156a5d
ER
45BuildRequires: pulseaudio-devel >= 0.5
46BuildRequires: tar >= 1:1.22
b23cdd31
JR
47BuildRequires: uchardet-devel
48BuildRequires: wxGTK3-unicode-gl-devel >= 3.0.0
553a2ba3 49BuildRequires: wxWidgets-devel >= 3.0.0
05156a5d
ER
50BuildRequires: xz
51BuildRequires: zlib-devel
553a2ba3
JB
52Requires(post,postun): desktop-file-utils
53Requires(post,postun): gtk-update-icon-cache
54Requires: ffms2 >= 2.16
55Requires: fftw3 >= 3.3
56Requires: fontconfig-libs >= 1:2.4
57Requires: freetype >= 1:2.1.9
58Requires: hunspell >= 1.2.0
59Requires: libass >= 0.9.7
60Requires: libicu >= 4.8.1.1
61Requires: pulseaudio-libs >= 0.5
ac934b9e
JB
62# due to luajit usage
63ExclusiveArch: %{ix86} %{x8664} arm mips ppc
c0ccb665 64# missing atomic_ops
553a2ba3 65ExcludeArch: i386 i486
05156a5d
ER
66BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68%description
69Aegisub is an advanced subtitle editor for Windows, and UNIX-like
70systems, such as Linux, Mac OS X and BSD. It is open source software
71and free for any use.
72
73Aegisub natively works with the Advanced SubStation Alpha format
74(aptly abbreviated ASS) which allows for many advanced effects in the
75subtitles, apart from just basic timed text. Aegisubs goal is to
76support using these advanced functions with ease.
77
553a2ba3
JB
78%description -l pl.UTF-8
79Aegisub to zaawansowany edytor napisów dla Windows oraz systemów
80uniksowych, takich jak Linux, Mac OS X czy BSD. Jest to program o
81otwartych źródłach, darmowy do dowolnego użytku.
82
83Aegisub działa natywnie na formacie Advanced SubStation Alpha (w
84stosownym skrócie ASS), pozwalającym na wiele zaawansowanych efektów w
85napisach, poza samym powiązaniem z czasem. Celem Aegisubs jest łatwa
86obsługa tych zaawansowanych funkcji.
87
05156a5d 88%prep
b23cdd31 89%setup -q -n Aegisub-%{gitrev}
699890b5 90%patch0 -p1
456c2089 91%patch1 -p1
b23cdd31
JR
92
93cat <<'EOF' >build/git_version.h
94#define BUILD_GIT_VERSION_NUMBER 9010
95#define BUILD_GIT_VERSION_STRING "3.2.2.6f546951b"
96#define TAGGED_RELEASE 0
97#define INSTALLER_VERSION "0.0.0"
98#define RESOURCE_BASE_VERSION 0, 0, 0
99EOF
05156a5d 100
553a2ba3 101%{__mv} vendor{,.keep}
fc87a4b8 102mkdir vendor
b23cdd31 103%{__mv} vendor.keep/{luabins,luajit} vendor
fc87a4b8 104
05156a5d 105%build
b23cdd31
JR
106./autogen.sh
107export C
05156a5d 108%configure \
655add79 109 --disable-compiler-flags \
05156a5d 110 --disable-update-checker \
0c514f40 111 --with-boost-libdir=%{_libdir} \
1987c5f6 112 %{__with_without ffms2} \
553a2ba3
JB
113 --without-oss \
114 --with-player-audio=PulseAudio \
b23cdd31 115 --with-wx-config=wx-gtk3-unicode-config
05156a5d
ER
116
117%{__make}
118
119%install
120rm -rf $RPM_BUILD_ROOT
fc87a4b8
ER
121%{__make} install \
122 DESTDIR=$RPM_BUILD_ROOT
05156a5d 123
553a2ba3
JB
124%{__mv} $RPM_BUILD_ROOT%{_localedir}/{fr_FR,fr}
125%{__mv} $RPM_BUILD_ROOT%{_localedir}/{pt_PT,pt}
126%{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS,sr}
127%{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS,sr}@latin
dd7e4de7 128%{__mv} $RPM_BUILD_ROOT%{_localedir}/{uk_UA,uk}
d40d8ddd 129
b23cdd31 130%find_lang %{name}
05156a5d
ER
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134
212f2f22
ER
135%post
136%update_desktop_database
137%update_icon_cache hicolor
138
139%postun
140%update_desktop_database
141%update_icon_cache hicolor
142
b23cdd31 143%files -f %{name}.lang
05156a5d 144%defattr(644,root,root,755)
553a2ba3 145%doc LICENCE README.md
9006741b 146%attr(755,root,root) %{_bindir}/%{name}
05156a5d
ER
147%{_datadir}/%{name}
148%{_desktopdir}/%{name}.desktop
b23cdd31 149%{_datadir}/metainfo/aegisub.appdata.xml
05156a5d 150%{_iconsdir}/hicolor/*/apps/%{name}.*
This page took 0.161696 seconds and 4 git commands to generate.