]> git.pld-linux.org Git - packages/aegisub.git/blame - aegisub.spec
- updated to latest buildable snapshot, rel 18
[packages/aegisub.git] / aegisub.spec
CommitLineData
05156a5d 1# TODO
fc87a4b8
ER
2# - unvendor vendor/luabins
3# - unvendor vendor/luajit
4# - unvendor vendor/universalchardet
f9d70368 5# - our cxxflags
05156a5d
ER
6
7# Conditional build:
1987c5f6 8%bcond_without ffms2 # build ffms2 A/V provider
05156a5d 9
b23cdd31
JR
10%define snap 85f711f
11%define gitrev 85f711fccc75f01fd44f25537b8777df10c4b3d1
12
05156a5d 13Summary: Subtitle editor
553a2ba3 14Summary(pl.UTF-8): Edytor napisów
05156a5d 15Name: aegisub
5fdef24d 16Version: 3.2.2
b23cdd31 17Release: 18
05156a5d
ER
18License: BSD
19Group: X11/Applications
b23cdd31
JR
20#Source0: http://ftp.aegisub.org/pub/releases/%{name}-%{version}.tar.xz
21Source0: https://github.com/Aegisub/Aegisub/archive/%{snap}/%{name}-%{version}-%{snap}.tar.gz
22# Source0-md5: ecb9b5441ead4135c9b1baec0abdec49
23Patch0: make-4.3.patch
fb56d99b 24URL: http://www.aegisub.org/
553a2ba3
JB
25# AC_AGI_COMPILE tries to run test program which tries to open device and most likely fails
26#BuildRequires: OpenAL-devel >= 0.0.8
27BuildRequires: OpenGL-devel
05156a5d 28BuildRequires: alsa-lib-devel
553a2ba3
JB
29BuildRequires: boost-devel >= 1.50.0
30%{?with_ffms2:BuildRequires: ffms2-devel >= 2.16}
05156a5d
ER
31BuildRequires: fftw3-devel >= 3.3
32BuildRequires: fontconfig-devel >= 1:2.4
553a2ba3
JB
33# pkgconfig(freetype2) >= 9.7.0
34BuildRequires: freetype-devel >= 1:2.1.9
bebc09b5 35BuildRequires: gettext-tools
05156a5d
ER
36BuildRequires: hunspell-devel >= 1.2.0
37BuildRequires: intltool
553a2ba3
JB
38BuildRequires: libass-devel >= 0.9.7
39BuildRequires: libicu-devel >= 4.8.1.1
05156a5d
ER
40BuildRequires: libstdc++-devel
41BuildRequires: lua51-devel
553a2ba3
JB
42BuildRequires: pkgconfig >= 1:0.20
43BuildRequires: portaudio-devel >= 19
05156a5d
ER
44BuildRequires: pulseaudio-devel >= 0.5
45BuildRequires: tar >= 1:1.22
b23cdd31
JR
46BuildRequires: uchardet-devel
47BuildRequires: wxGTK3-unicode-gl-devel >= 3.0.0
553a2ba3 48BuildRequires: wxWidgets-devel >= 3.0.0
05156a5d
ER
49BuildRequires: xz
50BuildRequires: zlib-devel
553a2ba3
JB
51Requires(post,postun): desktop-file-utils
52Requires(post,postun): gtk-update-icon-cache
53Requires: ffms2 >= 2.16
54Requires: fftw3 >= 3.3
55Requires: fontconfig-libs >= 1:2.4
56Requires: freetype >= 1:2.1.9
57Requires: hunspell >= 1.2.0
58Requires: libass >= 0.9.7
59Requires: libicu >= 4.8.1.1
60Requires: pulseaudio-libs >= 0.5
ac934b9e
JB
61# due to luajit usage
62ExclusiveArch: %{ix86} %{x8664} arm mips ppc
c0ccb665 63# missing atomic_ops
553a2ba3 64ExcludeArch: i386 i486
05156a5d
ER
65BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67%description
68Aegisub is an advanced subtitle editor for Windows, and UNIX-like
69systems, such as Linux, Mac OS X and BSD. It is open source software
70and free for any use.
71
72Aegisub natively works with the Advanced SubStation Alpha format
73(aptly abbreviated ASS) which allows for many advanced effects in the
74subtitles, apart from just basic timed text. Aegisubs goal is to
75support using these advanced functions with ease.
76
553a2ba3
JB
77%description -l pl.UTF-8
78Aegisub to zaawansowany edytor napisów dla Windows oraz systemów
79uniksowych, takich jak Linux, Mac OS X czy BSD. Jest to program o
80otwartych źródłach, darmowy do dowolnego użytku.
81
82Aegisub działa natywnie na formacie Advanced SubStation Alpha (w
83stosownym skrócie ASS), pozwalającym na wiele zaawansowanych efektów w
84napisach, poza samym powiązaniem z czasem. Celem Aegisubs jest łatwa
85obsługa tych zaawansowanych funkcji.
86
05156a5d 87%prep
b23cdd31 88%setup -q -n Aegisub-%{gitrev}
699890b5 89%patch0 -p1
b23cdd31
JR
90
91cat <<'EOF' >build/git_version.h
92#define BUILD_GIT_VERSION_NUMBER 9010
93#define BUILD_GIT_VERSION_STRING "3.2.2.6f546951b"
94#define TAGGED_RELEASE 0
95#define INSTALLER_VERSION "0.0.0"
96#define RESOURCE_BASE_VERSION 0, 0, 0
97EOF
05156a5d 98
553a2ba3 99%{__mv} vendor{,.keep}
fc87a4b8 100mkdir vendor
b23cdd31 101%{__mv} vendor.keep/{luabins,luajit} vendor
fc87a4b8 102
05156a5d 103%build
b23cdd31
JR
104./autogen.sh
105export C
05156a5d 106%configure \
655add79 107 --disable-compiler-flags \
05156a5d 108 --disable-update-checker \
1987c5f6 109 %{__with_without ffms2} \
553a2ba3
JB
110 --without-oss \
111 --with-player-audio=PulseAudio \
b23cdd31 112 --with-wx-config=wx-gtk3-unicode-config
05156a5d
ER
113
114%{__make}
115
116%install
117rm -rf $RPM_BUILD_ROOT
fc87a4b8
ER
118%{__make} install \
119 DESTDIR=$RPM_BUILD_ROOT
05156a5d 120
553a2ba3
JB
121%{__mv} $RPM_BUILD_ROOT%{_localedir}/{fr_FR,fr}
122%{__mv} $RPM_BUILD_ROOT%{_localedir}/{pt_PT,pt}
123%{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS,sr}
124%{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS,sr}@latin
dd7e4de7 125%{__mv} $RPM_BUILD_ROOT%{_localedir}/{uk_UA,uk}
d40d8ddd 126
b23cdd31 127%find_lang %{name}
05156a5d
ER
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
212f2f22
ER
132%post
133%update_desktop_database
134%update_icon_cache hicolor
135
136%postun
137%update_desktop_database
138%update_icon_cache hicolor
139
b23cdd31 140%files -f %{name}.lang
05156a5d 141%defattr(644,root,root,755)
553a2ba3 142%doc LICENCE README.md
9006741b 143%attr(755,root,root) %{_bindir}/%{name}
05156a5d
ER
144%{_datadir}/%{name}
145%{_desktopdir}/%{name}.desktop
b23cdd31 146%{_datadir}/metainfo/aegisub.appdata.xml
05156a5d 147%{_iconsdir}/hicolor/*/apps/%{name}.*
This page took 0.83552 seconds and 4 git commands to generate.