]> git.pld-linux.org Git - packages/adobe-flash.git/blob - adobe-flash.spec
- use versioned url
[packages/adobe-flash.git] / adobe-flash.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4 #
5 %define         _ver_major      7
6 %define         _ver_minor      0
7 %define         _ver_patch      61
8 %define         _ver_serial     0
9 Summary:        Flash plugin for Netscape-compatible WWW browsers
10 Summary(pl):    Wtyczka Flash dla przegl±darek WWW zgodnych z Netscape
11 %define         base_name       macromedia-flash
12 %if %{with license_agreement}
13 Name:           %{base_name}
14 %else
15 Name:           %{base_name}-installer
16 %endif
17 Version:        %{_ver_major}.%{_ver_minor}.%{_ver_patch}.%{_ver_serial}
18 %define         _rel 1
19 Release:        %{_rel}%{?with_license_agreement:wla}
20 License:        Free to use, non-distributable
21 Group:          X11/Applications/Multimedia
22 %if %{with license_agreement}
23 Source0:        http://distfiles.gentoo.org/distfiles/flash-plugin-%{_ver_major}.%{_ver_minor}.%{_ver_patch}.tar.gz
24 # NoSource0-md5:        b063b512076d4c88a56cb7521e6b5409
25 %else
26 Source0:        license-installer.sh
27 %endif
28 URL:            http://www.macromedia.com/software/flashplayer/
29 %if %{with license_agreement}
30 BuildRequires:  rpmbuild(macros) >= 1.236
31 %endif
32 Requires:       browser-plugins(%{_target_cpu})
33 %if %{without license_agreement}
34 Requires:       cpio
35 Requires:       rpm-build-tools
36 Requires:       wget
37 %endif
38 Obsoletes:      flash-plugin
39 Obsoletes:      mozilla-plugin-macromedia-flash
40 Obsoletes:      mozilla-firefox-plugin-macromedia-flash
41 Obsoletes:      konqueror-plugin-macromedia-flash
42 ExclusiveArch:  %{ix86}
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _plugindir      %{_libdir}/browser-plugins
46
47 # TODO: galeon and skipstone.
48 # use macro, otherwise extra LF inserted along with the ifarch
49 %define browsers mozilla, mozilla-firefox, konqueror, opera
50
51 %description
52 Flash plugin for Netscape-compatible WWW browsers.
53
54 Supported browsers: %{browsers}.
55
56 %description -l pl
57 Wtyczka Flash dla przegl±darek WWW zgodnych z Netscape.
58
59 Obs³ugiwane przegl±darki: %{browsers}.
60
61 %prep
62 %if %{with license_agreement}
63 %setup -q -n install_flash_player_7_linux
64 %endif
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %if %{without license_agreement}
69 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
70
71 sed -e '
72         s/@BASE_NAME@/%{base_name}/g
73         s/@TARGET_CPU@/%{_target_cpu}/g
74         s-@VERSION@-%{version}-g
75         s-@RELEASE@-%{release}-g
76         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
77 ' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
78
79 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
80
81 %else
82
83 install -d $RPM_BUILD_ROOT%{_plugindir}
84 install *.{so,xpt} $RPM_BUILD_ROOT%{_plugindir}
85
86 %endif
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %if %{without license_agreement}
92 %post
93 %{_bindir}/%{base_name}.install
94
95 %else
96
97 %triggerin -- mozilla-firefox
98 %nsplugin_install -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
99
100 %triggerun -- mozilla-firefox
101 %nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
102
103 %triggerin -- mozilla
104 %nsplugin_install -d %{_libdir}/mozilla/plugins libflashplayer.so flashplayer.xpt
105 if [ -d /usr/%{_lib}/mozilla ]; then
106         umask 022
107         rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
108         if [ -x /usr/bin/regxpcom ]; then
109                 MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
110         fi
111 fi
112
113 %triggerun -- mozilla
114 %nsplugin_uninstall -d %{_libdir}/mozilla/plugins libflashplayer.so flashplayer.xpt
115 if [ -d /usr/%{_lib}/mozilla ]; then
116         umask 022
117         rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
118         if [ -x /usr/bin/regxpcom ]; then
119                 MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
120         fi
121 fi
122
123 %triggerin -- konqueror
124 %nsplugin_install -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
125
126 %triggerun -- konqueror
127 %nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
128
129 %triggerin -- opera
130 %nsplugin_install -d %{_libdir}/opera/plugins libflashplayer.so
131
132 %triggerun -- opera
133 %nsplugin_uninstall -d %{_libdir}/opera/plugins libflashplayer.so
134
135 # as rpm removes the old obsoleted package files after the triggers
136 # above are ran, add another trigger to make the links there.
137 %triggerpostun -- mozilla-firefox-plugin-macromedia-flash
138 %nsplugin_install -f -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
139
140 %triggerpostun -- mozilla-plugin-macromedia-flash
141 %nsplugin_install -f -d %{_libdir}/mozilla/plugins libflashplayer.so flashplayer.xpt
142
143 %triggerpostun -- konqueror-plugin-macromedia-flash
144 %nsplugin_install -f -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
145 %endif
146
147 %files
148 %defattr(644,root,root,755)
149
150 %if %{without license_agreement}
151 %attr(755,root,root) %{_bindir}/%{base_name}.install
152 %{_datadir}/%{base_name}
153
154 %else
155 %doc Readme.txt
156 %attr(755,root,root) %{_plugindir}/*.so
157 %{_plugindir}/*.xpt
158 %endif
This page took 0.074104 seconds and 4 git commands to generate.