]> git.pld-linux.org Git - packages/acroread.git/blame - acroread.spec
- license-installer.sh moved to DistFiles
[packages/acroread.git] / acroread.spec
CommitLineData
14b68627 1#
2# Conditional build:
3%bcond_with license_agreement # generates package
4#
26e61bd9 5%define base_name acroread
80a5eb81 6%define rel 2
0eb57bee 7Summary: Adobe Acrobat Reader
aadbc0c6
ER
8Summary(pl.UTF-8): Adobe Acrobat Reader - czytnik plików PDF
9Summary(ru.UTF-8): Программа для чтения документов в формате PDF от Adobe
10Summary(uk.UTF-8): Програма для читання документів у форматі PDF від Adobe
14b68627 11%if %{with license_agreement}
12Name: %{base_name}
13%else
14Name: %{base_name}-installer
15%endif
815aeaff 16Version: 9.1.3
80a5eb81 17Release: %{rel}%{?with_license_agreement:wla}
22bd4e96 18Epoch: 1
ef009d9a
JB
19License: distribution restricted (http://www.adobe.com/products/acrobat/distribute.html)
20# in short:
21# - not distributable on public sites (only linking to adobe.com permitted)
22# - distribution on CD requires signing Distribution Agreement (see URL above)
94abd8dc 23Group: X11/Applications/Graphics
14b68627 24%if %{with license_agreement}
2185f2ce 25Source0: ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/%{version}/enu/AdbeRdr%{version}-1_i486linux_enu.tar.bz2
815aeaff 26# NoSource0-md5: fec3eed6dfc921a6dcc4deab400e207e
ecf5969f 27NoSource: 0
e4f54b4c 28%else
0337a7fe 29Source1: http://svn.pld-linux.org/svn/license-installer/license-installer.sh
30# Source1-md5: 4fb1600353dd57fe088e0b12fb0ecac2
14b68627 31%endif
a189ca6f 32# please update @COPYSOURCES@ below if you add more Sources or Patches.
1af9d1cc 33Source2: %{base_name}.desktop
34Source3: %{base_name}.png
14f626f0 35URL: http://www.adobe.com/products/acrobat/
976c259d 36%if %{with license_agreement}
3e94b2a4 37BuildRequires: rpmbuild(macros) >= 1.357
7a2c413b 38Requires: openldap-libs < 2.5
2da3bb9c 39Requires: openldap-libs >= 2.4
26e61bd9 40%else
ea2413cd 41Requires: rpm-build-tools >= 4.4.35
976c259d 42%endif
14f626f0 43ExclusiveArch: %{ix86}
9947ca59 44ExcludeArch: i386
aed33851 45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
7985bc82 46
fcf3bf1c 47%define platform intellinux
22bd4e96 48%define tar0 ILINXR.TAR
fcf3bf1c 49%define tar1 COMMON.TAR
94abd8dc 50
dfbbcb35 51%define _noautostrip .*\.api
2da3bb9c 52%define _noautoprov libcrypto\.so.* libssl\.so.* libcurl\.so.* libicu.* libstdc++\.so.* libgcc_s\.so.*
7a2c413b 53%define _noautoreq %{_noautoprov} '^lib.*\.so$' '^lib.*\(VERSION\)$'
f21ac523 54
7985bc82 55%description
26e61bd9
ER
56Adobe(R) Reader(R) is free software that lets you view and print PDF
57files (Portable Document Format) on a variety of hardware and
62807d83 58operating system platforms.
7985bc82 59
e013bd4f
JR
60%description -l pl.UTF-8
61Adobe(R) Reader(R) jest darmowym oprogramowaniem umożliwiającym
62oglądanie oraz drukowanie plików PDF (Portable Document Format) na
63różnych platformach sprzętowych oraz różnych systemach operacyjnych.
7985bc82 64
e013bd4f
JR
65%description -l ru.UTF-8
66Программа для чтения документов в формате Portable Document Format
67(PDF), сгенерированных Adobe Acrobat'ом.
d44545ff 68
e013bd4f
JR
69%description -l uk.UTF-8
70Програма для читання документів у форматі Portable Document Format
71(PDF), згенерованих Adobe Acrobat'ом.
d44545ff 72
f994d3ef 73%package -n browser-plugin-%{name}
ae0ad7e9 74Summary: PDF plugin for Mozilla compatible browsers
aadbc0c6 75Summary(pl.UTF-8): Wtyczka PDF dla przeglądarek zgodnych Mozilla
2e45421f 76Group: X11/Applications
26e61bd9 77Requires: %{base_name} = %{epoch}:%{version}-%{release}
3e94b2a4 78Requires: browser-plugins >= 2.0
f994d3ef 79Obsoletes: acroread-plugin
ae0ad7e9 80Obsoletes: mozilla-plugin-acroread
2e45421f 81
f994d3ef 82%description -n browser-plugin-%{name}
62807d83 83A Mozilla plugin for displaying PDF (Portable Document Format) files.
2e45421f 84
e013bd4f
JR
85%description -n browser-plugin-%{name} -l pl.UTF-8
86Wtyczka Mozilli do wyświetlania plików PDF (Portable Document Format).
2e45421f 87
7985bc82 88%prep
14b68627 89%if %{with license_agreement}
17a8eeab 90%setup -q -c
22bd4e96 91cd AdobeReader
ea015334
AM
92tar xf %{tar0}
93tar xf %{tar1}
14b68627 94%endif
7985bc82 95
96%install
97rm -rf $RPM_BUILD_ROOT
0eb57bee 98%if %{without license_agreement}
14b68627 99install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
100
e4f54b4c
ER
101sed -e '
102 s/@BASE_NAME@/%{base_name}/g
103 s/@TARGET_CPU@/%{_target_cpu}/g
104 s-@VERSION@-%{version}-g
105 s-@RELEASE@-%{release}-g
106 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
107 s,@DATADIR@,%{_datadir}/%{base_name},g
78a918bf 108 s/@COPYSOURCES@/%{base_name}{.desktop,.png}/g
1af9d1cc 109' %{SOURCE1} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
14b68627 110
111install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
14b68627 112install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
1af9d1cc 113install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
14b68627 114
115%else
3e94b2a4 116install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{base_name},%{_browserpluginsdir}} \
a7dabf0b 117 $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
7985bc82 118
c7dc1b0b 119# note: there're also AdobeReader/Adobe/Help{,Viewer}
6dc16e8f 120cd AdobeReader/Adobe/Reader9
14b68627 121cp -a Reader Resource $RPM_BUILD_ROOT%{_libdir}/%{base_name}
122awk -v INSTDIR=%{_libdir}/%{base_name}/Reader \
14f626f0
TP
123 '/^install_dir=/ {print "install_dir="INSTDIR; next} \
124 {print}' \
22bd4e96 125 bin/%{base_name} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}
3e94b2a4 126install Browser/%{platform}/* $RPM_BUILD_ROOT%{_browserpluginsdir}
1af9d1cc 127install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
128install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
22bd4e96 129
6dc16e8f 130cp -a Browser/HowTo $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/
131
3f07d2af 132rm -rf $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Patch
133
7a2c413b
JB
134ln -sf /usr/lib/liblber-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/liblber.so
135ln -sf /usr/lib/libldap-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/libldap.so
22bd4e96
AM
136ln -sf /usr/share/ssl/ca-bundle.crt $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Cert/curl-ca-bundle.crt
137
138chmod a-x $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/*.so.*
14b68627 139%endif
7985bc82 140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
0eb57bee 144%if %{without license_agreement}
5d59434a 145%post
e4f54b4c 146%{_bindir}/%{base_name}.install
3e94b2a4 147%endif
ae0ad7e9 148
3e94b2a4 149%if %{with license_agreement}
150%post -n browser-plugin-%{name}
151%update_browser_plugins
ae0ad7e9 152
3e94b2a4 153%postun -n browser-plugin-%{name}
154if [ "$1" = 0 ]; then
155 %update_browser_plugins
156fi
14b68627 157%endif
158
7985bc82 159%files
160%defattr(644,root,root,755)
0eb57bee 161%if %{without license_agreement}
14b68627 162%attr(755,root,root) %{_bindir}/%{base_name}.install
163%{_datadir}/%{base_name}
164%else
78a918bf 165%doc AdobeReader/ReadMe.htm
7985bc82 166%attr(755,root,root) %{_bindir}/*
14b68627 167%dir %{_libdir}/%{base_name}
168%{_libdir}/%{base_name}/Resource
14b68627 169%dir %{_libdir}/%{base_name}/Reader
170%{_libdir}/%{base_name}/Reader/help
14b68627 171%{_libdir}/%{base_name}/Reader/AcroVersion
22bd4e96
AM
172%{_libdir}/%{base_name}/Reader/Cert
173%{_libdir}/%{base_name}/Reader/GlobalPrefs
174%{_libdir}/%{base_name}/Reader/HowTo
c7dc1b0b 175%{_libdir}/%{base_name}/Reader/IDTemplates
22bd4e96 176%{_libdir}/%{base_name}/Reader/JavaScripts
c7dc1b0b
TP
177%{_libdir}/%{base_name}/Reader/Legal
178%{_libdir}/%{base_name}/Reader/Tracker
179%{_libdir}/%{base_name}/Reader/PDFSigQFormalRep.pdf
180%{_libdir}/%{base_name}/Reader/pmd.cer
78a918bf 181%{_libdir}/%{base_name}/Reader/%{platform}/mozilla
14b68627 182%dir %{_libdir}/%{base_name}/Reader/%{platform}
714a6915 183%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins
c7dc1b0b 184%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia
43255eee 185%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d
714a6915 186%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/SPPlugins
14b68627 187%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/bin
188%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/lib
714a6915 189%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/*.api
43255eee 190%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/*.x3d
78a918bf 191%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia/MPP
714a6915
KK
192%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/AcroForm
193%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Annotations
c7dc1b0b 194%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/prc
a7dabf0b 195%{_desktopdir}/acroread.desktop
8a44dca4 196%{_pixmapsdir}/*
2e45421f 197
f994d3ef 198%files -n browser-plugin-%{name}
2e45421f 199%defattr(644,root,root,755)
3e94b2a4 200%attr(755,root,root) %{_browserpluginsdir}/*
14b68627 201%endif
This page took 0.067843 seconds and 4 git commands to generate.