]> git.pld-linux.org Git - packages/acroread.git/commitdiff
- license-installer.sh moved to DistFiles
authorpawelz <pawelz@pld-linux.org>
Sat, 26 Dec 2009 11:26:41 +0000 (11:26 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    acroread.spec -> 1.100
    license-installer.sh -> 1.16

acroread.spec
license-installer.sh [deleted file]

index 42260b48dc7430051a610325a82e95338980625e..86632e3d3b36145b7774334d6fe66b0603ac559c 100644 (file)
@@ -26,7 +26,8 @@ Source0:      ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/%{version}/enu/AdbeRdr%{v
 # NoSource0-md5:       fec3eed6dfc921a6dcc4deab400e207e
 NoSource:      0
 %else
-Source1:       license-installer.sh
+Source1:       http://svn.pld-linux.org/svn/license-installer/license-installer.sh
+# Source1-md5: 4fb1600353dd57fe088e0b12fb0ecac2
 %endif
 # please update @COPYSOURCES@ below if you add more Sources or Patches.
 Source2:       %{base_name}.desktop
diff --git a/license-installer.sh b/license-installer.sh
deleted file mode 100644 (file)
index 455c702..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-#!/bin/sh
-if [ "$1" = "--with" -a "$2" = "license_agreement" ]; then
-       tmp=$(mktemp -d)
-       SRPMDIR=`rpm --define "_topdir $tmp" --eval "%{_srcrpmdir}"`
-       BUILDDIR=`rpm --define "_topdir $tmp" --eval "%{_builddir}"`
-       RPMDIR=`rpm --define "_topdir $tmp" --eval "%{_rpmdir}"`
-       PACKAGEDIR="$tmp/packages/@BASE_NAME@"
-       mkdir -p $SRPMDIR $RPMDIR $BUILDDIR $PACKAGEDIR
-
-       if echo "$3" | grep '\.src\.rpm$' >/dev/null; then
-               (
-               if echo "$3" | grep '://' >/dev/null; then
-                       cd $SRPMDIR
-                       wget --passive-ftp -t0 "$3"
-               else
-                       cp -f "$3" $SRPMDIR
-               fi
-               rpm2cpio `basename "$3"` | ( cd $PACKAGEDIR; cpio -i @BASE_NAME@.spec )
-               if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
-                       rpm2cpio `basename "$3"` | ( cd $PACKAGEDIR; cpio -i @COPYSOURCES@ )
-               fi
-               )
-       else
-               cp -i "$3" $PACKAGEDIR || exit 1
-               if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
-                       for i in @COPYSOURCES@; do
-                               cp -i @DATADIR@/$i $PACKAGEDIR/$i || exit 1
-                       done
-               fi
-       fi
-       ( cd $PACKAGEDIR
-       nd=
-       if [ '@USE_DISTFILES@' = 'no' ]; then
-               nd=-nd
-       fi
-       /usr/bin/builder --define _topdir $tmp --define _binary_payload w1.gzdio $nd -nm -nc -ncs --with license_agreement --target @TARGET_CPU@ @BASE_NAME@.spec
-       if [ "$?" -ne 0 ]; then
-               exit 2
-       fi
-       RPMNAMES="$RPMDIR/@BASE_NAME@-@VERSION@-@RELEASE@wla.@TARGET_CPU@.rpm"
-       rpm -Uhv $RPMNAMES || echo -e "Install manually the file(s):\n   $RPMNAMES" )
-else
-       if [ "@LICENSE@" != '@'LICENSE'@' ]; then
-               cat @LICENSE@
-               echo "
-If you accept the above license rebuild the package using:
-"
-       else
-               echo "
-License issues made us not to include inherent files into
-this package by default. If you want to create full working
-package please build it with the following command:
-"
-       fi
-       echo "$0 --with license_agreement @SPECFILE@"
-fi
This page took 0.070406 seconds and 4 git commands to generate.