]> git.pld-linux.org Git - packages/acroread.git/blame - acroread.spec
- don't use _rel macro. It is was used only in Release tag.
[packages/acroread.git] / acroread.spec
CommitLineData
14b68627 1#
2# Conditional build:
3%bcond_with license_agreement # generates package
4#
26e61bd9 5%define base_name acroread
0eb57bee 6Summary: Adobe Acrobat Reader
aadbc0c6
ER
7Summary(pl.UTF-8): Adobe Acrobat Reader - czytnik plików PDF
8Summary(ru.UTF-8): Программа для чтения документов в формате PDF от Adobe
9Summary(uk.UTF-8): Програма для читання документів у форматі PDF від Adobe
14b68627 10%if %{with license_agreement}
11Name: %{base_name}
12%else
13Name: %{base_name}-installer
14%endif
815aeaff 15Version: 9.1.3
2a7acb80 16Release: 2%{?with_license_agreement:wla}
22bd4e96 17Epoch: 1
ef009d9a
JB
18License: distribution restricted (http://www.adobe.com/products/acrobat/distribute.html)
19# in short:
20# - not distributable on public sites (only linking to adobe.com permitted)
21# - distribution on CD requires signing Distribution Agreement (see URL above)
94abd8dc 22Group: X11/Applications/Graphics
14b68627 23%if %{with license_agreement}
2185f2ce 24Source0: ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/%{version}/enu/AdbeRdr%{version}-1_i486linux_enu.tar.bz2
815aeaff 25# NoSource0-md5: fec3eed6dfc921a6dcc4deab400e207e
ecf5969f 26NoSource: 0
e4f54b4c 27%else
1af9d1cc 28Source1: license-installer.sh
14b68627 29%endif
a189ca6f 30# please update @COPYSOURCES@ below if you add more Sources or Patches.
1af9d1cc 31Source2: %{base_name}.desktop
32Source3: %{base_name}.png
14f626f0 33URL: http://www.adobe.com/products/acrobat/
976c259d 34%if %{with license_agreement}
3e94b2a4 35BuildRequires: rpmbuild(macros) >= 1.357
7a2c413b 36Requires: openldap-libs < 2.5
2da3bb9c 37Requires: openldap-libs >= 2.4
26e61bd9 38%else
1d9c4a3e 39Requires: rpm-build-tools >= 0:4.4.35
976c259d 40%endif
14f626f0 41ExclusiveArch: %{ix86}
9947ca59 42ExcludeArch: i386
aed33851 43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
7985bc82 44
fcf3bf1c 45%define platform intellinux
22bd4e96 46%define tar0 ILINXR.TAR
fcf3bf1c 47%define tar1 COMMON.TAR
94abd8dc 48
dfbbcb35 49%define _noautostrip .*\.api
2da3bb9c 50%define _noautoprov libcrypto\.so.* libssl\.so.* libcurl\.so.* libicu.* libstdc++\.so.* libgcc_s\.so.*
7a2c413b 51%define _noautoreq %{_noautoprov} '^lib.*\.so$' '^lib.*\(VERSION\)$'
f21ac523 52
7985bc82 53%description
26e61bd9
ER
54Adobe(R) Reader(R) is free software that lets you view and print PDF
55files (Portable Document Format) on a variety of hardware and
62807d83 56operating system platforms.
7985bc82 57
e013bd4f
JR
58%description -l pl.UTF-8
59Adobe(R) Reader(R) jest darmowym oprogramowaniem umożliwiającym
60oglądanie oraz drukowanie plików PDF (Portable Document Format) na
61różnych platformach sprzętowych oraz różnych systemach operacyjnych.
7985bc82 62
e013bd4f
JR
63%description -l ru.UTF-8
64Программа для чтения документов в формате Portable Document Format
65(PDF), сгенерированных Adobe Acrobat'ом.
d44545ff 66
e013bd4f
JR
67%description -l uk.UTF-8
68Програма для читання документів у форматі Portable Document Format
69(PDF), згенерованих Adobe Acrobat'ом.
d44545ff 70
f994d3ef 71%package -n browser-plugin-%{name}
ae0ad7e9 72Summary: PDF plugin for Mozilla compatible browsers
aadbc0c6 73Summary(pl.UTF-8): Wtyczka PDF dla przeglądarek zgodnych Mozilla
2e45421f 74Group: X11/Applications
26e61bd9 75Requires: %{base_name} = %{epoch}:%{version}-%{release}
3e94b2a4 76Requires: browser-plugins >= 2.0
f994d3ef 77Obsoletes: acroread-plugin
ae0ad7e9 78Obsoletes: mozilla-plugin-acroread
2e45421f 79
f994d3ef 80%description -n browser-plugin-%{name}
62807d83 81A Mozilla plugin for displaying PDF (Portable Document Format) files.
2e45421f 82
e013bd4f
JR
83%description -n browser-plugin-%{name} -l pl.UTF-8
84Wtyczka Mozilli do wyświetlania plików PDF (Portable Document Format).
2e45421f 85
7985bc82 86%prep
14b68627 87%if %{with license_agreement}
17a8eeab 88%setup -q -c
22bd4e96 89cd AdobeReader
ea015334
AM
90tar xf %{tar0}
91tar xf %{tar1}
14b68627 92%endif
7985bc82 93
94%install
95rm -rf $RPM_BUILD_ROOT
0eb57bee 96%if %{without license_agreement}
14b68627 97install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
98
e4f54b4c
ER
99sed -e '
100 s/@BASE_NAME@/%{base_name}/g
101 s/@TARGET_CPU@/%{_target_cpu}/g
102 s-@VERSION@-%{version}-g
103 s-@RELEASE@-%{release}-g
104 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
105 s,@DATADIR@,%{_datadir}/%{base_name},g
78a918bf 106 s/@COPYSOURCES@/%{base_name}{.desktop,.png}/g
1af9d1cc 107' %{SOURCE1} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
14b68627 108
109install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
14b68627 110install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
1af9d1cc 111install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
14b68627 112
113%else
3e94b2a4 114install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{base_name},%{_browserpluginsdir}} \
a7dabf0b 115 $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
7985bc82 116
c7dc1b0b 117# note: there're also AdobeReader/Adobe/Help{,Viewer}
6dc16e8f 118cd AdobeReader/Adobe/Reader9
14b68627 119cp -a Reader Resource $RPM_BUILD_ROOT%{_libdir}/%{base_name}
120awk -v INSTDIR=%{_libdir}/%{base_name}/Reader \
14f626f0
TP
121 '/^install_dir=/ {print "install_dir="INSTDIR; next} \
122 {print}' \
22bd4e96 123 bin/%{base_name} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}
3e94b2a4 124install Browser/%{platform}/* $RPM_BUILD_ROOT%{_browserpluginsdir}
1af9d1cc 125install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
126install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
22bd4e96 127
6dc16e8f 128cp -a Browser/HowTo $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/
129
3f07d2af 130rm -rf $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Patch
131
7a2c413b
JB
132ln -sf /usr/lib/liblber-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/liblber.so
133ln -sf /usr/lib/libldap-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/libldap.so
22bd4e96
AM
134ln -sf /usr/share/ssl/ca-bundle.crt $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Cert/curl-ca-bundle.crt
135
136chmod a-x $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/*.so.*
14b68627 137%endif
7985bc82 138
139%clean
140rm -rf $RPM_BUILD_ROOT
141
0eb57bee 142%if %{without license_agreement}
5d59434a 143%post
e4f54b4c 144%{_bindir}/%{base_name}.install
3e94b2a4 145%endif
ae0ad7e9 146
3e94b2a4 147%if %{with license_agreement}
148%post -n browser-plugin-%{name}
149%update_browser_plugins
ae0ad7e9 150
3e94b2a4 151%postun -n browser-plugin-%{name}
152if [ "$1" = 0 ]; then
153 %update_browser_plugins
154fi
14b68627 155%endif
156
7985bc82 157%files
158%defattr(644,root,root,755)
0eb57bee 159%if %{without license_agreement}
14b68627 160%attr(755,root,root) %{_bindir}/%{base_name}.install
161%{_datadir}/%{base_name}
162%else
78a918bf 163%doc AdobeReader/ReadMe.htm
7985bc82 164%attr(755,root,root) %{_bindir}/*
14b68627 165%dir %{_libdir}/%{base_name}
166%{_libdir}/%{base_name}/Resource
14b68627 167%dir %{_libdir}/%{base_name}/Reader
168%{_libdir}/%{base_name}/Reader/help
14b68627 169%{_libdir}/%{base_name}/Reader/AcroVersion
22bd4e96
AM
170%{_libdir}/%{base_name}/Reader/Cert
171%{_libdir}/%{base_name}/Reader/GlobalPrefs
172%{_libdir}/%{base_name}/Reader/HowTo
c7dc1b0b 173%{_libdir}/%{base_name}/Reader/IDTemplates
22bd4e96 174%{_libdir}/%{base_name}/Reader/JavaScripts
c7dc1b0b
TP
175%{_libdir}/%{base_name}/Reader/Legal
176%{_libdir}/%{base_name}/Reader/Tracker
177%{_libdir}/%{base_name}/Reader/PDFSigQFormalRep.pdf
178%{_libdir}/%{base_name}/Reader/pmd.cer
78a918bf 179%{_libdir}/%{base_name}/Reader/%{platform}/mozilla
14b68627 180%dir %{_libdir}/%{base_name}/Reader/%{platform}
714a6915 181%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins
c7dc1b0b 182%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia
43255eee 183%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d
714a6915 184%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/SPPlugins
14b68627 185%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/bin
186%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/lib
714a6915 187%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/*.api
43255eee 188%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/*.x3d
78a918bf 189%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia/MPP
714a6915
KK
190%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/AcroForm
191%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Annotations
c7dc1b0b 192%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/prc
a7dabf0b 193%{_desktopdir}/acroread.desktop
8a44dca4 194%{_pixmapsdir}/*
2e45421f 195
f994d3ef 196%files -n browser-plugin-%{name}
2e45421f 197%defattr(644,root,root,755)
3e94b2a4 198%attr(755,root,root) %{_browserpluginsdir}/*
14b68627 199%endif
This page took 0.128354 seconds and 4 git commands to generate.