]> git.pld-linux.org Git - packages/acpi_call.git/blame_incremental - acpi_call.spec
- unconditional noarch subpackages
[packages/acpi_call.git] / acpi_call.spec
... / ...
CommitLineData
1# Conditional build:
2%bcond_without kernel # don't build kernel modules
3%bcond_without userspace # don't build userspace tools
4
5%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
6%{error:kernel and userspace cannot be built at the same time on PLD builders}
7exit 1
8%endif
9
10%define rel 1
11%define pname acpi_call
12Summary: A linux kernel module that enables calls to ACPI methods through /proc/acpi/call
13Name: %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
14Version: 1.1.0
15Release: %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
16License: GPL v2
17Group: Base/Kernel
18Source0: https://github.com/mkottman/acpi_call/archive/v%{version}/%{pname}-%{version}.tar.gz
19# Source0-md5: f69d40e130b0e5ed17ce8adb19e6dda1
20Patch0: %{pname}-build.patch
21URL: https://github.com/mkottman/acpi_call
22%{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
23BuildRequires: rpmbuild(macros) >= 1.701
24ExclusiveArch: %{ix86} %{x8664}
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28A linux kernel module that enables calls to ACPI methods through
29/proc/acpi/call.
30
31%package -n %{pname}-scripts
32Summary: This package contains sample scripts for acpi_call kernel module
33Group: Applications/System
34BuildArch: noarch
35
36%description -n %{pname}-scripts
37This package contains sample scripts for acpi_call kernel module.
38
39%define kernel_pkg()\
40%package -n kernel%{_alt_kernel}-misc-acpi_call\
41Summary: A linux kernel module that enables calls to ACPI methods through /proc/acpi/call\
42Release: %{rel}@%{_kernel_ver_str}\
43Group: Base/Kernel\
44Requires(post,postun): /sbin/depmod\
45%requires_releq_kernel\
46Requires(postun): %releq_kernel\
47\
48%description -n kernel%{_alt_kernel}-misc-acpi_call\
49A linux kernel module that enables calls to ACPI methods through\
50/proc/acpi/call.\
51%files -n kernel%{_alt_kernel}-misc-acpi_call\
52%defattr(644,root,root,755)\
53%doc README.md\
54/lib/modules/%{_kernel_ver}/misc/acpi_call.ko*\
55\
56%post -n kernel%{_alt_kernel}-misc-acpi_call\
57%depmod %{_kernel_ver}\
58\
59%postun -n kernel%{_alt_kernel}-misc-acpi_call\
60%depmod %{_kernel_ver}\
61%{nil}
62
63%define build_kernel_pkg()\
64%build_kernel_modules -m acpi_call\
65%install_kernel_modules -D installed -m acpi_call -d misc\
66%{nil}
67
68%{?with_kernel:%{expand:%create_kernel_packages}}
69
70%prep
71%setup -q -n %{pname}-%{version}
72%patch0 -p1
73
74%build
75%{?with_kernel:%{expand:%build_kernel_packages}}
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80install -d $RPM_BUILD_ROOT
81
82%if %{with userspace}
83install -d $RPM_BUILD_ROOT%{_datadir}/acpi_call
84cp -a examples/* $RPM_BUILD_ROOT%{_datadir}/acpi_call
85%endif
86
87%if %{with kernel}
88cp -a installed/* $RPM_BUILD_ROOT
89%endif
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%if %{with userspace}
95%files -n %{pname}-scripts
96%defattr(644,root,root,755)
97%dir %{_datadir}/acpi_call
98%attr(755,root,root) %{_datadir}/acpi_call/*.sh
99%endif
This page took 0.095663 seconds and 5 git commands to generate.