]> git.pld-linux.org Git - packages/ack.git/blob - ack.spec
- fix R: for strange version of File::Glob
[packages/ack.git] / ack.spec
1 # TODO:
2 # - split /usr/share/perl* part into perl-ack subpackage
3 #
4 # Conditional build:
5 %bcond_without  tests           # do not perform "make test"
6 #
7 %include        /usr/lib/rpm/macros.perl
8 %define pdir    ack
9 Summary:        grep-like text finder
10 Summary(pl.UTF-8):      produkt grepopodobny
11 Name:           ack
12 Version:        2.02
13 Release:        1
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/P/PE/PETDANCE/ack-%{version}.tar.gz
17 # Source0-md5:  9ae2c3939d0f069c6781ee5b6de47c27
18 Patch0:         %{name}-deps.patch
19 URL:            http://betterthangrep.com/
20 %if %{with tests}
21 BuildRequires:  perl-File-Next >= 1.10
22 BuildRequires:  perl-Test-Simple >= 0.98
23 %endif
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  perl-perldoc
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Ack is designed as a replacement for 99% of the uses of grep.
32
33 Ack searches the named input FILEs (or standard input if no files are
34 named, or the file name - is given) for lines containing a match to
35 the given PATTERN. By default, ack prints the matching lines.
36
37 Ack can also list files that would be searched, without actually
38 searching them, to let you take advantage of ack's file-type filtering
39 capabilities.
40
41 %description -l pl.UTF-8
42 ack jest narzędziem podobnym do grepa, zaprojektowanym dla
43 programistów pracujących z dużymi drzewami różnorodnych plików.
44
45 ack jest napisane w czystym Perlu i korzysta z ptęgi wyrażeń
46 regularnych języka Perl.
47
48 %package -n perl-ack
49 Summary:        ack perl library
50 Summary(pl.UTF-8):      biblioteka ack dla języka perl
51 Group:          Development/Languages/Perl
52
53 %description -n perl-ack
54 ack perl library.
55
56 %description -n perl-ack -l pl.UTF-8
57 ack perl library.
58
59 %prep
60 %setup -q -n %{pdir}-%{version}
61 %patch0 -p0
62
63 %build
64 %{__perl} Makefile.PL \
65         INSTALLDIRS=vendor
66 %{__make} \
67         CC="%{__cc}" \
68         OPTIMIZE="%{rpmcflags}"
69
70 %{?with_tests:%{__make} -j1 test}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} pure_install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc Changes README.md
84 %attr(755,root,root) %{_bindir}/ack
85 %{_mandir}/man1/ack.1p*
86
87 %files -n perl-ack
88 %defattr(644,root,root,755)
89 %{perl_vendorlib}/App/Ack.pm
90 %{perl_vendorlib}/App/Ack
This page took 0.098411 seconds and 3 git commands to generate.