]> git.pld-linux.org Git - packages/accelio.git/blob - accelio.spec
- updated comments
[packages/accelio.git] / accelio.spec
1 # TODO:
2 # - fio engine module (BR: headers from fio sources)
3 # - kernel modules (BR: OFED kernel headers)
4 #
5 # Conditional build:
6 %bcond_with     fio             # FIO module
7 %bcond_with     kernel          # kernel modules
8 %bcond_without  static_libs     # static libraries
9 #
10 Summary:        Open Source I/O, Message and RPC Acceleration library
11 Summary(pl.UTF-8):      Mająca otwarte źródła biblioteka przyspieszająca we/wy, komunikaty i RPC
12 Name:           accelio
13 Version:        1.3
14 Release:        1
15 License:        BSD
16 Group:          Libraries
17 Source0:        https://github.com/accelio/accelio/archive/v%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  3a75f4139c72a797740a50e8033f74ae
19 URL:            http://www.accelio.org/
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake >= 1:1.11
22 BuildRequires:  libaio-devel
23 BuildRequires:  libevent-devel >= 2
24 BuildRequires:  libibverbs-devel
25 BuildRequires:  libtool >= 2:2
26 BuildRequires:  numactl-devel
27 BuildRequires:  sed >= 4.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Accelio provides an easy-to-use, reliable, scalable, and high
32 performance data/message delivery middleware that maximizes the
33 efficiency of modern CPU and NIC hardware and that reduces
34 time-to-market of new scale-out applications.
35
36 %description -l pl.UTF-8
37 Accelio dostarcza łatwą w użyciu, wiarygodną, skalowalną i szybką
38 warstwę pośrednią przekazującą dane i komunikaty, maksymalizującą
39 wydajność współczesnych CPU i NIC, zmniejszającą czas potrzebny
40 na wytworzenie nowych aplikacji.
41
42 %package devel
43 Summary:        Header files for Accelio libraries
44 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Accelio
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47
48 %description devel
49 Header files for Accelio libraries.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe bibliotek Accelio.
53
54 %package static
55 Summary:        Static Accelio libraries
56 Summary(pl.UTF-8):      Statyczne biblioteki Accelio
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static Accelio libraries.
62
63 %description static -l pl.UTF-8
64 Statyczne biblioteki Accelio.
65
66 %prep
67 %setup -q
68
69 %{__sed} -i -e 's/-Werror //' configure.ac
70
71 %build
72 %{__libtoolize}
73 %{__aclocal}
74 %{__autoconf}
75 %{__automake}
76 for d in src/kernel/xio src/kernel/rdma src/kernel/tcp examples/kernel/hello_world examples/kernel/hello_world_mt tests/kernel/hello_test ; do
77 cd $d
78 %{__autoconf}
79 cd -
80 done
81 %configure \
82         --disable-silent-rules \
83         %{!?with_static_libs:--disable-static} \
84         %{?with_fio:--enable-fio-build} \
85         %{?with_kernel:--enable-kernel-module}
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc AUTHORS COPYING ChangeLog NEWS README README.md
103 %attr(755,root,root) %{_bindir}/raio_client
104 %attr(755,root,root) %{_bindir}/raio_server
105 %attr(755,root,root) %{_bindir}/reg_basic_mt
106 %attr(755,root,root) %{_bindir}/xio_*
107 %attr(755,root,root) %{_bindir}/xioclntd
108 %attr(755,root,root) %{_bindir}/xiosrvd
109 %attr(755,root,root) %{_libdir}/libraio.so.*.*.*
110 %attr(755,root,root) %ghost %{_libdir}/libraio.so.0
111 %attr(755,root,root) %{_libdir}/libxio.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libxio.so.0
113
114 %files devel
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/libraio.so
117 %attr(755,root,root) %{_libdir}/libxio.so
118 %{_libdir}/libraio.la
119 %{_libdir}/libxio.la
120 %{_includedir}/libraio.h
121 %{_includedir}/libxio.h
122 %{_includedir}/xio_base.h
123 %{_includedir}/xio_predefs.h
124 %{_includedir}/xio_user.h
125
126 %if %{with static_libs}
127 %files static
128 %defattr(644,root,root,755)
129 %{_libdir}/libraio.a
130 %{_libdir}/libxio.a
131 %endif
This page took 0.087242 seconds and 3 git commands to generate.