]> git.pld-linux.org Git - packages/accel-ppp.git/blob - accel-ppp.spec
- initscript: one kill is really enough, different versions came from template; add...
[packages/accel-ppp.git] / accel-ppp.spec
1 # TODO:
2 # - check accel-ppp.tmpfiles
3 # - logrotate archivedir
4 # - add bconds
5 # - initscript: remove duplicate force-reload, remove one depending whether it supports reload or not
6 #
7 Summary:        High performance PPTP/L2TP/PPPoE server
8 Name:           accel-ppp
9 Version:        1.6.1
10 Release:        0.1
11 License:        GPL v2+
12 Group:          Networking
13 URL:            http://sourceforge.net/projects/accel-ppp/
14 Source0:        http://downloads.sourceforge.net/accel-ppp/%{name}-%{version}.tar.bz2
15 # Source0-md5:  8985ab9f743b952396f6dc53d6fd56a8
16 Source1:        %{name}.tmpfiles
17 Source2:        %{name}.init
18 Source3:        %{name}.logrotate
19 Patch0:         %{name}-cmake.patch
20 Patch1:         %{name}-cmake-lib64.patch
21 BuildRequires:  cmake >= 2.6
22 BuildRequires:  libnl1-devel
23 BuildRequires:  net-snmp-devel >= 5.0
24 BuildRequires:  openssl-devel
25 BuildRequires:  pcre-devel
26 BuildRequires:  rpmbuild(macros) >= 1.600
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The ACCEL-PPP is completly new implementation of PPTP/PPPoE/L2TP which
31 was written from scratch. Userspace daemon has its own PPP
32 implementation, so it does not uses pppd and one process
33 (multi-threaded) manages all connections. ACCEL-PPP uses only
34 kernel-mode implementations of pptp/l2tp/pppoe.
35
36 Features:
37 - PPTP server
38 - PPPoE server
39 - L2TPv2 server
40 - Radius CoA/DM(PoD)
41 - Built-in shaper (tbf)
42 - Command line interface (telnet)
43 - SNMP
44 - IPv6 (including builtin Neighbor Discovery and DHCPv6)
45
46 %prep
47 %setup -q
48 %patch0 -p1
49 %ifarch %{x8664}
50 %patch1 -p1
51 %endif
52
53 %build
54 install -d build
55 cd build
56 %cmake \
57         -DSHAPER=TRUE \
58         -DRADIUS=TRUE \
59         -DNETSNMP=TRUE \
60         -DBUILD_INSTALL_PREFIX=$RPM_BUILD_ROOT \
61         -DLOG_PGSQL=FALSE \
62         ..
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 %{__make} -C build install/fast \
68           DESTDIR=$RPM_BUILD_ROOT
69
70 install -d $RPM_BUILD_ROOT/etc/{sysconfig,logrotate.d,rc.d/init.d} $RPM_BUILD_ROOT%{systemdtmpfilesdir}
71 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
72 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/accel-pppd
73 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
74 echo "0" > $RPM_BUILD_ROOT/var/run/accel-ppp/seq
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc README
82 %dir %{_sysconfdir}
83 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/accel-ppp.conf.dist
84 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
85 %attr(755,root,root) %{_sbindir}/accel-pppd
86 %attr(755,root,root) %{_libdir}/accel-ppp
87 %attr(754,root,root) /etc/rc.d/init.d/accel-pppd
88 %dir /var/run/%{name}
89 # XXX do you really want to overwrite this?
90 /var/run/%{name}/seq
91 %{systemdtmpfilesdir}/%{name}.conf
92 %{_datadir}/%{name}
93 %{_mandir}/man5/accel-ppp.conf.5*
94 %dir /var/log/accel-ppp
This page took 0.044959 seconds and 3 git commands to generate.