]> git.pld-linux.org Git - packages/accel-ppp.git/blob - accel-ppp.spec
- removed duplicated status
[packages/accel-ppp.git] / accel-ppp.spec
1 #
2 # TODO:
3 #
4 # - change libdir from /usr/lib to %{_libdir}
5 # - check accel-ppp.tmpfiles
6 # - add bconds
7 #
8 Summary:        High performance PPTP/L2TP/PPPoE server
9 Name:           accel-ppp
10 Version:        1.6.1
11 Release:        0.1
12 License:        GPL v2+
13 Group:          Networking
14 URL:            http://sourceforge.net/projects/accel-ppp/
15 Source0:        http://downloads.sourceforge.net/accel-ppp/%{name}-%{version}.tar.bz2
16 # Source0-md5:  8985ab9f743b952396f6dc53d6fd56a8
17 Source1:        %{name}.tmpfiles
18 Source2:        %{name}.init
19 Patch0:         %{name}-cmake.patch
20 BuildRequires:  cmake >= 2.6
21 BuildRequires:  libnl1-devel
22 BuildRequires:  net-snmp-devel >= 5.0
23 BuildRequires:  openssl-devel
24 BuildRequires:  pcre-devel
25
26 %description
27 The ACCEL-PPP is completly new implementation of PPTP/PPPoE/L2TP which
28 was written from scratch. Userspace daemon has its own PPP
29 implementation, so it does not uses pppd and one process
30 (multi-threaded) manages all connections. ACCEL-PPP uses only
31 kernel-mode implementations of pptp/l2tp/pppoe.
32
33 Features:
34 - PPTP server
35 - PPPoE server
36 - L2TPv2 server
37 - Radius CoA/DM(PoD)
38 - Built-in shaper (tbf)
39 - Command line interface (telnet)
40 - SNMP
41 - IPv6 (including builtin Neighbor Discovery and DHCPv6)
42
43
44 %prep
45 %setup -q
46 %patch0 -p1
47
48 %build
49 install -d build
50 cd build
51 %{cmake} \
52           -DSHAPER=TRUE \
53           -DRADIUS=TRUE \
54                   -DNETSNMP=TRUE \
55           -DLOG_PGSQL=FALSE \
56           ../
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 %{__make} -C build install/fast \
62           DESTDIR=$RPM_BUILD_ROOT
63
64 install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d} $RPM_BUILD_ROOT%{systemdtmpfilesdir}
65 install -d $RPM_BUILD_ROOT/var/{log/accel-ppp,run/accel-ppp}
66 install %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
67 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/
68 echo "0" > $RPM_BUILD_ROOT/var/run/accel-ppp/seq
69
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc COPYING README
77 %dir %{_sysconfdir}
78 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/accel-ppp.conf.dist
79 %attr(755,root,root) %{_sbindir}/accel-pppd
80 %attr(755,root,root) %{_prefix}/lib/accel-ppp
81 %attr(754,root,root) /etc/rc.d/init.d/
82 %dir /var/run/%{name}
83 /var/run/%{name}/seq
84 %{systemdtmpfilesdir}/%{name}.conf
85 %{_datadir}/accel-ppp/
86 %{_mandir}/man5/accel-ppp.conf.5*
87 %dir /var/log/accel-ppp
This page took 0.405351 seconds and 3 git commands to generate.