]> git.pld-linux.org Git - packages/accel-ppp.git/blob - accel-ppp.spec
- updated description
[packages/accel-ppp.git] / accel-ppp.spec
1 # TODO:
2 # - check accel-ppp.tmpfiles
3 # - logrotate archivedir
4 # - add bconds
5 # - initscript: remove duplicate force-reload, remove one depending whether it supports reload or not
6 #
7 Summary:        High performance PPTP/L2TP/PPPoE server
8 Name:           accel-ppp
9 Version:        1.8.0
10 Release:        1
11 License:        GPL v2+
12 Group:          Networking
13 URL:            http://sourceforge.net/projects/accel-ppp
14 Source0:        http://downloads.sourceforge.net/accel-ppp/%{name}-%{version}.tar.bz2
15 # Source0-md5:  bc3a02b24fb9f304f7417a9011a494d6
16 Source1:        %{name}.tmpfiles
17 Source2:        %{name}.init
18 Source3:        %{name}.logrotate
19 Source4:        %{name}.sysconfig
20 BuildRequires:  cmake >= 2.6
21 BuildRequires:  libnl1-devel
22 BuildRequires:  net-snmp-devel >= 5.0
23 BuildRequires:  openssl-devel
24 BuildRequires:  pcre-devel
25 BuildRequires:  rpmbuild(macros) >= 1.600
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The ACCEL-PPP is completly new implementation of PPTP/PPPoE/L2TP which
30 was written from scratch. Userspace daemon has its own PPP
31 implementation, so it does not uses pppd and one process
32 (multi-threaded) manages all connections. ACCEL-PPP uses only
33 kernel-mode implementations of pptp/l2tp/pppoe.
34
35 Features:
36 - PPTP server
37 - PPPoE server
38 - L2TPv2 server
39 - Radius CoA/DM(PoD)
40 - Built-in shaper
41 - Command line interface
42 - SNMP
43 - IPv6 (including builtin Neighbor Discovery and DHCPv6)
44 - IPoE (start session by DHCPv4 or unclassified IPv4 packet)
45
46 %prep
47 %setup -q
48
49 %build
50 install -d build
51 cd build
52 %cmake \
53         -DSHAPER=TRUE \
54         -DRADIUS=TRUE \
55         -DNETSNMP=TRUE \
56         -DLOG_PGSQL=FALSE \
57         ..
58
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 %{__make} -C build install/fast \
64           DESTDIR=$RPM_BUILD_ROOT
65
66 install -d $RPM_BUILD_ROOT/etc/{sysconfig,logrotate.d,rc.d/init.d} $RPM_BUILD_ROOT%{systemdtmpfilesdir} $RPM_BUILD_ROOT/var/log/accel-ppp
67 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
68 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/accel-pppd
69 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
70 install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/accel-ppp
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc README
78 %dir %{_sysconfdir}
79 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/accel-ppp.conf.dist
80 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
81 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
82 %attr(755,root,root) %{_bindir}/accel-cmd
83 %attr(755,root,root) %{_sbindir}/accel-pppd
84 %attr(755,root,root) %{_libdir}/accel-ppp
85 %attr(754,root,root) /etc/rc.d/init.d/accel-pppd
86 %{systemdtmpfilesdir}/%{name}.conf
87 %{_datadir}/%{name}
88 %{_mandir}/man1/accel-cmd.*
89 %{_mandir}/man5/accel-ppp.conf.5*
90 %dir /var/log/accel-ppp
This page took 0.067279 seconds and 3 git commands to generate.