]> git.pld-linux.org Git - packages/abrt.git/blob - abrt.spec
- python3 rebuild
[packages/abrt.git] / abrt.spec
1 #
2 # TODO:
3 # - handle obsolete packages: abrt-plugin-{catcut,rhfastcheck,rhticket,ticketuploader}
4 # - SysV init scripts for -addon-ccpp, -addon-kerneloops, -addon-pstoreoops, -addon-upload-watch, -addon-vmcore, -addon-xorg
5 # - teach build system to use python3.2+ __pycache__
6 #
7 # Conditional build:
8 %bcond_without  tests   # disable pythontests
9 #
10 %define         libreport_ver   2.6.0
11 Summary:        Automatic bug detection and reporting tool
12 Summary(pl.UTF-8):      Narzędzie do automatycznego wykrywania i zgłaszania błędów
13 Name:           abrt
14 Version:        2.6.0
15 Release:        2
16 License:        GPL v2+
17 Group:          Applications/System
18 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
19 # Source0-md5:  b764d6a2a12aaae8cbab3fb7fbe37089
20 Source1:        %{name}.init
21 Patch0:         %{name}-rpm5.patch
22 Patch1:         %{name}-rpm45.patch
23 Patch2:         format_security.patch
24 Patch3:         %{name}-link.patch
25 Patch4:         profile.sh.patch
26 URL:            https://fedorahosted.org/abrt/
27 BuildRequires:  asciidoc
28 BuildRequires:  autoconf >= 2.50
29 BuildRequires:  automake
30 BuildRequires:  dbus-devel
31 BuildRequires:  gettext-tools >= 0.17
32 BuildRequires:  glib2-devel >= 1:2.43
33 BuildRequires:  gsettings-desktop-schemas-devel >= 3.15.1
34 BuildRequires:  gtk+3-devel >= 3.0
35 BuildRequires:  intltool >= 0.35.0
36 BuildRequires:  json-c-devel
37 BuildRequires:  libmagic-devel
38 BuildRequires:  libnotify-devel >= 0.7.0
39 BuildRequires:  libreport-devel >= %{libreport_ver}
40 BuildRequires:  libreport-gtk-devel >= %{libreport_ver}
41 BuildRequires:  libreport-web-devel >= %{libreport_ver}
42 BuildRequires:  libselinux-devel
43 BuildRequires:  libtool
44 BuildRequires:  libxml2-devel >= 2
45 BuildRequires:  nss-devel
46 BuildRequires:  pkgconfig
47 BuildRequires:  polkit-devel
48 BuildRequires:  python-devel >= 2
49 BuildRequires:  python-modules >= 2
50 %{?with_tests:BuildRequires:    python-nose}
51 BuildRequires:  python3-devel >= 3
52 BuildRequires:  python3-modules >= 3
53 BuildRequires:  rpm-devel >= 4.5-28
54 BuildRequires:  rpm-pythonprov
55 BuildRequires:  rpmbuild(macros) >= 1.219
56 BuildRequires:  satyr-devel
57 BuildRequires:  systemd-devel
58 BuildRequires:  xmlto
59 BuildRequires:  xorg-lib-libICE-devel
60 BuildRequires:  xorg-lib-libSM-devel
61 Requires(postun):       /usr/sbin/groupdel
62 Requires(postun):       /usr/sbin/userdel
63 Requires(pre):  /bin/id
64 Requires(pre):  /usr/bin/getgid
65 Requires(pre):  /usr/sbin/groupadd
66 Requires(pre):  /usr/sbin/useradd
67 Requires:       %{name}-libs = %{version}-%{release}
68 Provides:       group(abrt)
69 Provides:       user(abrt)
70 Obsoletes:      abrt-plugin-filetransfer
71 Obsoletes:      abrt-plugin-runapp
72 Obsoletes:      abrt-plugin-sosreport
73 Obsoletes:      abrt-plugin-sqlite3
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %description
77 ABRT is a tool to help users to detect defects in applications and to
78 create a bug report with all informations needed by maintainer to fix
79 it. It uses plugin system to extend its functionality.
80
81 %description -l pl.UTF-8
82 ABRT to narzędzie pomagające użytkownikom w wykrywaniu defektów w
83 aplikacjach oraz tworzeniu raportów błędów ze wszystkimi informacjami
84 potrzebnymi utrzymującemu pakiet do poprawienia go. Wykorzystuje
85 system wtyczek do rozszerzania funkcjonalności.
86
87 %package libs
88 Summary:        ABRT shared library
89 Summary(pl.UTF-8):      Biblioteka współdzielona ABRT
90 Group:          Libraries
91 Requires:       glib2 >= 1:2.43
92 Requires:       libreport >= %{libreport_ver}
93
94 %description libs
95 ABRT shared library.
96
97 %description libs -l pl.UTF-8
98 Biblioteka współdzielona ABRT.
99
100 %package devel
101 Summary:        Header files for ABRT livrary
102 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotekia ABRT
103 Group:          Development/Libraries
104 Requires:       %{name}-libs = %{version}-%{release}
105 Requires:       glib2-devel >= 1:2.43
106 Requires:       libreport-devel >= %{libreport_ver}
107
108 %description devel
109 Header files for ABRT livrary.
110
111 %description devel -l pl.UTF-8
112 Pliki nagłówkowe biblioteki ABRT.
113
114 %package addon-ccpp
115 Summary:        ABRT's C/C++ addon
116 Summary(pl.UTF-8):      Dodatek C/C++ do ABRT
117 Group:          Libraries
118 Requires:       %{name} = %{version}-%{release}
119 Requires:       %{name}-addon-coredump-helper = %{version}-%{release}
120 Requires:       %{name}-retrace-client = %{version}-%{release}
121 Requires:       cpio
122 Requires:       elfutils
123 Requires:       gdb >= 7.0-3
124 Requires:       satyr
125 Requires:       yum-utils
126 Obsoletes:      %{name}-atomic
127
128 %description addon-ccpp
129 This package contains hook for C/C++ crashed programs and abrt's C/C++
130 analyzer plugin.
131
132 %description addon-ccpp -l pl.UTF-8
133 Ten pakiet zawiera punkt zaczepienia dla programów w C/C++, które
134 uległy awarii oraz wtyczkę analizatora C/C++ ABRT.
135
136 %package addon-coredump-helper
137 Summary:        ABRT's /proc/sys/kernel/core_pattern helper
138 Summary(pl.UTF-8):      Program pomocniczy ABRT do /proc/sys/kernel/core_pattern
139 Group:          Libraries
140 Requires:       %{name}-libs = %{version}-%{release}
141
142 %description addon-coredump-helper
143 This package contains hook for C/C++ crashed programs.
144
145 %description addon-coredump-helper -l pl.UTF-8
146 Ten pakiet zawiera uchwyt dla programów w C/C++, które uległy awarii.
147
148 %package addon-kerneloops
149 Summary:        ABRT's kerneloops addon
150 Summary(pl.UTF-8):      Dodatek kerneloops do ABRT
151 Group:          Libraries
152 Requires:       %{name} = %{version}-%{release}
153 Requires:       curl
154 Requires:       libreport-plugin-kerneloops >= %{libreport_ver}
155 Obsoletes:      abrt-plugin-kerneloops
156 Obsoletes:      abrt-plugin-kerneloopsreporter
157 Obsoletes:      kerneloops
158
159 %description addon-kerneloops
160 This package contains plugin for collecting kernel crash information
161 from system log.
162
163 %description addon-kerneloops -l pl.UTF-8
164 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
165 logu systemowego.
166
167 %package addon-pstoreoops
168 Summary:        ABRT's pstoreoops addon
169 Summary(pl.UTF-8):      Dodatek pstoreoops do ABRT
170 Group:          Libraries
171 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
172 Obsoletes:      abrt-addon-uefioops
173
174 %description addon-pstoreoops
175 This package contains plugin for collecting kernel oopses from pstore
176 storage.
177
178 %description addon-pstoreoops -l pl.UTF-8
179 Ten pakiet zawiera wtyczkę do zbierania oopsów jądra z danych pstore.
180
181 %package addon-python
182 Summary:        ABRT's addon for catching and analyzing Python 2 exceptions
183 Summary(pl.UTF-8):      Dodatek ABRT do przechwytywania i analizy wyjątków Pythona 2
184 Group:          Libraries
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       %{name}-python = %{version}-%{release}
187 # for detecting package name containing offending file
188 Suggests:       python-rpm
189 # for logging to journal
190 Suggests:       python-systemd
191 Obsoletes:      gnome-python2-bugbuddy
192
193 %description addon-python
194 This package contains Python hook and Python analyzer plugin for
195 handling uncaught exception in Python 2 programs.
196
197 %description addon-python -l pl.UTF-8
198 Ten pakiet zawiera pythonowy punkt zaczepienia oraz wtyczkę
199 analizatora Pythona do obsługi nie obsłużonych wyjątków w programach w
200 Pythonie 2.
201
202 %package addon-python3
203 Summary:        ABRT's addon for catching and analyzing Python 3 exceptions
204 Summary(pl.UTF-8):      Dodatek ABRT do przechwytywania i analizy wyjątków Pythona 3
205 Group:          Libraries
206 Requires:       %{name} = %{version}-%{release}
207 Requires:       %{name}-python3 = %{version}-%{release}
208 # for detecting package name containing offending file (TODO: python3-rpm package)
209 #Suggests:      python3-rpm
210 # for logging to journal (TODO: python3-systemd package)
211 #Suggests:      python3-systemd
212
213 %description addon-python3
214 This package contains Python hook and Python analyzer plugin for
215 handling uncaught exception in Python 3 programs.
216
217 %description addon-python3 -l pl.UTF-8
218 Ten pakiet zawiera pythonowy punkt zaczepienia oraz wtyczkę
219 analizatora Pythona do obsługi nie obsłużonych wyjątków w programach w
220 Pythonie 3.
221
222 %package addon-upload-watch
223 Summary:        ABRT's upload addon
224 Summary(pl.UTF-8):      Dodatek upload do ABRT
225 Group:          Libraries
226 Requires:       %{name} = %{version}-%{release}
227
228 %description addon-upload-watch
229 This package contains hook for uploaded problems.
230
231 %description addon-upload-watch -l pl.UTF-8
232 Ten pakiet zawiera uchwyt dla problemów przysłanych.
233
234 %package addon-vmcore
235 Summary:        ABRT's vmcore addon
236 Summary(pl.UTF-8):      Dodatek vmcore do ABRT
237 Group:          Libraries
238 Requires:       %{name} = %{version}-%{release}
239 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
240 Requires:       crash
241
242 %description addon-vmcore
243 This package contains plugin for collecting kernel crash information
244 from vmcore files.
245
246 %description addon-vmcore -l pl.UTF-8
247 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
248 plików vmcore.
249
250 %package addon-xorg
251 Summary:        ABRT's Xorg addon
252 Summary(pl.UTF-8):      Dodatek Xorg do ABRT
253 Group:          Libraries
254 Requires:       %{name} = %{version}-%{release}
255 Requires:       curl
256
257 %description addon-xorg
258 This package contains plugin for collecting Xorg crash information
259 from Xorg log.
260
261 %description addon-xorg -l pl.UTF-8
262 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
263 logu Xorg.
264
265 %package atomic
266 Summary:        Package to make easy default installation on Atomic hosts
267 Summary(pl.UTF-8):      Pakiet ułatwiający domyślną instalację na hostach Atomic
268 Group:          Applications/System
269 Requires:       %{name}-addon-coredump-helper = %{version}-%{release}
270 Obsoletes:      %{name}-addon-ccpp
271
272 %description atomic
273 Package to install all necessary packages for usage from Atomic hosts.
274
275 %description atomic -l pl.UTF-8
276 Pakiet służący do instalacji wszystkich wymaganych pakietów
277 przeznaczonych do użycia z hostów Atomic.
278
279 %package plugin-bodhi
280 Summary:        ABRT's bodhi plugin
281 Summary(pl.UTF-8):      Wtyczka bodhi do ABRT
282 Group:          Libraries
283 Requires:       %{name} = %{version}-%{release}
284 Requires:       libreport-web >= %{libreport_ver}
285 Obsoletes:      libreport-plugin-bodhi
286
287 %description plugin-bodhi
288 Plugin to search for a new updates in bodhi server.
289
290 %description plugin-bodhi -l pl.UTF-8
291 Wtyczka do wyszukiwania nowych uaktualnień na serwerze bodhi.
292
293 %package retrace-client
294 Summary:        ABRT's retrace client
295 Summary(pl.UTF-8):      Klient Retrace dla ABRT
296 Group:          Libraries
297 Requires:       %{name} = %{version}-%{release}
298 Requires:       xz
299
300 %description retrace-client
301 This package contains the client application for Retrace server which
302 is able to analyze C/C++ crashes remotely.
303
304 %description retrace-client -l pl.UTF-8
305 Ten pakiet zawiera aplikację kliencką dla serwera Retrace, który
306 potrafi zdalnie przeanalizować awarię programu w C/C++.
307
308 %package dbus
309 Summary:        ABRT DBus service
310 Summary(pl.UTF-8):      Usługa DBus ABRT
311 Group:          Applications/System
312 Requires:       %{name} = %{version}-%{release}
313 Requires:       libreport >= %{libreport_ver}
314
315 %description dbus
316 ABRT DBus service which provides org.freedesktop.problems API on DBus
317 and uses PolicyKit to authorize to access the problem data.
318
319 %description dbus -l pl.UTF-8
320 Usługa DBus ABRT, udostępniająca poprzez DBus API
321 org.freedesktop.problems, używająca PolicyKit do autoryzacji dostępu
322 do danych o problemach.
323
324 %package python
325 Summary:        ABRT Python 2 API
326 Summary(pl.UTF-8):      API Pythona 2 do ABRT
327 Group:          Libraries/Python
328 Requires:       %{name} = %{version}-%{release}
329 Requires:       python-libreport >= %{libreport_ver}
330
331 %description python
332 High-level API for querying, creating and manipulating problems
333 handled by ABRT in Python 2.
334
335 %description python -l pl.UTF-8
336 Wysokopoziomowe API do odpytywania, tworzenia i obróbki z poziomu
337 Pythona 2 problemów obsługiwanych przez ABRT.
338
339 %package python3
340 Summary:        ABRT Python 3 API
341 Summary(pl.UTF-8):      API Pythona 3 do ABRT
342 Group:          Libraries/Python
343 Requires:       %{name} = %{version}-%{release}
344 Requires:       python3-libreport >= %{libreport_ver}
345
346 %description python3
347 High-level API for querying, creating and manipulating problems
348 handled by ABRT in Python.
349
350 %description python3 -l pl.UTF-8
351 Wysokopoziomowe API do odpytywania, tworzenia i obróbki z poziomu
352 Pythona 3 problemów obsługiwanych przez ABRT.
353
354 %package cli
355 Summary:        ABRT's command line interface
356 Summary(pl.UTF-8):      Interfejs linii poleceń ABRT
357 Group:          Applications/System
358 Requires:       %{name} = %{version}-%{release}
359 # analyzers
360 Requires:       %{name}-addon-ccpp = %{version}-%{release}
361 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
362 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
363 Requires:       %{name}-addon-python = %{version}-%{release}
364 # reporters
365 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
366 Requires:       libreport-plugin-logger >= %{libreport_ver}
367
368 %description cli
369 This package contains simple command line client for controling ABRT
370 daemon over the sockets.
371
372 %description cli -l pl.UTF-8
373 Ten pakiet zawiera prostego klienta obsługiwanego z linii poleceń,
374 pozwalającego na sterowanie demonem poprzez gniazda.
375
376 %package gui
377 Summary:        ABRT's GUI
378 Summary(pl.UTF-8):      Graficzny interfejs użytkownika do ABRT
379 Group:          X11/Applications
380 Requires(post,postun):  /sbin/ldconfig
381 Requires(post,postun):  gtk-update-icon-cache
382 Requires(post,postun):  hicolor-icon-theme
383 Requires:       %{name} = %{version}-%{release}
384 Requires:       %{name}-dbus = %{version}-%{release}
385 Requires:       %{name}-gui-libs = %{version}-%{release}
386 Suggests:       gnome-abrt
387 Provides:       abrt-applet = %{version}-%{release}
388 Obsoletes:      abrt-applet < 0.0.5
389 Conflicts:      abrt-applet < 0.0.5
390
391 %description gui
392 GTK+ wizard for convenient bug reporting.
393
394 %description gui -l pl.UTF-8
395 Oparty na GTK+ kreator do wygodnego zgłaszania błędów.
396
397 %package gui-libs
398 Summary:        ABRT's GUI library
399 Summary(pl.UTF-8):      Biblioteka graficznego interfejsu użytkownika ABRT
400 Group:          X11/Libraries
401 Requires:       %{name}-libs = %{version}-%{release}
402 Requires:       gtk+3 >= 3.0
403
404 %description gui-libs
405 ABRT's GUI library.
406
407 %description gui-libs -l pl.UTF-8
408 Biblioteka graficznego interfejsu użytkownika ABRT.
409
410 %package gui-devel
411 Summary:        Header files for ABRT GUI library
412 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT
413 Group:          X11/Development/Libraries
414 Requires:       %{name}-devel = %{version}-%{release}
415 Requires:       %{name}-gui-libs = %{version}-%{release}
416 Requires:       gtk+3-devel >= 3.0
417
418 %description gui-devel
419 Header files for ABRT GUI library.
420
421 %description gui-devel -l pl.UTF-8
422 Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT.
423
424 %package desktop
425 Summary:        Virtual package to install all necessary packages for usage from desktop environment
426 Summary(pl.UTF-8):      Writualny pakiet do instalacji pakietów potrzebnych do użycia w środowisku graficznym
427 Group:          X11/Applications
428 # This package should be installed when anything requests bug-buddy;
429 # installing abrt-desktop should result in the abrt which works without
430 # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
431 Requires:       %{name} = %{version}-%{release}
432 Requires:       %{name}-addon-ccpp = %{version}-%{release}
433 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
434 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
435 Requires:       %{name}-addon-python = %{version}-%{release}
436 Requires:       %{name}-addon-vmcore = %{version}-%{release}
437 Requires:       %{name}-addon-xorg = %{version}-%{release}
438 Requires:       %{name}-gui = %{version}-%{release}
439 Requires:       %{name}-plugin-bodhi = %{version}-%{release}
440 Requires:       %{name}-retrace-client = %{version}-%{release}
441 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
442 Requires:       libreport-plugin-logger >= %{libreport_ver}
443 Requires:       libreport-plugin-ureport >= %{libreport_ver}
444 Provides:       bug-buddy
445 Obsoletes:      bug-buddy
446
447 %description desktop
448 Virtual package to make easy default installation on desktop
449 environments.
450
451 %description desktop -l pl.UTF-8
452 Wirtualny pakiet ułatwiający domyślną instalację w środowiskach
453 graficznych.
454
455 %package console-notification
456 Summary:        ABRT console notification script
457 Summary(pl.UTF-8):      Skrypt ABRT do powiadomień na konsoli
458 Group:          Applications/System
459 Requires:       %{name} = %{version}-%{release}
460 Requires:       %{name}-cli = %{version}-%{release}
461
462 %description console-notification
463 A small script which prints a count of detected problems when someone
464 logs in to the shell.
465
466 %description console-notification -l pl.UTF-8
467 Mały skrypt wypisujący liczbę wykrytych problemów, kiedy ktoś loguje
468 się do powłoki.
469
470 %prep
471 %setup -q
472 %if "%{_rpmversion}" >= "5.0"
473 %patch0 -p1
474 %else
475 %patch1 -p1
476 %endif
477 %patch2 -p1
478 %patch3 -p1
479 %patch4 -p1
480
481 %build
482 %{__libtoolize}
483 %{__aclocal}
484 %{__autoconf}
485 %{__autoheader}
486 %{__automake}
487 %configure \
488         --disable-silent-rules \
489         %{!?with_tests:--without-pythontests} \
490         --with-systemdsystemunitdir=%{systemdunitdir}
491
492 %{__make}
493
494 %install
495 rm -rf $RPM_BUILD_ROOT
496 %{__make} install \
497         DESTDIR=$RPM_BUILD_ROOT
498
499 %py_postclean
500
501 # obsoleted by pkg-config
502 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
503
504 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/abrtd
505 install -d $RPM_BUILD_ROOT/var/cache/%{name}
506 install -d $RPM_BUILD_ROOT/var/cache/%{name}-di
507 install -d $RPM_BUILD_ROOT/var/run/%{name}
508
509 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
510 cat > $RPM_BUILD_ROOT%{systemdtmpfilesdir}/abrt.conf <<EOF
511 d /var/run/%{name} 0755 root root -
512 EOF
513
514 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/problem/*.la
515 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/problem/*.la
516 # examples
517 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/problem_examples
518 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/problem_examples
519 # empty version of ru
520 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ru_RU
521
522 # fool man verification - report_event.conf.5 belongs to libreport (NOTE: don't package it here)
523 touch $RPM_BUILD_ROOT%{_mandir}/man5/report_event.conf.5
524
525 %find_lang %{name}
526
527 %clean
528 rm -rf $RPM_BUILD_ROOT
529
530 %pre
531 %groupadd -g 248 abrt
532 %useradd -u 248 -g abrt -d /etc/abrt -s /sbin/nologin abrt
533
534 %post
535 /sbin/chkconfig --add abrtd
536 %service abrtd restart
537 %systemd_post abrtd.service
538
539 %preun
540 if [ "$1" = "0" ]; then
541         %service abrtd stop
542         /sbin/chkconfig --del abrtd
543 fi
544 %systemd_preun abrtd.service
545
546 %postun
547 if [ "$1" = "0" ]; then
548         %userremove abrt
549         %groupremove abrt
550 fi
551
552 %post   libs -p /sbin/ldconfig
553 %postun libs -p /sbin/ldconfig
554
555 %post addon-ccpp
556 %systemd_post abrt-ccpp.service
557 %systemd_post abrt-journal-core.service
558
559 %preun addon-ccpp
560 %systemd_preun abrt-ccpp.service
561 %systemd_preun abrt-journal-core.service
562
563 %post addon-kerneloops
564 %systemd_post abrt-oops.service
565
566 %preun addon-kerneloops
567 %systemd_preun abrt-oops.service
568
569 %post addon-pstoreoops
570 %systemd_post abrt-pstoreoops.service
571
572 %preun addon-pstoreoops
573 %systemd_preun abrt-pstoreoops.service
574
575 %post addon-upload-watch
576 %systemd_post abrt-upload-watch.service
577
578 %preun addon-upload-watch
579 %systemd_preun abrt-upload-watch.service
580
581 %post addon-vmcore
582 %systemd_post abrt-vmcore.service
583
584 %preun addon-vmcore
585 %systemd_preun abrt-vmcore.service
586
587 %post addon-xorg
588 %systemd_post abrt-xorg.service
589
590 %preun addon-xorg
591 %systemd_preun abrt-xorg.service
592
593 %post atomic
594 if [ -f %{_sysconfdir}/%{name}/plugins/CCpp.conf ]; then
595         mv -f %{_sysconfdir}/%{name}/plugins/CCpp.conf %{_sysconfdir}/%{name}/plugins/CCpp.conf.rpmsave.atomic || exit 1
596 fi
597 ln -sf %{_sysconfdir}/%{name}/plugins/CCpp_Atomic.conf %{_sysconfdir}/%{name}/plugins/CCpp.conf
598 if [ -f %{_datadir}/%{name}/conf.d/plugins/CCpp.conf ]; then
599         mv -f %{_datadir}/%{name}/conf.d/plugins/CCpp.conf %{_datadir}/%{name}/conf.d/plugins/CCpp.conf.rpmsave.atomic || exit 1;
600 fi
601 ln -sf %{_datadir}/%{name}/conf.d/plugins/CCpp_Atomic.conf %{_datadir}/%{name}/conf.d/plugins/CCpp.conf
602 %systemd_post abrt-coredump-helper.service
603
604 %preun atomic
605 if [ -L %{_sysconfdir}/%{name}/plugins/CCpp.conf ]; then
606         rm -f %{_sysconfdir}/%{name}/plugins/CCpp.conf
607 fi
608 if [ -L %{_datadir}/%{name}/conf.d/plugins/CCpp.conf ]; then
609         rm -f %{_datadir}/%{name}/conf.d/plugins/CCpp.conf
610 fi
611 if [ -f %{_sysconfdir}/%{name}/plugins/CCpp.conf.rpmsave.atomic ]; then
612         mv -f %{_sysconfdir}/%{name}/plugins/CCpp.conf.rpmsave.atomic %{_sysconfdir}/%{name}/plugins/CCpp.conf || exit 1
613 fi
614 if [ -f %{_datadir}/%{name}/conf.d/plugins/CCpp.conf.rpmsave.atomic ]; then
615         mv -f %{_datadir}/%{name}/conf.d/plugins/CCpp.conf.rpmsave.atomic %{_datadir}/%{name}/conf.d/plugins/CCpp.conf || exit 1
616 fi
617
618 %postun atomic
619 %systemd_postun_with_restart abrt-coredump-helper.service
620
621 %post gui
622 %update_icon_cache hicolor
623
624 %postun gui
625 %update_icon_cache hicolor
626
627 %post   gui-libs -p /sbin/ldconfig
628 %postun gui-libs -p /sbin/ldconfig
629
630 %files -f %{name}.lang
631 %defattr(644,root,root,755)
632 %doc README
633 %attr(755,root,root) %{_bindir}/abrt-action-analyze-python
634 %attr(755,root,root) %{_bindir}/abrt-action-notify
635 %attr(755,root,root) %{_bindir}/abrt-action-save-container-data
636 %attr(755,root,root) %{_bindir}/abrt-action-save-package-data
637 %attr(755,root,root) %{_bindir}/abrt-handle-upload
638 %attr(755,root,root) %{_bindir}/abrt-watch-log
639 %attr(755,root,root) %{_sbindir}/abrt-auto-reporting
640 %attr(755,root,root) %{_sbindir}/abrt-server
641 %attr(755,root,root) %{_sbindir}/abrtd
642 %attr(755,root,root) %{_libexecdir}/abrt-action-generate-machine-id
643 %attr(755,root,root) %{_libexecdir}/abrt-action-ureport
644 %attr(755,root,root) %{_libexecdir}/abrt-handle-event
645 %dir %{_datadir}/%{name}
646 %dir %{_datadir}/%{name}/conf.d
647 %{_datadir}/%{name}/conf.d/abrt.conf
648 %{_datadir}/%{name}/conf.d/abrt-action-save-package-data.conf
649 %{_datadir}/%{name}/conf.d/gpg_keys.conf
650 %dir %{_datadir}/%{name}/conf.d/plugins
651 %{_datadir}/augeas/lenses/abrt.aug
652 %dir %{_sysconfdir}/%{name}
653 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt.conf
654 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt-action-save-package-data.conf
655 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/gpg_keys.conf
656 %dir %{_sysconfdir}/%{name}/plugins
657 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_event.conf
658 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/smart_event.conf
659 %attr(754,root,root) /etc/rc.d/init.d/abrtd
660 %{systemdunitdir}/abrtd.service
661 %attr(775,root,abrt) %dir /var/cache/%{name}
662 %dir /var/run/%{name}
663 %{systemdtmpfilesdir}/abrt.conf
664 %{_mandir}/man1/abrt-action-analyze-python.1*
665 %{_mandir}/man1/abrt-action-notify.1*
666 %{_mandir}/man1/abrt-action-save-package-data.1*
667 %{_mandir}/man1/abrt-auto-reporting.1*
668 %{_mandir}/man1/abrt-handle-upload.1*
669 %{_mandir}/man1/abrt-server.1*
670 %{_mandir}/man1/abrt-watch-log.1*
671 %{_mandir}/man5/abrt.conf.5*
672 %{_mandir}/man5/abrt-action-save-package-data.conf.5*
673 %{_mandir}/man5/abrt_event.conf.5*
674 %{_mandir}/man5/gpg_keys.conf.5*
675 %{_mandir}/man5/smart_event.conf.5*
676 %{_mandir}/man8/abrtd.8*
677
678 %files libs
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_libdir}/libabrt.so.*.*.*
681 %attr(755,root,root) %ghost %{_libdir}/libabrt.so.0
682
683 %files devel
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_libdir}/libabrt.so
686 %dir %{_includedir}/abrt
687 %{_includedir}/abrt/abrt-dbus.h
688 %{_includedir}/abrt/hooklib.h
689 %{_includedir}/abrt/libabrt.h
690 %{_includedir}/abrt/problem_api.h
691 %{_pkgconfigdir}/abrt.pc
692
693 %files addon-ccpp
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_bindir}/abrt-action-analyze-backtrace
696 %attr(755,root,root) %{_bindir}/abrt-action-analyze-c
697 %attr(755,root,root) %{_bindir}/abrt-action-analyze-ccpp-local
698 %attr(755,root,root) %{_bindir}/abrt-action-analyze-core
699 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vulnerability
700 %attr(755,root,root) %{_bindir}/abrt-action-generate-backtrace
701 %attr(755,root,root) %{_bindir}/abrt-action-generate-core-backtrace
702 %attr(755,root,root) %{_bindir}/abrt-action-install-debuginfo
703 %attr(755,root,root) %{_bindir}/abrt-action-list-dsos
704 %attr(755,root,root) %{_bindir}/abrt-action-perform-ccpp-analysis
705 %attr(755,root,root) %{_bindir}/abrt-action-trim-files
706 %attr(755,root,root) %{_bindir}/abrt-dump-journal-core
707 %attr(6755,abrt,abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
708 %attr(755,root,root) %{_libexecdir}/abrt-gdb-exploitable
709 %{_datadir}/%{name}/conf.d/plugins/CCpp.conf
710 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/CCpp.conf
711 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_event.conf
712 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/gconf_event.conf
713 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vimrc_event.conf
714 %attr(775,abrt,abrt) %dir %{_localstatedir}/cache/abrt-di
715 #%attr(754,root,root) /etc/rc.d/init.d/abrt-ccpp
716 %{_datadir}/libreport/events/analyze_CCpp.xml
717 %{_datadir}/libreport/events/analyze_LocalGDB.xml
718 %{_datadir}/libreport/events/collect_GConf.xml
719 %{_datadir}/libreport/events/collect_vimrc_system.xml
720 %{_datadir}/libreport/events/collect_vimrc_user.xml
721 %{_datadir}/libreport/events/collect_xsession_errors.xml
722 %{_datadir}/libreport/events/post_report.xml
723 %{systemdunitdir}/abrt-ccpp.service
724 %{systemdunitdir}/abrt-journal-core.service
725 %{_mandir}/man1/abrt-action-analyze-backtrace.1*
726 %{_mandir}/man1/abrt-action-analyze-c.1*
727 %{_mandir}/man1/abrt-action-analyze-ccpp-local.1*
728 %{_mandir}/man1/abrt-action-analyze-core.1*
729 %{_mandir}/man1/abrt-action-analyze-vulnerability.1*
730 %{_mandir}/man1/abrt-action-generate-backtrace.1*
731 %{_mandir}/man1/abrt-action-generate-core-backtrace.1*
732 %{_mandir}/man1/abrt-action-install-debuginfo.1*
733 %{_mandir}/man1/abrt-action-list-dsos.1*
734 %{_mandir}/man1/abrt-action-perform-ccpp-analysis.1*
735 %{_mandir}/man1/abrt-action-trim-files.1*
736 %{_mandir}/man5/abrt-CCpp.conf.5*
737 %{_mandir}/man5/ccpp_event.conf.5*
738 %{_mandir}/man5/ccpp_retrace_event.conf.5*
739 %{_mandir}/man5/gconf_event.conf.5*
740 %{_mandir}/man5/vimrc_event.conf.5*
741
742 %files addon-coredump-helper
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{_sbindir}/abrt-install-ccpp-hook
745 %attr(755,root,root) %{_libexecdir}/abrt-hook-ccpp
746 %{_mandir}/man1/abrt-install-ccpp-hook.1*
747
748 %files addon-kerneloops
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{_bindir}/abrt-action-analyze-oops
751 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-hw-error
752 %attr(755,root,root) %{_bindir}/abrt-action-save-kernel-data
753 %attr(755,root,root) %{_bindir}/abrt-dump-journal-oops
754 %attr(755,root,root) %{_bindir}/abrt-dump-oops
755 %{_datadir}/%{name}/conf.d/plugins/oops.conf
756 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/koops_event.conf
757 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/oops.conf
758 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.oops.xml
759 #%attr(754,root,root) /etc/rc.d/init.d/abrt-oops
760 %{systemdunitdir}/abrt-oops.service
761 %{_mandir}/man1/abrt-action-analyze-oops.1*
762 %{_mandir}/man1/abrt-action-check-oops-for-hw-error.1*
763 %{_mandir}/man1/abrt-action-save-kernel-data.1*
764 %{_mandir}/man1/abrt-dump-journal-oops.1*
765 %{_mandir}/man1/abrt-dump-oops.1*
766 %{_mandir}/man5/abrt-oops.conf.5*
767 %{_mandir}/man5/koops_event.conf.5*
768
769 %files addon-pstoreoops
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_bindir}/abrt-merge-pstoreoops
772 %attr(755,root,root) %{_sbindir}/abrt-harvest-pstoreoops
773 %{systemdunitdir}/abrt-pstoreoops.service
774 #%attr(754,root,root) /etc/rc.d/init.d/abrt-pstoreoops
775 %{_mandir}/man1/abrt-harvest-pstoreoops.1*
776 %{_mandir}/man1/abrt-merge-pstoreoops.1*
777
778 %files addon-python
779 %defattr(644,root,root,755)
780 %{_datadir}/%{name}/conf.d/plugins/python.conf
781 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/python.conf
782 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/python_event.conf
783 %{py_sitedir}/abrt_exception_handler.py[co]
784 %{py_sitedir}/abrt.pth
785 %{_mandir}/man5/abrt-python.conf.5*
786 %{_mandir}/man5/python_event.conf.5*
787
788 %files addon-python3
789 %defattr(644,root,root,755)
790 %{_datadir}/%{name}/conf.d/plugins/python3.conf
791 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/python3.conf
792 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/python3_event.conf
793 %{py3_sitedir}/abrt_exception_handler3.py*
794 %{py3_sitedir}/abrt3.pth
795 %{_mandir}/man5/abrt-python3.conf.5*
796 %{_mandir}/man5/python3_event.conf.5*
797
798 %files addon-upload-watch
799 %defattr(644,root,root,755)
800 %attr(755,root,root) %{_sbindir}/abrt-upload-watch
801 %{systemdunitdir}/abrt-upload-watch.service
802 %{_mandir}/man1/abrt-upload-watch.1*
803
804 %files addon-vmcore
805 %defattr(644,root,root,755)
806 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vmcore
807 %attr(755,root,root) %{_sbindir}/abrt-harvest-vmcore
808 %dir %{_datadir}/%{name}/conf.d/plugins/vmcore.conf
809 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/vmcore.conf
810 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vmcore_event.conf
811 #%attr(754,root,root) /etc/rc.d/init.d/abrt-vmcore
812 %{_datadir}/libreport/events/analyze_VMcore.xml
813 %{systemdunitdir}/abrt-vmcore.service
814 %{_mandir}/man1/abrt-action-analyze-vmcore.1*
815 %{_mandir}/man1/abrt-harvest-vmcore.1*
816 %{_mandir}/man5/abrt-vmcore.conf.5*
817 %{_mandir}/man5/vmcore_event.conf.5*
818
819 %files addon-xorg
820 %defattr(644,root,root,755)
821 %attr(755,root,root) %{_bindir}/abrt-action-analyze-xorg
822 %attr(755,root,root) %{_bindir}/abrt-dump-xorg
823 %dir %{_datadir}/%{name}/conf.d/plugins/xorg.conf
824 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/xorg.conf
825 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/xorg_event.conf
826 #%attr(754,root,root) /etc/rc.d/init.d/abrt-xorg
827 %{systemdunitdir}/abrt-xorg.service
828 %{_mandir}/man1/abrt-action-analyze-xorg.1*
829 %{_mandir}/man1/abrt-dump-xorg.1*
830 %{_mandir}/man5/abrt-xorg.conf.5*
831 %{_mandir}/man5/xorg_event.conf.5*
832
833 %files atomic
834 %defattr(644,root,root,755)
835 %{_datadir}/%{name}/conf.d/plugins/CCpp_Atomic.conf
836 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/CCpp_Atomic.conf
837 %{systemdunitdir}/abrt-coredump-helper.service
838
839 %files plugin-bodhi
840 %defattr(644,root,root,755)
841 %attr(755,root,root) %{_bindir}/abrt-bodhi
842 %{_mandir}/man1/abrt-bodhi.1*
843
844 %files retrace-client
845 %defattr(644,root,root,755)
846 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_retrace_event.conf
847 %attr(755,root,root) %{_bindir}/abrt-retrace-client
848 %{_datadir}/libreport/events/analyze_RetraceServer.xml
849 %{_mandir}/man1/abrt-retrace-client.1*
850
851 %files dbus
852 %defattr(644,root,root,755)
853 %attr(755,root,root) %{_sbindir}/abrt-configuration
854 %attr(755,root,root) %{_sbindir}/abrt-dbus
855 /etc/dbus-1/system.d/dbus-abrt.conf
856 /etc/dbus-1/system.d/org.freedesktop.problems.daemon.conf
857 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.abrt.xml
858 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ccpp.xml
859 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.python.xml
860 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.vmcore.xml
861 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.xml
862 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.xorg.xml
863 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems.xml
864 %{_datadir}/dbus-1/system-services/com.redhat.problems.configuration.service
865 %{_datadir}/dbus-1/system-services/org.freedesktop.problems.service
866 %{_datadir}/polkit-1/actions/abrt_polkit.policy
867 %{_mandir}/man8/abrt-configuration.8*
868 %{_mandir}/man8/abrt-dbus.8*
869 %{_docdir}/abrt-dbus-%{version}
870
871 %files python
872 %defattr(644,root,root,755)
873 %dir %{py_sitedir}/problem
874 %attr(755,root,root) %{py_sitedir}/problem/_pyabrt.so
875 %{py_sitedir}/problem/*.py[co]
876 %{_mandir}/man5/abrt-python.5*
877
878 %files python3
879 %defattr(644,root,root,755)
880 %dir %{py3_sitedir}/problem
881 %attr(755,root,root) %{py3_sitedir}/problem/_py3abrt.so
882 %{py3_sitedir}/problem/*.py*
883 %{_mandir}/man5/abrt-python3.5*
884
885 %files cli
886 %defattr(644,root,root,755)
887 %attr(755,root,root) %{_bindir}/abrt-cli
888 %{_mandir}/man1/abrt-cli.1*
889
890 %files gui
891 %defattr(644,root,root,755)
892 %attr(755,root,root) %{_bindir}/abrt-applet
893 %attr(755,root,root) %{_bindir}/system-config-abrt
894 %dir %{_datadir}/%{name}
895 %{_datadir}/%{name}/icons
896 %{_datadir}/%{name}/ui
897 %{_iconsdir}/hicolor/*/apps/abrt.png
898 %{_iconsdir}/hicolor/*/status/abrt.png
899 %{_sysconfdir}/xdg/autostart/abrt-applet.desktop
900 %{_mandir}/man1/abrt-applet.1*
901 %{_mandir}/man1/system-config-abrt.1*
902
903 %files gui-libs
904 %defattr(644,root,root,755)
905 %attr(755,root,root) %{_libdir}/libabrt_gui.so.*.*.*
906 %attr(755,root,root) %ghost %{_libdir}/libabrt_gui.so.0
907
908 %files gui-devel
909 %defattr(644,root,root,755)
910 %attr(755,root,root) %{_libdir}/libabrt_gui.so
911 %{_includedir}/abrt/abrt-config-widget.h
912 %{_includedir}/abrt/system-config-abrt.h
913 %{_pkgconfigdir}/abrt_gui.pc
914
915 %files desktop
916 %defattr(644,root,root,755)
917
918 %files console-notification
919 %defattr(644,root,root,755)
920 %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/abrt-console-notification.sh
This page took 0.170385 seconds and 3 git commands to generate.