]> git.pld-linux.org Git - packages/abrt.git/blob - abrt.spec
- updated to 2.5.0
[packages/abrt.git] / abrt.spec
1 #
2 # TODO:
3 # - handle obsolete packages: abrt-plugin-{catcut,rhfastcheck,rhticket,ticketuploader}
4 # - SysV init scripts for -addon-ccpp, -addon-kerneloops, -addon-pstoreoops, -addon-upload-watch, -addon-vmcore, -addon-xorg
5 # - teach build system to use python3.2+ __pycache__
6 %define         libreport_ver   2.5.0
7 Summary:        Automatic bug detection and reporting tool
8 Summary(pl.UTF-8):      Narzędzie do automatycznego wykrywania i zgłaszania błędów
9 Name:           abrt
10 Version:        2.5.0
11 Release:        1
12 License:        GPL v2+
13 Group:          Applications/System
14 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
15 # Source0-md5:  f2b2f9393117db5365cea014f82dbb73
16 Source1:        %{name}.init
17 Patch0:         %{name}-rpm5.patch
18 Patch1:         %{name}-rpm45.patch
19 Patch2:         format_security.patch
20 Patch3:         %{name}-link.patch
21 Patch4:         profile.sh.patch
22 URL:            https://fedorahosted.org/abrt/
23 BuildRequires:  asciidoc
24 BuildRequires:  autoconf >= 2.50
25 BuildRequires:  automake
26 BuildRequires:  dbus-devel
27 BuildRequires:  gettext-tools >= 0.17
28 BuildRequires:  glib2-devel >= 1:2.43
29 BuildRequires:  gsettings-desktop-schemas-devel >= 3.15.1
30 BuildRequires:  gtk+3-devel >= 3.0
31 BuildRequires:  intltool >= 0.35.0
32 BuildRequires:  json-c-devel
33 BuildRequires:  libmagic-devel
34 BuildRequires:  libnotify-devel >= 0.7.0
35 BuildRequires:  libreport-devel >= %{libreport_ver}
36 BuildRequires:  libreport-gtk-devel >= %{libreport_ver}
37 BuildRequires:  libreport-web-devel >= %{libreport_ver}
38 BuildRequires:  libtool
39 BuildRequires:  libxml2-devel >= 2
40 BuildRequires:  nss-devel
41 BuildRequires:  pkgconfig
42 BuildRequires:  polkit-devel
43 BuildRequires:  python-devel >= 2
44 BuildRequires:  python-modules >= 2
45 BuildRequires:  python3-devel >= 3
46 BuildRequires:  python3-modules >= 3
47 BuildRequires:  rpm-devel >= 4.5-28
48 BuildRequires:  rpm-pythonprov
49 BuildRequires:  rpmbuild(macros) >= 1.219
50 BuildRequires:  satyr-devel
51 BuildRequires:  systemd-devel
52 BuildRequires:  xmlto
53 BuildRequires:  xorg-lib-libICE-devel
54 BuildRequires:  xorg-lib-libSM-devel
55 Requires(postun):       /usr/sbin/groupdel
56 Requires(postun):       /usr/sbin/userdel
57 Requires(pre):  /bin/id
58 Requires(pre):  /usr/bin/getgid
59 Requires(pre):  /usr/sbin/groupadd
60 Requires(pre):  /usr/sbin/useradd
61 Requires:       %{name}-libs = %{version}-%{release}
62 Provides:       group(abrt)
63 Provides:       user(abrt)
64 Obsoletes:      abrt-plugin-filetransfer
65 Obsoletes:      abrt-plugin-runapp
66 Obsoletes:      abrt-plugin-sosreport
67 Obsoletes:      abrt-plugin-sqlite3
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %description
71 ABRT is a tool to help users to detect defects in applications and to
72 create a bug report with all informations needed by maintainer to fix
73 it. It uses plugin system to extend its functionality.
74
75 %description -l pl.UTF-8
76 ABRT to narzędzie pomagające użytkownikom w wykrywaniu defektów w
77 aplikacjach oraz tworzeniu raportów błędów ze wszystkimi informacjami
78 potrzebnymi utrzymującemu pakiet do poprawienia go. Wykorzystuje
79 system wtyczek do rozszerzania funkcjonalności.
80
81 %package libs
82 Summary:        ABRT shared library
83 Summary(pl.UTF-8):      Biblioteka współdzielona ABRT
84 Group:          Libraries
85 Requires:       glib2 >= 1:2.43
86 Requires:       libreport >= %{libreport_ver}
87
88 %description libs
89 ABRT shared library.
90
91 %description libs -l pl.UTF-8
92 Biblioteka współdzielona ABRT.
93
94 %package devel
95 Summary:        Header files for ABRT livrary
96 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotekia ABRT
97 Group:          Development/Libraries
98 Requires:       %{name}-libs = %{version}-%{release}
99 Requires:       glib2-devel >= 1:2.43
100 Requires:       libreport-devel >= %{libreport_ver}
101
102 %description devel
103 Header files for ABRT livrary.
104
105 %description devel -l pl.UTF-8
106 Pliki nagłówkowe biblioteki ABRT.
107
108 %package addon-ccpp
109 Summary:        ABRT's C/C++ addon
110 Summary(pl.UTF-8):      Dodatek C/C++ do ABRT
111 Group:          Libraries
112 Requires:       %{name} = %{version}-%{release}
113 Requires:       %{name}-addon-coredump-helper = %{version}-%{release}
114 Requires:       %{name}-retrace-client = %{version}-%{release}
115 Requires:       cpio
116 Requires:       elfutils
117 Requires:       gdb >= 7.0-3
118 Requires:       satyr
119 Requires:       yum-utils
120 Obsoletes:      %{name}-atomic
121
122 %description addon-ccpp
123 This package contains hook for C/C++ crashed programs and abrt's C/C++
124 analyzer plugin.
125
126 %description addon-ccpp -l pl.UTF-8
127 Ten pakiet zawiera punkt zaczepienia dla programów w C/C++, które
128 uległy awarii oraz wtyczkę analizatora C/C++ ABRT.
129
130 %package addon-coredump-helper
131 Summary:        ABRT's /proc/sys/kernel/core_pattern helper
132 Summary(pl.UTF-8):      Program pomocniczy ABRT do /proc/sys/kernel/core_pattern
133 Group:          Libraries
134 Requires:       %{name}-libs = %{version}-%{release}
135
136 %description addon-coredump-helper
137 This package contains hook for C/C++ crashed programs.
138
139 %description addon-coredump-helper -l pl.UTF-8
140 Ten pakiet zawiera uchwyt dla programów w C/C++, które uległy awarii.
141
142 %package addon-kerneloops
143 Summary:        ABRT's kerneloops addon
144 Summary(pl.UTF-8):      Dodatek kerneloops do ABRT
145 Group:          Libraries
146 Requires:       %{name} = %{version}-%{release}
147 Requires:       curl
148 Requires:       libreport-plugin-kerneloops >= %{libreport_ver}
149 Obsoletes:      abrt-plugin-kerneloops
150 Obsoletes:      abrt-plugin-kerneloopsreporter
151 Obsoletes:      kerneloops
152
153 %description addon-kerneloops
154 This package contains plugin for collecting kernel crash information
155 from system log.
156
157 %description addon-kerneloops -l pl.UTF-8
158 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
159 logu systemowego.
160
161 %package addon-pstoreoops
162 Summary:        ABRT's pstoreoops addon
163 Summary(pl.UTF-8):      Dodatek pstoreoops do ABRT
164 Group:          Libraries
165 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
166 Obsoletes:      abrt-addon-uefioops
167
168 %description addon-pstoreoops
169 This package contains plugin for collecting kernel oopses from pstore
170 storage.
171
172 %description addon-pstoreoops -l pl.UTF-8
173 Ten pakiet zawiera wtyczkę do zbierania oopsów jądra z danych pstore.
174
175 %package addon-python
176 Summary:        ABRT's addon for catching and analyzing Python 2 exceptions
177 Summary(pl.UTF-8):      Dodatek ABRT do przechwytywania i analizy wyjątków Pythona 2
178 Group:          Libraries
179 Requires:       %{name} = %{version}-%{release}
180 Requires:       %{name}-python = %{version}-%{release}
181 # for detecting package name containing offending file
182 Suggests:       python-rpm
183 # for logging to journal
184 Suggests:       python-systemd
185 Obsoletes:      gnome-python2-bugbuddy
186
187 %description addon-python
188 This package contains Python hook and Python analyzer plugin for
189 handling uncaught exception in Python 2 programs.
190
191 %description addon-python -l pl.UTF-8
192 Ten pakiet zawiera pythonowy punkt zaczepienia oraz wtyczkę
193 analizatora Pythona do obsługi nie obsłużonych wyjątków w programach w
194 Pythonie 2.
195
196 %package addon-python3
197 Summary:        ABRT's addon for catching and analyzing Python 3 exceptions
198 Summary(pl.UTF-8):      Dodatek ABRT do przechwytywania i analizy wyjątków Pythona 3
199 Group:          Libraries
200 Requires:       %{name} = %{version}-%{release}
201 Requires:       %{name}-python3 = %{version}-%{release}
202 # for detecting package name containing offending file (TODO: python3-rpm package)
203 #Suggests:      python3-rpm
204 # for logging to journal (TODO: python3-systemd package)
205 #Suggests:      python3-systemd
206
207 %description addon-python3
208 This package contains Python hook and Python analyzer plugin for
209 handling uncaught exception in Python 3 programs.
210
211 %description addon-python3 -l pl.UTF-8
212 Ten pakiet zawiera pythonowy punkt zaczepienia oraz wtyczkę
213 analizatora Pythona do obsługi nie obsłużonych wyjątków w programach w
214 Pythonie 3.
215
216 %package addon-upload-watch
217 Summary:        ABRT's upload addon
218 Summary(pl.UTF-8):      Dodatek upload do ABRT
219 Group:          Libraries
220 Requires:       %{name} = %{version}-%{release}
221
222 %description addon-upload-watch
223 This package contains hook for uploaded problems.
224
225 %description addon-upload-watch -l pl.UTF-8
226 Ten pakiet zawiera uchwyt dla problemów przysłanych.
227
228 %package addon-vmcore
229 Summary:        ABRT's vmcore addon
230 Summary(pl.UTF-8):      Dodatek vmcore do ABRT
231 Group:          Libraries
232 Requires:       %{name} = %{version}-%{release}
233 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
234 Requires:       crash
235
236 %description addon-vmcore
237 This package contains plugin for collecting kernel crash information
238 from vmcore files.
239
240 %description addon-vmcore -l pl.UTF-8
241 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
242 plików vmcore.
243
244 %package addon-xorg
245 Summary:        ABRT's Xorg addon
246 Summary(pl.UTF-8):      Dodatek Xorg do ABRT
247 Group:          Libraries
248 Requires:       %{name} = %{version}-%{release}
249 Requires:       curl
250
251 %description addon-xorg
252 This package contains plugin for collecting Xorg crash information
253 from Xorg log.
254
255 %description addon-xorg -l pl.UTF-8
256 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
257 logu Xorg.
258
259 %package atomic
260 Summary:        Package to make easy default installation on Atomic hosts
261 Summary(pl.UTF-8):      Pakiet ułatwiający domyślną instalację na hostach Atomic
262 Group:          Applications/System
263 Requires:       %{name}-addon-coredump-helper = %{version}-%{release}
264 Obsoletes:      %{name}-addon-ccpp
265
266 %description atomic
267 Package to install all necessary packages for usage from Atomic hosts.
268
269 %description atomic -l pl.UTF-8
270 Pakiet służący do instalacji wszystkich wymaganych pakietów
271 przeznaczonych do użycia z hostów Atomic.
272
273 %package plugin-bodhi
274 Summary:        ABRT's bodhi plugin
275 Summary(pl.UTF-8):      Wtyczka bodhi do ABRT
276 Group:          Libraries
277 Requires:       %{name} = %{version}-%{release}
278 Requires:       libreport-web >= %{libreport_ver}
279 Obsoletes:      libreport-plugin-bodhi
280
281 %description plugin-bodhi
282 Plugin to search for a new updates in bodhi server.
283
284 %description plugin-bodhi -l pl.UTF-8
285 Wtyczka do wyszukiwania nowych uaktualnień na serwerze bodhi.
286
287 %package retrace-client
288 Summary:        ABRT's retrace client
289 Summary(pl.UTF-8):      Klient Retrace dla ABRT
290 Group:          Libraries
291 Requires:       %{name} = %{version}-%{release}
292 Requires:       xz
293
294 %description retrace-client
295 This package contains the client application for Retrace server which
296 is able to analyze C/C++ crashes remotely.
297
298 %description retrace-client -l pl.UTF-8
299 Ten pakiet zawiera aplikację kliencką dla serwera Retrace, który
300 potrafi zdalnie przeanalizować awarię programu w C/C++.
301
302 %package dbus
303 Summary:        ABRT DBus service
304 Summary(pl.UTF-8):      Usługa DBus ABRT
305 Group:          Applications/System
306 Requires:       %{name} = %{version}-%{release}
307 Requires:       libreport >= %{libreport_ver}
308
309 %description dbus
310 ABRT DBus service which provides org.freedesktop.problems API on DBus
311 and uses PolicyKit to authorize to access the problem data.
312
313 %description dbus -l pl.UTF-8
314 Usługa DBus ABRT, udostępniająca poprzez DBus API
315 org.freedesktop.problems, używająca PolicyKit do autoryzacji dostępu
316 do danych o problemach.
317
318 %package python
319 Summary:        ABRT Python 2 API
320 Summary(pl.UTF-8):      API Pythona 2 do ABRT
321 Group:          Libraries/Python
322 Requires:       %{name} = %{version}-%{release}
323 Requires:       python-libreport >= %{libreport_ver}
324
325 %description python
326 High-level API for querying, creating and manipulating problems
327 handled by ABRT in Python 2.
328
329 %description python -l pl.UTF-8
330 Wysokopoziomowe API do odpytywania, tworzenia i obróbki z poziomu
331 Pythona 2 problemów obsługiwanych przez ABRT.
332
333 %package python3
334 Summary:        ABRT Python 3 API
335 Summary(pl.UTF-8):      API Pythona 3 do ABRT
336 Group:          Libraries/Python
337 Requires:       %{name} = %{version}-%{release}
338 Requires:       python3-libreport >= %{libreport_ver}
339
340 %description python3
341 High-level API for querying, creating and manipulating problems
342 handled by ABRT in Python.
343
344 %description python3 -l pl.UTF-8
345 Wysokopoziomowe API do odpytywania, tworzenia i obróbki z poziomu
346 Pythona 3 problemów obsługiwanych przez ABRT.
347
348 %package cli
349 Summary:        ABRT's command line interface
350 Summary(pl.UTF-8):      Interfejs linii poleceń ABRT
351 Group:          Applications/System
352 Requires:       %{name} = %{version}-%{release}
353 # analyzers
354 Requires:       %{name}-addon-ccpp = %{version}-%{release}
355 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
356 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
357 Requires:       %{name}-addon-python = %{version}-%{release}
358 # reporters
359 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
360 Requires:       libreport-plugin-logger >= %{libreport_ver}
361
362 %description cli
363 This package contains simple command line client for controling ABRT
364 daemon over the sockets.
365
366 %description cli -l pl.UTF-8
367 Ten pakiet zawiera prostego klienta obsługiwanego z linii poleceń,
368 pozwalającego na sterowanie demonem poprzez gniazda.
369
370 %package gui
371 Summary:        ABRT's GUI
372 Summary(pl.UTF-8):      Graficzny interfejs użytkownika do ABRT
373 Group:          X11/Applications
374 Requires(post,postun):  /sbin/ldconfig
375 Requires(post,postun):  gtk-update-icon-cache
376 Requires(post,postun):  hicolor-icon-theme
377 Requires:       %{name} = %{version}-%{release}
378 Requires:       %{name}-dbus = %{version}-%{release}
379 Requires:       %{name}-gui-libs = %{version}-%{release}
380 Suggests:       gnome-abrt
381 Provides:       abrt-applet = %{version}-%{release}
382 Obsoletes:      abrt-applet < 0.0.5
383 Conflicts:      abrt-applet < 0.0.5
384
385 %description gui
386 GTK+ wizard for convenient bug reporting.
387
388 %description gui -l pl.UTF-8
389 Oparty na GTK+ kreator do wygodnego zgłaszania błędów.
390
391 %package gui-libs
392 Summary:        ABRT's GUI library
393 Summary(pl.UTF-8):      Biblioteka graficznego interfejsu użytkownika ABRT
394 Group:          X11/Libraries
395 Requires:       %{name}-libs = %{version}-%{release}
396 Requires:       gtk+3 >= 3.0
397
398 %description gui-libs
399 ABRT's GUI library.
400
401 %description gui-libs -l pl.UTF-8
402 Biblioteka graficznego interfejsu użytkownika ABRT.
403
404 %package gui-devel
405 Summary:        Header files for ABRT GUI library
406 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT
407 Group:          X11/Development/Libraries
408 Requires:       %{name}-devel = %{version}-%{release}
409 Requires:       %{name}-gui-libs = %{version}-%{release}
410 Requires:       gtk+3-devel >= 3.0
411
412 %description gui-devel
413 Header files for ABRT GUI library.
414
415 %description gui-devel -l pl.UTF-8
416 Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT.
417
418 %package desktop
419 Summary:        Virtual package to install all necessary packages for usage from desktop environment
420 Summary(pl.UTF-8):      Writualny pakiet do instalacji pakietów potrzebnych do użycia w środowisku graficznym
421 Group:          X11/Applications
422 # This package should be installed when anything requests bug-buddy;
423 # installing abrt-desktop should result in the abrt which works without
424 # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
425 Requires:       %{name} = %{version}-%{release}
426 Requires:       %{name}-addon-ccpp = %{version}-%{release}
427 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
428 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
429 Requires:       %{name}-addon-python = %{version}-%{release}
430 Requires:       %{name}-addon-vmcore = %{version}-%{release}
431 Requires:       %{name}-addon-xorg = %{version}-%{release}
432 Requires:       %{name}-gui = %{version}-%{release}
433 Requires:       %{name}-plugin-bodhi = %{version}-%{release}
434 Requires:       %{name}-retrace-client = %{version}-%{release}
435 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
436 Requires:       libreport-plugin-logger >= %{libreport_ver}
437 Requires:       libreport-plugin-ureport >= %{libreport_ver}
438 Provides:       bug-buddy
439 Obsoletes:      bug-buddy
440
441 %description desktop
442 Virtual package to make easy default installation on desktop
443 environments.
444
445 %description desktop -l pl.UTF-8
446 Wirtualny pakiet ułatwiający domyślną instalację w środowiskach
447 graficznych.
448
449 %package console-notification
450 Summary:        ABRT console notification script
451 Summary(pl.UTF-8):      Skrypt ABRT do powiadomień na konsoli
452 Group:          Applications/System
453 Requires:       %{name} = %{version}-%{release}
454 Requires:       %{name}-cli = %{version}-%{release}
455
456 %description console-notification
457 A small script which prints a count of detected problems when someone
458 logs in to the shell.
459
460 %description console-notification -l pl.UTF-8
461 Mały skrypt wypisujący liczbę wykrytych problemów, kiedy ktoś loguje
462 się do powłoki.
463
464 %prep
465 %setup -q
466 %if "%{_rpmversion}" >= "5.0"
467 %patch0 -p1
468 %else
469 %patch1 -p1
470 %endif
471 %patch2 -p1
472 %patch3 -p1
473 %patch4 -p1
474
475 %build
476 %{__libtoolize}
477 %{__aclocal}
478 %{__autoconf}
479 %{__autoheader}
480 %{__automake}
481 %configure \
482         --disable-silent-rules \
483         --with-systemdsystemunitdir=%{systemdunitdir}
484
485 %{__make}
486
487 %install
488 rm -rf $RPM_BUILD_ROOT
489 %{__make} install \
490         DESTDIR=$RPM_BUILD_ROOT
491
492 %py_postclean
493
494 # obsoleted by pkg-config
495 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
496
497 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/abrtd
498 install -d $RPM_BUILD_ROOT/var/cache/%{name}
499 install -d $RPM_BUILD_ROOT/var/cache/%{name}-di
500 install -d $RPM_BUILD_ROOT/var/run/%{name}
501
502 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
503 cat > $RPM_BUILD_ROOT%{systemdtmpfilesdir}/abrt.conf <<EOF
504 d /var/run/%{name} 0755 root root -
505 EOF
506
507 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/problem/*.la
508 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/problem/*.la
509 # examples
510 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/problem_examples
511 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/problem_examples
512 # empty version of ru
513 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ru_RU
514
515 # fool man verification - report_event.conf.5 belongs to libreport (NOTE: don't package it here)
516 touch $RPM_BUILD_ROOT%{_mandir}/man5/report_event.conf.5
517
518 %find_lang %{name}
519
520 %clean
521 rm -rf $RPM_BUILD_ROOT
522
523 %pre
524 %groupadd -g 248 abrt
525 %useradd -u 248 -g abrt -d /etc/abrt -s /sbin/nologin abrt
526
527 %post
528 /sbin/chkconfig --add abrtd
529 %service abrtd restart
530 %systemd_post abrtd.service
531
532 %preun
533 if [ "$1" = "0" ]; then
534         %service abrtd stop
535         /sbin/chkconfig --del abrtd
536 fi
537 %systemd_preun abrtd.service
538
539 %postun
540 if [ "$1" = "0" ]; then
541         %userremove abrt
542         %groupremove abrt
543 fi
544
545 %post   libs -p /sbin/ldconfig
546 %postun libs -p /sbin/ldconfig
547
548 %post addon-ccpp
549 %systemd_post abrt-ccpp.service
550 %systemd_post abrt-journal-core.service
551
552 %preun addon-ccpp
553 %systemd_preun abrt-ccpp.service
554 %systemd_preun abrt-journal-core.service
555
556 %post addon-kerneloops
557 %systemd_post abrt-oops.service
558
559 %preun addon-kerneloops
560 %systemd_preun abrt-oops.service
561
562 %post addon-pstoreoops
563 %systemd_post abrt-pstoreoops.service
564
565 %preun addon-pstoreoops
566 %systemd_preun abrt-pstoreoops.service
567
568 %post addon-upload-watch
569 %systemd_post abrt-upload-watch.service
570
571 %preun addon-upload-watch
572 %systemd_preun abrt-upload-watch.service
573
574 %post addon-vmcore
575 %systemd_post abrt-vmcore.service
576
577 %preun addon-vmcore
578 %systemd_preun abrt-vmcore.service
579
580 %post addon-xorg
581 %systemd_post abrt-xorg.service
582
583 %preun addon-xorg
584 %systemd_preun abrt-xorg.service
585
586 %post atomic
587 if [ -f %{_sysconfdir}/%{name}/plugins/CCpp.conf ]; then
588         mv -f %{_sysconfdir}/%{name}/plugins/CCpp.conf %{_sysconfdir}/%{name}/plugins/CCpp.conf.rpmsave.atomic || exit 1
589 fi
590 ln -sf %{_sysconfdir}/%{name}/plugins/CCpp_Atomic.conf %{_sysconfdir}/%{name}/plugins/CCpp.conf
591 if [ -f %{_datadir}/%{name}/conf.d/plugins/CCpp.conf ]; then
592         mv -f %{_datadir}/%{name}/conf.d/plugins/CCpp.conf %{_datadir}/%{name}/conf.d/plugins/CCpp.conf.rpmsave.atomic || exit 1;
593 fi
594 ln -sf %{_datadir}/%{name}/conf.d/plugins/CCpp_Atomic.conf %{_datadir}/%{name}/conf.d/plugins/CCpp.conf
595 %systemd_post abrt-coredump-helper.service
596
597 %preun atomic
598 if [ -L %{_sysconfdir}/%{name}/plugins/CCpp.conf ]; then
599         rm -f %{_sysconfdir}/%{name}/plugins/CCpp.conf
600 fi
601 if [ -L %{_datadir}/%{name}/conf.d/plugins/CCpp.conf ]; then
602         rm -f %{_datadir}/%{name}/conf.d/plugins/CCpp.conf
603 fi
604 if [ -f %{_sysconfdir}/%{name}/plugins/CCpp.conf.rpmsave.atomic ]; then
605         mv -f %{_sysconfdir}/%{name}/plugins/CCpp.conf.rpmsave.atomic %{_sysconfdir}/%{name}/plugins/CCpp.conf || exit 1
606 fi
607 if [ -f %{_datadir}/%{name}/conf.d/plugins/CCpp.conf.rpmsave.atomic ]; then
608         mv -f %{_datadir}/%{name}/conf.d/plugins/CCpp.conf.rpmsave.atomic %{_datadir}/%{name}/conf.d/plugins/CCpp.conf || exit 1
609 fi
610
611 %postun atomic
612 %systemd_postun_with_restart abrt-coredump-helper.service
613
614 %post gui
615 %update_icon_cache hicolor
616
617 %postun gui
618 %update_icon_cache hicolor
619
620 %post   gui-libs -p /sbin/ldconfig
621 %postun gui-libs -p /sbin/ldconfig
622
623 %files -f %{name}.lang
624 %defattr(644,root,root,755)
625 %doc README
626 %attr(755,root,root) %{_bindir}/abrt-action-analyze-python
627 %attr(755,root,root) %{_bindir}/abrt-action-notify
628 %attr(755,root,root) %{_bindir}/abrt-action-save-container-data
629 %attr(755,root,root) %{_bindir}/abrt-action-save-package-data
630 %attr(755,root,root) %{_bindir}/abrt-handle-upload
631 %attr(755,root,root) %{_bindir}/abrt-watch-log
632 %attr(755,root,root) %{_sbindir}/abrt-auto-reporting
633 %attr(755,root,root) %{_sbindir}/abrt-server
634 %attr(755,root,root) %{_sbindir}/abrtd
635 %attr(755,root,root) %{_libexecdir}/abrt-action-generate-machine-id
636 %attr(755,root,root) %{_libexecdir}/abrt-action-ureport
637 %attr(755,root,root) %{_libexecdir}/abrt-handle-event
638 %dir %{_datadir}/%{name}
639 %dir %{_datadir}/%{name}/conf.d
640 %{_datadir}/%{name}/conf.d/abrt.conf
641 %{_datadir}/%{name}/conf.d/abrt-action-save-package-data.conf
642 %{_datadir}/%{name}/conf.d/gpg_keys.conf
643 %dir %{_datadir}/%{name}/conf.d/plugins
644 %{_datadir}/augeas/lenses/abrt.aug
645 %dir %{_sysconfdir}/%{name}
646 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt.conf
647 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt-action-save-package-data.conf
648 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/gpg_keys.conf
649 %dir %{_sysconfdir}/%{name}/plugins
650 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_event.conf
651 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/smart_event.conf
652 %attr(754,root,root) /etc/rc.d/init.d/abrtd
653 %{systemdunitdir}/abrtd.service
654 %attr(775,root,abrt) %dir /var/cache/%{name}
655 %dir /var/run/%{name}
656 %{systemdtmpfilesdir}/abrt.conf
657 %{_mandir}/man1/abrt-action-analyze-python.1*
658 %{_mandir}/man1/abrt-action-notify.1*
659 %{_mandir}/man1/abrt-action-save-package-data.1*
660 %{_mandir}/man1/abrt-auto-reporting.1*
661 %{_mandir}/man1/abrt-handle-upload.1*
662 %{_mandir}/man1/abrt-server.1*
663 %{_mandir}/man1/abrt-watch-log.1*
664 %{_mandir}/man5/abrt.conf.5*
665 %{_mandir}/man5/abrt-action-save-package-data.conf.5*
666 %{_mandir}/man5/abrt_event.conf.5*
667 %{_mandir}/man5/gpg_keys.conf.5*
668 %{_mandir}/man5/smart_event.conf.5*
669 %{_mandir}/man8/abrtd.8*
670
671 %files libs
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_libdir}/libabrt.so.*.*.*
674 %attr(755,root,root) %ghost %{_libdir}/libabrt.so.0
675
676 %files devel
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/libabrt.so
679 %dir %{_includedir}/abrt
680 %{_includedir}/abrt/abrt-dbus.h
681 %{_includedir}/abrt/hooklib.h
682 %{_includedir}/abrt/libabrt.h
683 %{_includedir}/abrt/problem_api.h
684 %{_pkgconfigdir}/abrt.pc
685
686 %files addon-ccpp
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_bindir}/abrt-action-analyze-backtrace
689 %attr(755,root,root) %{_bindir}/abrt-action-analyze-c
690 %attr(755,root,root) %{_bindir}/abrt-action-analyze-ccpp-local
691 %attr(755,root,root) %{_bindir}/abrt-action-analyze-core
692 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vulnerability
693 %attr(755,root,root) %{_bindir}/abrt-action-generate-backtrace
694 %attr(755,root,root) %{_bindir}/abrt-action-generate-core-backtrace
695 %attr(755,root,root) %{_bindir}/abrt-action-install-debuginfo
696 %attr(755,root,root) %{_bindir}/abrt-action-list-dsos
697 %attr(755,root,root) %{_bindir}/abrt-action-perform-ccpp-analysis
698 %attr(755,root,root) %{_bindir}/abrt-action-trim-files
699 %attr(755,root,root) %{_bindir}/abrt-dump-journal-core
700 %attr(6755,abrt,abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
701 %attr(755,root,root) %{_libexecdir}/abrt-gdb-exploitable
702 %{_datadir}/%{name}/conf.d/plugins/CCpp.conf
703 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/CCpp.conf
704 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_event.conf
705 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/gconf_event.conf
706 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vimrc_event.conf
707 %attr(775,abrt,abrt) %dir %{_localstatedir}/cache/abrt-di
708 #%attr(754,root,root) /etc/rc.d/init.d/abrt-ccpp
709 %{_datadir}/libreport/events/analyze_CCpp.xml
710 %{_datadir}/libreport/events/analyze_LocalGDB.xml
711 %{_datadir}/libreport/events/collect_GConf.xml
712 %{_datadir}/libreport/events/collect_vimrc_system.xml
713 %{_datadir}/libreport/events/collect_vimrc_user.xml
714 %{_datadir}/libreport/events/collect_xsession_errors.xml
715 %{_datadir}/libreport/events/post_report.xml
716 %{systemdunitdir}/abrt-ccpp.service
717 %{systemdunitdir}/abrt-journal-core.service
718 %{_mandir}/man1/abrt-action-analyze-backtrace.1*
719 %{_mandir}/man1/abrt-action-analyze-c.1*
720 %{_mandir}/man1/abrt-action-analyze-ccpp-local.1*
721 %{_mandir}/man1/abrt-action-analyze-core.1*
722 %{_mandir}/man1/abrt-action-analyze-vulnerability.1*
723 %{_mandir}/man1/abrt-action-generate-backtrace.1*
724 %{_mandir}/man1/abrt-action-generate-core-backtrace.1*
725 %{_mandir}/man1/abrt-action-install-debuginfo.1*
726 %{_mandir}/man1/abrt-action-list-dsos.1*
727 %{_mandir}/man1/abrt-action-perform-ccpp-analysis.1*
728 %{_mandir}/man1/abrt-action-trim-files.1*
729 %{_mandir}/man5/abrt-CCpp.conf.5*
730 %{_mandir}/man5/ccpp_event.conf.5*
731 %{_mandir}/man5/ccpp_retrace_event.conf.5*
732 %{_mandir}/man5/gconf_event.conf.5*
733 %{_mandir}/man5/vimrc_event.conf.5*
734
735 %files addon-coredump-helper
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_sbindir}/abrt-install-ccpp-hook
738 %attr(755,root,root) %{_libexecdir}/abrt-hook-ccpp
739 %{_mandir}/man1/abrt-install-ccpp-hook.1*
740
741 %files addon-kerneloops
742 %defattr(644,root,root,755)
743 %attr(755,root,root) %{_bindir}/abrt-action-analyze-oops
744 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-hw-error
745 %attr(755,root,root) %{_bindir}/abrt-action-save-kernel-data
746 %attr(755,root,root) %{_bindir}/abrt-dump-journal-oops
747 %attr(755,root,root) %{_bindir}/abrt-dump-oops
748 %{_datadir}/%{name}/conf.d/plugins/oops.conf
749 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/koops_event.conf
750 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/oops.conf
751 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.oops.xml
752 #%attr(754,root,root) /etc/rc.d/init.d/abrt-oops
753 %{systemdunitdir}/abrt-oops.service
754 %{_mandir}/man1/abrt-action-analyze-oops.1*
755 %{_mandir}/man1/abrt-action-check-oops-for-hw-error.1*
756 %{_mandir}/man1/abrt-action-save-kernel-data.1*
757 %{_mandir}/man1/abrt-dump-journal-oops.1*
758 %{_mandir}/man1/abrt-dump-oops.1*
759 %{_mandir}/man5/abrt-oops.conf.5*
760 %{_mandir}/man5/koops_event.conf.5*
761
762 %files addon-pstoreoops
763 %defattr(644,root,root,755)
764 %attr(755,root,root) %{_bindir}/abrt-merge-pstoreoops
765 %attr(755,root,root) %{_sbindir}/abrt-harvest-pstoreoops
766 %{systemdunitdir}/abrt-pstoreoops.service
767 #%attr(754,root,root) /etc/rc.d/init.d/abrt-pstoreoops
768 %{_mandir}/man1/abrt-harvest-pstoreoops.1*
769 %{_mandir}/man1/abrt-merge-pstoreoops.1*
770
771 %files addon-python
772 %defattr(644,root,root,755)
773 %{_datadir}/%{name}/conf.d/plugins/python.conf
774 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/python.conf
775 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/python_event.conf
776 %{py_sitedir}/abrt_exception_handler.py[co]
777 %{py_sitedir}/abrt.pth
778 %{_mandir}/man5/abrt-python.conf.5*
779 %{_mandir}/man5/python_event.conf.5*
780
781 %files addon-python3
782 %defattr(644,root,root,755)
783 %{_datadir}/%{name}/conf.d/plugins/python3.conf
784 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/python3.conf
785 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/python3_event.conf
786 %{py3_sitedir}/abrt_exception_handler3.py*
787 %{py3_sitedir}/abrt3.pth
788 %{_mandir}/man5/abrt-python3.conf.5*
789 %{_mandir}/man5/python3_event.conf.5*
790
791 %files addon-upload-watch
792 %defattr(644,root,root,755)
793 %attr(755,root,root) %{_sbindir}/abrt-upload-watch
794 %{systemdunitdir}/abrt-upload-watch.service
795 %{_mandir}/man1/abrt-upload-watch.1*
796
797 %files addon-vmcore
798 %defattr(644,root,root,755)
799 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vmcore
800 %attr(755,root,root) %{_sbindir}/abrt-harvest-vmcore
801 %dir %{_datadir}/%{name}/conf.d/plugins/vmcore.conf
802 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/vmcore.conf
803 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vmcore_event.conf
804 #%attr(754,root,root) /etc/rc.d/init.d/abrt-vmcore
805 %{_datadir}/libreport/events/analyze_VMcore.xml
806 %{systemdunitdir}/abrt-vmcore.service
807 %{_mandir}/man1/abrt-action-analyze-vmcore.1*
808 %{_mandir}/man1/abrt-harvest-vmcore.1*
809 %{_mandir}/man5/abrt-vmcore.conf.5*
810 %{_mandir}/man5/vmcore_event.conf.5*
811
812 %files addon-xorg
813 %defattr(644,root,root,755)
814 %attr(755,root,root) %{_bindir}/abrt-action-analyze-xorg
815 %attr(755,root,root) %{_bindir}/abrt-dump-xorg
816 %dir %{_datadir}/%{name}/conf.d/plugins/xorg.conf
817 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/xorg.conf
818 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/xorg_event.conf
819 #%attr(754,root,root) /etc/rc.d/init.d/abrt-xorg
820 %{systemdunitdir}/abrt-xorg.service
821 %{_mandir}/man1/abrt-action-analyze-xorg.1*
822 %{_mandir}/man1/abrt-dump-xorg.1*
823 %{_mandir}/man5/abrt-xorg.conf.5*
824 %{_mandir}/man5/xorg_event.conf.5*
825
826 %files atomic
827 %defattr(644,root,root,755)
828 %{_datadir}/%{name}/conf.d/plugins/CCpp_Atomic.conf
829 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/CCpp_Atomic.conf
830 %{systemdunitdir}/abrt-coredump-helper.service
831
832 %files plugin-bodhi
833 %defattr(644,root,root,755)
834 %attr(755,root,root) %{_bindir}/abrt-bodhi
835 %{_mandir}/man1/abrt-bodhi.1*
836
837 %files retrace-client
838 %defattr(644,root,root,755)
839 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_retrace_event.conf
840 %attr(755,root,root) %{_bindir}/abrt-retrace-client
841 %{_datadir}/libreport/events/analyze_RetraceServer.xml
842 %{_mandir}/man1/abrt-retrace-client.1*
843
844 %files dbus
845 %defattr(644,root,root,755)
846 %attr(755,root,root) %{_sbindir}/abrt-configuration
847 %attr(755,root,root) %{_sbindir}/abrt-dbus
848 /etc/dbus-1/system.d/dbus-abrt.conf
849 /etc/dbus-1/system.d/org.freedesktop.problems.daemon.conf
850 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.abrt.xml
851 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ccpp.xml
852 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.python.xml
853 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.vmcore.xml
854 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.xml
855 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.xorg.xml
856 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems.xml
857 %{_datadir}/dbus-1/system-services/com.redhat.problems.configuration.service
858 %{_datadir}/dbus-1/system-services/org.freedesktop.problems.service
859 %{_datadir}/polkit-1/actions/abrt_polkit.policy
860 %{_mandir}/man8/abrt-configuration.8*
861 %{_mandir}/man8/abrt-dbus.8*
862 %{_docdir}/abrt-dbus-%{version}
863
864 %files python
865 %defattr(644,root,root,755)
866 %dir %{py_sitedir}/problem
867 %attr(755,root,root) %{py_sitedir}/problem/_pyabrt.so
868 %{py_sitedir}/problem/*.py[co]
869 %{_mandir}/man5/abrt-python.5*
870
871 %files python3
872 %defattr(644,root,root,755)
873 %dir %{py3_sitedir}/problem
874 %attr(755,root,root) %{py3_sitedir}/problem/_py3abrt.so
875 %{py3_sitedir}/problem/*.py*
876 %{_mandir}/man5/abrt-python3.5*
877
878 %files cli
879 %defattr(644,root,root,755)
880 %attr(755,root,root) %{_bindir}/abrt-cli
881 %{_mandir}/man1/abrt-cli.1*
882
883 %files gui
884 %defattr(644,root,root,755)
885 %attr(755,root,root) %{_bindir}/abrt-applet
886 %attr(755,root,root) %{_bindir}/system-config-abrt
887 %dir %{_datadir}/%{name}
888 %{_datadir}/%{name}/icons
889 %{_datadir}/%{name}/ui
890 %{_iconsdir}/hicolor/*/apps/abrt.png
891 %{_iconsdir}/hicolor/*/status/abrt.png
892 %{_sysconfdir}/xdg/autostart/abrt-applet.desktop
893 %{_mandir}/man1/abrt-applet.1*
894 %{_mandir}/man1/system-config-abrt.1*
895
896 %files gui-libs
897 %defattr(644,root,root,755)
898 %attr(755,root,root) %{_libdir}/libabrt_gui.so.*.*.*
899 %attr(755,root,root) %ghost %{_libdir}/libabrt_gui.so.0
900
901 %files gui-devel
902 %defattr(644,root,root,755)
903 %attr(755,root,root) %{_libdir}/libabrt_gui.so
904 %{_includedir}/abrt/abrt-config-widget.h
905 %{_includedir}/abrt/system-config-abrt.h
906 %{_pkgconfigdir}/abrt_gui.pc
907
908 %files desktop
909 %defattr(644,root,root,755)
910
911 %files console-notification
912 %defattr(644,root,root,755)
913 %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/abrt-console-notification.sh
This page took 0.202718 seconds and 3 git commands to generate.