]> git.pld-linux.org Git - packages/abrt.git/blob - abrt.spec
- updated to 2.2.0
[packages/abrt.git] / abrt.spec
1 #
2 # TODO:
3 # - handle obsolete packages: abrt-plugin-{catcut,rhfastcheck,rhticket,ticketuploader}
4 # - SysV init scripts for -addon-ccpp, -addon-kerneloops, -addon-pstoreoops, -addon-upload-watch, -addon-vmcore, -addon-xorg
5 # - teach build system to use python3.2+ __pycache__
6 %define         libreport_ver   2.2.0
7 Summary:        Automatic bug detection and reporting tool
8 Summary(pl.UTF-8):      Narzędzie do automatycznego wykrywania i zgłaszania błędów
9 Name:           abrt
10 Version:        2.2.0
11 Release:        1
12 License:        GPL v2+
13 Group:          Applications/System
14 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
15 # Source0-md5:  7d5325ece7728a6058c94999ce2ceccb
16 Source1:        %{name}.init
17 Patch0:         %{name}-rpm5.patch
18 Patch1:         %{name}-rpm45.patch
19 Patch2:         format_security.patch
20 Patch3:         %{name}-link.patch
21 Patch4:         %{name}-po.patch
22 URL:            https://fedorahosted.org/abrt/
23 BuildRequires:  asciidoc
24 BuildRequires:  autoconf >= 2.50
25 BuildRequires:  automake
26 BuildRequires:  dbus-devel
27 BuildRequires:  gettext-devel >= 0.17
28 BuildRequires:  glib2-devel >= 1:2.21
29 BuildRequires:  gtk+3-devel >= 3.0
30 BuildRequires:  intltool >= 0.35.0
31 BuildRequires:  json-c-devel
32 BuildRequires:  libmagic-devel
33 BuildRequires:  libnotify-devel
34 BuildRequires:  libreport-devel >= %{libreport_ver}
35 BuildRequires:  libreport-gtk-devel >= %{libreport_ver}
36 BuildRequires:  libreport-web-devel >= %{libreport_ver}
37 BuildRequires:  libtool
38 BuildRequires:  libxml2-devel >= 2
39 BuildRequires:  nss-devel
40 BuildRequires:  pkgconfig
41 BuildRequires:  polkit-devel
42 BuildRequires:  python-devel >= 2
43 BuildRequires:  python-modules >= 2
44 BuildRequires:  python3-devel >= 3
45 BuildRequires:  python3-modules >= 3
46 BuildRequires:  rpm-devel >= 4.5-28
47 BuildRequires:  rpm-pythonprov
48 BuildRequires:  rpmbuild(macros) >= 1.219
49 BuildRequires:  satyr-devel
50 BuildRequires:  xmlto
51 BuildRequires:  xorg-lib-libICE-devel
52 BuildRequires:  xorg-lib-libSM-devel
53 Requires(postun):       /usr/sbin/groupdel
54 Requires(postun):       /usr/sbin/userdel
55 Requires(pre):  /bin/id
56 Requires(pre):  /usr/bin/getgid
57 Requires(pre):  /usr/sbin/groupadd
58 Requires(pre):  /usr/sbin/useradd
59 Requires:       %{name}-libs = %{version}-%{release}
60 Provides:       group(abrt)
61 Provides:       user(abrt)
62 Obsoletes:      abrt-plugin-filetransfer
63 Obsoletes:      abrt-plugin-runapp
64 Obsoletes:      abrt-plugin-sosreport
65 Obsoletes:      abrt-plugin-sqlite3
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 ABRT is a tool to help users to detect defects in applications and to
70 create a bug report with all informations needed by maintainer to fix
71 it. It uses plugin system to extend its functionality.
72
73 %description -l pl.UTF-8
74 ABRT to narzędzie pomagające użytkownikom w wykrywaniu defektów w
75 aplikacjach oraz tworzeniu raportów błędów ze wszystkimi informacjami
76 potrzebnymi utrzymującemu pakiet do poprawienia go. Wykorzystuje
77 system wtyczek do rozszerzania funkcjonalności.
78
79 %package libs
80 Summary:        ABRT shared library
81 Summary(pl.UTF-8):      Biblioteka współdzielona ABRT
82 Group:          Libraries
83 Requires:       glib2 >= 1:2.21
84 Requires:       libreport >= %{libreport_ver}
85
86 %description libs
87 ABRT shared library.
88
89 %description libs -l pl.UTF-8
90 Biblioteka współdzielona ABRT.
91
92 %package devel
93 Summary:        Header files for ABRT livrary
94 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotekia ABRT
95 Group:          Development/Libraries
96 Requires:       %{name}-libs = %{version}-%{release}
97 Requires:       glib2-devel >= 1:2.21
98 Requires:       libreport-devel >= %{libreport_ver}
99
100 %description devel
101 Header files for ABRT livrary.
102
103 %description devel -l pl.UTF-8
104 Pliki nagłówkowe biblioteki ABRT.
105
106 %package addon-ccpp
107 Summary:        ABRT's C/C++ addon
108 Summary(pl.UTF-8):      Dodatek C/C++ do ABRT
109 Group:          Libraries
110 Requires:       %{name} = %{version}-%{release}
111 Requires:       %{name}-retrace-client = %{version}-%{release}
112 Requires:       cpio
113 Requires:       elfutils
114 Requires:       gdb >= 7.0-3
115 Requires:       satyr
116 Requires:       yum-utils
117
118 %description addon-ccpp
119 This package contains hook for C/C++ crashed programs and abrt's C/C++
120 analyzer plugin.
121
122 %description addon-ccpp -l pl.UTF-8
123 Ten pakiet zawiera punkt zaczepienia dla programów w C/C++, które
124 uległy awarii oraz wtyczkę analizatora C/C++ ABRT.
125
126 %package addon-kerneloops
127 Summary:        ABRT's kerneloops addon
128 Summary(pl.UTF-8):      Dodatek kerneloops do ABRT
129 Group:          Libraries
130 Requires:       %{name} = %{version}-%{release}
131 Requires:       curl
132 Requires:       libreport-plugin-kerneloops >= %{libreport_ver}
133 Obsoletes:      abrt-plugin-kerneloops
134 Obsoletes:      abrt-plugin-kerneloopsreporter
135 Obsoletes:      kerneloops
136
137 %description addon-kerneloops
138 This package contains plugin for collecting kernel crash information
139 from system log.
140
141 %description addon-kerneloops -l pl.UTF-8
142 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
143 logu systemowego.
144
145 %package addon-pstoreoops
146 Summary:        ABRT's pstoreoops addon
147 Summary(pl.UTF-8):      Dodatek pstoreoops do ABRT
148 Group:          Libraries
149 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
150 Obsoletes:      abrt-addon-uefioops
151
152 %description addon-pstoreoops
153 This package contains plugin for collecting kernel oopses from pstore
154 storage.
155
156 %description addon-pstoreoops -l pl.UTF-8
157 Ten pakiet zawiera wtyczkę do zbierania oopsów jądra z danych pstore.
158
159 %package addon-python
160 Summary:        ABRT's addon for catching and analyzing Python 2 exceptions
161 Summary(pl.UTF-8):      Dodatek ABRT do przechwytywania i analizy wyjątków Pythona 2
162 Group:          Libraries
163 Requires:       %{name} = %{version}-%{release}
164 Requires:       %{name}-python = %{version}-%{release}
165 # for detecting package name containing offending file
166 Suggests:       python-rpm
167 # for logging to journal
168 Suggests:       python-systemd
169 Obsoletes:      gnome-python2-bugbuddy
170
171 %description addon-python
172 This package contains Python hook and Python analyzer plugin for
173 handling uncaught exception in Python 2 programs.
174
175 %description addon-python -l pl.UTF-8
176 Ten pakiet zawiera pythonowy punkt zaczepienia oraz wtyczkę
177 analizatora Pythona do obsługi nie obsłużonych wyjątków w programach w
178 Pythonie 2.
179
180 %package addon-python3
181 Summary:        ABRT's addon for catching and analyzing Python 3 exceptions
182 Summary(pl.UTF-8):      Dodatek ABRT do przechwytywania i analizy wyjątków Pythona 3
183 Group:          Libraries
184 Requires:       %{name} = %{version}-%{release}
185 Requires:       %{name}-python3 = %{version}-%{release}
186 # for detecting package name containing offending file (TODO: python3-rpm package)
187 #Suggests:      python3-rpm
188 # for logging to journal (TODO: python3-systemd package)
189 #Suggests:      python3-systemd
190
191 %description addon-python3
192 This package contains Python hook and Python analyzer plugin for
193 handling uncaught exception in Python 3 programs.
194
195 %description addon-python3 -l pl.UTF-8
196 Ten pakiet zawiera pythonowy punkt zaczepienia oraz wtyczkę
197 analizatora Pythona do obsługi nie obsłużonych wyjątków w programach w
198 Pythonie 3.
199
200 %package addon-upload-watch
201 Summary:        ABRT's upload addon
202 Summary(pl.UTF-8):      Dodatek upload do ABRT
203 Group:          Libraries
204 Requires:       %{name} = %{version}-%{release}
205
206 %description addon-upload-watch
207 This package contains hook for uploaded problems.
208
209 %description addon-upload-watch -l pl.UTF-8
210 Ten pakiet zawiera uchwyt dla problemów przysłanych.
211
212 %package addon-vmcore
213 Summary:        ABRT's vmcore addon
214 Summary(pl.UTF-8):      Dodatek vmcore do ABRT
215 Group:          Libraries
216 Requires:       %{name} = %{version}-%{release}
217 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
218 Requires:       crash
219
220 %description addon-vmcore
221 This package contains plugin for collecting kernel crash information
222 from vmcore files.
223
224 %description addon-vmcore -l pl.UTF-8
225 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
226 plików vmcore.
227
228 %package addon-xorg
229 Summary:        ABRT's Xorg addon
230 Summary(pl.UTF-8):      Dodatek Xorg do ABRT
231 Group:          Libraries
232 Requires:       %{name} = %{version}-%{release}
233 Requires:       curl
234
235 %description addon-xorg
236 This package contains plugin for collecting Xorg crash information
237 from Xorg log.
238
239 %description addon-xorg -l pl.UTF-8
240 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
241 logu Xorg.
242
243 %package plugin-bodhi
244 Summary:        ABRT's bodhi plugin
245 Summary(pl.UTF-8):      Wtyczka bodhi do ABRT
246 Group:          Libraries
247 Requires:       %{name} = %{version}-%{release}
248 Requires:       libreport-web >= %{libreport_ver}
249 Obsoletes:      libreport-plugin-bodhi
250
251 %description plugin-bodhi
252 Plugin to search for a new updates in bodhi server.
253
254 %description plugin-bodhi -l pl.UTF-8
255 Wtyczka do wyszukiwania nowych uaktualnień na serwerze bodhi.
256
257 %package retrace-client
258 Summary:        ABRT's retrace client
259 Summary(pl.UTF-8):      Klient Retrace dla ABRT
260 Group:          Libraries
261 Requires:       %{name} = %{version}-%{release}
262 Requires:       xz
263
264 %description retrace-client
265 This package contains the client application for Retrace server which
266 is able to analyze C/C++ crashes remotely.
267
268 %description retrace-client -l pl.UTF-8
269 Ten pakiet zawiera aplikację kliencką dla serwera Retrace, który
270 potrafi zdalnie przeanalizować awarię programu w C/C++.
271
272 %package dbus
273 Summary:        ABRT DBus service
274 Summary(pl.UTF-8):      Usługa DBus ABRT
275 Group:          Applications/System
276 Requires:       %{name} = %{version}-%{release}
277 Requires:       libreport >= %{libreport_ver}
278
279 %description dbus
280 ABRT DBus service which provides org.freedesktop.problems API on DBus
281 and uses PolicyKit to authorize to access the problem data.
282
283 %description dbus -l pl.UTF-8
284 Usługa DBus ABRT, udostępniająca poprzez DBus API
285 org.freedesktop.problems, używająca PolicyKit do autoryzacji dostępu
286 do danych o problemach.
287
288 %package python
289 Summary:        ABRT Python 2 API
290 Summary(pl.UTF-8):      API Pythona 2 do ABRT
291 Group:          Libraries/Python
292 Requires:       %{name} = %{version}-%{release}
293 Requires:       python-libreport >= %{libreport_ver}
294
295 %description python
296 High-level API for querying, creating and manipulating problems
297 handled by ABRT in Python 2.
298
299 %description python -l pl.UTF-8
300 Wysokopoziomowe API do odpytywania, tworzenia i obróbki z poziomu
301 Pythona 2 problemów obsługiwanych przez ABRT.
302
303 %package python3
304 Summary:        ABRT Python 3 API
305 Summary(pl.UTF-8):      API Pythona 3 do ABRT
306 Group:          Libraries/Python
307 Requires:       %{name} = %{version}-%{release}
308 Requires:       python3-libreport >= %{libreport_ver}
309
310 %description python3
311 High-level API for querying, creating and manipulating problems
312 handled by ABRT in Python.
313
314 %description python3 -l pl.UTF-8
315 Wysokopoziomowe API do odpytywania, tworzenia i obróbki z poziomu
316 Pythona 3 problemów obsługiwanych przez ABRT.
317
318 %package cli
319 Summary:        ABRT's command line interface
320 Summary(pl.UTF-8):      Interfejs linii poleceń ABRT
321 Group:          Applications/System
322 Requires:       %{name} = %{version}-%{release}
323 # analyzers
324 Requires:       %{name}-addon-ccpp = %{version}-%{release}
325 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
326 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
327 Requires:       %{name}-addon-python = %{version}-%{release}
328 # reporters
329 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
330 Requires:       libreport-plugin-logger >= %{libreport_ver}
331
332 %description cli
333 This package contains simple command line client for controling ABRT
334 daemon over the sockets.
335
336 %description cli -l pl.UTF-8
337 Ten pakiet zawiera prostego klienta obsługiwanego z linii poleceń,
338 pozwalającego na sterowanie demonem poprzez gniazda.
339
340 %package gui
341 Summary:        ABRT's GUI
342 Summary(pl.UTF-8):      Graficzny interfejs użytkownika do ABRT
343 Group:          X11/Applications
344 Requires(post,postun):  /sbin/ldconfig
345 Requires(post,postun):  gtk-update-icon-cache
346 Requires(post,postun):  hicolor-icon-theme
347 Requires:       %{name} = %{version}-%{release}
348 Requires:       %{name}-dbus = %{version}-%{release}
349 Requires:       %{name}-gui-libs = %{version}-%{release}
350 Suggests:       gnome-abrt
351 Provides:       abrt-applet = %{version}-%{release}
352 Obsoletes:      abrt-applet < 0.0.5
353 Conflicts:      abrt-applet < 0.0.5
354
355 %description gui
356 GTK+ wizard for convenient bug reporting.
357
358 %description gui -l pl.UTF-8
359 Oparty na GTK+ kreator do wygodnego zgłaszania błędów.
360
361 %package gui-libs
362 Summary:        ABRT's GUI library
363 Summary(pl.UTF-8):      Biblioteka graficznego interfejsu użytkownika ABRT
364 Group:          X11/Libraries
365 Requires:       %{name}-libs = %{version}-%{release}
366 Requires:       gtk+3 >= 3.0
367
368 %description gui-libs
369 ABRT's GUI library.
370
371 %description gui-libs -l pl.UTF-8
372 Biblioteka graficznego interfejsu użytkownika ABRT.
373
374 %package gui-devel
375 Summary:        Header files for ABRT GUI library
376 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT
377 Group:          X11/Development/Libraries
378 Requires:       %{name}-devel = %{version}-%{release}
379 Requires:       %{name}-gui-libs = %{version}-%{release}
380 Requires:       gtk+3-devel >= 3.0
381
382 %description gui-devel
383 Header files for ABRT GUI library.
384
385 %description gui-devel -l pl.UTF-8
386 Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT.
387
388 %package desktop
389 Summary:        Virtual package to install all necessary packages for usage from desktop environment
390 Summary(pl.UTF-8):      Writualny pakiet do instalacji pakietów potrzebnych do użycia w środowisku graficznym
391 Group:          X11/Applications
392 # This package should be installed when anything requests bug-buddy;
393 # installing abrt-desktop should result in the abrt which works without
394 # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
395 Requires:       %{name} = %{version}-%{release}
396 Requires:       %{name}-addon-ccpp = %{version}-%{release}
397 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
398 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
399 Requires:       %{name}-addon-python = %{version}-%{release}
400 Requires:       %{name}-addon-vmcore = %{version}-%{release}
401 Requires:       %{name}-addon-xorg = %{version}-%{release}
402 Requires:       %{name}-gui = %{version}-%{release}
403 Requires:       %{name}-plugin-bodhi = %{version}-%{release}
404 Requires:       %{name}-retrace-client = %{version}-%{release}
405 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
406 Requires:       libreport-plugin-logger >= %{libreport_ver}
407 Requires:       libreport-plugin-ureport >= %{libreport_ver}
408 Provides:       bug-buddy
409 Obsoletes:      bug-buddy
410
411 %description desktop
412 Virtual package to make easy default installation on desktop
413 environments.
414
415 %description desktop -l pl.UTF-8
416 Wirtualny pakiet ułatwiający domyślną instalację w środowiskach
417 graficznych.
418
419 %package console-notification
420 Summary:        ABRT console notification script
421 Summary(pl.UTF-8):      Skrypt ABRT do powiadomień na konsoli
422 Group:          Applications/System
423 Requires:       %{name} = %{version}-%{release}
424 Requires:       %{name}-cli = %{version}-%{release}
425
426 %description console-notification
427 A small script which prints a count of detected problems when someone
428 logs in to the shell.
429
430 %description console-notification -l pl.UTF-8
431 Mały skrypt wypisujący liczbę wykrytych problemów, kiedy ktoś loguje
432 się do powłoki.
433
434 %prep
435 %setup -q
436 %if "%{_rpmversion}" >= "5.0"
437 %patch0 -p1
438 %else
439 %patch1 -p1
440 %endif
441 %patch2 -p1
442 %patch3 -p1
443 %patch4 -p1
444
445 %build
446 %{__libtoolize}
447 %{__aclocal}
448 %{__autoconf}
449 %{__autoheader}
450 %{__automake}
451 %configure \
452         --disable-silent-rules \
453         --with-systemdsystemunitdir=%{systemdunitdir}
454
455 %{__make}
456
457 %install
458 rm -rf $RPM_BUILD_ROOT
459 %{__make} install \
460         DESTDIR=$RPM_BUILD_ROOT
461
462 %py_postclean
463
464 # obsoleted by pkg-config
465 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
466
467 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/abrtd
468 install -d $RPM_BUILD_ROOT/var/cache/%{name}
469 install -d $RPM_BUILD_ROOT/var/cache/%{name}-di
470 install -d $RPM_BUILD_ROOT/var/run/%{name}
471
472 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
473 cat > $RPM_BUILD_ROOT%{systemdtmpfilesdir}/abrt.conf <<EOF
474 d /var/run/%{name} 0755 root root -
475 EOF
476
477 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/problem/*.la
478 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/problem/*.la
479 # examples
480 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/problem_examples
481 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/problem_examples
482 # outdated copy of lt
483 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/lt_LT
484
485 # fool man verification - report_event.conf.5 belongs to libreport (NOTE: don't package it here)
486 touch $RPM_BUILD_ROOT%{_mandir}/man5/report_event.conf.5
487
488 %find_lang %{name}
489
490 %clean
491 rm -rf $RPM_BUILD_ROOT
492
493 %pre
494 %groupadd -g 248 abrt
495 %useradd -u 248 -g abrt -d /etc/abrt -s /sbin/nologin abrt
496
497 %post
498 /sbin/chkconfig --add abrtd
499 %service abrtd restart
500 %systemd_post abrtd.service
501
502 %preun
503 if [ "$1" = "0" ]; then
504         %service abrtd stop
505         /sbin/chkconfig --del abrtd
506 fi
507 %systemd_preun abrtd.service
508
509 %postun
510 if [ "$1" = "0" ]; then
511         %userremove abrt
512         %groupremove abrt
513 fi
514
515 %post   libs -p /sbin/ldconfig
516 %postun libs -p /sbin/ldconfig
517
518 %post addon-ccpp
519 %systemd_post abrt-ccpp.service
520
521 %preun addon-ccpp
522 %systemd_preun abrt-ccpp.service
523
524 %post addon-kerneloops
525 %systemd_post abrt-oops.service
526
527 %preun addon-kerneloops
528 %systemd_preun abrt-oops.service
529
530 %post addon-pstoreoops
531 %systemd_post abrt-pstoreoops.service
532
533 %preun addon-pstoreoops
534 %systemd_preun abrt-pstoreoops.service
535
536 %post addon-upload-watch
537 %systemd_post abrt-upload-watch.service
538
539 %preun addon-upload-watch
540 %systemd_preun abrt-upload-watch.service
541
542 %post addon-vmcore
543 %systemd_post abrt-vmcore.service
544
545 %preun addon-vmcore
546 %systemd_preun abrt-vmcore.service
547
548 %post addon-xorg
549 %systemd_post abrt-xorg.service
550
551 %preun addon-xorg
552 %systemd_preun abrt-xorg.service
553
554 %post gui
555 %update_icon_cache hicolor
556
557 %postun gui
558 %update_icon_cache hicolor
559
560 %post   gui-libs -p /sbin/ldconfig
561 %postun gui-libs -p /sbin/ldconfig
562
563 %files -f %{name}.lang
564 %defattr(644,root,root,755)
565 %doc README
566 %attr(755,root,root) %{_bindir}/abrt-action-analyze-python
567 %attr(755,root,root) %{_bindir}/abrt-action-notify
568 %attr(755,root,root) %{_bindir}/abrt-action-save-package-data
569 %attr(755,root,root) %{_bindir}/abrt-handle-upload
570 %attr(755,root,root) %{_bindir}/abrt-watch-log
571 %attr(755,root,root) %{_sbindir}/abrt-auto-reporting
572 %attr(755,root,root) %{_sbindir}/abrt-server
573 %attr(755,root,root) %{_sbindir}/abrtd
574 %attr(755,root,root) %{_libexecdir}/abrt-action-ureport
575 %attr(755,root,root) %{_libexecdir}/abrt-handle-event
576 %dir %{_datadir}/%{name}
577 %dir %{_datadir}/%{name}/conf.d
578 %{_datadir}/%{name}/conf.d/abrt.conf
579 %{_datadir}/%{name}/conf.d/abrt-action-save-package-data.conf
580 %{_datadir}/%{name}/conf.d/gpg_keys.conf
581 %dir %{_datadir}/%{name}/conf.d/plugins
582 %{_datadir}/augeas/lenses/abrt.aug
583 %dir %{_sysconfdir}/%{name}
584 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt.conf
585 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt-action-save-package-data.conf
586 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/gpg_keys.conf
587 %dir %{_sysconfdir}/%{name}/plugins
588 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_event.conf
589 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/smart_event.conf
590 %attr(754,root,root) /etc/rc.d/init.d/abrtd
591 %{systemdunitdir}/abrtd.service
592 %attr(775,root,abrt) %dir /var/cache/%{name}
593 %dir /var/run/%{name}
594 %{systemdtmpfilesdir}/abrt.conf
595 %{_mandir}/man1/abrt-action-analyze-python.1*
596 %{_mandir}/man1/abrt-action-notify.1*
597 %{_mandir}/man1/abrt-action-save-package-data.1*
598 %{_mandir}/man1/abrt-auto-reporting.1*
599 %{_mandir}/man1/abrt-handle-upload.1*
600 %{_mandir}/man1/abrt-server.1*
601 %{_mandir}/man1/abrt-watch-log.1*
602 %{_mandir}/man5/abrt.conf.5*
603 %{_mandir}/man5/abrt-action-save-package-data.conf.5*
604 %{_mandir}/man5/abrt_event.conf.5*
605 %{_mandir}/man5/gpg_keys.conf.5*
606 %{_mandir}/man5/smart_event.conf.5*
607 %{_mandir}/man8/abrtd.8*
608
609 %files libs
610 %defattr(644,root,root,755)
611 %attr(755,root,root) %{_libdir}/libabrt.so.*.*.*
612 %attr(755,root,root) %ghost %{_libdir}/libabrt.so.0
613
614 %files devel
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_libdir}/libabrt.so
617 %dir %{_includedir}/abrt
618 %{_includedir}/abrt/abrt-dbus.h
619 %{_includedir}/abrt/hooklib.h
620 %{_includedir}/abrt/libabrt.h
621 %{_includedir}/abrt/problem_api.h
622 %{_pkgconfigdir}/abrt.pc
623
624 %files addon-ccpp
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_bindir}/abrt-action-analyze-backtrace
627 %attr(755,root,root) %{_bindir}/abrt-action-analyze-c
628 %attr(755,root,root) %{_bindir}/abrt-action-analyze-ccpp-local
629 %attr(755,root,root) %{_bindir}/abrt-action-analyze-core
630 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vulnerability
631 %attr(755,root,root) %{_bindir}/abrt-action-generate-backtrace
632 %attr(755,root,root) %{_bindir}/abrt-action-generate-core-backtrace
633 %attr(755,root,root) %{_bindir}/abrt-action-install-debuginfo
634 %attr(755,root,root) %{_bindir}/abrt-action-list-dsos
635 %attr(755,root,root) %{_bindir}/abrt-action-perform-ccpp-analysis
636 %attr(755,root,root) %{_bindir}/abrt-action-trim-files
637 %attr(755,root,root) %{_sbindir}/abrt-install-ccpp-hook
638 %attr(6755,abrt,abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
639 %attr(755,root,root) %{_libexecdir}/abrt-gdb-exploitable
640 %attr(755,root,root) %{_libexecdir}/abrt-hook-ccpp
641 %dir %{_datadir}/%{name}/conf.d/plugins/CCpp.conf
642 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/CCpp.conf
643 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_event.conf
644 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/gconf_event.conf
645 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vimrc_event.conf
646 %attr(775,abrt,abrt) %dir %{_localstatedir}/cache/abrt-di
647 #%attr(754,root,root) /etc/rc.d/init.d/abrt-ccpp
648 %{_datadir}/libreport/events/analyze_CCpp.xml
649 %{_datadir}/libreport/events/analyze_LocalGDB.xml
650 %{_datadir}/libreport/events/collect_GConf.xml
651 %{_datadir}/libreport/events/collect_vimrc_system.xml
652 %{_datadir}/libreport/events/collect_vimrc_user.xml
653 %{_datadir}/libreport/events/collect_xsession_errors.xml
654 %{_datadir}/libreport/events/post_report.xml
655 %{systemdunitdir}/abrt-ccpp.service
656 %{_mandir}/man1/abrt-action-analyze-backtrace.1*
657 %{_mandir}/man1/abrt-action-analyze-c.1*
658 %{_mandir}/man1/abrt-action-analyze-ccpp-local.1*
659 %{_mandir}/man1/abrt-action-analyze-core.1*
660 %{_mandir}/man1/abrt-action-analyze-vulnerability.1*
661 %{_mandir}/man1/abrt-action-generate-backtrace.1*
662 %{_mandir}/man1/abrt-action-generate-core-backtrace.1*
663 %{_mandir}/man1/abrt-action-install-debuginfo.1*
664 %{_mandir}/man1/abrt-action-list-dsos.1*
665 %{_mandir}/man1/abrt-action-perform-ccpp-analysis.1*
666 %{_mandir}/man1/abrt-action-trim-files.1*
667 %{_mandir}/man1/abrt-install-ccpp-hook.1*
668 %{_mandir}/man5/abrt-CCpp.conf.5*
669 %{_mandir}/man5/ccpp_event.conf.5*
670 %{_mandir}/man5/ccpp_retrace_event.conf.5*
671 %{_mandir}/man5/gconf_event.conf.5*
672 %{_mandir}/man5/vimrc_event.conf.5*
673
674 %files addon-kerneloops
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_bindir}/abrt-action-analyze-oops
677 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-hw-error
678 %attr(755,root,root) %{_bindir}/abrt-action-save-kernel-data
679 %attr(755,root,root) %{_bindir}/abrt-dump-oops
680 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/koops_event.conf
681 #%attr(754,root,root) /etc/rc.d/init.d/abrt-oops
682 %{systemdunitdir}/abrt-oops.service
683 %{_mandir}/man1/abrt-action-analyze-oops.1*
684 %{_mandir}/man1/abrt-action-check-oops-for-hw-error.1*
685 %{_mandir}/man1/abrt-action-save-kernel-data.1*
686 %{_mandir}/man1/abrt-dump-oops.1*
687 %{_mandir}/man5/koops_event.conf.5*
688
689 %files addon-pstoreoops
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{_bindir}/abrt-merge-pstoreoops
692 %attr(755,root,root) %{_sbindir}/abrt-harvest-pstoreoops
693 %{systemdunitdir}/abrt-pstoreoops.service
694 #%attr(754,root,root) /etc/rc.d/init.d/abrt-pstoreoops
695 %{_mandir}/man1/abrt-harvest-pstoreoops.1*
696 %{_mandir}/man1/abrt-merge-pstoreoops.1*
697
698 %files addon-python
699 %defattr(644,root,root,755)
700 %{_datadir}/%{name}/conf.d/plugins/python.conf
701 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/python.conf
702 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/python_event.conf
703 %{py_sitedir}/abrt_exception_handler.py[co]
704 %{py_sitedir}/abrt.pth
705 %{_mandir}/man5/abrt-python.conf.5*
706 %{_mandir}/man5/python_event.conf.5*
707
708 %files addon-python3
709 %defattr(644,root,root,755)
710 %{_datadir}/%{name}/conf.d/plugins/python3.conf
711 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/python3.conf
712 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/python3_event.conf
713 %{py3_sitedir}/abrt_exception_handler3.py*
714 %{py3_sitedir}/abrt3.pth
715 %{_mandir}/man5/abrt-python3.conf.5*
716 %{_mandir}/man5/python3_event.conf.5*
717
718 %files addon-upload-watch
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_sbindir}/abrt-upload-watch
721 %{systemdunitdir}/abrt-upload-watch.service
722 %{_mandir}/man1/abrt-upload-watch.1*
723
724 %files addon-vmcore
725 %defattr(644,root,root,755)
726 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vmcore
727 %attr(755,root,root) %{_sbindir}/abrt-harvest-vmcore
728 %dir %{_datadir}/%{name}/conf.d/plugins/vmcore.conf
729 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/vmcore.conf
730 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vmcore_event.conf
731 #%attr(754,root,root) /etc/rc.d/init.d/abrt-vmcore
732 %{_datadir}/libreport/events/analyze_VMcore.xml
733 %{systemdunitdir}/abrt-vmcore.service
734 %{_mandir}/man1/abrt-action-analyze-vmcore.1*
735 %{_mandir}/man1/abrt-harvest-vmcore.1*
736 %{_mandir}/man5/abrt-vmcore.conf.5*
737 %{_mandir}/man5/vmcore_event.conf.5*
738
739 %files addon-xorg
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{_bindir}/abrt-action-analyze-xorg
742 %attr(755,root,root) %{_bindir}/abrt-dump-xorg
743 %dir %{_datadir}/%{name}/conf.d/plugins/xorg.conf
744 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/xorg.conf
745 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/xorg_event.conf
746 #%attr(754,root,root) /etc/rc.d/init.d/abrt-xorg
747 %{systemdunitdir}/abrt-xorg.service
748 %{_mandir}/man1/abrt-action-analyze-xorg.1*
749 %{_mandir}/man1/abrt-dump-xorg.1*
750 %{_mandir}/man5/abrt-xorg.conf.5*
751 %{_mandir}/man5/xorg_event.conf.5*
752
753 %files plugin-bodhi
754 %defattr(644,root,root,755)
755 %attr(755,root,root) %{_bindir}/abrt-bodhi
756 %{_mandir}/man1/abrt-bodhi.1*
757
758 %files retrace-client
759 %defattr(644,root,root,755)
760 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_retrace_event.conf
761 %attr(755,root,root) %{_bindir}/abrt-retrace-client
762 %{_datadir}/libreport/events/analyze_RetraceServer.xml
763 %{_mandir}/man1/abrt-retrace-client.1*
764
765 %files dbus
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_sbindir}/abrt-configuration
768 %attr(755,root,root) %{_sbindir}/abrt-dbus
769 /etc/dbus-1/system.d/dbus-abrt.conf
770 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.abrt.xml
771 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ccpp.xml
772 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.python.xml
773 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.vmcore.xml
774 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.xml
775 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.xorg.xml
776 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems.xml
777 %{_datadir}/dbus-1/system-services/com.redhat.problems.configuration.service
778 %{_datadir}/dbus-1/system-services/org.freedesktop.problems.service
779 %{_datadir}/polkit-1/actions/abrt_polkit.policy
780 %{_mandir}/man8/abrt-configuration.8*
781 %{_mandir}/man8/abrt-dbus.8*
782 %{_docdir}/abrt-dbus-%{version}
783
784 %files python
785 %defattr(644,root,root,755)
786 %dir %{py_sitedir}/problem
787 %attr(755,root,root) %{py_sitedir}/problem/_pyabrt.so
788 %{py_sitedir}/problem/*.py[co]
789 %{_mandir}/man5/abrt-python.5*
790
791 %files python3
792 %defattr(644,root,root,755)
793 %dir %{py3_sitedir}/problem
794 %attr(755,root,root) %{py3_sitedir}/problem/_py3abrt.so
795 %{py3_sitedir}/problem/*.py*
796 %{_mandir}/man5/abrt-python3.5*
797
798 %files cli
799 %defattr(644,root,root,755)
800 %attr(755,root,root) %{_bindir}/abrt-cli
801 %{_mandir}/man1/abrt-cli.1*
802
803 %files gui
804 %defattr(644,root,root,755)
805 %attr(755,root,root) %{_bindir}/abrt-applet
806 %attr(755,root,root) %{_bindir}/system-config-abrt
807 %dir %{_datadir}/%{name}
808 %{_datadir}/%{name}/icons
809 %{_datadir}/%{name}/ui
810 %{_iconsdir}/hicolor/*/apps/abrt.png
811 %{_iconsdir}/hicolor/*/status/abrt.png
812 %{_sysconfdir}/xdg/autostart/abrt-applet.desktop
813 %{_mandir}/man1/abrt-applet.1*
814 %{_mandir}/man1/system-config-abrt.1*
815
816 %files gui-libs
817 %defattr(644,root,root,755)
818 %attr(755,root,root) %{_libdir}/libabrt_gui.so.*.*.*
819 %attr(755,root,root) %ghost %{_libdir}/libabrt_gui.so.0
820
821 %files gui-devel
822 %defattr(644,root,root,755)
823 %attr(755,root,root) %{_libdir}/libabrt_gui.so
824 %{_includedir}/abrt/abrt-config-widget.h
825 %{_includedir}/abrt/system-config-abrt.h
826 %{_pkgconfigdir}/abrt_gui.pc
827
828 %files desktop
829 %defattr(644,root,root,755)
830
831 %files console-notification
832 %defattr(644,root,root,755)
833 %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/abrt-console-notification.sh
This page took 0.173676 seconds and 3 git commands to generate.