]> git.pld-linux.org Git - packages/aMule.git/blob - aMule.spec
- why it depends on binutils?
[packages/aMule.git] / aMule.spec
1 #
2 # TODO:
3 # - split into subpackages
4 # - package %{_libdir}/xchat/plugins/xas.pl
5 # - depends on binutils, why?
6 #
7 Summary:        Unix port of eMule client
8 Summary(pl):    Uniksowy port klienta eMule
9 Name:           aMule
10 Version:        2.0.1
11 Release:        1
12 License:        GPL
13 Group:          X11/Applications
14 Source0:        http://download.berlios.de/amule/%{name}-%{version}.tar.gz
15 # Source0-md5:  a88e6d9b263d684d8dc064a2bf535569
16 Patch0:         %{name}-configure_in.patch
17 Patch1:         %{name}-desktop.patch
18 Patch2:         %{name}-cas-datadir.patch
19 URL:            http://www.amule.org/
20 BuildRequires:  autoconf
21 BuildRequires:  automake >= 1:1.7.3
22 BuildRequires:  bison
23 #BuildRequires: cryptopp-devel >= 5.1
24 BuildRequires:  curl-devel >= 7.9.7
25 BuildRequires:  expat-devel
26 BuildRequires:  gd-devel
27 BuildRequires:  gettext-devel >= 0.11.5
28 BuildRequires:  gtk+2-devel >= 2:2.2.0
29 BuildRequires:  libpng-devel
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  wxBase-devel >= 2.6.0
32 BuildRequires:  wxGTK2-devel >= 2.6.0
33 Requires:       wget
34 Obsoletes:      lmule
35 Obsoletes:      xmule
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 aMule is a Linux port of eMule client.
40
41 %description -l pl
42 aMule to linuksowy port klienta eMule.
43
44 %package plugin-xchat
45 Summary:        Xchat plugin
46 Summary(pl):    Wtyczka dla xchat
47 Requires:       %{name} = %{version}-%{release}
48 Group:          X11/Applications
49 Provides:       %{name}-plugin-xchat
50
51 %description plugin-xchat
52 Plugin for Xchat IRC client.
53
54 %description plugin-xchat -l pl
55 Wtczka dla klienta IRC xchat.
56
57 %package alc
58 Summary:        Ed2k link creator for aMule
59 Summary(pl):    Kreator linków ed2k dla aMule
60 Requires:       %{name} = %{version}-%{release}
61 Group:          X11/Applications
62 Provides:       alc
63
64 %description alc
65 Tool for creating ed2k links.
66
67 %description -l pl alc
68 Narzêdzie do tworzenia linków ed2k.
69
70 %package cas
71 Summary:        aMule online stats
72 Summary(pl):    Statystyki online aMule
73 Requires:       %{name} = %{version}-%{release}
74 Group:          X11/Applications
75 Provides:       cas
76
77 %description cas
78 Tool for generating aMule online stats.
79
80 %description -l cas
81 Narzêdzie do generownia statystyk aMule.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87 %patch2 -p1
88
89 %build
90 %{__gettextize}
91 %{__aclocal} -I m4
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 %configure \
96         --with-wx-config=%{_bindir}/wx-gtk2-ansi-config \
97         --%{?debug:en}%{!?debug:dis}able-debug          \
98         --enable-optimise                               \
99         --enable-amule-daemon                           \
100         --enable-amulecmd                               \
101         --enable-amulecmdgui                            \
102         --enable-webserver                              \
103         --enable-webservergui                           \
104         --enable-cas                                    \
105         --enable-wxcas                                  \
106         --enable-alc                                    \
107         --enable-alcc
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{et_EE,et}
118 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{pt_PT,pt}
119
120 %find_lang amule
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files -f amule.lang
126 %defattr(644,root,root,755)
127 %doc docs/AUTHORS docs/README docs/Changelog docs/ED2K-Links.HOWTO docs/TODO docs/amulesig.txt
128 %attr(755,root,root) %{_bindir}/amule*
129 %{_bindir}/ed2k
130 %dir %{_datadir}/amule
131 %{_datadir}/amule/webserver
132 %{_desktopdir}/amule.desktop
133 %{_pixmapsdir}/amule.xpm
134 %{_mandir}/man1/amule*
135 %{_mandir}/man1/ed2k*
136 %{_mandir}/man1/xas*
137 %lang(de) %{_mandir}/de/man1/amule*
138 %lang(de) %{_mandir}/de/man1/ed2k*
139 %lang(de) %{_mandir}/de/man1/xas*
140 %lang(es) %{_mandir}/es/man1/amule*
141 %lang(es) %{_mandir}/es/man1/ed2k*
142 %lang(es) %{_mandir}/es/man1/xas*
143 %lang(fr) %{_mandir}/fr/man1/amule*
144 %lang(fr) %{_mandir}/fr/man1/ed2k*
145 %lang(hu) %{_mandir}/hu/man1/amule*
146 %lang(hu) %{_mandir}/hu/man1/ed2k*
147 %lang(hu) %{_mandir}/hu/man1/xas*
148
149 %files plugin-xchat
150 %defattr(644,root,root,755)
151 %{_libdir}/xchat/plugins/xas.pl
152
153 %files alc
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/alc*
156 %{_desktopdir}/alc.desktop
157 %{_pixmapsdir}/alc.xpm
158 %{_mandir}/man1/alc*
159 %lang(de) %{_mandir}/de/man1/alc*
160 %lang(es) %{_mandir}/es/man1/alc*
161 %lang(fr) %{_mandir}/fr/man1/alc*
162 %lang(hu) %{_mandir}/hu/man1/alc*
163
164 %files cas
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_bindir}/*cas
167 %{_datadir}/amule/cas
168 %{_desktopdir}/*cas.desktop
169 %{_pixmapsdir}/wxcas.xpm
170 %{_mandir}/man1/*cas*
171 %lang(de) %{_mandir}/de/man1/*cas*
172 %lang(es) %{_mandir}/es/man1/*cas*
173 %lang(hu) %{_mandir}/hu/man1/*cas*
This page took 0.059407 seconds and 4 git commands to generate.