]> git.pld-linux.org Git - packages/Zope-iHotfix.git/commitdiff
- initial release
authorciesiel <ciesiel@pld-linux.org>
Wed, 19 Nov 2003 20:51:09 +0000 (20:51 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    Zope-iHotfix.spec -> 1.1

Zope-iHotfix.spec [new file with mode: 0644]

diff --git a/Zope-iHotfix.spec b/Zope-iHotfix.spec
new file mode 100644 (file)
index 0000000..4d4230f
--- /dev/null
@@ -0,0 +1,61 @@
+%include       /usr/lib/rpm/macros.python
+%define                zope_subname    iHotfix
+Summary:       It dynamically applies several patches to Zope
+Summary(pl):   Dodatek do Zope aplikuj±cy wiele poprawek dla Zope
+Name:          Zope-%{zope_subname}
+Version:       0.2.0
+Release:       1
+License:       GPL
+Group:         Development/Tools
+Source0:       http://dl.sourceforge.net/lleu/%{zope_subname}-%{version}.tgz
+# Source0-md5: e1e20772e6b0c1e58a3627a213fba46d
+URL:           http://sourceforge.net/projects/lleu
+BuildRequires: python >= 2.2
+%pyrequires_eq python-modules
+Requires:      Zope >= 2.6
+Requires(post,postun): /usr/sbin/installzopeproduct
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+It dynamically applies several patches to Zope
+
+%description -l pl
+Dodatek do Zope aplikuj±cy wiele poprawek dla Zope
+
+%prep
+%setup -q -n %{zope_subname}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
+
+# should tests be included or not?
+cp -af *.py $RPM_BUILD_ROOT%{_datadir}/%{name}
+
+%py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
+%py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
+
+# find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+/usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
+if [ -f /var/lock/subsys/zope ]; then
+       /etc/rc.d/init.d/zope restart >&2
+fi
+
+%postun
+if [ "$1" = "0" ]; then
+        /usr/sbin/installzopeproduct -d %{zope_subname}
+        if [ -f /var/lock/subsys/zope ]; then
+                /etc/rc.d/init.d/zope restart >&2
+        fi
+fi
+
+%files
+%defattr(644,root,root,755)
+%doc TODO.txt
+%{_datadir}/%{name}
This page took 0.06744 seconds and 4 git commands to generate.