]> git.pld-linux.org Git - packages/Zope-iHotfix.git/blob - Zope-iHotfix.spec
- initial release
[packages/Zope-iHotfix.git] / Zope-iHotfix.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         zope_subname    iHotfix
3 Summary:        It dynamically applies several patches to Zope
4 Summary(pl):    Dodatek do Zope aplikuj±cy wiele poprawek dla Zope
5 Name:           Zope-%{zope_subname}
6 Version:        0.2.0
7 Release:        1
8 License:        GPL
9 Group:          Development/Tools
10 Source0:        http://dl.sourceforge.net/lleu/%{zope_subname}-%{version}.tgz
11 # Source0-md5:  e1e20772e6b0c1e58a3627a213fba46d
12 URL:            http://sourceforge.net/projects/lleu
13 BuildRequires:  python >= 2.2
14 %pyrequires_eq  python-modules
15 Requires:       Zope >= 2.6
16 Requires(post,postun):  /usr/sbin/installzopeproduct
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 It dynamically applies several patches to Zope
22
23 %description -l pl
24 Dodatek do Zope aplikuj±cy wiele poprawek dla Zope
25
26 %prep
27 %setup -q -n %{zope_subname}
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
32
33 # should tests be included or not?
34 cp -af *.py $RPM_BUILD_ROOT%{_datadir}/%{name}
35
36 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
37 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
38
39 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %post
45 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
46 if [ -f /var/lock/subsys/zope ]; then
47         /etc/rc.d/init.d/zope restart >&2
48 fi
49
50 %postun
51 if [ "$1" = "0" ]; then
52         /usr/sbin/installzopeproduct -d %{zope_subname}
53         if [ -f /var/lock/subsys/zope ]; then
54                 /etc/rc.d/init.d/zope restart >&2
55         fi
56 fi
57
58 %files
59 %defattr(644,root,root,755)
60 %doc TODO.txt
61 %{_datadir}/%{name}
This page took 0.059566 seconds and 3 git commands to generate.