]> git.pld-linux.org Git - packages/ZendDebugger.git/blob - ZendDebugger.spec
- drop no_install_post_strip (not reasoned)
[packages/ZendDebugger.git] / ZendDebugger.spec
1 # NOTE
2 # - Unusable in PLD Linux as our PHP is compiled with ZTS, while this extension is not
3 # - Can't find what Free Download means (http://www.zend.com/free_download/list)
4 %define         php4_version    4.4
5 %define         php5_version    5.2
6 Summary:        The Zend Debug Server enabling remote debugging of PHP applications
7 Summary(pl.UTF-8):      Zend Debug Server pozwalający na zdalne śledzenie aplikacji PHP
8 Name:           ZendDebugger
9 Version:        5.2.10
10 Release:        0.4
11 License:        Free Download
12 Group:          Development/Languages/PHP
13 Source0:        http://downloads.zend.com/pdt/server-debugger/%{name}-%{version}-linux-glibc21-i386.tar.gz
14 # NoSource0-md5:        d2ee7659c0c8721221696cab5e765936
15 NoSource:       0
16 Source1:        http://downloads.zend.com/pdt/server-debugger/%{name}-%{version}-linux-glibc23-x86_64.tar.gz
17 # NoSource1-md5:        3238904ebd1accd5795a50fb88fc6fff
18 NoSource:       1
19 URL:            http://www.zend.com/store/software/zend_studio
20 BuildRequires:  tar >= 1:1.15.1
21 ExclusiveArch:  %{ix86} %{x8664}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _datadir        %{_prefix}/share/Zend
25 %define         _php4_extensiondir      %{_libdir}/php4
26 %define         _php5_extensiondir      %{_libdir}/php
27 %define         _php4_sysconfdir        /etc/php4/conf.d
28 %define         _php5_sysconfdir        /etc/php/conf.d
29
30 %description
31 The Zend Debug Server enables remote debugging of PHP applications. It
32 plugs into a PHP server and allows the Zend Development Environment to
33 control the execution of PHP applications on the server.
34
35 The Debug Server is designed be deployed safely on production servers.
36 It does not affect server performance and features access-list based
37 security for protecting the server from unauthorized access.
38
39 %description -l pl.UTF-8
40 Zend Debug Server pozwala na zdalne śledzenie aplikacji PHP. Podłącza
41 się do serwera PHP i pozwala środowisku Zend Development Environment
42 sterować wykonywaniem aplikacji PHP na serwerze.
43
44 Debug server jest zaprojektowany z myślą o bezpiecznym wdrożeniu na
45 serwerach produkcyjnych. Nie wpływa na wydajność serwera i cechuje się
46 bezpieczeństwem opartym na listach dostępu.
47
48 %package -n php4-%{name}
49 Summary:        Zend Debugger for PHP 4.x
50 Summary(pl.UTF-8):      Zend Debugger dla PHP 4.x
51 Group:          Development/Languages/PHP
52 Requires:       php4(thread-safety) = 0
53 Requires:       php4-common < 3:%(awk 'BEGIN{print %{php4_version} + 0.1}')
54 Requires:       php4-common >= 3:%{php4_version}
55 Conflicts:      ZendStudioServer <= 5.2.0
56
57 %description -n php4-%{name}
58 The Zend Debug Server enables remote debugging of PHP applications. It
59 plugs into a PHP server and allows the Zend Development Environment to
60 control the execution of PHP applications on the server.
61
62 The Debug Server is designed be deployed safely on production servers.
63 It does not affect server performance and features access-list based
64 security for protecting the server from unauthorized access.
65
66 %description -n php4-%{name} -l pl.UTF-8
67 Zend Debug Server pozwala na zdalne śledzenie aplikacji PHP. Podłącza
68 się do serwera PHP i pozwala środowisku Zend Development Environment
69 sterować wykonywaniem aplikacji PHP na serwerze.
70
71 Debug server jest zaprojektowany z myślą o bezpiecznym wdrożeniu na
72 serwerach produkcyjnych. Nie wpływa na wydajność serwera i cechuje się
73 bezpieczeństwem opartym na listach dostępu.
74
75 %package -n php-%{name}
76 Summary:        Zend Debugger for PHP 5.x
77 Summary(pl.UTF-8):      Zend Debugger dla PHP 5.x
78 Group:          Development/Languages/PHP
79 Requires:       php-common < 4:%(awk 'BEGIN{print %{php5_version} + 0.1}')
80 Requires:       php-common >= 4:%{php5_version}
81 Requires:       php5(thread-safety) = 0
82 Conflicts:      ZendStudioServer <= 5.2.0
83
84 %description -n php-%{name}
85 The Zend Debug Server enables remote debugging of PHP applications. It
86 plugs into a PHP server and allows the Zend Development Environment to
87 control the execution of PHP applications on the server.
88
89 The Debug Server is designed be deployed safely on production servers.
90 It does not affect server performance and features access-list based
91 security for protecting the server from unauthorized access.
92
93 %description -n php-%{name} -l pl.UTF-8
94 Zend Debug Server pozwala na zdalne śledzenie aplikacji PHP. Podłącza
95 się do serwera PHP i pozwala środowisku Zend Development Environment
96 sterować wykonywaniem aplikacji PHP na serwerze.
97
98 Debug server jest zaprojektowany z myślą o bezpiecznym wdrożeniu na
99 serwerach produkcyjnych. Nie wpływa na wydajność serwera i cechuje się
100 bezpieczeństwem opartym na listach dostępu.
101
102 %prep
103 %setup -qcT
104 %ifarch %{x8664}
105 tar --strip-components=1 -xzf %{SOURCE1}
106 %else
107 tar --strip-components=1 -xzf %{SOURCE0}
108 %endif
109
110 cat > zend.ini <<EOF
111 [Zend]
112 zend_debugger.allow_hosts=127.0.0.1
113 zend_debugger.expose_remotely=always
114 EOF
115
116 cat <<'EOF' > pack4.ini
117 ; %{name} package settings. Overwritten with each upgrade.
118 ; if you need to add options, edit %{name}.ini instead
119 [Zend]
120 zend_extension=%{_php4_extensiondir}/ZendDebugger.so
121 EOF
122
123 cat <<'EOF' > pack5.ini
124 ; %{name} package settings. Overwritten with each upgrade.
125 ; if you need to add options, edit %{name}.ini instead
126 [Zend]
127 zend_extension=%{_php5_extensiondir}/ZendDebugger.so
128 EOF
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT{%{_php4_extensiondir},%{_php5_extensiondir}}
133 install %(echo %{php4_version} | tr . _)_x_comp/ZendDebugger.so $RPM_BUILD_ROOT%{_php4_extensiondir}
134 install %(echo %{php5_version} | tr . _)_x_comp/ZendDebugger.so $RPM_BUILD_ROOT%{_php5_extensiondir}
135
136 install -d $RPM_BUILD_ROOT{%{_php4_sysconfdir},%{_php5_sysconfdir}}
137 install zend.ini $RPM_BUILD_ROOT%{_php4_sysconfdir}/%{name}.ini
138 install zend.ini $RPM_BUILD_ROOT%{_php5_sysconfdir}/%{name}.ini
139 install pack4.ini $RPM_BUILD_ROOT%{_php4_sysconfdir}/%{name}_pack.ini
140 install pack5.ini $RPM_BUILD_ROOT%{_php5_sysconfdir}/%{name}_pack.ini
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %preun -n php4-%{name}
146 if [ "$1" = "0" ]; then
147         %php4_webserver_restart
148 fi
149
150 %post -n php4-%{name}
151 %php4_webserver_restart
152
153 %preun -n php-%{name}
154 if [ "$1" = "0" ]; then
155         %php_webserver_restart
156 fi
157
158 %post -n php-%{name}
159 %php_webserver_restart
160
161 %files -n php4-%{name}
162 %defattr(644,root,root,755)
163 %config(noreplace) %verify(not md5 mtime size) %{_php4_sysconfdir}/%{name}.ini
164 %config %verify(not md5 mtime size) %{_php4_sysconfdir}/%{name}_pack.ini
165 %attr(755,root,root) %{_php4_extensiondir}/ZendDebugger.so
166
167 %files -n php-%{name}
168 %defattr(644,root,root,755)
169 %config(noreplace) %verify(not md5 mtime size) %{_php5_sysconfdir}/%{name}.ini
170 %config %verify(not md5 mtime size) %{_php5_sysconfdir}/%{name}_pack.ini
171 %attr(755,root,root) %{_php5_extensiondir}/ZendDebugger.so
This page took 0.071406 seconds and 3 git commands to generate.