]> git.pld-linux.org Git - packages/ZendDebugger.git/blame - ZendDebugger.spec
- drop no_install_post_strip (not reasoned)
[packages/ZendDebugger.git] / ZendDebugger.spec
CommitLineData
9212a2fd
ER
1# NOTE
2# - Unusable in PLD Linux as our PHP is compiled with ZTS, while this extension is not
3# - Can't find what Free Download means (http://www.zend.com/free_download/list)
4%define php4_version 4.4
5%define php5_version 5.2
8a8e4f08
JB
6Summary: The Zend Debug Server enabling remote debugging of PHP applications
7Summary(pl.UTF-8): Zend Debug Server pozwalający na zdalne śledzenie aplikacji PHP
9212a2fd
ER
8Name: ZendDebugger
9Version: 5.2.10
10Release: 0.4
11License: Free Download
12Group: Development/Languages/PHP
13Source0: http://downloads.zend.com/pdt/server-debugger/%{name}-%{version}-linux-glibc21-i386.tar.gz
14# NoSource0-md5: d2ee7659c0c8721221696cab5e765936
15NoSource: 0
16Source1: http://downloads.zend.com/pdt/server-debugger/%{name}-%{version}-linux-glibc23-x86_64.tar.gz
17# NoSource1-md5: 3238904ebd1accd5795a50fb88fc6fff
18NoSource: 1
19URL: http://www.zend.com/store/software/zend_studio
20BuildRequires: tar >= 1:1.15.1
21ExclusiveArch: %{ix86} %{x8664}
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%define _datadir %{_prefix}/share/Zend
9212a2fd
ER
25%define _php4_extensiondir %{_libdir}/php4
26%define _php5_extensiondir %{_libdir}/php
27%define _php4_sysconfdir /etc/php4/conf.d
28%define _php5_sysconfdir /etc/php/conf.d
29
30%description
31The Zend Debug Server enables remote debugging of PHP applications. It
32plugs into a PHP server and allows the Zend Development Environment to
33control the execution of PHP applications on the server.
34
35The Debug Server is designed be deployed safely on production servers.
36It does not affect server performance and features access-list based
37security for protecting the server from unauthorized access.
38
8a8e4f08
JB
39%description -l pl.UTF-8
40Zend Debug Server pozwala na zdalne śledzenie aplikacji PHP. Podłącza
41się do serwera PHP i pozwala środowisku Zend Development Environment
42sterować wykonywaniem aplikacji PHP na serwerze.
43
44Debug server jest zaprojektowany z myślą o bezpiecznym wdrożeniu na
45serwerach produkcyjnych. Nie wpływa na wydajność serwera i cechuje się
46bezpieczeństwem opartym na listach dostępu.
47
9212a2fd
ER
48%package -n php4-%{name}
49Summary: Zend Debugger for PHP 4.x
8a8e4f08 50Summary(pl.UTF-8): Zend Debugger dla PHP 4.x
9212a2fd
ER
51Group: Development/Languages/PHP
52Requires: php4(thread-safety) = 0
53Requires: php4-common < 3:%(awk 'BEGIN{print %{php4_version} + 0.1}')
54Requires: php4-common >= 3:%{php4_version}
55Conflicts: ZendStudioServer <= 5.2.0
56
57%description -n php4-%{name}
58The Zend Debug Server enables remote debugging of PHP applications. It
59plugs into a PHP server and allows the Zend Development Environment to
60control the execution of PHP applications on the server.
61
62The Debug Server is designed be deployed safely on production servers.
63It does not affect server performance and features access-list based
64security for protecting the server from unauthorized access.
65
8a8e4f08
JB
66%description -n php4-%{name} -l pl.UTF-8
67Zend Debug Server pozwala na zdalne śledzenie aplikacji PHP. Podłącza
68się do serwera PHP i pozwala środowisku Zend Development Environment
69sterować wykonywaniem aplikacji PHP na serwerze.
70
71Debug server jest zaprojektowany z myślą o bezpiecznym wdrożeniu na
72serwerach produkcyjnych. Nie wpływa na wydajność serwera i cechuje się
73bezpieczeństwem opartym na listach dostępu.
74
9212a2fd
ER
75%package -n php-%{name}
76Summary: Zend Debugger for PHP 5.x
8a8e4f08 77Summary(pl.UTF-8): Zend Debugger dla PHP 5.x
9212a2fd
ER
78Group: Development/Languages/PHP
79Requires: php-common < 4:%(awk 'BEGIN{print %{php5_version} + 0.1}')
80Requires: php-common >= 4:%{php5_version}
81Requires: php5(thread-safety) = 0
82Conflicts: ZendStudioServer <= 5.2.0
83
84%description -n php-%{name}
e500d975
ER
85The Zend Debug Server enables remote debugging of PHP applications. It
86plugs into a PHP server and allows the Zend Development Environment to
87control the execution of PHP applications on the server.
9212a2fd 88
e500d975
ER
89The Debug Server is designed be deployed safely on production servers.
90It does not affect server performance and features access-list based
91security for protecting the server from unauthorized access.
9212a2fd 92
8a8e4f08
JB
93%description -n php-%{name} -l pl.UTF-8
94Zend Debug Server pozwala na zdalne śledzenie aplikacji PHP. Podłącza
95się do serwera PHP i pozwala środowisku Zend Development Environment
96sterować wykonywaniem aplikacji PHP na serwerze.
97
98Debug server jest zaprojektowany z myślą o bezpiecznym wdrożeniu na
99serwerach produkcyjnych. Nie wpływa na wydajność serwera i cechuje się
100bezpieczeństwem opartym na listach dostępu.
101
9212a2fd
ER
102%prep
103%setup -qcT
104%ifarch %{x8664}
105tar --strip-components=1 -xzf %{SOURCE1}
106%else
107tar --strip-components=1 -xzf %{SOURCE0}
108%endif
109
110cat > zend.ini <<EOF
111[Zend]
112zend_debugger.allow_hosts=127.0.0.1
113zend_debugger.expose_remotely=always
114EOF
115
116cat <<'EOF' > pack4.ini
117; %{name} package settings. Overwritten with each upgrade.
118; if you need to add options, edit %{name}.ini instead
119[Zend]
120zend_extension=%{_php4_extensiondir}/ZendDebugger.so
121EOF
122
123cat <<'EOF' > pack5.ini
124; %{name} package settings. Overwritten with each upgrade.
125; if you need to add options, edit %{name}.ini instead
126[Zend]
127zend_extension=%{_php5_extensiondir}/ZendDebugger.so
128EOF
129
130%install
131rm -rf $RPM_BUILD_ROOT
132install -d $RPM_BUILD_ROOT{%{_php4_extensiondir},%{_php5_extensiondir}}
133install %(echo %{php4_version} | tr . _)_x_comp/ZendDebugger.so $RPM_BUILD_ROOT%{_php4_extensiondir}
134install %(echo %{php5_version} | tr . _)_x_comp/ZendDebugger.so $RPM_BUILD_ROOT%{_php5_extensiondir}
135
136install -d $RPM_BUILD_ROOT{%{_php4_sysconfdir},%{_php5_sysconfdir}}
137install zend.ini $RPM_BUILD_ROOT%{_php4_sysconfdir}/%{name}.ini
138install zend.ini $RPM_BUILD_ROOT%{_php5_sysconfdir}/%{name}.ini
139install pack4.ini $RPM_BUILD_ROOT%{_php4_sysconfdir}/%{name}_pack.ini
140install pack5.ini $RPM_BUILD_ROOT%{_php5_sysconfdir}/%{name}_pack.ini
141
142%clean
143rm -rf $RPM_BUILD_ROOT
144
145%preun -n php4-%{name}
146if [ "$1" = "0" ]; then
147 %php4_webserver_restart
148fi
149
150%post -n php4-%{name}
151%php4_webserver_restart
152
153%preun -n php-%{name}
154if [ "$1" = "0" ]; then
155 %php_webserver_restart
156fi
157
158%post -n php-%{name}
159%php_webserver_restart
160
161%files -n php4-%{name}
162%defattr(644,root,root,755)
163%config(noreplace) %verify(not md5 mtime size) %{_php4_sysconfdir}/%{name}.ini
164%config %verify(not md5 mtime size) %{_php4_sysconfdir}/%{name}_pack.ini
165%attr(755,root,root) %{_php4_extensiondir}/ZendDebugger.so
166
167%files -n php-%{name}
168%defattr(644,root,root,755)
169%config(noreplace) %verify(not md5 mtime size) %{_php5_sysconfdir}/%{name}.ini
170%config %verify(not md5 mtime size) %{_php5_sysconfdir}/%{name}_pack.ini
171%attr(755,root,root) %{_php5_extensiondir}/ZendDebugger.so
This page took 0.077411 seconds and 4 git commands to generate.