]> git.pld-linux.org Git - packages/Xnee.git/blob - Xnee.spec
- invoke fix-info-dir via /sbin/postshell where possible to avoid extra /bin/sh dep
[packages/Xnee.git] / Xnee.spec
1 # TODO:
2 # - package libxnee if needed for anything (it's noinst now)
3 # - generate docs - (some files are missing)
4 #
5 # Conditional build:
6 %bcond_with     doc     # documentation (broken, missing files)
7 %bcond_without  gnome   # GNOME panel applet
8 #
9 Summary:        Suite of programs that can record and replay user actions under X11
10 Summary(pl.UTF-8):      Zestaw programów do nagrywania i odtwarzania akcji użytkownika pod X11
11 Name:           Xnee
12 Version:        3.01
13 Release:        0.1
14 License:        GPL v3+
15 Group:          X11/Applications
16 Source0:        ftp://ftp.gnu.org/gnu/xnee/%{name}-%{version}.tar.gz
17 # Source0-md5:  a6e1e797170317a7454723a7cd7b3c58
18 Patch0:         %{name}-info.patch
19 URL:            http://www.gnu.org/software/xnee/www/index.html
20 BuildRequires:  gtk+2-devel >= 1:2.0.0
21 BuildRequires:  pkgconfig >= 1:0.9.0
22 BuildRequires:  texinfo
23 BuildRequires:  xorg-proto-recordproto-devel
24 BuildRequires:  xorg-lib-libXtst-devel
25 %if %{with gnome}
26 BuildRequires:  GConf2-devel >= 2.0
27 BuildRequires:  gnome-panel-devel >= 2.0
28 %endif
29 %if %{with doc}
30 BuildRequires:  ImageMagick
31 BuildRequires:  ImageMagick-coder-jpeg
32 BuildRequires:  ImageMagick-coder-png
33 BuildRequires:  dia
34 BuildRequires:  ghostscript
35 BuildRequires:  tetex-dvips
36 BuildRequires:  tetex-format-plain
37 BuildRequires:  tetex-tex-misc
38 BuildRequires:  texinfo-texi2dvi
39 %endif
40 Provides:       xnee
41 Obsoletes:      xnee
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Xnee is a suite of programs that can record, replay and distribute
46 user actions under the X11 environment. Think of it as a robot that
47 can imitate the job you just did. Xnee can be used to: automate tests,
48 demonstrate programs, distribute actions, record and replay "macros",
49 retype a file etc.
50
51 %description -l pl.UTF-8
52 Xnee to zestaw programów do nagrywania, odtwarzania i powielania akcji
53 użytkownika w środowisku X11. Można je określić jako maszynę
54 powtarzającą pracę wykonaną przez nas. Xnee można użyć do:
55 automatyzowania testów, demonstrowania programów, powielania akcji (na
56 wielu komputerach), nagrywania i odtwarzania "makr", przepisywania
57 plików itp.
58
59 %package gtk
60 Summary:        gnee - GTK+ based graphical frontent to GNU Xnee
61 Summary(pl.UTF-8):      gnee - oparty na GTK+ graficzny interfejs do GNU Xnee
62 Group:          X11/Applications
63 Requires:       %{name} = %{version}-%{release}
64
65 %description gtk
66 gnee is the graphical frontend to GNU Xnee, based on GTK+ toolkit.
67
68 %description gtk -l pl.UTF-8
69 gnee to graficzny interfejs do GNU Xnee, oparty na GTK+.
70
71 %package gnome
72 Summary:        pnee - GNOME panel applet for GNU Xnee
73 Summary(pl.UTF-8):      pnee - aplet panelu GNOME dla GNU Xnee
74 Group:          X11/Applications
75 Requires:       %{name} = %{version}-%{release}
76
77 %description gnome
78 pnee is the GNOME panel applet for GNU Xnee.
79
80 %description gnome -l pl.UTF-8
81 pnee to aplet panelu GNOME dla GNU Xnee.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86
87 %build
88 %configure \
89         --disable-doc \
90         %{!?with_gnome:--disable-gnome-applet} \
91         --enable-xosd
92
93 %{__make} \
94         CNEE_INFO="cnee.info"
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT \
101         CNEE_INFO="cnee.info" \
102         PANEL_APPLET_DIR=$RPM_BUILD_ROOT%{_bindir} \
103         PANEL_SERVER_DIR=$RPM_BUILD_ROOT%{_libdir}/bonobo/servers
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p      /sbin/postshell
109 -/usr/sbin/fix-info-dir -c %{_infodir}
110
111 %postun -p      /sbin/postshell
112 -/usr/sbin/fix-info-dir -c %{_infodir}
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS BUGS ChangeLog FAQ NEWS README TODO
117 %attr(755,root,root) %{_bindir}/cnee
118 %dir %{_datadir}/xnee
119 %{_datadir}/xnee/*.sh
120 %{_datadir}/xnee/*.xns
121 %dir %{_datadir}/xnee/pixmaps
122 %{_datadir}/xnee/pixmaps/xnee.png
123 %{_datadir}/xnee/pixmaps/xnee.xpm
124 %{_mandir}/man1/cnee.1*
125 %{_mandir}/man1/xnee.1*
126 %{_infodir}/cnee.info*
127
128 %files gtk
129 %defattr(644,root,root,755)
130 %doc gnee/AUTHORS
131 %attr(755,root,root) %{_bindir}/gnee
132 %{_mandir}/man1/gnee.1*
133
134 %if %{with gnome}
135 %files gnome
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_bindir}/pnee
138 %{_libdir}/bonobo/servers/pnee.server
139 %{_datadir}/xnee/pixmaps/pnee-*.png
140 %{_mandir}/man1/pnee.1*
141 %endif
This page took 0.051969 seconds and 3 git commands to generate.