]> git.pld-linux.org Git - packages/VirtualBox.git/blob - VirtualBox.spec
- BR: curl-devel
[packages/VirtualBox.git] / VirtualBox.spec
1 #
2 # TODO:
3 # - Find how to compile with PLD CFLAGS/CXXFLAGS/LDFLAGS.
4 # - Package SDK.
5 # - Package utils (and write initscripts ?) for Guest OS.
6 # - Check License of VBoxGuestAdditions_*.iso, it's propably not GPL v2.
7 #   If so check if it is distributable.
8 #
9 # Conditional build:
10 %bcond_without  dist_kernel     # without distribution kernel
11 %bcond_without  kernel          # don't build kernel module
12 %bcond_without  userspace       # don't build userspace package
13 %bcond_with     verbose
14
15 %if %{without kernel}
16 %undefine       with_dist_kernel
17 %endif
18 %if "%{_alt_kernel}" != "%{nil}"
19 %undefine       with_userspace
20 %endif
21 %if %{without userspace}
22 # nothing to be placed to debuginfo package
23 %define         _enable_debug_packages  0
24 %endif
25
26 %define         rel             0.1
27 %define         pname   VirtualBox
28 Summary:        VirtualBox OSE - x86 hardware virtualizer
29 Summary(pl.UTF-8):      VirtualBox OSE - wirtualizator sprzętu x86
30 Name:           %{pname}%{_alt_kernel}
31 Version:        3.0.0
32 Release:        %{rel}
33 License:        GPL v2
34 Group:          Applications/Emulators
35 Source0:        http://download.virtualbox.org/virtualbox/%{version}/%{pname}-%{version}-OSE.tar.bz2
36 # Source0-md5:  d1560d8b0a766236161eeb659e802b5a
37 Source1:        http://download.virtualbox.org/virtualbox/%{version}/UserManual.pdf
38 # Source1-md5:  e62fce82380b3368e2558a663715734c
39 Source2:        http://download.virtualbox.org/virtualbox/%{version}/VBoxGuestAdditions_%{version}.iso
40 # Source2-md5:  0e6f41edbee05a9d7c9677559cd9728c
41 Source3:        %{pname}-vboxdrv.init
42 Source4:        %{pname}-vboxadd.init
43 Source5:        %{pname}-vboxnetflt.init
44 Source6:        %{pname}-vboxvfs.init
45 Source7:        %{pname}.desktop
46 Source8:        %{pname}.sh
47 Source9:        mount.vdi
48 Patch0:         %{pname}-configure.patch
49 Patch1:         %{pname}-configure-spaces.patch
50 Patch2:         %{pname}-export_modules.patch
51 Patch3:         %{pname}-VBoxSysInfo.patch
52 URL:            http://www.virtualbox.org/
53 BuildRequires:  rpmbuild(macros) >= 1.379
54 %if %{with userspace}
55 %ifarch %{x8664}
56 BuildRequires:  gcc-multilib
57 BuildRequires:  glibc-devel(i686)
58 BuildRequires:  libstdc++-multilib-devel
59 %endif
60 %if "%{pld_release}" == "ac"
61 BuildRequires:  XFree86-devel
62 %else
63 BuildRequires:  xorg-lib-libXcursor-devel
64 BuildRequires:  xorg-lib-libXmu-devel
65 %endif
66 BuildRequires:  OpenGL-GLU-devel
67 BuildRequires:  OpenGL-devel
68 BuildRequires:  QtGui-devel
69 BuildRequires:  QtNetwork-devel
70 BuildRequires:  SDL-devel >= 1.2.7
71 BuildRequires:  acpica
72 BuildRequires:  alsa-lib-devel >= 1.0.6
73 BuildRequires:  bash
74 BuildRequires:  bcc
75 BuildRequires:  bin86
76 BuildRequires:  curl-devel
77 BuildRequires:  gcc >= 5:3.2.3
78 BuildRequires:  libIDL-devel
79 BuildRequires:  libpng-devel >= 1.2.5
80 BuildRequires:  libstdc++-devel >= 5:3.2.3
81 BuildRequires:  libuuid-devel
82 BuildRequires:  libxml2-devel >= 2.6.26
83 BuildRequires:  libxslt-devel >= 1.1.17
84 BuildRequires:  libxslt-progs >= 1.1.17
85 BuildRequires:  pkgconfig
86 BuildRequires:  pulseaudio-devel >= 0.9.0
87 BuildRequires:  python-devel
88 BuildRequires:  qt4-build >= 4.2.0
89 BuildRequires:  qt4-linguist
90 BuildRequires:  sed >= 4.0
91 BuildRequires:  which
92 BuildRequires:  xalan-c-devel >= 1.10.0
93 BuildRequires:  xerces-c-devel >= 2.6.0
94 BuildRequires:  zlib-devel >= 1.2.1
95 BuildRequires:  libcap-static
96 %endif
97 %if %{with dist_kernel}
98 BuildRequires:  kernel%{_alt_kernel}-module-build >= 3:2.6.20
99 %endif
100 Requires(post,preun):   /sbin/chkconfig
101 Requires(postun):       /usr/sbin/groupdel
102 Requires(pre):  /usr/bin/getgid
103 Requires(pre):  /usr/sbin/groupadd
104 Suggests:       gxmessage
105 Provides:       group(vbox)
106 ExclusiveArch:  %{ix86} %{x8664}
107 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109 %ifarch %{x8664}
110 %define         outdir  amd64
111 %else
112 %define         outdir  x86
113 %endif
114
115 %description
116 InnoTek VirtualBox OSE is a general-purpose full virtualizer for x86
117 hardware. Targeted at server, desktop and embedded use, it is now the
118 only professional-quality virtualization solution that is also Open
119 Source Software.
120
121 Some of the features of VirtualBox OSE are:
122
123 Modularity: VirtualBox OSE has an extremely modular design with
124 well-defined internal programming interfaces and a client/server
125 design. This makes it easy to control it from several interfaces at
126 once: for example, you can start a virtual machine in a typical
127 virtual machine GUI and then control that machine from the command
128 line. VirtualBox OSE also comes with a full Software Development Kit:
129 even though it is Open Source Software, you don't have to hack the
130 source to write a new interface for VirtualBox OSE.
131
132 Virtual machine descriptions in XML: the configuration settings of
133 virtual machines are stored entirely in XML and are independent of the
134 local machines. Virtual machine definitions can therefore easily be
135 ported to other computers.
136
137 %description -l pl.UTF-8
138 InnoTek VirtualBox OSE jest emulatorem sprzętu x86. Kierowany do
139 zastosowań serwerowych, desktopowych oraz wbudowanych jest obecnie
140 jedynym wysokiej jakości rozwiązaniem wirtualizacyjnym dostępnym
141 również jako Otwarte Oprogramowanie.
142
143 Przykładowe cechy VirtualBoksa:
144
145 Modularność: VirtualBox OSE jest wysoce zmodularyzowanym produktem z
146 dobrze zaprojektowanym wewnętrznym interfejsem programowym typu
147 klient/serwer. Dzięki temu można łatwo kontrolować go za pomocą
148 różnych interfejsów. Można na przykład uruchomić maszynę wirtualną z
149 poziomu interfejsu graficznego, a później kontrolować ją z linii
150 poleceń. VirtualBox OSE dostarcza również pełny pakiet deweloperski,
151 co pozwala stworzyć dowolny inny interfejs zarządzania maszyną
152 wirtualną.
153
154 Opisy maszyn wirtualnych w XML-u: konfiguracje poszczególnych maszyn
155 wirtualnych są w całości przechowywane w XML-u i są niezależne od
156 lokalnej maszyny. Dzięki temu można szybko i łatwo przenieść
157 konfigurację maszyny wirtualnej na inny komputer.
158
159 %package udev
160 Summary:        udev rules for VirtualBox OSE kernel modules
161 Summary(pl.UTF-8):      Reguły udev dla modułów jądra Linuksa dla VirtualBoksa
162 Release:        %{rel}
163 Group:          Base/Kernel
164 Requires:       udev-core
165
166 %description udev
167 udev rules for VirtualBox OSE kernel modules.
168
169 %description udev -l pl.UTF-8
170 Reguły udev dla modułów jądra Linuksa dla VirtualBoksa.
171
172 %package -n kernel%{_alt_kernel}-misc-vboxadd
173 Summary:        VirtualBox OSE Guest Additions for Linux Module
174 Summary(pl.UTF-8):      Moduł jądra Linuksa dla VirtualBoksa OSE
175 Release:        %{rel}@%{_kernel_ver_str}
176 Group:          Base/Kernel
177 Requires(post,postun):  /sbin/depmod
178 Requires:       dev >= 2.9.0-7
179 %if %{with dist_kernel}
180 %requires_releq_kernel
181 Requires(postun):       %releq_kernel
182 %endif
183 Provides:       kernel(vboxadd) = %{version}-%{rel}
184
185 %description -n kernel%{_alt_kernel}-misc-vboxadd
186 VirtualBox OSE Guest Additions for Linux Module.
187
188 %description -n kernel%{_alt_kernel}-misc-vboxadd -l pl.UTF-8
189 Moduł jądra Linuksa vboxadd dla VirtualBoksa OSE - dodatki dla systemu
190 gościa.
191
192 %package -n kernel%{_alt_kernel}-misc-vboxdrv
193 Summary:        VirtualBox OSE Support Driver
194 Summary(pl.UTF-8):      Moduł jądra Linuksa dla VirtualBoksa OSE
195 Release:        %{rel}@%{_kernel_ver_str}
196 Group:          Base/Kernel
197 Requires(post,postun):  /sbin/depmod
198 Requires:       dev >= 2.9.0-7
199 %if %{with dist_kernel}
200 %requires_releq_kernel
201 Requires(postun):       %releq_kernel
202 %endif
203 Provides:       kernel(vboxdrv) = %{version}-%{rel}
204
205 %description -n kernel%{_alt_kernel}-misc-vboxdrv
206 VirtualBox OSE Support Driver.
207
208 %description -n kernel%{_alt_kernel}-misc-vboxdrv -l pl.UTF-8
209 Moduł jądra Linuksa dla VirtualBoksa OSE - sterownik wsparcia dla
210 systemu głównego.
211
212 %package -n kernel%{_alt_kernel}-misc-vboxnetflt
213 Summary:        VirtualBox OSE Guest Additions for Linux Module
214 Summary(pl.UTF-8):      Moduł jądra Linuksa dla VirtualBoksa OSE
215 Release:        %{rel}@%{_kernel_ver_str}
216 Group:          Base/Kernel
217 Requires(post,postun):  /sbin/depmod
218 Requires:       dev >= 2.9.0-7
219 Requires:       kernel%{_alt_kernel}-misc-vboxdrv
220 %if %{with dist_kernel}
221 %requires_releq_kernel
222 Requires(postun):       %releq_kernel
223 %endif
224 Provides:       kernel(vboxnetflt) = %{version}-%{rel}
225
226 %description -n kernel%{_alt_kernel}-misc-vboxnetflt
227 VirtualBox OSE Network Filter Driver.
228
229 %description -n kernel%{_alt_kernel}-misc-vboxnetflt -l pl.UTF-8
230 Moduł jądra Linuksa dla VirtualBoksa OSE - sterownik filtrowania sieci
231 dla systemu głównego.
232
233 %package -n kernel%{_alt_kernel}-misc-vboxvfs
234 Summary:        Host file system access VFS for VirtualBox OSE
235 Summary(pl.UTF-8):      Moduł jądra Linuksa dla VirtualBoksa OSE
236 Release:        %{rel}@%{_kernel_ver_str}
237 Group:          Base/Kernel
238 Requires(post,postun):  /sbin/depmod
239 Requires:       dev >= 2.9.0-7
240 Requires:       kernel%{_alt_kernel}-misc-vboxadd
241 %if %{with dist_kernel}
242 %requires_releq_kernel
243 Requires(postun):       %releq_kernel
244 %endif
245 Provides:       kernel(vboxvfs) = %{version}-%{rel}
246
247 %description -n kernel%{_alt_kernel}-misc-vboxvfs
248 Host file system access VFS for VirtualBox OSE.
249
250 %description -n kernel%{_alt_kernel}-misc-vboxvfs -l pl.UTF-8
251 Moduł jądra Linuksa dla VirtualBoksa OSE - dostęp do plików systemu
252 głównego z poziomu systemu gościa.
253
254 %package -n kernel%{_alt_kernel}-misc-vboxvideo
255 Summary:        DRM support for VirtualBox OSE
256 Summary(pl.UTF-8):      Moduł jądra Linuksa dla VirtualBoksa OSE
257 Release:        %{rel}@%{_kernel_ver_str}
258 Group:          Base/Kernel
259 Requires(post,postun):  /sbin/depmod
260 Requires:       dev >= 2.9.0-7
261 %if %{with dist_kernel}
262 %requires_releq_kernel
263 Requires(postun):       %releq_kernel
264 %endif
265 Provides:       kernel(vboxvideo) = %{version}-%{rel}
266
267 %description -n kernel%{_alt_kernel}-misc-vboxvideo
268 DRM support for VirtualBox OSE.
269
270 %description -n kernel%{_alt_kernel}-misc-vboxvideo -l pl.UTF-8
271 Moduł jądra Linuksa dla VirtualBoksa OSE - sterownik obsługi DRM.
272
273 %package -n xorg-driver-input-vboxmouse
274 Summary:        X.org mouse driver for VirtualBox OSE guest OS
275 Summary(pl.UTF-8):      Sterownik myszy dla systemu gościa w VirtualBoksie OSE
276 Release:        %{rel}
277 Group:          X11/Applications
278 Requires:       xorg-xserver-server(xinput-abi) >= 4.0
279 Requires:       xorg-xserver-server(xinput-abi) < 5.0
280 Requires:       xorg-xserver-server >= 1.0.99.901
281
282 %description -n xorg-driver-input-vboxmouse
283 X.org mouse driver for VirtualBox OSE guest OS.
284
285 %description -n xorg-driver-input-vboxmouse  -l pl.UTF-8
286 Sterownik myszy dla systemu gościa w VirtualBoksie.
287
288 %package -n xorg-driver-video-vboxvideo
289 Summary:        X.org video driver for VirtualBox OSE guest OS
290 Summary(pl.UTF-8):      Sterownik grafiki dla systemu gościa w VirtualBoksie OSE
291 Release:        %{rel}
292 Group:          X11/Applications
293 Requires:       xorg-xserver-server(videodrv-abi) < 6.0
294 Requires:       xorg-xserver-server(videodrv-abi) >= 2.0
295 Requires:       xorg-xserver-server >= 1.0.99.901
296
297 %description -n xorg-driver-video-vboxvideo
298 X.org video driver for VirtualBox OSE guest OS.
299
300 %description -n xorg-driver-video-vboxvideo -l pl.UTF-8
301 Sterownik grafiki dla systemu gościa w VirtualBoksie OSE.
302
303 %prep
304 %setup -q -n %{pname}-%{version}_OSE
305 %patch0 -p1
306 %patch1 -p1
307 %patch2 -p1
308 %patch3 -p1
309
310 cat <<'EOF' > udev.conf
311 KERNEL=="vboxdrv", NAME="%k", GROUP="vbox", MODE="0660"
312 KERNEL=="vboxadd", NAME="%k", GROUP="vbox", MODE="0660"
313 EOF
314
315 install %{SOURCE1} .
316 sed 's#@LIBDIR@#%{_libdir}#' < %{SOURCE8} > VirtualBox-wrapper.sh
317
318 rm -rf PLD-MODULE-BUILD && mkdir PLD-MODULE-BUILD && cd PLD-MODULE-BUILD
319 ../src/VBox/Additions/linux/export_modules modules.tar.gz
320         tar -zxf modules.tar.gz && rm -f modules.tar.gz
321 ../src/VBox/HostDrivers/linux/export_modules modules.tar.gz --without-hardening && \
322         tar -zxf modules.tar.gz && rm -f modules.tar.gz
323 #./src/VBox/HostDrivers/Support/linux/Makefile:70:
324 #./PLD-MODULE-BUILD/vboxdrv/Makefile:70:
325
326
327 %build
328 %if %{with userspace}
329 ./configure \
330         --with-gcc="%{__cc}" \
331         --with-g++="%{__cxx}" \
332         --disable-hardening \
333         --disable-kmods
334
335 . ./env.sh && \
336 kmk -j1 %{?with_verbose:KBUILD_VERBOSE=3} USER=$(id -un)
337 %endif
338
339 %if %{with kernel}
340 cd PLD-MODULE-BUILD
341 %build_kernel_modules -m vboxadd -C vboxadd
342 %build_kernel_modules -m vboxdrv -C vboxdrv
343 %build_kernel_modules -m vboxnetflt -C vboxnetflt
344 cp -a vboxadd/Module.symvers vboxvfs
345 %build_kernel_modules -m vboxvfs -C vboxvfs -c
346 %build_kernel_modules -m vboxvideo -C vboxvideo_drm
347 cd ..
348 %endif
349
350 %install
351 rm -rf $RPM_BUILD_ROOT
352
353 %if %{with userspace}
354 install -d \
355         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_desktopdir}} \
356         $RPM_BUILD_ROOT%{_libdir}/VirtualBox \
357         $RPM_BUILD_ROOT/sbin
358
359 install %{SOURCE9} $RPM_BUILD_ROOT/sbin/mount.vdi
360 install VirtualBox-wrapper.sh $RPM_BUILD_ROOT%{_libdir}/VirtualBox
361 for f in {VBox{BFE,Headless,Manage,SDL,SVC,Tunctl,XPCOMIPCD},VirtualBox}; do
362         install out/linux.%{outdir}/release/bin/$f $RPM_BUILD_ROOT%{_libdir}/VirtualBox/$f
363         ln -s %{_libdir}/VirtualBox/VirtualBox-wrapper.sh $RPM_BUILD_ROOT%{_bindir}/$f
364 done
365
366 install out/linux.%{outdir}/release/bin/VBox*.so \
367         $RPM_BUILD_ROOT%{_libdir}/VirtualBox
368 install out/linux.%{outdir}/release/bin/{VBox{DD,DD2}{GC.gc,R0.r0},VMM{GC.gc,R0.r0}} \
369         $RPM_BUILD_ROOT%{_libdir}/VirtualBox
370 install out/linux.%{outdir}/release/bin/VBoxSysInfo.sh \
371         $RPM_BUILD_ROOT%{_libdir}/VirtualBox
372
373 install -d $RPM_BUILD_ROOT%{_libdir}/VirtualBox/additions
374 install -d $RPM_BUILD_ROOT%{_libdir}/VirtualBox/nls
375
376 install %{SOURCE2} $RPM_BUILD_ROOT%{_libdir}/VirtualBox/additions/VBoxGuestAdditions.iso
377 cp -a out/linux.%{outdir}/release/bin/components $RPM_BUILD_ROOT%{_libdir}/VirtualBox
378 cp -a out/linux.%{outdir}/release/bin/nls/* $RPM_BUILD_ROOT%{_libdir}/VirtualBox/nls
379
380 install out/linux.%{outdir}/release/bin/additions/mountvboxsf           \
381         $RPM_BUILD_ROOT%{_bindir}
382
383 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{drivers,input}
384
385 install out/linux.%{outdir}/release/bin/additions/vboxmouse_drv_16.so   \
386         $RPM_BUILD_ROOT%{_libdir}/xorg/modules/input/vboxmouse_drv.so
387 install out/linux.%{outdir}/release/bin/additions/vboxvideo_drv_16.so   \
388         $RPM_BUILD_ROOT%{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
389
390 install out/linux.%{outdir}/release/bin/VBox.png $RPM_BUILD_ROOT%{_pixmapsdir}/VBox.png
391 install %{SOURCE7} $RPM_BUILD_ROOT%{_desktopdir}/%{pname}.desktop
392
393 install -d $RPM_BUILD_ROOT/etc/udev/rules.d
394 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/virtualbox.rules
395 %endif
396
397 %if %{with kernel}
398 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
399 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxdrv
400 install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxadd
401 install %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxnetflt
402 install %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxvfs
403 %install_kernel_modules -m PLD-MODULE-BUILD/vboxadd/vboxadd -d misc
404 %install_kernel_modules -m PLD-MODULE-BUILD/vboxdrv/vboxdrv -d misc
405 %install_kernel_modules -m PLD-MODULE-BUILD/vboxnetflt/vboxnetflt -d misc
406 %install_kernel_modules -m PLD-MODULE-BUILD/vboxvfs/vboxvfs -d misc
407 %install_kernel_modules -m PLD-MODULE-BUILD/vboxvideo_drm/vboxvideo -d misc
408 %endif
409
410 %clean
411 rm -rf $RPM_BUILD_ROOT
412
413 %pre
414 %groupadd -g 221 -r -f vbox
415
416 %post
417 cat << 'EOF'
418 You must also install kernel module for this software to work:
419     kernel-misc-vboxdrv-%{version}-%{rel}@%{_kernel_ver_str}
420
421 Additionally you might want to install:
422     kernel-misc-vboxnetflt-%{version}-%{rel}@%{_kernel_ver_str}
423
424 On guest Linux system you might want to install:
425     kernel-misc-vboxadd-%{version}-%{rel}@%{_kernel_ver_str}
426     kernel-misc-vboxvfs-%{version}-%{rel}@%{_kernel_ver_str}
427     kernel-misc-vboxvideo-%{version}-%{rel}@%{_kernel_ver_str}
428
429 NOTE: for different kernel brands append after word kernel the brand, like:
430     kernel-desktop-misc-vboxdrv-%{version}-%{rel}@%{_kernel_ver_str}
431     kernel-laptop-misc-vboxdrv-%{version}-%{rel}@%{_kernel_ver_str}
432     kernel-vanilla-misc-vboxdrv-%{version}-%{rel}@%{_kernel_ver_str}
433     ...etc.
434
435 Depending on which kernel brand You use.
436
437 EOF
438
439 %postun
440 if [ "$1" = "0" ]; then
441         %groupremove vbox
442 fi
443
444 %post   -n kernel%{_alt_kernel}-misc-vboxadd
445 %depmod %{_kernel_ver}
446 /sbin/chkconfig --add vboxadd
447 %service vboxadd restart "VirtualBox OSE guest additions driver"
448
449 %postun -n kernel%{_alt_kernel}-misc-vboxadd
450 %depmod %{_kernel_ver}
451
452 %preun -n kernel%{_alt_kernel}-misc-vboxadd
453 if [ "$1" = "0" ]; then
454         %service vboxadd stop
455         /sbin/chkconfig --del vboxadd
456 fi
457
458 %post   -n kernel%{_alt_kernel}-misc-vboxdrv
459 %depmod %{_kernel_ver}
460 /sbin/chkconfig --add vboxdrv
461 %service vboxdrv restart "VirtualBox OSE driver"
462
463 %postun -n kernel%{_alt_kernel}-misc-vboxdrv
464 %depmod %{_kernel_ver}
465
466 %preun -n kernel%{_alt_kernel}-misc-vboxdrv
467 if [ "$1" = "0" ]; then
468         %service vboxdrv stop
469         /sbin/chkconfig --del vboxdrv
470 fi
471
472 %post   -n kernel%{_alt_kernel}-misc-vboxnetflt
473 %depmod %{_kernel_ver}
474 /sbin/chkconfig --add vboxnetflt
475 %service vboxnetflt restart "VirtualBox OSE Network Filter driver"
476
477 %postun -n kernel%{_alt_kernel}-misc-vboxnetflt
478 %depmod %{_kernel_ver}
479
480 %preun -n kernel%{_alt_kernel}-misc-vboxnetflt
481 if [ "$1" = "0" ]; then
482         %service vboxnetflt stop
483         /sbin/chkconfig --del vboxnetflt
484 fi
485
486 %post   -n kernel%{_alt_kernel}-misc-vboxvfs
487 %depmod %{_kernel_ver}
488 /sbin/chkconfig --add vboxvfs
489 %service vboxvfs restart "VirtualBox OSE guest additions VFS driver"
490
491 %postun -n kernel%{_alt_kernel}-misc-vboxvfs
492 %depmod %{_kernel_ver}
493
494 %preun -n kernel%{_alt_kernel}-misc-vboxvfs
495 if [ "$1" = "0" ]; then
496         %service vboxvfs stop
497         /sbin/chkconfig --del vboxvfs
498 fi
499
500 %post   -n kernel%{_alt_kernel}-misc-vboxvideo
501 %depmod %{_kernel_ver}
502
503 %postun -n kernel%{_alt_kernel}-misc-vboxvideo
504 %depmod %{_kernel_ver}
505
506 %if %{with userspace}
507 %files
508 %defattr(644,root,root,755)
509 %doc UserManual.pdf
510 %dir %{_libdir}/VirtualBox
511 %dir %{_libdir}/VirtualBox/additions
512 %dir %{_libdir}/VirtualBox/components
513 %dir %{_libdir}/VirtualBox/nls
514 %attr(755,root,root) %{_bindir}/mountvboxsf
515 %attr(755,root,root) %{_bindir}/VBox*
516 %attr(755,root,root) %{_bindir}/VirtualBox
517 %attr(755,root,root) /sbin/mount.vdi
518 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxSVC
519 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxBFE
520 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxHeadless
521 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxManage
522 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxSDL
523 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxTunctl
524 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxXPCOMIPCD
525 %attr(755,root,root) %{_libdir}/VirtualBox/VBox*.so
526 %attr(755,root,root) %{_libdir}/VirtualBox/VirtualBox
527 %attr(755,root,root) %{_libdir}/VirtualBox/VirtualBox-wrapper.sh
528 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxSysInfo.sh
529 %{_libdir}/VirtualBox/*.gc
530 %{_libdir}/VirtualBox/*.r0
531 %{_libdir}/VirtualBox/additions/*
532 %{_libdir}/VirtualBox/components/*
533 %lang(ar) %{_libdir}/VirtualBox/nls/*_ar.qm
534 %lang(bg) %{_libdir}/VirtualBox/nls/*_bg.qm
535 %lang(ca) %{_libdir}/VirtualBox/nls/*_ca.qm
536 %lang(cs) %{_libdir}/VirtualBox/nls/*_cs.qm
537 %lang(de) %{_libdir}/VirtualBox/nls/*_de.qm
538 %lang(el) %{_libdir}/VirtualBox/nls/*_el.qm
539 %lang(es) %{_libdir}/VirtualBox/nls/*_es.qm
540 %lang(eu) %{_libdir}/VirtualBox/nls/*_eu.qm
541 %lang(fi) %{_libdir}/VirtualBox/nls/*_fi.qm
542 %lang(fr) %{_libdir}/VirtualBox/nls/*_fr.qm
543 %lang(hu) %{_libdir}/VirtualBox/nls/*_hu.qm
544 %lang(id) %{_libdir}/VirtualBox/nls/*_id.qm
545 %lang(it) %{_libdir}/VirtualBox/nls/*_it.qm
546 %lang(ja) %{_libdir}/VirtualBox/nls/*_ja.qm
547 %lang(km_KH) %{_libdir}/VirtualBox/nls/*_km_KH.qm
548 %lang(ko) %{_libdir}/VirtualBox/nls/*_ko.qm
549 %lang(nl) %{_libdir}/VirtualBox/nls/*_nl.qm
550 %lang(pl) %{_libdir}/VirtualBox/nls/*_pl.qm
551 %lang(pt) %{_libdir}/VirtualBox/nls/*_pt.qm
552 %lang(pt_BR) %{_libdir}/VirtualBox/nls/*_pt_BR.qm
553 %lang(ro) %{_libdir}/VirtualBox/nls/*_ro.qm
554 %lang(ru) %{_libdir}/VirtualBox/nls/*_ru.qm
555 %lang(sk) %{_libdir}/VirtualBox/nls/*_sk.qm
556 %lang(sr) %{_libdir}/VirtualBox/nls/*_sr.qm
557 %lang(sv) %{_libdir}/VirtualBox/nls/*_sv.qm
558 %lang(tr) %{_libdir}/VirtualBox/nls/*_tr.qm
559 %lang(zh_CN) %{_libdir}/VirtualBox/nls/*_zh_CN.qm
560 %lang(zh_TW) %{_libdir}/VirtualBox/nls/*_zh_TW.qm
561 %{_pixmapsdir}/VBox.png
562 %{_desktopdir}/%{pname}.desktop
563
564 %files udev
565 %defattr(644,root,root,755)
566 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/virtualbox.rules
567
568 %files -n xorg-driver-input-vboxmouse
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_libdir}/xorg/modules/input/vboxmouse_drv.so
571
572 %files -n xorg-driver-video-vboxvideo
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
575 %endif
576
577 %if %{with kernel}
578 %files -n kernel%{_alt_kernel}-misc-vboxadd
579 %defattr(644,root,root,755)
580 %attr(754,root,root) /etc/rc.d/init.d/vboxadd
581 /lib/modules/%{_kernel_ver}/misc/vboxadd.ko*
582
583 %files -n kernel%{_alt_kernel}-misc-vboxdrv
584 %defattr(644,root,root,755)
585 %attr(754,root,root) /etc/rc.d/init.d/vboxdrv
586 /lib/modules/%{_kernel_ver}/misc/vboxdrv.ko*
587
588 %files -n kernel%{_alt_kernel}-misc-vboxnetflt
589 %defattr(644,root,root,755)
590 %attr(754,root,root) /etc/rc.d/init.d/vboxnetflt
591 /lib/modules/%{_kernel_ver}/misc/vboxnetflt.ko*
592
593 %files -n kernel%{_alt_kernel}-misc-vboxvfs
594 %defattr(644,root,root,755)
595 %attr(754,root,root) /etc/rc.d/init.d/vboxvfs
596 /lib/modules/%{_kernel_ver}/misc/vboxvfs.ko*
597
598 %files -n kernel%{_alt_kernel}-misc-vboxvideo
599 %defattr(644,root,root,755)
600 /lib/modules/%{_kernel_ver}/misc/vboxvideo.ko*
601 %endif
This page took 0.109508 seconds and 4 git commands to generate.