]> git.pld-linux.org Git - packages/VirtualBox.git/blob - VirtualBox.spec
- BR: OpenGL-GLU-devel
[packages/VirtualBox.git] / VirtualBox.spec
1 #
2 # TODO:
3 # - Find how to compile with PLD CFLAGS/CXXFLAGS/LDFLAGS.
4 # - Package SDK.
5 # - Package utils (and write initscripts ?) for Guest OS.
6 # - Check License of VBoxGuestAdditions_*.iso, it's propably not GPL v2.
7 #   If so check if it is distributable.
8 #
9 # Conditional build:
10 %bcond_without  dist_kernel     # without distribution kernel
11 %bcond_without  kernel          # don't build kernel module
12 %bcond_without  userspace       # don't build userspace package
13 %bcond_with     verbose
14
15 %if %{without kernel}
16 %undefine       with_dist_kernel
17 %endif
18 %if "%{_alt_kernel}" != "%{nil}"
19 %undefine       with_userspace
20 %endif
21 %if %{without userspace}
22 # nothing to be placed to debuginfo package
23 %define         _enable_debug_packages  0
24 %endif
25
26 %define         rel             1
27 %define         pname   VirtualBox
28 Summary:        VirtualBox OSE - x86 hardware virtualizer
29 Summary(pl.UTF-8):      VirtualBox OSE - wirtualizator sprzętu x86
30 Name:           %{pname}%{_alt_kernel}
31 Version:        2.2.4
32 Release:        %{rel}
33 License:        GPL v2
34 Group:          Applications/Emulators
35 Source0:        http://download.virtualbox.org/virtualbox/%{version}/%{pname}-%{version}-OSE.tar.bz2
36 # Source0-md5:  b90176e3878ccfef2991322b2248dcb0
37 Source1:        http://download.virtualbox.org/virtualbox/%{version}/UserManual.pdf
38 # Source1-md5:  1f8ec67c1dbc0bcdfbbfbe26171eb098
39 Source2:        http://download.virtualbox.org/virtualbox/%{version}/VBoxGuestAdditions_%{version}.iso
40 # Source2-md5:  00e64c25f87155540a3d106c5257530f
41 Source3:        %{pname}-vboxdrv.init
42 Source4:        %{pname}-vboxadd.init
43 Source5:        %{pname}-vboxnetflt.init
44 Source6:        %{pname}-vboxvfs.init
45 Source7:        %{pname}.desktop
46 Source8:        %{pname}.sh
47 Source9:        mount.vdi
48 Patch0:         %{pname}-configure.patch
49 Patch1:         %{pname}-configure-spaces.patch
50 Patch2:         %{pname}-export_modules.patch
51 Patch3:         %{pname}-VBoxSysInfo.patch
52 URL:            http://www.virtualbox.org/
53 BuildRequires:  rpmbuild(macros) >= 1.379
54 %if %{with userspace}
55 %ifarch %{x8664}
56 BuildRequires:  gcc-multilib
57 BuildRequires:  glibc-devel(i686)
58 BuildRequires:  libstdc++-multilib-devel
59 %endif
60 %if "%{pld_release}" == "ac"
61 BuildRequires:  XFree86-devel
62 %else
63 BuildRequires:  xorg-lib-libXcursor-devel
64 BuildRequires:  xorg-lib-libXmu-devel
65 %endif
66 BuildRequires:  OpenGL-GLU-devel
67 BuildRequires:  OpenGL-devel
68 BuildRequires:  QtGui-devel
69 BuildRequires:  QtNetwork-devel
70 BuildRequires:  SDL-devel >= 1.2.7
71 BuildRequires:  acpica
72 BuildRequires:  alsa-lib-devel >= 1.0.6
73 BuildRequires:  bash
74 BuildRequires:  bcc
75 BuildRequires:  bin86
76 BuildRequires:  gcc >= 5:3.2.3
77 BuildRequires:  libIDL-devel
78 BuildRequires:  libpng-devel >= 1.2.5
79 BuildRequires:  libstdc++-devel >= 5:3.2.3
80 BuildRequires:  libuuid-devel
81 BuildRequires:  libxml2-devel >= 2.6.26
82 BuildRequires:  libxslt-devel >= 1.1.17
83 BuildRequires:  libxslt-progs >= 1.1.17
84 BuildRequires:  pkgconfig
85 BuildRequires:  pulseaudio-devel >= 0.9.0
86 BuildRequires:  python-devel
87 BuildRequires:  qt4-build >= 4.2.0
88 BuildRequires:  qt4-linguist
89 BuildRequires:  sed >= 4.0
90 BuildRequires:  which
91 BuildRequires:  xalan-c-devel >= 1.10.0
92 BuildRequires:  xerces-c-devel >= 2.6.0
93 BuildRequires:  zlib-devel >= 1.2.1
94 BuildRequires:  libcap-static
95 %endif
96 %if %{with dist_kernel}
97 BuildRequires:  kernel%{_alt_kernel}-module-build >= 3:2.6.20
98 %endif
99 Requires(post,preun):   /sbin/chkconfig
100 Requires(postun):       /usr/sbin/groupdel
101 Requires(pre):  /usr/bin/getgid
102 Requires(pre):  /usr/sbin/groupadd
103 Suggests:       gxmessage
104 Provides:       group(vbox)
105 ExclusiveArch:  %{ix86} %{x8664}
106 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108 %ifarch %{x8664}
109 %define         outdir  amd64
110 %else
111 %define         outdir  x86
112 %endif
113
114 %description
115 InnoTek VirtualBox OSE is a general-purpose full virtualizer for x86
116 hardware. Targeted at server, desktop and embedded use, it is now the
117 only professional-quality virtualization solution that is also Open
118 Source Software.
119
120 Some of the features of VirtualBox OSE are:
121
122 Modularity: VirtualBox OSE has an extremely modular design with
123 well-defined internal programming interfaces and a client/server
124 design. This makes it easy to control it from several interfaces at
125 once: for example, you can start a virtual machine in a typical
126 virtual machine GUI and then control that machine from the command
127 line. VirtualBox OSE also comes with a full Software Development Kit:
128 even though it is Open Source Software, you don't have to hack the
129 source to write a new interface for VirtualBox OSE.
130
131 Virtual machine descriptions in XML: the configuration settings of
132 virtual machines are stored entirely in XML and are independent of the
133 local machines. Virtual machine definitions can therefore easily be
134 ported to other computers.
135
136 %description -l pl.UTF-8
137 InnoTek VirtualBox OSE jest emulatorem sprzętu x86. Kierowany do
138 zastosowań serwerowych, desktopowych oraz wbudowanych jest obecnie
139 jedynym wysokiej jakości rozwiązaniem wirtualizacyjnym dostępnym
140 również jako Otwarte Oprogramowanie.
141
142 Przykładowe cechy VirtualBoksa:
143
144 Modularność: VirtualBox OSE jest wysoce zmodularyzowanym produktem z
145 dobrze zaprojektowanym wewnętrznym interfejsem programowym typu
146 klient/serwer. Dzięki temu można łatwo kontrolować go za pomocą
147 różnych interfejsów. Można na przykład uruchomić maszynę wirtualną z
148 poziomu interfejsu graficznego, a później kontrolować ją z linii
149 poleceń. VirtualBox OSE dostarcza również pełny pakiet deweloperski,
150 co pozwala stworzyć dowolny inny interfejs zarządzania maszyną
151 wirtualną.
152
153 Opisy maszyn wirtualnych w XML-u: konfiguracje poszczególnych maszyn
154 wirtualnych są w całości przechowywane w XML-u i są niezależne od
155 lokalnej maszyny. Dzięki temu można szybko i łatwo przenieść
156 konfigurację maszyny wirtualnej na inny komputer.
157
158 %package udev
159 Summary:        udev rules for VirtualBox OSE kernel modules
160 Summary(pl.UTF-8):      Reguły udev dla modułów jądra Linuksa dla VirtualBoksa
161 Release:        %{rel}
162 Group:          Base/Kernel
163 Requires:       udev-core
164
165 %description udev
166 udev rules for VirtualBox OSE kernel modules.
167
168 %description udev -l pl.UTF-8
169 Reguły udev dla modułów jądra Linuksa dla VirtualBoksa.
170
171 %package -n kernel%{_alt_kernel}-misc-vboxadd
172 Summary:        VirtualBox OSE Guest Additions for Linux Module
173 Summary(pl.UTF-8):      Moduł jądra Linuksa dla VirtualBoksa OSE
174 Release:        %{rel}@%{_kernel_ver_str}
175 Group:          Base/Kernel
176 Requires(post,postun):  /sbin/depmod
177 Requires:       dev >= 2.9.0-7
178 %if %{with dist_kernel}
179 %requires_releq_kernel
180 Requires(postun):       %releq_kernel
181 %endif
182 Provides:       kernel(vboxadd) = %{version}-%{rel}
183
184 %description -n kernel%{_alt_kernel}-misc-vboxadd
185 VirtualBox OSE Guest Additions for Linux Module.
186
187 %description -n kernel%{_alt_kernel}-misc-vboxadd -l pl.UTF-8
188 Moduł jądra Linuksa vboxadd dla VirtualBoksa OSE - dodatki dla systemu
189 gościa.
190
191 %package -n kernel%{_alt_kernel}-misc-vboxdrv
192 Summary:        VirtualBox OSE Support Driver
193 Summary(pl.UTF-8):      Moduł jądra Linuksa dla VirtualBoksa OSE
194 Release:        %{rel}@%{_kernel_ver_str}
195 Group:          Base/Kernel
196 Requires(post,postun):  /sbin/depmod
197 Requires:       dev >= 2.9.0-7
198 %if %{with dist_kernel}
199 %requires_releq_kernel
200 Requires(postun):       %releq_kernel
201 %endif
202 Provides:       kernel(vboxdrv) = %{version}-%{rel}
203
204 %description -n kernel%{_alt_kernel}-misc-vboxdrv
205 VirtualBox OSE Support Driver.
206
207 %description -n kernel%{_alt_kernel}-misc-vboxdrv -l pl.UTF-8
208 Moduł jądra Linuksa dla VirtualBoksa OSE - sterownik wsparcia dla
209 systemu głównego.
210
211 %package -n kernel%{_alt_kernel}-misc-vboxnetflt
212 Summary:        VirtualBox OSE Guest Additions for Linux Module
213 Summary(pl.UTF-8):      Moduł jądra Linuksa dla VirtualBoksa OSE
214 Release:        %{rel}@%{_kernel_ver_str}
215 Group:          Base/Kernel
216 Requires(post,postun):  /sbin/depmod
217 Requires:       dev >= 2.9.0-7
218 Requires:       kernel%{_alt_kernel}-misc-vboxdrv
219 %if %{with dist_kernel}
220 %requires_releq_kernel
221 Requires(postun):       %releq_kernel
222 %endif
223 Provides:       kernel(vboxnetflt) = %{version}-%{rel}
224
225 %description -n kernel%{_alt_kernel}-misc-vboxnetflt
226 VirtualBox OSE Network Filter Driver.
227
228 %description -n kernel%{_alt_kernel}-misc-vboxnetflt -l pl.UTF-8
229 Moduł jądra Linuksa dla VirtualBoksa OSE - sterownik filtrowania sieci
230 dla systemu głównego.
231
232 %package -n kernel%{_alt_kernel}-misc-vboxvfs
233 Summary:        Host file system access VFS for VirtualBox OSE
234 Summary(pl.UTF-8):      Moduł jądra Linuksa dla VirtualBoksa OSE
235 Release:        %{rel}@%{_kernel_ver_str}
236 Group:          Base/Kernel
237 Requires(post,postun):  /sbin/depmod
238 Requires:       dev >= 2.9.0-7
239 Requires:       kernel%{_alt_kernel}-misc-vboxadd
240 %if %{with dist_kernel}
241 %requires_releq_kernel
242 Requires(postun):       %releq_kernel
243 %endif
244 Provides:       kernel(vboxvfs) = %{version}-%{rel}
245
246 %description -n kernel%{_alt_kernel}-misc-vboxvfs
247 Host file system access VFS for VirtualBox OSE.
248
249 %description -n kernel%{_alt_kernel}-misc-vboxvfs -l pl.UTF-8
250 Moduł jądra Linuksa dla VirtualBoksa OSE - dostęp do plików systemu
251 głównego z poziomu systemu gościa.
252
253 %package -n kernel%{_alt_kernel}-misc-vboxvideo
254 Summary:        DRM support for VirtualBox OSE
255 Summary(pl.UTF-8):      Moduł jądra Linuksa dla VirtualBoksa OSE
256 Release:        %{rel}@%{_kernel_ver_str}
257 Group:          Base/Kernel
258 Requires(post,postun):  /sbin/depmod
259 Requires:       dev >= 2.9.0-7
260 %if %{with dist_kernel}
261 %requires_releq_kernel
262 Requires(postun):       %releq_kernel
263 %endif
264 Provides:       kernel(vboxvideo) = %{version}-%{rel}
265
266 %description -n kernel%{_alt_kernel}-misc-vboxvideo
267 DRM support for VirtualBox OSE.
268
269 %description -n kernel%{_alt_kernel}-misc-vboxvideo -l pl.UTF-8
270 Moduł jądra Linuksa dla VirtualBoksa OSE - sterownik obsługi DRM.
271
272 %package -n xorg-driver-input-vboxmouse
273 Summary:        X.org mouse driver for VirtualBox OSE guest OS
274 Summary(pl.UTF-8):      Sterownik myszy dla systemu gościa w VirtualBoksie OSE
275 Release:        %{rel}
276 Group:          X11/Applications
277 Requires:       xorg-xserver-server(xinput-abi) >= 4.0
278 Requires:       xorg-xserver-server(xinput-abi) < 5.0
279 Requires:       xorg-xserver-server >= 1.0.99.901
280
281 %description -n xorg-driver-input-vboxmouse
282 X.org mouse driver for VirtualBox OSE guest OS.
283
284 %description -n xorg-driver-input-vboxmouse  -l pl.UTF-8
285 Sterownik myszy dla systemu gościa w VirtualBoksie.
286
287 %package -n xorg-driver-video-vboxvideo
288 Summary:        X.org video driver for VirtualBox OSE guest OS
289 Summary(pl.UTF-8):      Sterownik grafiki dla systemu gościa w VirtualBoksie OSE
290 Release:        %{rel}
291 Group:          X11/Applications
292 Requires:       xorg-xserver-server(videodrv-abi) < 6.0
293 Requires:       xorg-xserver-server(videodrv-abi) >= 2.0
294 Requires:       xorg-xserver-server >= 1.0.99.901
295
296 %description -n xorg-driver-video-vboxvideo
297 X.org video driver for VirtualBox OSE guest OS.
298
299 %description -n xorg-driver-video-vboxvideo -l pl.UTF-8
300 Sterownik grafiki dla systemu gościa w VirtualBoksie OSE.
301
302 %prep
303 %setup -q -n %{pname}-%{version}_OSE
304 %patch0 -p1
305 %patch1 -p1
306 %patch2 -p1
307 %patch3 -p1
308
309 cat <<'EOF' > udev.conf
310 KERNEL=="vboxdrv", NAME="%k", GROUP="vbox", MODE="0660"
311 KERNEL=="vboxadd", NAME="%k", GROUP="vbox", MODE="0660"
312 EOF
313
314 install %{SOURCE1} .
315 sed 's#@LIBDIR@#%{_libdir}#' < %{SOURCE8} > VirtualBox-wrapper.sh
316
317 rm -rf PLD-MODULE-BUILD && mkdir PLD-MODULE-BUILD && cd PLD-MODULE-BUILD
318 ../src/VBox/Additions/linux/export_modules modules.tar.gz
319         tar -zxf modules.tar.gz && rm -f modules.tar.gz
320 ../src/VBox/HostDrivers/linux/export_modules modules.tar.gz --without-hardening && \
321         tar -zxf modules.tar.gz && rm -f modules.tar.gz
322 #./src/VBox/HostDrivers/Support/linux/Makefile:70:
323 #./PLD-MODULE-BUILD/vboxdrv/Makefile:70:
324
325
326 %build
327 %if %{with userspace}
328 ./configure \
329         --with-gcc="%{__cc}" \
330         --with-g++="%{__cxx}" \
331         --disable-hardening \
332         --disable-kmods
333
334 . ./env.sh && \
335 kmk -j1 %{?with_verbose:KBUILD_VERBOSE=3} USER=$(id -un)
336 %endif
337
338 %if %{with kernel}
339 cd PLD-MODULE-BUILD
340 %build_kernel_modules -m vboxadd -C vboxadd
341 %build_kernel_modules -m vboxdrv -C vboxdrv
342 %build_kernel_modules -m vboxnetflt -C vboxnetflt
343 cp -a vboxadd/Module.symvers vboxvfs
344 %build_kernel_modules -m vboxvfs -C vboxvfs -c
345 %build_kernel_modules -m vboxvideo -C vboxvideo_drm
346 cd ..
347 %endif
348
349 %install
350 rm -rf $RPM_BUILD_ROOT
351
352 %if %{with userspace}
353 install -d \
354         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_desktopdir}} \
355         $RPM_BUILD_ROOT%{_libdir}/VirtualBox \
356         $RPM_BUILD_ROOT/sbin
357
358 install %{SOURCE9} $RPM_BUILD_ROOT/sbin/mount.vdi
359 install VirtualBox-wrapper.sh $RPM_BUILD_ROOT%{_libdir}/VirtualBox
360 for f in {VBox{BFE,Headless,Manage,SDL,SVC,Tunctl,XPCOMIPCD},VirtualBox}; do
361         install out/linux.%{outdir}/release/bin/$f $RPM_BUILD_ROOT%{_libdir}/VirtualBox/$f
362         ln -s %{_libdir}/VirtualBox/VirtualBox-wrapper.sh $RPM_BUILD_ROOT%{_bindir}/$f
363 done
364
365 install out/linux.%{outdir}/release/bin/VBox*.so \
366         $RPM_BUILD_ROOT%{_libdir}/VirtualBox
367 install out/linux.%{outdir}/release/bin/{VBox{DD,DD2}{GC.gc,R0.r0},VMM{GC.gc,R0.r0}} \
368         $RPM_BUILD_ROOT%{_libdir}/VirtualBox
369 install out/linux.%{outdir}/release/bin/VBoxSysInfo.sh \
370         $RPM_BUILD_ROOT%{_libdir}/VirtualBox
371
372 install -d $RPM_BUILD_ROOT%{_libdir}/VirtualBox/additions
373 install -d $RPM_BUILD_ROOT%{_libdir}/VirtualBox/nls
374
375 install %{SOURCE2} $RPM_BUILD_ROOT%{_libdir}/VirtualBox/additions/VBoxGuestAdditions.iso
376 cp -a out/linux.%{outdir}/release/bin/components $RPM_BUILD_ROOT%{_libdir}/VirtualBox
377 cp -a out/linux.%{outdir}/release/bin/nls/* $RPM_BUILD_ROOT%{_libdir}/VirtualBox/nls
378
379 install out/linux.%{outdir}/release/bin/additions/mountvboxsf           \
380         $RPM_BUILD_ROOT%{_bindir}
381
382 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{drivers,input}
383
384 install out/linux.%{outdir}/release/bin/additions/vboxmouse_drv_16.so   \
385         $RPM_BUILD_ROOT%{_libdir}/xorg/modules/input/vboxmouse_drv.so
386 install out/linux.%{outdir}/release/bin/additions/vboxvideo_drv_16.so   \
387         $RPM_BUILD_ROOT%{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
388
389 install out/linux.%{outdir}/release/bin/VBox.png $RPM_BUILD_ROOT%{_pixmapsdir}/VBox.png
390 install %{SOURCE7} $RPM_BUILD_ROOT%{_desktopdir}/%{pname}.desktop
391
392 install -d $RPM_BUILD_ROOT/etc/udev/rules.d
393 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/virtualbox.rules
394 %endif
395
396 %if %{with kernel}
397 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
398 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxdrv
399 install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxadd
400 install %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxnetflt
401 install %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxvfs
402 %install_kernel_modules -m PLD-MODULE-BUILD/vboxadd/vboxadd -d misc
403 %install_kernel_modules -m PLD-MODULE-BUILD/vboxdrv/vboxdrv -d misc
404 %install_kernel_modules -m PLD-MODULE-BUILD/vboxnetflt/vboxnetflt -d misc
405 %install_kernel_modules -m PLD-MODULE-BUILD/vboxvfs/vboxvfs -d misc
406 %install_kernel_modules -m PLD-MODULE-BUILD/vboxvideo_drm/vboxvideo -d misc
407 %endif
408
409 %clean
410 rm -rf $RPM_BUILD_ROOT
411
412 %pre
413 %groupadd -g 221 -r -f vbox
414
415 %post
416 cat << 'EOF'
417 You must also install kernel module for this software to work:
418     kernel-misc-vboxdrv-%{version}-%{rel}@%{_kernel_ver_str}
419
420 Additionally you might want to install:
421     kernel-misc-vboxnetflt-%{version}-%{rel}@%{_kernel_ver_str}
422
423 On guest Linux system you might want to install:
424     kernel-misc-vboxadd-%{version}-%{rel}@%{_kernel_ver_str}
425     kernel-misc-vboxvfs-%{version}-%{rel}@%{_kernel_ver_str}
426     kernel-misc-vboxvideo-%{version}-%{rel}@%{_kernel_ver_str}
427
428 NOTE: for different kernel brands append after word kernel the brand, like:
429     kernel-desktop-misc-vboxdrv-%{version}-%{rel}@%{_kernel_ver_str}
430     kernel-laptop-misc-vboxdrv-%{version}-%{rel}@%{_kernel_ver_str}
431     kernel-vanilla-misc-vboxdrv-%{version}-%{rel}@%{_kernel_ver_str}
432     ...etc.
433
434 Depending on which kernel brand You use.
435
436 EOF
437
438 %postun
439 if [ "$1" = "0" ]; then
440         %groupremove vbox
441 fi
442
443 %post   -n kernel%{_alt_kernel}-misc-vboxadd
444 %depmod %{_kernel_ver}
445 /sbin/chkconfig --add vboxadd
446 %service vboxadd restart "VirtualBox OSE guest additions driver"
447
448 %postun -n kernel%{_alt_kernel}-misc-vboxadd
449 %depmod %{_kernel_ver}
450
451 %preun -n kernel%{_alt_kernel}-misc-vboxadd
452 if [ "$1" = "0" ]; then
453         %service vboxadd stop
454         /sbin/chkconfig --del vboxadd
455 fi
456
457 %post   -n kernel%{_alt_kernel}-misc-vboxdrv
458 %depmod %{_kernel_ver}
459 /sbin/chkconfig --add vboxdrv
460 %service vboxdrv restart "VirtualBox OSE driver"
461
462 %postun -n kernel%{_alt_kernel}-misc-vboxdrv
463 %depmod %{_kernel_ver}
464
465 %preun -n kernel%{_alt_kernel}-misc-vboxdrv
466 if [ "$1" = "0" ]; then
467         %service vboxdrv stop
468         /sbin/chkconfig --del vboxdrv
469 fi
470
471 %post   -n kernel%{_alt_kernel}-misc-vboxnetflt
472 %depmod %{_kernel_ver}
473 /sbin/chkconfig --add vboxnetflt
474 %service vboxnetflt restart "VirtualBox OSE Network Filter driver"
475
476 %postun -n kernel%{_alt_kernel}-misc-vboxnetflt
477 %depmod %{_kernel_ver}
478
479 %preun -n kernel%{_alt_kernel}-misc-vboxnetflt
480 if [ "$1" = "0" ]; then
481         %service vboxnetflt stop
482         /sbin/chkconfig --del vboxnetflt
483 fi
484
485 %post   -n kernel%{_alt_kernel}-misc-vboxvfs
486 %depmod %{_kernel_ver}
487 /sbin/chkconfig --add vboxvfs
488 %service vboxvfs restart "VirtualBox OSE guest additions VFS driver"
489
490 %postun -n kernel%{_alt_kernel}-misc-vboxvfs
491 %depmod %{_kernel_ver}
492
493 %preun -n kernel%{_alt_kernel}-misc-vboxvfs
494 if [ "$1" = "0" ]; then
495         %service vboxvfs stop
496         /sbin/chkconfig --del vboxvfs
497 fi
498
499 %post   -n kernel%{_alt_kernel}-misc-vboxvideo
500 %depmod %{_kernel_ver}
501
502 %postun -n kernel%{_alt_kernel}-misc-vboxvideo
503 %depmod %{_kernel_ver}
504
505 %if %{with userspace}
506 %files
507 %defattr(644,root,root,755)
508 %doc UserManual.pdf
509 %dir %{_libdir}/VirtualBox
510 %dir %{_libdir}/VirtualBox/additions
511 %dir %{_libdir}/VirtualBox/components
512 %dir %{_libdir}/VirtualBox/nls
513 %attr(755,root,root) %{_bindir}/mountvboxsf
514 %attr(755,root,root) %{_bindir}/VBox*
515 %attr(755,root,root) %{_bindir}/VirtualBox
516 %attr(755,root,root) /sbin/mount.vdi
517 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxSVC
518 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxBFE
519 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxHeadless
520 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxManage
521 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxSDL
522 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxTunctl
523 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxXPCOMIPCD
524 %attr(755,root,root) %{_libdir}/VirtualBox/VBox*.so
525 %attr(755,root,root) %{_libdir}/VirtualBox/VirtualBox
526 %attr(755,root,root) %{_libdir}/VirtualBox/VirtualBox-wrapper.sh
527 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxSysInfo.sh
528 %{_libdir}/VirtualBox/*.gc
529 %{_libdir}/VirtualBox/*.r0
530 %{_libdir}/VirtualBox/additions/*
531 %{_libdir}/VirtualBox/components/*
532 %lang(ar) %{_libdir}/VirtualBox/nls/*_ar.qm
533 %lang(bg) %{_libdir}/VirtualBox/nls/*_bg.qm
534 %lang(ca) %{_libdir}/VirtualBox/nls/*_ca.qm
535 %lang(cs) %{_libdir}/VirtualBox/nls/*_cs.qm
536 %lang(de) %{_libdir}/VirtualBox/nls/*_de.qm
537 %lang(el) %{_libdir}/VirtualBox/nls/*_el.qm
538 %lang(es) %{_libdir}/VirtualBox/nls/*_es.qm
539 %lang(eu) %{_libdir}/VirtualBox/nls/*_eu.qm
540 %lang(fi) %{_libdir}/VirtualBox/nls/*_fi.qm
541 %lang(fr) %{_libdir}/VirtualBox/nls/*_fr.qm
542 %lang(hu) %{_libdir}/VirtualBox/nls/*_hu.qm
543 %lang(id) %{_libdir}/VirtualBox/nls/*_id.qm
544 %lang(it) %{_libdir}/VirtualBox/nls/*_it.qm
545 %lang(ja) %{_libdir}/VirtualBox/nls/*_ja.qm
546 %lang(km_KH) %{_libdir}/VirtualBox/nls/*_km_KH.qm
547 %lang(ko) %{_libdir}/VirtualBox/nls/*_ko.qm
548 %lang(nl) %{_libdir}/VirtualBox/nls/*_nl.qm
549 %lang(pl) %{_libdir}/VirtualBox/nls/*_pl.qm
550 %lang(pt) %{_libdir}/VirtualBox/nls/*_pt.qm
551 %lang(pt_BR) %{_libdir}/VirtualBox/nls/*_pt_BR.qm
552 %lang(ro) %{_libdir}/VirtualBox/nls/*_ro.qm
553 %lang(ru) %{_libdir}/VirtualBox/nls/*_ru.qm
554 %lang(sk) %{_libdir}/VirtualBox/nls/*_sk.qm
555 %lang(sr) %{_libdir}/VirtualBox/nls/*_sr.qm
556 %lang(sv) %{_libdir}/VirtualBox/nls/*_sv.qm
557 %lang(tr) %{_libdir}/VirtualBox/nls/*_tr.qm
558 %lang(zh_CN) %{_libdir}/VirtualBox/nls/*_zh_CN.qm
559 %lang(zh_TW) %{_libdir}/VirtualBox/nls/*_zh_TW.qm
560 %{_pixmapsdir}/VBox.png
561 %{_desktopdir}/%{pname}.desktop
562
563 %files udev
564 %defattr(644,root,root,755)
565 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/virtualbox.rules
566
567 %files -n xorg-driver-input-vboxmouse
568 %defattr(644,root,root,755)
569 %attr(755,root,root) %{_libdir}/xorg/modules/input/vboxmouse_drv.so
570
571 %files -n xorg-driver-video-vboxvideo
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
574 %endif
575
576 %if %{with kernel}
577 %files -n kernel%{_alt_kernel}-misc-vboxadd
578 %defattr(644,root,root,755)
579 %attr(754,root,root) /etc/rc.d/init.d/vboxadd
580 /lib/modules/%{_kernel_ver}/misc/vboxadd.ko*
581
582 %files -n kernel%{_alt_kernel}-misc-vboxdrv
583 %defattr(644,root,root,755)
584 %attr(754,root,root) /etc/rc.d/init.d/vboxdrv
585 /lib/modules/%{_kernel_ver}/misc/vboxdrv.ko*
586
587 %files -n kernel%{_alt_kernel}-misc-vboxnetflt
588 %defattr(644,root,root,755)
589 %attr(754,root,root) /etc/rc.d/init.d/vboxnetflt
590 /lib/modules/%{_kernel_ver}/misc/vboxnetflt.ko*
591
592 %files -n kernel%{_alt_kernel}-misc-vboxvfs
593 %defattr(644,root,root,755)
594 %attr(754,root,root) /etc/rc.d/init.d/vboxvfs
595 /lib/modules/%{_kernel_ver}/misc/vboxvfs.ko*
596
597 %files -n kernel%{_alt_kernel}-misc-vboxvideo
598 %defattr(644,root,root,755)
599 /lib/modules/%{_kernel_ver}/misc/vboxvideo.ko*
600 %endif
This page took 0.060161 seconds and 3 git commands to generate.