]> git.pld-linux.org Git - packages/VirtualBox.git/blame - VirtualBox.spec
- todo update
[packages/VirtualBox.git] / VirtualBox.spec
CommitLineData
48363591 1#
2# TODO:
3# - Doesn't compile without /usr/src/linux/include/linux/autoconf.h so one must
4# symlink it before building package. This is because during compilation kernel
5# module is being build. Since we are building kernel modules later
6# sources/makefiles probably needs some hacking to drop this requirement.
7# - Home page says that some addons should be compiled, I don't see any except.
8# vboxaddon kernel module and {vboxmouse,vboxvideo)_drv.so. Are they required?
9# - BR list was a quickie so it may be incomplete or too big.
10# - R list probably required.
11# - .desktop file, some wrapper to launch VirtualBox (LD_LIBRARY_PATH must include
12# %{_libdir}/VirtualBox), maybe some init script to launch VBoxSVC.
13# - Devel stuff is not packaged yet.
eba4b2aa
JB
14# - Now its EA ix86 x8664, but looking into autogenerated env.sh suggests that
15# code may be compiled exclusively for i686.
32b670ab 16# - use %kernel_build macros
48363591 17#
18# Conditional build:
19%bcond_without dist_kernel # without distribution kernel
20%bcond_without smp # without SMP kernel modules
21#
22%define _snap 20070116
23Summary: VirtualBox
24Summary(pl): VirtualBox
25Name: VirtualBox
26Version: 1.3.3
27Release: 0.1
28License: GPL v2
29Group: Applications/Emulators
30Source0: %{name}-%{version}_%{_snap}.tar.bz2
31# Source0-md5: 8554cf552c3ad07b2ae5229c3f8825dc
32Patch0: %{name}-configure.patch
33Patch1: %{name}-qt-paths.patch
34URL: http://www.virtualbox.org/
35BuildRequires: SDL-devel
e5aaadde 36BuildRequires: bash
48363591 37BuildRequires: bcc
38BuildRequires: bin86
eba4b2aa 39BuildRequires: gcc >= 5:3.2.3
48363591 40BuildRequires: iasl
41%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7}
42BuildRequires: libIDL-devel
43BuildRequires: libuuid-devel
e5aaadde 44BuildRequires: libxslt-progs
45BuildRequires: qt-devel >= 6:3.3.6
48363591 46BuildRequires: rpmbuild(macros) >= 1.329
e5aaadde 47BuildRequires: xalan-c-devel >= 1.10.0
eba4b2aa 48#BuildRequires: xcursor-devel
e5aaadde 49BuildRequires: xerces-c-devel >= 2.6.0
eba4b2aa 50BuildRequires: xorg-lib-libXcursor-devel
e5aaadde 51BuildRequires: zlib-devel >= 1.2.1
eba4b2aa 52ExclusiveArch: %{ix86} %{x8664}
48363591 53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
eba4b2aa 55%ifarch %{x8664}
5088674d 56%define _outdir amd64
57%else
58%define _outdir x86
59%endif
60
48363591 61%description
62InnoTek VirtualBox is a general-purpose full virtualizer for x86
63hardware. Targeted at server, desktop and embedded use, it is now the
64only professional-quality virtualization solution that is also Open
65Source Software.
66
67Some of the features of VirtualBox are:
68
69Modularity: VirtualBox has an extremely modular design with
70well-defined internal programming interfaces and a client/server
71design. This makes it easy to control it from several interfaces at
72once: for example, you can start a virtual machine in a typical
73virtual machine GUI and then control that machine from the command
74line. VirtualBox also comes with a full Software Development Kit: even
75though it is Open Source Software, you don't have to hack the source
76to write a new interface for VirtualBox.
77
78Virtual machine descriptions in XML: the configuration settings of
79virtual machines are stored entirely in XML and are independent of the
80local machines. Virtual machine definitions can therefore easily be
81ported to other computers.
82
83%description -l pl
70bcd77e 84