]> git.pld-linux.org Git - packages/VirtualBox.git/blame - VirtualBox.spec
- partial merge from vbox.spec
[packages/VirtualBox.git] / VirtualBox.spec
CommitLineData
48363591 1#
2# TODO:
3# - Doesn't compile without /usr/src/linux/include/linux/autoconf.h so one must
4# symlink it before building package. This is because during compilation kernel
5# module is being build. Since we are building kernel modules later
6# sources/makefiles probably needs some hacking to drop this requirement.
7# - Home page says that some addons should be compiled, I don't see any except.
8# vboxaddon kernel module and {vboxmouse,vboxvideo)_drv.so. Are they required?
9# - BR list was a quickie so it may be incomplete or too big.
10# - R list probably required.
11# - .desktop file, some wrapper to launch VirtualBox (LD_LIBRARY_PATH must include
12# %{_libdir}/VirtualBox), maybe some init script to launch VBoxSVC.
13# - Devel stuff is not packaged yet.
14# - Now its EA ix86 amd64, but looking into autogenerated env.sh suggests that
15# code may be compiled exclusively for i686. Probably x86_64 must be put in EA for Th.
16#
17# Conditional build:
18%bcond_without dist_kernel # without distribution kernel
19%bcond_without smp # without SMP kernel modules
20#
21%define _snap 20070116
22Summary: VirtualBox
23Summary(pl): VirtualBox
24Name: VirtualBox
25Version: 1.3.3
26Release: 0.1
27License: GPL v2
28Group: Applications/Emulators
29Source0: %{name}-%{version}_%{_snap}.tar.bz2
30# Source0-md5: 8554cf552c3ad07b2ae5229c3f8825dc
31Patch0: %{name}-configure.patch
32Patch1: %{name}-qt-paths.patch
33URL: http://www.virtualbox.org/
34BuildRequires: SDL-devel
35BuildRequires: bcc
36BuildRequires: bin86
37BuildRequires: gcc >= 3.2.3
38BuildRequires: iasl
39%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7}
40BuildRequires: libIDL-devel
41BuildRequires: libuuid-devel
42BuildRequires: libxslt-devel
43BuildRequires: qt-devel
44BuildRequires: rpmbuild(macros) >= 1.329
45BuildRequires: xalan-c-devel
46BuildRequires: xcursor-devel
47BuildRequires: xerces-c-devel
48BuildRequires: zlib-devel
49ExclusiveArch: %{ix86} amd64
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
5088674d 52%ifarch amd64
53%define _outdir amd64
54%else
55%define _outdir x86
56%endif
57
48363591 58%description
59InnoTek VirtualBox is a general-purpose full virtualizer for x86
60hardware. Targeted at server, desktop and embedded use, it is now the
61only professional-quality virtualization solution that is also Open
62Source Software.
63
64Some of the features of VirtualBox are:
65
66Modularity: VirtualBox has an extremely modular design with
67well-defined internal programming interfaces and a client/server
68design. This makes it easy to control it from several interfaces at
69once: for example, you can start a virtual machine in a typical
70virtual machine GUI and then control that machine from the command
71line. VirtualBox also comes with a full Software Development Kit: even
72though it is Open Source Software, you don't have to hack the source
73to write a new interface for VirtualBox.
74
75Virtual machine descriptions in XML: the configuration settings of
76virtual machines are stored entirely in XML and are independent of the
77local machines. Virtual machine definitions can therefore easily be
78ported to other computers.
79
80%description -l pl
81