]> git.pld-linux.org Git - packages/SuperLU.git/blob - SuperLU.spec
- updated to 5.3.0
[packages/SuperLU.git] / SuperLU.spec
1 Summary:        Subroutines to solve a sparse linear system A*X=B
2 Summary(pl.UTF-8):      Procedury do rozwiązywania rzadkich układów równań liniowych A*X=B
3 Name:           SuperLU
4 Version:        5.3.0
5 Release:        1
6 License:        BSD
7 Group:          Libraries
8 #Source0Download: https://github.com/xiaoyeli/superlu/releases
9 Source0:        https://github.com/xiaoyeli/superlu/archive/v%{version}/superlu-%{version}.tar.gz
10 # Source0-md5:  3a5123b86bd517fe28c830ae7d12cb25
11 Patch0:         %{name}-shared.patch
12 URL:            https://portal.nersc.gov/project/sparse/superlu/
13 BuildRequires:  blas-devel
14 BuildRequires:  cmake >= 2.8.12
15 BuildRequires:  gcc-fortran
16 BuildRequires:  rpm-build >= 4.6
17 BuildRequires:  rpmbuild(macros) >= 1.752
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 SuperLU contains a set of subroutines to solve a sparse linear system
22 A*X=B. It uses Gaussian elimination with partial pivoting (GEPP). The
23 columns of A may be preordered before factorization; the preordering
24 for sparsity is completely separate from the factorization.
25
26 %description -l pl.UTF-8
27 SuperLU zawiera zbiór procedur do rozwiązywania rzadkich układów
28 równań liniowych A*X=B. Wykorzystuje eliminację Gaussa z częściowym
29 wyborem elementu głównego (GEPP). Kolumny A mogą być wstępnie
30 uporządkowane przed rozkładem; ustalanie kolejności pod kątem
31 rzadkości jest całkowicie odrębne od samego rozkładu.
32
33 %package devel
34 Summary:        Header files for SuperLU library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SuperLU
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       blas-devel
39 Obsoletes:      SuperLU-static < 5
40
41 %description devel
42 Header files for SuperLU library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki SuperLU.
46
47 %package apidocs
48 Summary:        SuperLU API documentation
49 Summary(pl.UTF-8):      Dokumentacja API biblioteki SuperLU
50 Group:          Documentation
51 BuildArch:      noarch
52
53 %description apidocs
54 API documentation for SuperLU library.
55
56 %description apidocs -l pl.UTF-8
57 Dokumentacja API biblioteki SuperLU.
58
59 %prep
60 %setup -q -n superlu-%{version}
61 %patch0 -p1
62
63 %build
64 install -d build
65 cd build
66 # .pc file generation expects relative CMAKE_INSTALL_{INCLUDE,LIB}DIR
67 %cmake .. \
68         -DCMAKE_INSTALL_INCLUDEDIR=include/superlu \
69         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
70         -Denable_internal_blaslib=OFF
71
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} -C build install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %doc License.txt README
89 %attr(755,root,root) %{_libdir}/libsuperlu.so.*.*.*
90 %attr(755,root,root) %ghost %{_libdir}/libsuperlu.so.5
91
92 %files devel
93 %defattr(644,root,root,755)
94 %doc DOC/ug.pdf
95 %attr(755,root,root) %{_libdir}/libsuperlu.so
96 %{_includedir}/superlu
97 %{_pkgconfigdir}/superlu.pc
98 %{_libdir}/cmake/superlu
99
100 %files apidocs
101 %defattr(644,root,root,755)
102 %doc DOC/html/*
This page took 0.040995 seconds and 4 git commands to generate.