]> git.pld-linux.org Git - packages/SoQt.git/blob - SoQt.spec
BR automake for _aclocaldir macro
[packages/SoQt.git] / SoQt.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        Qt GUI component toolkit library for Coin
6 Summary(pl.UTF-8):      Biblioteka komponentu graficznego interfejsu Qt dla biblioteki Coin
7 Name:           SoQt
8 Version:        1.5.0
9 Release:        2
10 License:        GPL v2 or Coin PEL
11 Group:          X11/Libraries
12 Source0:        https://bitbucket.org/Coin3D/coin/downloads/%{name}-%{version}.tar.gz
13 # Source0-md5:  9f1e582373d66f556b1db113a93ac68e
14 Patch0:         %{name}-pc.patch
15 URL:            http://www.coin3d.org/lib/soqt/
16 BuildRequires:  Coin-devel
17 BuildRequires:  OpenGL-GLU-devel
18 BuildRequires:  OpenGL-GLX-devel
19 BuildRequires:  QtCore-devel >= 4
20 BuildRequires:  QtGui-devel >= 4
21 BuildRequires:  QtOpenGL-devel >= 4
22 BuildRequires:  automake
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  pkgconfig
25 BuildRequires:  qt4-build >= 4
26 BuildRequires:  sed >= 4.0
27 BuildRequires:  xorg-lib-libX11-devel
28 BuildRequires:  xorg-lib-libXext-devel
29 BuildRequires:  xorg-lib-libXmu-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 SoQt is a Qt GUI component toolkit library for Coin. It is also
34 compatible with SGI and TGS Open Inventor, and the API is based on the
35 API of the InventorXt GUI component toolkit.
36
37 %description -l pl.UTF-8
38 SoQt to biblioteka toolkitu komponentu graficznego interfejsu
39 użytkownika (GUI) Qt dla biblioteki Coin. Jest zgodna także z
40 biblioteką SGI i TGS Open Inventor, a API jest oparte na API toolkitu
41 komponentu graficznego interfejsu użytkownika InventorXt.
42
43 %package devel
44 Summary:        Header files for SoQt library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SoQt
46 Group:          X11/Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       Coin-devel
49 Requires:       OpenGL-GLX-devel
50 Requires:       QtCore-devel >= 4
51
52 %description devel
53 Header files for SoQt library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki SoQt.
57
58 %package static
59 Summary:        Static SoQt library
60 Summary(pl.UTF-8):      Statyczna biblioteka SoQt
61 Group:          X11/Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63
64 %description static
65 Static SoQt library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka SoQt.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73
74 %build
75 # -DHAVE_GLX is not passed properly from configure
76 CXXFLAGS="%{rpmcxxflags} -DHAVE_GLX"
77 %configure \
78         %{?with_static_libs:--enable-static}
79
80 # GL is missing; cannot rebuild auto* because of missing m4 files
81 %{__sed} -i -e '/^LIBS =/s/$/ -lGL/' src/Inventor/Qt/Makefile
82
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 # obsoleted by pkg-config
92 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libSoQt.la
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc AUTHORS BUGS.txt COPYING ChangeLog FAQ NEWS README
103 %attr(755,root,root) %{_libdir}/libSoQt.so.*.*.*
104 %attr(755,root,root) %ghost %{_libdir}/libSoQt.so.20
105
106 %files devel
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_libdir}/libSoQt.so
109 %attr(755,root,root) %{_bindir}/soqt-config
110 %{_includedir}/Inventor/Qt
111 %{_pkgconfigdir}/SoQt.pc
112 %{_aclocaldir}/soqt.m4
113 %{_datadir}/Coin/conf/soqt-default.cfg
114 %{_mandir}/man1/soqt-config.1*
115
116 %if %{with static_libs}
117 %files static
118 %defattr(644,root,root,755)
119 %{_libdir}/libSoQt.a
120 %endif
This page took 1.083778 seconds and 3 git commands to generate.