]> git.pld-linux.org Git - packages/Smarty-plugin-paginate.git/blob - Smarty-plugin-paginate.spec
- use virtual php extension deps (to be independant of php version)
[packages/Smarty-plugin-paginate.git] / Smarty-plugin-paginate.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         php_min_version 5.0.0
3 Summary:        Smarty plugin for data set pagination
4 Name:           Smarty-plugin-paginate
5 Version:        1.6
6 Release:        5
7 License:        LGPL v2.1+
8 Group:          Development/Languages/PHP
9 Source0:        http://www.phpinsider.com/php/code/SmartyPaginate/SmartyPaginate-%{version}.tar.gz
10 # Source0-md5:  1407027bd2cc319cdb3b8535a498289d
11 URL:            http://www.phpinsider.com/php/code/SmartyPaginate/
12 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
13 Requires:       Smarty
14 Requires:       php(pcre)
15 Requires:       php-common >= 4:%{php_min_version}
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _smartydir      %{_datadir}/php/Smarty
20
21 %description
22 SmartyPaginate is a data pagination class for the Smarty template
23 engine.
24
25 Often times when you display a large result set on a web page (such as
26 a database query), you will want to break it up across multiple pages
27 with "previous" and "next" links that aid in navigating through the
28 data. SmartyPaginate automates the task of keeping track of the
29 pagination and displaying pagination navigation links.
30
31 %prep
32 %setup -q -n SmartyPaginate-%{version}
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT{%{_smartydir}/plugins,%{php_data_dir}}
37 cp -a libs/SmartyPaginate.class.php $RPM_BUILD_ROOT%{php_data_dir}
38 cp -a plugins/*.php $RPM_BUILD_ROOT%{_smartydir}/plugins
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %files
44 %defattr(644,root,root,755)
45 %doc NEWS README
46 %{php_data_dir}/*.class.php
47 %{_smartydir}/plugins/*.php
This page took 0.057293 seconds and 3 git commands to generate.